Support » Allgemeine Fragen » Responsive Design wird nicht richtig angezeigt

  • Gelöst serjen

    (@serjen)


    Hallo zusammen!

    Nachdem ich mich durch das Forum gesucht und bisher keinen Post gefunden habe, der „mein“ Problem behandelt, ich aber schon gefühlt halb ergraut bin, stelle ich euch die Frage einmal hier (falls ich die entsprechenden Beiträge übersehen habe, entschuldige ich mich):

    Ich nutze seit vorgestern ein neues Theme – „Melange“ von Lightmorango. Alles eingerichtet, alles wunderbar.

    Bis auf eine Sache: Das Design wird responsive nicht richtig angezeigt.
    Google und andere Responsive-Analyse-Tools spucken mir zwar aus, dass die Darstellung top ist, doch im Praxistest unter anderem mit dem IPhone6 zeigt sich, dass die Breite viel zu gering eingestellt ist und sich das Theme nicht richtig aufzulösen scheint.
    (Die Ersteller habe ich bereits angeschrieben, aber noch keine Rückmeldung erhalten und ich sitze gewissermaßen auf glühenden Kohlen.)

    ES geht um folgenden Blog: http://www.mehralsgruenzeug.com

    Ich habe bereits sämtliche Plugins deaktiviert und wieder aktiviert, aber es hat sich keine Ändeurng ergeben. Das Demo-Theme der Seite funktioniert responsive auf denselben Geräten einwandfrei (ihr findet es hier: http://lightmorango.com/melange/

    Als nicht wirklich (nein: überhaupt nicht) versierte Person in CSS und anderen Dingen habe ich zwar schon Ausschau gehalten nach möglichen Problemen, konnte mir da aber aktuell nicht weiterhelfen.

    Ich hoffe, jemand von euch weiß Rat.

    Liebe Grüße
    Jenni

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Moin!

    Das Problem sollte gelöst sein, wenn du Folgendes im html code änderst:

    Vorher:
    <meta name="viewport" content="width=device-width">

    Nachher:
    <meta name="viewport" content="width=device-width, initial-scale=1.0">

    Thread-Ersteller serjen

    (@serjen)

    Hey!
    Danke dir für die schnelle Antwort!

    Die Frage ist vielleicht noch dümmer als die erste, aber: Wo genau muss ich das ändern und wie erhalte ich Zugriff auf den HTML-Code?

    Liebe Grüße
    Jenni

    Thread-Ersteller serjen

    (@serjen)

    Okay, nach einigem Suchen bin ich etwas schlauer geworden und habe gemerkt, was ich da nun zu bearbeiten habe (php.Dateien) und habe deinen Code nun in der header.php eingefügt.

    Leider ergab das keine Änderungen, das Bild bzw. die Auflösung bleibt nach wie vor dieselbe.

    Liebe Grüße
    Jenni

    In welcher Datei hast du den Code denn geändert? Gib bitte vor allem mal den Dateipfad an.

    Thread-Ersteller serjen

    (@serjen)

    Ich habe die Änderung unter wp-content/themes/MelangeTheme/header.php vorgenommen gehabt. (Mittlerweile wieder rückgängig gemacht.)

    Was mir nur komisch vorkommt, ist, dass dieselbe Seite auf denselben Endgeräten, wenn sie nicht bei mir installiert ist, ohne Fehler angezeigt wird.
    Liegt dann das Problem wirklich im Theme selbst?
    Aktuell bin ich am Überlegen, ob es nicht vielleicht auch mit falsch proportionierten Bildern zusammenhängen könnte…

    Wenn du die Änderungen wieder rückgängig gemacht hast, können wir die Auswirkung schlecht beurteilen. Vor allem musst du sicher stellen, dass die geänderte Datei auch wirklich hochgeladen wird.

    Thread-Ersteller serjen

    (@serjen)

    Okay, ich habe die Änderung wiederholt und die Datei ist erfolgreich hochgeladen.

    Was du eingetragen hast:

    
    <meta name="viewport" content="width=device-width", initial-scale="1.0">
    

    was du eintragen solltest:

    
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    
    Thread-Ersteller serjen

    (@serjen)

    Oje, ich bin offensichtlich zu doof, eine einfache Code-Zeile zu kopieren…nun denn.

    Ich danke euch jedenfalls ganz herzlich – es funktioniert endlich alles wie es soll!
    Wunderbar, ihr habt mich erlöst vom stümperhaften Herumgeeiere! 🙂

    Liebe Grüße!
    Jenni

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Das Thema „Responsive Design wird nicht richtig angezeigt“ ist für neue Antworten geschlossen.