Title: REST Api Fehler
Last modified: 14. Juni 2024

---

# REST Api Fehler

 *  [hkruse](https://de.wordpress.org/support/users/hkruse/)
 * (@hkruse)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/)
 * Hallo,
   im „Health-Check“ meiner WP Site heißt es unter anderem:
 * Beim Testen des REST-API ist ein Fehler aufgetreten:
 * REST-API-Endpunkt: [https://www.naturfotografie-kruse.de/wp-json/wp/v2/types/post?context=edit](https://www.naturfotografie-kruse.de/wp-json/wp/v2/types/post?context=edit)
   
   REST-API-Antwort: (http_request_failed) cURL error 7: Failed to connect to [http://www.naturfotografie-kruse.de](http://www.naturfotografie-kruse.de)
   port 443: Connection timed outHm…wie gehe ich hier nun am besten vor?
 *     ```wp-block-code
       Hier mal der Website-Bericht:` wp-coreversion: 6.5.4site_language: de_DEuser_language: de_DEtimezone: Europe/Berlinpermalink: /%postname%/https_status: truemultisite: falseuser_registration: 1blog_public: 1default_comment_status: openenvironment_type: productionuser_count: 10dotorg_communication: true wp-paths-sizeswordpress_path: /var/www/web22442389/html/fotografie/blogwordpress_size: 338,42 MB (354861538 bytes)uploads_path: /var/www/web22442389/html/fotografie/blog/wp-content/uploadsuploads_size: 6,19 GB (6646170543 bytes)themes_path: /var/www/web22442389/html/fotografie/blog/wp-content/themesthemes_size: 8,84 MB (9270589 bytes)plugins_path: /var/www/web22442389/html/fotografie/blog/wp-content/pluginsplugins_size: 148,43 MB (155637660 bytes)database_size: 112,47 MB (117936139 bytes)total_size: 6,78 GB (7283876469 bytes) wp-dropins (1)advanced-cache.php: true wp-active-themename: Impreza (Impreza)version: 8.25author: UpSolutionauthor_website: http://us-themes.com/parent_theme: nonetheme_features: editor-color-palette, automatic-feed-links, title-tag, post-thumbnails, post-formats, html5, widgets, menustheme_path: /var/www/web22442389/html/fotografie/blog/wp-content/themes/Impreza wp-mu-plugins (1)NinjaFirewall WP (mu-plugin): version: 1.0, author: The Ninja Technologies Network wp-plugins-active (26)Add-on Contact Form 7 - Mailpoet 3: version: 1.3.21, author: TikwebAlfahosting Sender Mail Plugin: version: 1.0, author: Alfahosting GmbHAnti-Spam by CleanTalk: version: 6.34, author: СleanTalk - Anti-Spam Protection welcome@cleantalk.orgBackWPup Pro: version: 3.7.1, author: Inpsyde GmbHBefore After Image Comparison Slider for WPBakery Page Builder Pro: version: 3.0.0, author: Web BuilderBorlabs Cookie - Cookie Opt-in: version: 2.2.67, author: Borlabs GmbHConnect Matomo: version: 1.0.30, author: André BräklingContact Form 7: version: 5.9.5, author: Takayuki MiyoshiCookie Information | Free WP GDPR Consent Plugin: version: 2.0.23, author: Cookie InformationHoneypot for Contact Form 7: version: 2.1.1, author: NoceanMailPoet: version: 4.51.2, author: MailPoetMailPoet Premium: version: 4.51.0, author: MailPoetMeta pixel for WordPress: version: 3.0.16, author: FacebookNinjaFirewall (WP Edition): version: 4.5.11, author: The Ninja Technologies NetworkOMGF: version: 5.9.0, author: Daan from Daan.devOMGF Pro: version: 3.12.0, author: Daan from Daan.dev (latest version: )Public Post Preview: version: 2.10.0, author: Dominik SchillingSOGO Add Script Header Footer: version: 3.9, author: orenhav (SOGO)TablePress: version: 2.3.2, author: Tobias BäthgeTwentyTwenty: version: 1.0, author: Corey MartinUltimate Addons for WPBakery Page Builder: version: 3.19.8, author: Brainstorm ForceUpSolution Core: version: 8.25.3, author: UpSolutionWidgets On Pages: version: 1.8.1, author: Todd HalfpennyWPBakery Page Builder: version: 7.7, author: Michael M - WPBakery.comWP Rocket: version: 3.16, author: WP MediaYoast SEO: version: 22.8, author: Team Yoast wp-plugins-inactive (2)Header Builder: version: 2.5.1, author: UpSolutionMeow Gallery: version: 5.1.6, author: Jordy Meow wp-mediaimage_editor: WP_Image_Editor_Imagickimagick_module_version: 1673imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-12-29 http://www.imagemagick.orgimagick_version: 3.4.3file_uploads: 1post_max_size: 128Mupload_max_filesize: 128Mmax_effective_size: 128 MBmax_file_uploads: 20imagick_limits:imagick::RESOURCETYPE_AREA: 256 GBimagick::RESOURCETYPE_DISK: -1imagick::RESOURCETYPE_FILE: 6144imagick::RESOURCETYPE_MAP: 256 GBimagick::RESOURCETYPE_MEMORY: 128 GBimagick::RESOURCETYPE_THREAD: 40imagick::RESOURCETYPE_TIME: -1imagemagick_file_formats: 3FR, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FITS, FRACTAL, FTS, G3, GIF, GIF87, GRADIENT, GRAY, GROUP4, GV, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, ICB, ICO, ICON, INFO, INLINE, IPL, ISOBRL, JBG, JBIG, JNG, JNX, JPEG, JPG, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAP, MASK, MAT, MATTE, MEF, MIFF, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUVgd_version: bundled (2.1.0 compatible)gd_formats: GIF, JPEG, PNG, WebP, BMP, XPMghostscript_version: 9.26 wp-serverserver_architecture: Linux 5.4.73-1-pve x86_64httpd_software: Apachephp_version: 7.4.30 64bitphp_sapi: cgi-fcgimax_input_variables: 10000time_limit: 120memory_limit: 384Mmax_input_time: 60upload_max_filesize: 128Mphp_post_max_size: 128Mcurl_version: 7.38.0 OpenSSL/1.0.2lsuhosin: falseimagick_availability: truepretty_permalinks: truehtaccess_extra_rules: truecurrent: 2024-06-14T11:01:48+00:00utc-time: Friday, 14-Jun-24 11:01:48 UTCserver-time: 2024-06-14T13:01:46+02:00 wp-databaseextension: mysqliserver_version: 5.7.25client_version: mysqlnd 7.4.30max_allowed_packet: 67108864max_connections: 300 wp-constantsWP_HOME: undefinedWP_SITEURL: undefinedWP_CONTENT_DIR: /var/www/web22442389/html/fotografie/blog/wp-contentWP_PLUGIN_DIR: /var/www/web22442389/html/fotografie/blog/wp-content/pluginsWP_MEMORY_LIMIT: 256MWP_MAX_MEMORY_LIMIT: 384MWP_DEBUG: falseWP_DEBUG_DISPLAY: trueWP_DEBUG_LOG: falseSCRIPT_DEBUG: falseWP_CACHE: trueCONCATENATE_SCRIPTS: undefinedCOMPRESS_SCRIPTS: undefinedCOMPRESS_CSS: undefinedWP_ENVIRONMENT_TYPE: Nicht definiertWP_DEVELOPMENT_MODE: undefinedDB_CHARSET: utf8DB_COLLATE: undefined wp-filesystemwordpress: writablewp-content: writableuploads: writableplugins: writablethemes: writablemu-plugins: writable
       ```
   
 * Komisch ist auch, das angeblich kein Cache aktiv sei, der ist jedoch mit WPRocket
   sehr wohl aktiv. Die Seite ist auch extrem langsam, vor allem im Backend
    -  Dieses Thema wurde vor 2 Jahren, 3 Monaten von [hkruse](https://de.wordpress.org/support/users/hkruse/)
      geändert.
 * Die Seite, für die ich Hilfe brauche: _[[Anmelden](https://login.wordpress.org/?redirect_to=https%3A%2F%2Fde.wordpress.org%2Fsupport%2Ftopic%2Frest-api-fehler%2F%3Foutput_format%3Dmd&locale=de_DE),
   um den Link zu sehen]_

Ansicht von 12 Antworten – 1 bis 12 (von insgesamt 12)

 *  Moderator [Bego Mario Garde](https://de.wordpress.org/support/users/pixolin/)
 * (@pixolin)
 * Moderator (nicht mehr aktiv)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160726)
 * Als erstes solltest du testen, ob der REST-API-Fehler auch gemeldet wird, wenn
   du alle Plugins vorübergehend deaktivierst. (Das geht prima mit dem Plugin [Health Check](https://de.wordpress.org/plugins/health-check/),
   das dafür einen unter Werkzeuge > Website-Zustand einen Problembehandlungsmodus
   anbietet. Damit bekommen andere nichts davon mit, dass du die Plugins deaktivierst.)
   Meine **Vermutung** ist, dass das Firewall-Plugin Probleme bereitet. Es gibt 
   ein gutes Dutzend weiterer Möglichkeiten, zum Beispiel dass der DNS-Server nicht
   richtig konfiguriert ist. Ich würde aber mit den Plugins als wahrscheinlichste
   Ursache anfangen.
 * Zur Installation von WP Rocket prüfe bitte mal, ob in der `wp-config.php` die
   Zeile `define('WP_CACHE', true);` eingetragen ist. Falls nicht, kannst du sie
   direkt unter dem `<?php`-Tag in der ersten Zeile hinzufügen.
 * Seit neuestem weist WordPress außerdem auf die Verwendung eines „persisten Cache“
   hin, also eines serverseitigen Cache der Datenbank-Abfragen zwischenspeichert
   und damit die Performance verbessert. Das hat nichts mit dem Cache der Webseiten
   zu tun, die WP Rocket vornimmt.
 * PHP 7.4 sowie noch ältere Versionen werden von offizieller Stelle nicht mehr 
   mit Sicherheits-Updates versorgt. Es ist aber durchaus denkbar, dass Provider
   Sicherheits-Patches einspielen, da müsstest bzw. solltest du unbedingt nachfragen,
   für den Fall, dass dir eine PHP-Umstellung derzeit noch nicht möglich ist. Grundsätzlich
   empfehlen wir aber, das Webhosting-Paket auf eine aktuelle PHP-Version (derzeit
   mindestens 8.1.x) umzustellen.
    -  Diese Antwort wurde vor 2 Jahren, 3 Monaten von [Bego Mario Garde](https://de.wordpress.org/support/users/pixolin/)
      geändert. Grund: Hinweis persistent Cache
 *  Anonymous User 22040435
 * (@anonymized-22040435)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160727)
 * Ich hatte ebensolche Probleme ([guckst Du hier](https://de.wordpress.org/support/topic/beim-testen-des-rest-api-wurde-ein-unerwartetes-ergebnis-zurueckgegeben/)).
   
   Nach langer Ursachenforschung bestätigte sich, dass es am Host liegt. Was genau,
   ließ sich nicht eruieren, weil der Anbieter wegen fehlender Kooperation die Site
   nun wieder los ist.
 * Sofern die üblichen Verdächtigen also ausgeschlossen werden können (ein paar 
   davon liste ich in dem Beitrag, Punkte A – F), dann würde ich den Hoster damit
   konfrontieren.
 * Wünsche Dir viel Glück, dass der kooperativer ist und im Falle dessen, das es
   wirklich an Server-Einstellungen liegt, auch hilft.
 *  Themenersteller [hkruse](https://de.wordpress.org/support/users/hkruse/)
 * (@hkruse)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160729)
 * Ich habe wie von [@pixolin](https://de.wordpress.org/support/users/pixolin/) 
   vorgeschlagen direkt mal das FireWall Plugin deaktiviert. Der REST API Fehler
   ist damit nun verschwunden!
   In der Config Datei ist die Zeile define(‚WP_CACHE‘,
   true); schon drin, der Fehler im Website Zustand ist nun auch weg.
 * Langsam ist die Seite immer noch, obwohl der google page speed Index sehr hoch
   ist…sehr komisch, besonders das Backend ist sehr lagsam…Matamo geht überhaupt
   nicht mehr, obwohl der direkte Aufruf per URL funktionier.
 *  Moderator [Bego Mario Garde](https://de.wordpress.org/support/users/pixolin/)
 * (@pixolin)
 * Moderator (nicht mehr aktiv)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160730)
 * @youngtimer Leider lässt sich das nicht verallgemeinern. Die Probleme mit deinem
   Webhoster scheinen mir eher die Ausnahme zu sein – deshalb der klassische Hinweis,
   zunächst bei den Plugins mit der Suche nach der Fehlerursache zu beginnen.
   Übrigens
   wäre es schön, wenn du deinen verlinkten Thread noch als gelöst markierst, wenn
   das Thema sich erledigt hat. Viele Helfer hier gehen die Liste ungelöster Threads
   durch und lesen sich in jeden Thread ein um dann am Ende festzustellen, dass 
   das Thema längst abgehakt ist. Wir versuchen hier, mit unseren knappen Ressource
   etwas besser zurecht zu kommen.
 *  Themenersteller [hkruse](https://de.wordpress.org/support/users/hkruse/)
 * (@hkruse)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160731)
 * Danke für Eure Hilfe 🙂
 *  Moderator [Bego Mario Garde](https://de.wordpress.org/support/users/pixolin/)
 * (@pixolin)
 * Moderator (nicht mehr aktiv)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160732)
 * [@hkruse](https://de.wordpress.org/support/users/hkruse/)
 * > Der REST API Fehler ist damit nun verschwunden!
 * Das ist doch schon mal ein erster Erfolg. Wahrscheinlich lässt sich das Plugin
   trotzdem nutzen, wenn du etwas an den Einstellungen änderst. Am besten sprichst
   du dazu den Entwickler an, der für das Plugin ein eigenes Forum betreibt: [https://wordpress.org/support/plugin/ninjafirewall/](https://wordpress.org/support/plugin/ninjafirewall/)
 * > Matamo geht überhaupt nicht mehr, obwohl der direkte Aufruf per URL funktioniert.
 * Hast du das getestet, während das Plugin Borlabs Cookie deaktiviert ist?
 * > Langsam ist die Seite immer noch …
 * Nur im Backend? [Laut GTMetrix](https://gtmetrix.com/reports/www.naturfotografie-kruse.de/HQsVfBBr/)
   ist die Performance im Frontend ausgezeichtet. Zum Prüfen deiner Website kannst
   du das Plugin [Query Monitor](https://wordpress.org/plugins/query-monitor/) installieren,
   das dir auflistet, welche Datenbankabfragen besonders viel Zeit kosten. Eine 
   kleine Warnung vorweg: Das Plugin liefert sehr viele Informationen und richtet
   sich eigentlich an professionelle Programmierung. Also nicht von der Datenflut
   einschüchtern lassen.
 *  Moderator [Bego Mario Garde](https://de.wordpress.org/support/users/pixolin/)
 * (@pixolin)
 * Moderator (nicht mehr aktiv)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160733)
 * Übrigens gibt das Plugin Ultimate Addons for WPBakery Page Builder einen JavaScript-
   Fehler in der Konsole des Browsers aus. Hierzu solltest du den Entwickler des
   Plugins ansprechen. Wir können bei gekauften Themes und Plugins nicht weiterhelfen.
 *  Themenersteller [hkruse](https://de.wordpress.org/support/users/hkruse/)
 * (@hkruse)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160734)
 * Alles klar, danke.
   Ich finde auch das frontend recht langsam, sonst waren die
   Seite eigentlich sofort da…jetzt dauert es oft recht lange, aber im Backend ist
   es besonders deutlich.Ich habe dazu auch mal den Webhoster kontaktiert, eigentlich
   sind die sehr kompetent und auch hilfsbereit.
 *  Moderator [Bego Mario Garde](https://de.wordpress.org/support/users/pixolin/)
 * (@pixolin)
 * Moderator (nicht mehr aktiv)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160738)
 * > Ich finde auch das frontend recht langsam …
 * Subjektives Empfinden ist für uns schwer nachvollziehbar. Rufe ich die Webseiten
   auf, laden sie recht rasch. Das HTML (DOM) der Startseite ist nach 1,15 Sekunden
   geladen und die komplette Website mit immerhin 5.9MB nach 4 Sekunden. Als Richtwert
   werden allgemein 3 Sekunden angenommen, wobei der Wert bei einer fotolastigen
   Website schnell höher ausfallen kann.
 * Das Hintergrundbild „zwei weiße Anemonen“ (`P3240099.jpg`) ist mit 1,22 MB für
   ein Headerbild etwas arg überdimensioniert und das Foto `Vergleich-I-Version3-
   vs.-Version-4-1920x1080.png` mit 2,26 MB viel zu groß. Auch die anderen Fotos
   können sicher noch für die Website optimiert werden. Ich verwende dazu auf meinem
   Mac imageOptim (neulich kam die Rückmeldung, dass es inzwischen bessere Tools
   gibt, ich verwende es trotzdem gerne), es gibt aber auch Online-Dienste wie z.
   B. [https://tinypng.com/](https://tinypng.com/).
 * Ich kenne das Theme Impreza nicht genug, um Aussagen zur Performance zu machen.
   Page Builder verschlechtern in vielen Fällen die Ladezeiten, wobei mir WP Bakery
   auch nicht für Tests zur Verfügung stehen.
 * Einen großen Unterschied kann das Webhosting machen. Wenn du Pech hast, hat man
   deine Website auf einen von vielen Kunden gleichzeitig genutzten Webserver gepackt,
   bei dem schon ein paar häufiger besuchte Websites anderer Kunden einen Flaschenhalseffekt
   auslösen können. Manchmal reicht eine Nachfrage beim Support um auf einen weniger
   stark frequentierten Server gesetzt zu werden.
 * Die geschickte Kombination von peristentem Cache, Cache zur Zwischenspeicherung
   der gerenderten Webseiten und Einstellungen zum Browser-Cache des Webseitenbesuchers
   machen auch nochmal viel aus. Dazu sind wir aber schon [in einem weiteren Thread](https://de.wordpress.org/support/topic/website-zustand/#post-160737)
   im Austausch.
 *  Themenersteller [hkruse](https://de.wordpress.org/support/users/hkruse/)
 * (@hkruse)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160739)
 * ok…ich arbeite daran.
   Nun bekomme ich beim Aufruf der website auf einmal folgenden
   Fehler:**Warning**: Constant WP_MEMORY_LIMIT already defined in**/var/www/web22442389/
   html/fotografie/blog/wp-config.php**on line**90**Das rührte wohl daher, das ich
   auf meinem Server auf php 8.2. umgestellt hatte. Ich habe die Version wieder 
   auf php 7.4. zurückgesetzt, nun geht auch die Seite wieder
    -  Diese Antwort wurde vor 2 Jahren, 3 Monaten von [hkruse](https://de.wordpress.org/support/users/hkruse/)
      geändert.
 *  Moderator [Bego Mario Garde](https://de.wordpress.org/support/users/pixolin/)
 * (@pixolin)
 * Moderator (nicht mehr aktiv)
 * [vor 2 Jahren, 3 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-160746)
 * Die Fehlermeldung sollte noch mehr Informationen beinhalten, was den Fehler ausgelöst
   hat. Scheinbar hast du in der `wp-config.php` eine Zeile `define('WP_MEMORY_LIMIT','
   256M');` eingetragen und vermutlich will ein Cache-Plugin diesen Wert neu setzen,
   was nicht erlaubt ist.
 *  Moderator [threadi](https://de.wordpress.org/support/users/threadi/)
 * (@threadi)
 * [vor 2 Jahren, 2 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-161300)
 * Besteht das Problem noch? Mir fällt nämlich auf, dass hier 2 verschiedene Protokoll
   für die Domain genutzt werden:
 * > REST-API-Endpunkt: [https://www.naturfotografie-kruse.de/wp-json/wp/v2/types/post?context=edit](https://www.naturfotografie-kruse.de/wp-json/wp/v2/types/post?context=edit)
   > 
   > REST-API-Antwort: (http_request_failed) cURL error 7: Failed to connect to 
   > [http://www.naturfotografie-kruse.de](http://www.naturfotografie-kruse.de) 
   > port 443: Connection timed out
 * Einmal mit `https://`, einmal mit `http://`. Das wiederum könnte an einer Fehleinstellung
   vor 3 Wochen liegen und das ganze verursachen. Heute sieht die Einstellung dazu
   aber richtig aus – daher meine Nachfrage.

Ansicht von 12 Antworten – 1 bis 12 (von insgesamt 12)

 Das Thema „REST Api Fehler“ ist für neue Antworten geschlossen.

 * In: [Allgemeine Fragen](https://de.wordpress.org/support/forum/allgemeine-fragen/)
 * 13 Antworten
 * 4 Teilnehmer
 * Letzte Antwort von: [threadi](https://de.wordpress.org/support/users/threadi/)
 * Letzte Aktivität: [vor 2 Jahren, 2 Monaten](https://de.wordpress.org/support/topic/rest-api-fehler/#post-161300)
 * Status: nicht gelöst

## Themen

### Beliebteste Themen

### Unbeantwortete Themen

### Nicht-Support-Themen

### Gelöste Themen

### Ungelöste Themen

### Alle Themen
