Support » Allgemeine Fragen » rest no route (404)

  • Guten Tag,
    ich benutze ein Plugin was die sogenannten „pretty permalinks“ benutzt. Der Entwickler des Plugins schriebt, dass man doch bitte überprüfen soll, ob eine REST-API verfügbar wäre. Das ganze soll mit /wp-json/wp/v1/posts funktionieren. In meinen Fall kommt folgender Fehler:

    {„code“:“rest_no_route“,“message“:“Es wurde keine Route gefunden, die mit der URL und der Request-Methode identisch ist.“,“data“:{„status“:404}}

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Wie sollen wir dir dazu helfen, wenn wir keine Informationen zur Website bekommen?

    Bevor du ein neues Thema (Thread) erstellst

    Thread-Starter bonatz7

    (@bonatz7)

    Was für Informationen wünscht ihr euch denn? Derzeit teste ich die Webseite über localhost. Ich kann euch höchstens den Website-Zustands-Bericht schicken.

    Thread-Starter bonatz7

    (@bonatz7)

    wp-core
    
    version: 6.1.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true wp-paths-sizes wordpress_path: C:\xampp\htdocs\wordpress
    wordpress_size: 55,11 MB (57789107 bytes)
    uploads_path: C:\xampp\htdocs\wordpress/wp-content/uploads
    uploads_size: 100,41 kB (102822 bytes)
    themes_path: C:\xampp\htdocs\wordpress/wp-content/themes
    themes_size: 17,35 MB (18188628 bytes)
    plugins_path: C:\xampp\htdocs\wordpress/wp-content/plugins
    plugins_size: 32,58 MB (34160888 bytes)
    database_size: 3,23 MB (3391488 bytes)
    total_size: 108,37 MB (113632933 bytes) wp-active-theme name: Storefront (storefront)
    version: 4.2.0
    author: Automattic
    author_website: https://woocommerce.com/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, post-thumbnails, automatic-feed-links, custom-logo, menus, html5, custom-background, custom-header, site-logo, title-tag, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-font-sizes, editor-style, responsive-embeds, amp, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, starter-content, widgets
    theme_path: C:\xampp\htdocs\wordpress/wp-content/themes/storefront
    auto_update: Deaktiviert wp-themes-inactive (3) Twenty Twenty-One: version: 1.7, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Three: version: 1.0, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.3, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert wp-plugins-active (3) WooCommerce: version: 7.5.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    WooMinecraft: version: 1.4.5, author: Jerry Wood, Automatische Aktualisierungen deaktiviert
    WP REST API Controller: version: 2.1.2, author: Evan Herman, Automatische Aktualisierungen deaktiviert wp-media image_editor: false
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 40M
    upload_max_filesize: 40M
    max_effective_size: 40 MB
    max_file_uploads: 20
    gd_version: not available
    ghostscript_version: not available wp-server server_architecture: Windows NT 10.0 AMD64
    httpd_software: Apache/2.4.54 (Win64) OpenSSL/1.1.1p PHP/8.2.0
    php_version: 8.2.0 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 120
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 40M
    php_post_max_size: 40M
    curl_version: 7.85.0 OpenSSL/3.0.7
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false wp-database extension: mysqli
    server_version: 10.4.27-MariaDB
    client_version: mysqlnd 8.2.0
    max_allowed_packet: 1048576
    max_connections: 151 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: C:\xampp\htdocs\wordpress/wp-content
    WP_PLUGIN_DIR: C:\xampp\htdocs\wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable

    Na, geht doch … 

    Du verwendest ein Plugin WP REST API Controller – wenn die REST API nicht wie erwartet funktioniert, wäre mein erster Gedanke, das Plugin doch mal zu deaktivieren? 🙂

    Die Fehlermeldung hat aber vermutlich damit zu tun, dass die WordPress API Version 2 nutzt. Der Link muss entsprechend wp-json/wp/v2/posts heißen.

    Thread-Starter bonatz7

    (@bonatz7)

    Danke für die Rückmeldung.

    Ich habe das Plugin WP REST API Controller zunächst deaktiviert. Das Plugin möchte dennoch nicht arbeiten. Ich habe euch die config von dem Plugin unten eingefügt. Die 2 URLs die er vorgeschlagen hat, schlagen bei mir immer fehl. Egal ob ich v1 oder v2 benutze.

    Thread-Starter bonatz7

    (@bonatz7)

    Egal ob ich eins von den unteren Beispielen nehme, es kommt immer der selbe Fehler (Siehe oben)
    /wp-json/wmc/v1/server/, /wp-json/wmc/v2/server/
    /index.php?rest_route=/wmc/v1/server/, /index.php?rest_route=/wmc/v2/server/

    @bonatz7

    Hast du das denn einmal ausprobiert, was in deinem Screenshot (config des Plugins) steht?

    prettyPermalinks: false (statt true)

    Thread-Starter bonatz7

    (@bonatz7)

    Ja leider ohne Erfolg. Dort steht immer Status: Bad, 400 Bad Request

    Moderator Michi91

    (@michi91)

    Was passierr wenn du http://localhost/wp-json/wp/v2/posts aufrufst? Auch nen 404?

    Edit: Und dein Minecraft-Server läuft auch auf localhost?

    • Diese Antwort wurde geändert vor 1 Jahr, 2 Monaten von Michi91.
    Thread-Starter bonatz7

    (@bonatz7)

    Wenn ich http://localhost/wp-json/wp/v2/posts aufrufe kommt folgender Fehler. Der Minecraft-Server läuft selbstverständlich auf localhost.

    Kunststück. Wenn du in htdocs/wordpress installierst, bekommst du bei Abfrage von http://localhost/wp-json/wp/v2/posts ein 404 – File not found. Probier mal http://localhost/wordpress/wp-json/wp/v2/posts.

    Thread-Starter bonatz7

    (@bonatz7)

    Danke für die Rückmeldung.

    Wenn ich http://localhost/wordpress/wp-json/wp/v2/posts eingebe kommt folgendes.

    Na super – das ist doch eine REST Antwort. Schau dir das in Firefox an, dann ist es (auch ohne Browser-Erweiterung) besser lesbar.

    Frage damit beantwortet?

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „rest no route (404)“ ist für neue Antworten geschlossen.