Support » Allgemeine Fragen » Safari Browser zerstört Webseite

  • Hallo Leute,
    bin ziemlich neu hier und ich hoffe Ihr könnt mir helfen. Bin echt verzweifelt und stehe voll auf dem Schlauch …

    Folgendes Problem:
    Ich habe mit WP eine Seite erstellt, die im Chrome, FF, und Edge einwandfrei funktioniert. Nur Safari macht mir Probleme – der Browser „zerreißt“ alle Seiten (s. Screenshots oder hvv-neufahrn.de).
    Alle Browser sind auf dem neuesten Stand (heute, 06.04.20)
    Das verwendete Theme ist OceanWP (neuester Stand) plus Elementor PRO

    Safari Console meldet mir folgende Fehler:

    1) ReferenceError: Can’t find variable: requestAnimationFrame (frontend.min.js:2 – hat anscheinend mit Elementor PRO zu tun)
    2) TypeError: ‚undefined‘ is not a function (evaluating ‚t.getAttribute(n)‘) (main.min.js:1 – hat anscheinend mit OceanWP zu tun)
    3) ReferenceError: Can’t find variable: requestAnimationFrame (frontend.min.js:2 – hat anscheinend mit Elementor PRO zu tun)
    4) ReferenceError: Can’t find variable: MutationObserver (rechaptcha_de.js:303 – hat anscheinend mit recaptch V.3 zu tun)
    5) ReferenceError: Can’t find variable: requestAnimationFrame (frontend.min.js:2 – hat anscheinend mit Elementor PRO zu tun)

    Jetzt bin ich nicht so der JavaScript-Typ – eigentlich überhaupt nicht …
    Vielleicht kann mir jemand helfen, so daß die Seite auch im Safari ordentlich angezeigt wird.
    Was habe ich schon versucht:
    – als Erstes die Suchfunktion hier im Forum – leider nichts gefunden
    – dann habe ich mal alle Plugins deaktiviert – keine Besserung
    – dann bin ich auf das Standarttheme 2020 gewechselt – keine Besserung
    – danach zurück auf OceanWP und die Plugins einzeln wieder aktiviert – war klar – keine Besserung ….

    HIIIILLFFEEEEEEE!

    Danke schon mal im Voraus
    Robert

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das verwendete Theme ist OceanWP (neuester Stand) plus Elementor PRO

    Für den Einstieg hier im Forum ist es sicherlich hilfreich, wenn du dich zunächst ein wenig umschaust und auch mit unseren Forenregeln vertraut machst. So können wir dir z.B. bei gekauften Themes und Plugins (hier: Elementor Pro) nur sehr allgemein weiterhelfen, weil sie uns nicht kostenlos zur Verfügung stehen. Ich müsste mir selbst erst das Plugin oder Theme kaufen, um dir dann kostenlos den Support anzubieten, für den du bereits beim Kauf einen Dritten bezahlt hast.

    Bitte wende dich an den Support des Theme-Entwicklers.

    Thread-Starter rdfnma

    (@rdfnma)

    Hallo Bego,
    danke für die schnelle Antwort.
    Ich weiß durch Eure Forenregeln, dass Ihr keine spezifische Antwort zu gekauften Themes und Plugins geben könnt oder wollt, aber auch eine allgemeiner Hinweis würde mir helfen.
    Danke
    Robert

    Hallo,

    Ich weiß durch Eure Forenregeln, dass Ihr keine spezifische Antwort zu gekauften Themes und Plugins geben könnt oder wollt

    Eine solide Antwort können wir nur geben, wenn wir z. B. ein Theme oder Plugin zur Verfügung haben. Bei gekauften Themes oder Plugins ist das allerdings logischerweise nicht möglich. Daher können wir hier auch gar keine Antwort geben und daher auch der Hinweis von @pixolin auf die Entwickler.
    Es würde dir sicher nicht helfen, wenn wir hier als „allgemeinen Hinweis“ schreiben würden, dass eben jeder Browser anders reagieren kann 😉 … und mehr kann ich im Moment dazu auch nicht sagen.
    Viele Grüße
    Hans-Gerd

    Hast Du schon was geändert? Ich habe Deine Seite mit Safari geöffnet, die sieht eigentlich richtig aus. Mein Safari (High Sierra) ist nicht das aktuellste, mag sein, dass es bei neueren Versionen anders aussieht.

    Thread-Starter rdfnma

    (@rdfnma)

    Hallo hupe13,
    nein ich habe noch nichts geändert. Warte noch auf das Feedback von Elementor und OceanWP.
    Das Seltsame ist, dass auf meinem IPhone 9 die Seite richtig dargestellt wirdauf dem Desktop und auf dem Pad zerreißt es mir das Layout, obwohl überall die neueste Version von Safari installiert ist …

    Mein Safari (High Sierra) ist nicht das aktuellste

    Mojave bzw. Catalina kann ich gerade nicht testen (Corona).
    Welche Safari-Version nutzt Du? Vielleicht hat Apple da was „verschlimmbessert“.

    Ich kann eigentlich auch keine ungewöhnlich aussehenden Dinge entdecken. Nur der Hinweis zur aktuellen Lage (roter Button ganz oben) hängt zu weit oben.

    Browser-Cache mal gelöscht?

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Safari Browser zerstört Webseite“ ist für neue Antworten geschlossen.