Support » Allgemeine Fragen » schlechte Speed – keinen Client-Cache-Antwort-Header erkannt

  • Gelöst wildwuchs123

    (@wildwuchs123)


    Hallo in die Runde,
    Ich bin noch am Aufbau meiner Website und im Wartungsmodus. Ich bin Laie, aber geb mein Bestes.
    Alle Plugins, Theme und WordPressversion sind auf dem neuesten Stand.

    Der Websitezustand meldet
    1 kritisches Problem: Seitencache wurde erkannt, aber die Antwortzeit des Servers ist langsam:

    • Die mittlere Antwortzeit des Servers betrug 828 Millisekunden. Sie sollte unter dem empfohlenen Schwellenwert von 600 Millisekunden liegen.
    • Es wurden keine Client-Cache-Antwort-Header erkannt.
    • Es wurde ein Seiten-Cache-Plugin erkannt.

    und eine Empfehlung: Du solltest eine persistenten Objekt-Cache verwenden.

    Ich habe heute WP Optimize installiert und die Datenbanken bereinigt, um das Problem zu beheben. Doch das hatte keine Auswirkungen auf die Antwortzeit.
    Ich habe die Plugins All-in-One Wp Security und Header Security Advanced deaktiviert, doch keine Änderung.
    Kann das kritische Problem mit dem persistenten Objekt-Cache zusammen hängen? Jetzt bin ich mit meinem Latein am Ende und würde mich über Unterstützung sehr freuen.
    Hier ist der Zustandsbericht:

    ### wp-core ###
    
    version: 6.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: undefined
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/38/d780433205/htdocs/imago
    wordpress_size: 266,03 MB (278951475 bytes)
    uploads_path: /homepages/38/d780433205/htdocs/imago/wp-content/uploads
    uploads_size: 16,53 MB (17332502 bytes)
    themes_path: /homepages/38/d780433205/htdocs/imago/wp-content/themes
    themes_size: 26,49 MB (27781905 bytes)
    plugins_path: /homepages/38/d780433205/htdocs/imago/wp-content/plugins
    plugins_size: 130,53 MB (136866557 bytes)
    database_size: 11,05 MB (11583488 bytes)
    total_size: 450,63 MB (472515927 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: OceanWP (oceanwp)
    version: 3.3.6
    author: OceanWP
    author_website: https://oceanwp.org/about-oceanwp/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: /homepages/38/d780433205/htdocs/imago/wp-content/themes/oceanwp
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Two: version: 1.3, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (18) ###
    
    All In One WP Security: version: 5.1.0, author: All In One WP Security & Firewall Team, Automatische Aktualisierungen deaktiviert
    Antispam Bee: version: 2.11.1, author: pluginkollektiv, Automatische Aktualisierungen deaktiviert
    Autoptimize: version: 3.1.3, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Broken Link Checker: version: 1.11.20, author: WPMU DEV, Automatische Aktualisierungen deaktiviert
    Coming Soon Page, Maintenance Mode, Landing Pages & WordPress Website Builder by SeedProd: version: 6.15.6, author: SeedProd, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.6.4, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.8.1, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Envato Elements: version: 2.0.11, author: Envato, Automatische Aktualisierungen deaktiviert
    Headers Security Advanced & HSTS WP: version: 5.0.06, author: 🐙  Andrea Ferro, Augusto Bombana, Automatische Aktualisierungen deaktiviert
    Honeypot for Contact Form 7: version: 2.1.1, author: Nocean, Automatische Aktualisierungen deaktiviert
    MailPoet: version: 3.103.1, author: MailPoet, Automatische Aktualisierungen deaktiviert
    Ocean Extra: version: 2.0.6, author: OceanWP, Automatische Aktualisierungen deaktiviert
    Real Cookie Banner: version: 3.4.0, author: devowl.io, Automatische Aktualisierungen aktiviert
    Two Factor: version: 0.7.3, author: Plugin Contributors, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.23, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WP-Optimize - Clean, Compress, Cache: version: 3.2.9, author: David Anderson, Ruhani Rabin, Team Updraft, Automatische Aktualisierungen deaktiviert
    WP-Sweep: version: 1.1.5, author: Lester 'GaMerZ' Chan, Automatische Aktualisierungen deaktiviert
    WPS Hide Login: version: 1.9.6, author: WPServeur, NicolasKulka, wpformation, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 256M
    upload_max_filesize: 256M
    max_effective_size: 256 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-088 x86_64
    httpd_software: Apache
    php_version: 7.4.32 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 912M
    max_input_time: -1
    upload_max_filesize: 256M
    php_post_max_size: 256M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 7.4.32
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/38/d780433205/htdocs/imago/wp-content
    WP_PLUGIN_DIR: /homepages/38/d780433205/htdocs/imago/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 912M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Herzlichen Dank und Gruß

    • Dieses Thema wurde geändert vor 2 Monaten, 2 Wochen von Hans-Gerd Gerhards. Grund: Formatierung als Code korrigiert

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hallo,

    Ich habe heute WP Optimize installiert und die Datenbanken bereinigt, um das Problem zu beheben. Doch das hatte keine Auswirkungen auf die Antwortzeit.

    Hast du denn dabei auch den Cache aktiviert?

    Du solltest eine persistenten Objekt-Cache verwenden.

    Das ist eine Empfehlung, die seit 6.1 beim Bericht angezeigt wird. Um zu klären, welche Möglichkeiten bestehen, solltest du dich mit deinem Hoster in Verbindung setzen.

    In einem umfangreichen Thread hier im Forum wurde das Thema bereits diskutiert. Weitere Hinweise findest du dazu evtl. in einem Beitrag von mir.

    Möglicherweise hilft es auch, wenn du zunächst alle Plugins deaktivierst, dann Plugin für Plugin aktivierst und anschließend die Meldung im Bericht prüfst.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von Hans-Gerd Gerhards. Grund: Tippfehler

    Die neue WordPress-Version hat die Zwischenspeicherung der Datenbankabfragen verbessert. Damit das auch genutzt werden kann, muss aber ein Plugin installiert werden, dass den serverseitigen Cache einbindet – z.B. OPcache Manager, wenn der Webhoster OPcache verwendet. Es gibt noch andere serverseitige Cache-Anwendungen wie APCu oder Redis, zu denen es ebenfalls Plugins gibt. Was auf deinem Webserver genutzt wird, kann dir der Support des Webhosters sagen (wenn es nicht schon in den Hilfedateien genannt wird). Bei IONOS wird wohl OPcache genutzt, muss aber durch Einträge in der php.ini aktiviert werden, wenn ich den Beitrag PHP 7 und OPcache beschleunigen Websites spürbar richtig verstehe.

    Mit dem serverseitigen Cache werden die Datenbankabfragen im RAM des Webservers vorgehalten, was die Ausführung weiterer Skripte beschleunigt. Das Plugin WP Optimize bietet eine ergänzende Möglichkeit, die bereits gerenderten Daten zu minimieren, zusammenzufassen und in einem Zwischenspeicher abzulegen. Weil zwei Cache noch nicht reichen 😉 gibt es dann noch die Möglichkeit, mit den Webseiten Informationen zur Zwischenspeicherung im Browser (Browser-Cache) mitzuschicken, was WP Optimize ebenfalls übernimmt.

    Vorsicht bei Nutzung eines Webshops, z.B. mit WooCommerce – du möchtest nicht, dass der Warenkorb eines Kunden beim Besuch des nächsten Kunden als zwischengespeicherte Version der Webseite angezeigt wird. In der Dokumentation von WooCommerce wird beschrieben, welche Teile nicht gecacht werden dürfen.

    Thread-Starter wildwuchs123

    (@wildwuchs123)

    Herzlichen Dank für die liebe Unterstützung. Beide Problemfälle sind erfolgreich behoben.

    LG

    @wildwuchs123
    super – freut uns. Danke für die Rückmeldung und “Gelöst”-Markieren. 👍

    Beide Problemfälle sind erfolgreich behoben.

    Vielleicht kannst du noch für Mitleser kurz beschreiben, wie du genau die Problemfälle lösen konntest.

    Thread-Starter wildwuchs123

    (@wildwuchs123)

    Gern teile ich mein Wissen bei der Problembehandlung. In diesem Fall hatte ich darauf verzichtet, da mir nicht klar ist, wie und ob hier die Dinge zusammen hängen. Aber vielleicht ist es trotzdem hilfreich.

    1. Thema – Antwortzeit des Servers ist langsam:
    Den Cache von WP-Optimize hatte ich aktiviert. Habe mehrmals alle Plugins deaktiviert und wieder aktiviert wie mir hier geraten wurde. Es war keinem bestimmten Plugin zuordenbar. Ab einer gewissen Anzahl von aktivierten Plugins wurde das kritische Problem „Seitencache wurde erkannt, aber die Antwortzeit des Servers ist immer noch langsam“ immer wieder angezeigt so wie vorab.

    Ich habe verschiedene Einstellungen im Plugin WP-Optimize getestet, ohne Veränderung.

    2. Thema – persistenter Cache:
    Mein absoluter Pfad in der php.ini konnte keine Verbindung zum Ordner opcache herstellen. Der Support von IONOS hat festgestellt, das die php.ini im falschen Ordner lag und sie angeblich in den Ordner wp-admin umgelagert und damit das Problem gelöst.

    Nach Überprüfung meinerseits liegt die php.ini aber weiterhin im Hauptverzeichnis so wie vorher und nicht im besagten Ordner wp-admin, aber die entsprechenden Einträge sind jetzt in ihr vorhanden.

    Naja die Ursachenbehebung durch den technischem Support wurde vom Telefonsupport offensichtlich nicht korrekt an mich weiter gegeben. Sorry, deshalb kann ich hier keine konkreten Lösungswege benennen. Laut Änderungsdatum der Daten im Webspace sieht es eher so aus als wäre es umgekehrt – die vorige php.ini aus dem Hauptverzeichnis wurde durch eine 2. php.ini aus dem wp admin-Ordner ersetzt.

    Was auch immer der technische Support verändert hat…es hatte wohl Auswirkungen auf die Fehlermeldung zum 1. Thema. Denn nun gibt es AUCH keine Probleme mehr mit der Antwortzeit des Headers.

    Bin erstmal froh, das es jetzt soweit funktioniert.

    Leider gibt es bereits das nächste Thema, was durch die Aktivierung des Plugins OPcache Manager ausgelöst wurde. Dazu eröffne ich einen neuen Thread.

    Liebe Grüße
    Annett

    Hallo Annett,
    danke für die umfangreiche Beschreibung der Problemlösung. 👍

    Viele Grüße
    Hans-Gerd

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)