Support » Themes » Schrift lässt sich nicht verkleinern

  • Hallo zusammen,

    ich kriege meine Basischrift einfach nicht kleiner. Ich verwende Gutenberg und Astra. Meine globale Schrift im Basistext ist für die mobile Ansicht leider viel zu groß, aber sie wird nicht kleiner angezeigt, egal, welche Schriftgröße ich in den globalen Einstellungen setze. Mit den Zeilenabständen lässt sich spielen, aber mit der Schriftgröße nicht. Woran liegt das?

    Danke und LG Madlen

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hallo Madlen,

    in welchen „globalen Einstellungen“ machst Du das?

    Im Customizer von „Astra“ gibt es einen Punkt „Typografie“ und dann „Basis-Schrift“ bzw. die einzelnen Headings (1-6).

    Viele Grüße,
    Ray

    @ray Die Einstellungen für die Typografie hat @madlenschrimpf wohl gefunden. Wenn sie schreibt „Meine globale Schrift im Basistext ist für die mobile Ansicht leider viel zu groß.“ interpretiere ich das so, dass die Schriftgröße für die Desktop-Ansicht passt, aber ihr mobil zu groß erscheint. (Das sehe ich übrigens nicht so, weil ich selbst mit Lesebrille auf meinem Smartphone mit kleineren Schriftgrößen eher Mühe habe, den Text zu lesen. Aber das ist natürlich subjektiv und jedem selbst überlassen.)

    Um die Schriftgöße nur für Mobilgerägte kleiner zu bekommen, wäre die Verwendung einer zusätzlichen CSS-Regel eine Option, sinngemäß sowas wie …

    
    @media (max-width: 544px) {
      h1, .entry-content h1 {
        font-size: 24px !important;
      }
      .has-medium-font-size {
        font-size: 10px !important;
      }
    }

    (An dieser Stelle mal wieder der freundliche Hinweis, dass wir hier keine Grundlagen vermitteln wollen und Fragen zu CSS-Regeln off topic sind. Wir stellen nicht auf Zuruf irgendwelche CSS-Regeln zur Verfügung. Aus dem beispielhaften Code hier sollen andere Teilnehmende bitte keine „Ansprüche“ irgendwelcher Art ableiten.)

    … übrigens bemängelt Google auch zu kleine Schriftgrößen bei der Mobilansicht und bewertet das mit einem schlechteren Suchmaschinen-Ranking. Der Theme-Entwickler von Astra hat dazu ein eigenes Hilfe-Dokument: Fix Mobile Usability Issues on Astra

    Hi,

    wenn man in dem Bereich des Customizers ist und zur Schriftgröße kommt, kann man auf das Icon mit dem Bildschirm klicken und auf die mobile Ansicht wechseln. Dort stellt man dann einfach die Schriftgröße für die mobile Ansicht ein (sowohl Tablet als auch Smartphone).

    Ups, das habe ich tatsächlich übersehen. Zu besseren Orientierung hier ein Screenshot des Menüs:

    Screenshot
    Thread-Starter madlenschrimpf

    (@madlenschrimpf)

    Hallo zusammen,

    danke euch. Genau – in diesem Menü bin ich unterwegs und habe die verschiedenen Devices auch gefunden. Wenn ich zu Mobile wechsele und die Schriftgröße ändere, tut sich leider nichts. Mit dem Zeilenabstand kann ich tatsächlich spielen. Aber die Schriftgröße bleibt gleich.

    So sah es aktuell auf meinem Handy aus: https://orgamami.de/wp-content/uploads/IMG_1986.png

    Ich habe nun den Tipp mit dem CSS von @pixolin ausprobiert und das hat tatsächlich gut geklappt. Mir wäre es zwar lieber, es würde über das Menü funktionieren, aber mit der Lösung komme ich klar.

    Vielen Dank an alle!

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)