Support » Plugins » Scroll to Top & Lightbox spinnen / Darstellungsfehler

  • Gelöst swinit

    (@swinit)


    Hallo! Folgende Probleme habe ich seit dem Wochenende festgestellt:
    Mein Plugin „To Top“ oder auch „WP Front Scroll“ hängen seit neuestem nur noch unten im Footer herum, was ja absolut nicht Sinn der Sache ist. Komischerweise wenn ich im WP-Admin bearbeite, funktioniert alles einwandrei und Fehler sind nicht ersichtlich. Mir ist das nur durch Zufall aufgefallen, da ich die Seite immer wieder auf verschiedenen Geräten und Browsern teste. Ich dachte es liegt am Plugin von WP Front Scroll, weshalb ich das einfach austauschte durch „To Top“. Aber das Problem blieb.
    Im gleichen Zuge fiel mir auf, dass in der Lightbox bei allen Gallerien die Icons der Pfeile nur noch als Kästchen dargestellt werden. Puh, ich habe absolut bei beiden Fehler keine Ahnung woran es liegt und bin ziemlich überfordert mittlerweile.

    Vielleicht kann mir jemand helfen?
    Danke vorab schon mal.

    🙂

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Hallo,
    deaktiviere doch mal bitte Autoptimize und teste mal, ob es dann funktioniert.
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Das lässt sich auch ganz einfach testen, wenn du an die Webadresse /?ao_noptimize=1 anhängst. Dann wird der „Back to top“-Pfeil hübsch unten rechts angezeigt, sobald auch nur ein paar Pixel nach unten gescrollt wird.

    Autoptimize ist ein cooles Plugin, aber (auch) in diesem Fall leider fehlerhaft eingerichtet.

    Thread-Ersteller swinit

    (@swinit)

    Hallo Bego Mario Garde, tatsache verschwindet der Fehler, wenn ich das /?ao_noptimize=1 hinter der Seite schreibe. Aber wieso entsteht überhaupt der Fehler, nach Wochen plötzlich?

    Ich habe auch kurz mal jetzt autoptimize deaktiviert. Diese Fehler sind dann auch weg. Aber das ist doch nicht die Lösung des Problems am Ende oder?

    Ich benutze Autoptimize jetzt schon eine ganz Weile und dieses Problem tauchte ganz plötzlich letzte Woche auf.

    Thread-Ersteller swinit

    (@swinit)

    Hier der Bericht bei inaktivem Autoptimize:

    
    ### wp-core ###
    
    version: 5.6.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/vhosts/grafikdesign-tini.de/httpdocs
    wordpress_size: 331,44 MB (347537402 bytes)
    uploads_path: /var/www/vhosts/grafikdesign-tini.de/httpdocs/wp-content/uploads
    uploads_size: 75,14 MB (78790920 bytes)
    themes_path: /var/www/vhosts/grafikdesign-tini.de/httpdocs/wp-content/themes
    themes_size: 5,73 MB (6010195 bytes)
    plugins_path: /var/www/vhosts/grafikdesign-tini.de/httpdocs/wp-content/plugins
    plugins_size: 92,02 MB (96494845 bytes)
    database_size: 16,11 MB (16893421 bytes)
    total_size: 520,45 MB (545726783 bytes)
    
    ### wp-dropins (1) ###
    
    maintenance.php: true
    
    ### wp-active-theme ###
    
    name: Pekko WP (pekko-wp)
    version: 1.1
    author: CocoBasic
    author_website: https://www.cocobasic.com
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, align-wide, title-tag, editor-style, widgets, menus
    theme_path: /var/www/vhosts/grafikdesign-tini.de/httpdocs/wp-content/themes/pekko-wp
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    GK Portfolio: version: 1.5.3, author: GavickPro, Automatische Aktualisierungen deaktiviert
    Pekko WP Child: author: CocoBasic, version: (undefined), Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.1, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (16) ###
    
    Akismet Anti-Spam: version: 4.1.8, author: Automattic, Automatische Aktualisierungen deaktiviert
    CocoBasic - Pekko Elementor Widgets: version: 1.0, author: CocoBasic, Automatische Aktualisierungen deaktiviert
    CocoBasic - Pekko WP: version: 1.0, author: CocoBasic, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.4, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.1.1, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Elementor - Header, Footer & Blocks: version: 1.5.6, author: Brainstorm Force, Nikhil Chavan, Automatische Aktualisierungen deaktiviert
    Kirki Customizer Framework: version: 3.1.6, author: David Vongries, Automatische Aktualisierungen deaktiviert
    Power-Ups for Elementor: version: 1.2, author: RexDot, Automatische Aktualisierungen deaktiviert
    Premium Addons for Elementor: version: 4.2.4, author: Leap13, Automatische Aktualisierungen deaktiviert
    To Top: version: 2.2, author: Catch Plugins, Automatische Aktualisierungen deaktiviert
    Under Construction: version: 3.88, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.16.47, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    Widget Data - Setting Import/Export Plugin: version: 1.5.3, author: Voce Communications - Kevin Langley, Sean McCafferty, Mark Parolisi, Automatische Aktualisierungen deaktiviert
    WordPress Importer v2: version: 2.0, author: wordpressdotorg, rmccue, Automatische Aktualisierungen deaktiviert
    WP Reset: version: 1.86, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 15.9, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (5) ###
    
    Async JavaScript: version: 2.20.12.09, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Autoptimize: version: 2.8.1, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Sticky Menu (or Anything!) on Scroll: version: 2.31, author: WebFactory Ltd, Automatische Aktualisierungen deaktiviert
    WPBakery Page Builder: version: 5.5.2, author: Michael M - WPBakery.com, Automatische Aktualisierungen deaktiviert
    WPFront Scroll Top: version: 2.0.2, author: Syam Mohan, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1650
    imagemagick_version: ImageMagick 6.7.2-7 2017-03-22 Q16 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 2M
    max_effective_size: 2 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 4 GB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 1536
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 8.70
    
    ### wp-server ###
    
    server_architecture: Linux 2.6.32-358.6.1.el6.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.3.25 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 2M
    php_post_max_size: 8M
    curl_version: 7.19.7 NSS/3.44
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.1.73
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/vhosts/grafikdesign-tini.de/httpdocs/wp-content
    WP_PLUGIN_DIR: /var/www/vhosts/grafikdesign-tini.de/httpdocs/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Moderator Bego Mario Garde

    (@pixolin)

    Ich habe auch kurz mal jetzt autoptimize deaktiviert. Diese Fehler sind dann auch weg. Aber das ist doch nicht die Lösung des Problems am Ende oder?

    Dazu hatte ich auch etwas geschrieben:

    Autoptimize ist ein cooles Plugin, aber (auch) in diesem Fall leider fehlerhaft eingerichtet.

    Wenn du Autoptimize nutzen möchtest, solltest du dich mehr mit den Einstellungsoptionen auseinandersetzen. Vielleicht kannst du deinen Webhoster aber auch überreden, HTTP/2 zu verwenden?

    Thread-Ersteller swinit

    (@swinit)

    Hm, dass hilft mir grundsätzlich beim Problem ja jetzt nicht weiter.
    Mit den Einstellungsoptionen bei Autoptimize habe ich mich tatsächlich umfangreich informiert. Ich habe mich da an den Optionen vom Beitrag von Kinsta gerichtet, da dies das Beste rausgeholt hat.

    Moderator Bego Mario Garde

    (@pixolin)

    Hm, dass hilft mir grundsätzlich beim Problem ja jetzt nicht weiter.

    Doch, eigentlich schon.

    Du hast ein Problem auf deiner Website.
    Wenn du das Plugin Autoptimize dekativierst, hast du auf deiner Website kein Problem.
    Wenn du das Plugin Autoptimize weiter verwenden möchtest, musst du die Einstellungen ändern.
    Scheinbar werden zum Beispiel, wenn Autoptimize aktiviert ist, die CSS-Regeln aus der Datei wp-content/plugins/to-top/public/css/to-top-public.css nicht geladen. Du musst Autoptimize so konfigurieren, dass dieses Stylesheet nicht mit anderen zusammengefasst und komprimiert wird. Oder du verzichtest auf das Plugin Autoptimize, was auch kein Beinbruch ist. Vielleicht kann dein Webhoster auch den Server auf HTTP/2 umschalten, das zu einem Teil die Funktionalität von Autoptimize übernimmt.

    Thread-Ersteller swinit

    (@swinit)

    Scheinbar werden zum Beispiel, wenn Autoptimize aktiviert ist, die CSS-Regeln aus der Datei wp-content/plugins/to-top/public/css/to-top-public.css nicht geladen. Du musst Autoptimize so konfigurieren, dass dieses Stylesheet nicht mit anderen zusammengefasst und komprimiert wird.

    Das habe ich gemacht, trotzallem bleibt der Fehler bestehen 🙁
    Auf Autoptimize möchte ich ungern verzichten, da ich viele Vorteile im Plugin sehe 🙂

    Thread-Ersteller swinit

    (@swinit)

    Zudem ist die Seite eigentlich auf https bereits umgestellt ^^

    Moderator Bego Mario Garde

    (@pixolin)

    HTTP/2 ist etwas anderes als HTTPS.

    Ansonsten kann ich dir da nicht weiterhelfen.

    Thread-Ersteller swinit

    (@swinit)

    Also vielleicht hat ja noch jemand paar Ideen oder Lösungsvorschläge, nebenbei schreibe ich noch im Forum von Autoptimize selbst. Würde mich freuen, wenn ich hier noch paar Hilfreiche Tipps oder allgemein Lösungvorschläge bekomme 🙂 Danke!

    Bezogen auf das Problem mit Autoptimize bist du wohl beim Entwickler in besten Händen. Aber ein wenig Geduld muss man da schon mitbringen.
    Bezogen auf HTTP/2 hatte dir Bego ja bereits geraten, dich an den Hoster zu wenden. Das wäre (ebenfalls) ein Ansatz, der wirklich wichtig wäre. Einen Test, ob HTTP/2 unterstützt wird, kannst du auf der folgenden Seite durchführen und als Argumentation gegenüber dem Hoster nutzen.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)