Support » Allgemeine Fragen » Seite bzw. Inhalt wird auf mobiler Ansicht nicht angezeigt.

  • Gelöst arminsheak

    (@arminsheak)


    Guten Abend

    Ich habe ein Problem mit der oben genannten Webseite. Seit länger Zeit werden die Seiten https://www.morscher.ch/projekte und https://www.morscher.ch/kunden auf der mobilen Version nicht angezeigt. Als Vorschau direkt auf WordPress werden die Seiten jedoch auch als mobile Anzeige richtig dargestellt.
    Ich habe bereits versucht das Theme oder das grid elements template zu ändern. Hat alles nichts gebracht. Beim Umstellen auf dem Browser auf ‚Desktop Seite‘ wird auf dem Handy auch kein Inhalt angezeigt. (wurde auf verschiedenen Geräten und Browsern getestet)
    Was könnte die Ursache für diesen Fehler Sein?

    Ein ähnliches Problem konnte ich vor einiger zeit mit dem Plugin ‚Enable jQuery Migrate Helper‘ beheben. Dieses Problem wurde (vermutlich) mit einem Update von Envato behoben.
    Kann es sein, dass dieses mal ein ähnliche Ursache für das Problem Verantwortlich ist (WordPress Update o.Ä.)?

    Ich bedanke mich bereits im Voraus für die Hilfe

    • Dieses Thema wurde geändert vor 5 Monaten, 2 Wochen von arminsheak.
    • Dieses Thema wurde geändert vor 5 Monaten, 2 Wochen von arminsheak.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Auch auf meinem Desktop schaffe ich es, dass die Seite leer bleibt. Allerdings scheint es ein Problem mit dem Plugin JS-Comoser zu geben:

    Uncaught ReferenceError: _ is not defined
    <anonymous> https://www.morscher.ch/wp-content/plugins/js_composer/assets/js/dist/vc_grid.min.js:10
    <anonymous> https://www.morscher.ch/wp-content/plugins/js_composer/assets/js/dist/vc_grid.min.js:10

    Thread-Starter arminsheak

    (@arminsheak)

    Danke für die schnelle Antwort, jedoch kann ich damit nicht wirklich viel anfangen. Wir Arbeiten mit dem WP Bakery builder. könnte es sein, dass dort ein Problem vorliegt oder meintest du das? Es sind wirklich nur die beiden Seiten betroffen, die ein Template vom Bakery builder haben. was könnte dort falsch eingestellt sein was mir die mobile Ansicht verhaut?
    Auf dem Desktop funktioniert die Seite eigentlich einwandfrei. Es sind wirklich nur die beiden Seiten die Auf der mobilen Ansicht nicht funktionieren. Dabei wird nicht angezeigt, dass die Seite leer ist, sondern einfach ein schwarzer bildschirm mit dem Burgermenu ohne Fehlermeldung.

    Hallo,
    wir können dir bei gekauften Themes oder Plugins (hier WP Bakery) so gut wie gar nicht helfen, weil sie uns nicht zur Verfügung stehen. Wir müssten sonst bei jeder Frage erst einmal das entsprechende Theme oder Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Du solltest dich in dem Fall an den Entwickler wenden. Lies bitte auch mal in der FAQ II, 1b zu diesem Thema.

    Sind alle Plugins und das Theme auf dem neuesten Stand?

    Vielleicht können wir mehr dazu sagen, wenn du uns den Bericht sendest:
    Den Bericht findest du unter Werkzeuge > Websitezustand > Info. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Viele Grüße
    Hans-Gerd

    Thread-Starter arminsheak

    (@arminsheak)

    Hallo,

    Danke für die Antwort. Werde mich also an den Support von WP Bakery Plugin wenden. Das Problem liegt vermutlich dort.

    Vielen Dank für die Hilfe!

    Hier noch der Bericht:

    
    ### wp-core ###
    
    version: 5.9.3
    site_language: de_CH_informal
    user_language: de_CH_informal
    timezone: +01:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/vhosts/morscher.ch/httpdocs
    wordpress_size: 230.48 MB (241677153 bytes)
    uploads_path: /var/www/vhosts/morscher.ch/httpdocs/wp-content/uploads
    uploads_size: 718.79 MB (753710246 bytes)
    themes_path: /var/www/vhosts/morscher.ch/httpdocs/wp-content/themes
    themes_size: 108.09 MB (113343104 bytes)
    plugins_path: /var/www/vhosts/morscher.ch/httpdocs/wp-content/plugins
    plugins_size: 75.01 MB (78650338 bytes)
    database_size: 7.60 MB (7964506 bytes)
    total_size: 1.11 GB (1195345347 bytes)
    
    ### wp-dropins (1) ###
    
    maintenance.php: true
    
    ### wp-active-theme ###
    
    name: Morscher Custom (stockholm-child)
    version: 1.1.0
    author: Morscher Architekten
    author_website: http://morscher.ch
    parent_theme: Stockholm (stockholm)
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, post-formats, post-thumbnails, title-tag, editor-style, menus, StockholmQodeSidebar, widgets
    theme_path: /var/www/vhosts/morscher.ch/httpdocs/wp-content/themes/stockholm-child
    auto_update: Aktiviert
    
    ### wp-parent-theme ###
    
    name: Stockholm (stockholm)
    version: 5.1.7
    author: Select Themes
    author_website: http://demo.select-themes.com
    theme_path: /var/www/vhosts/morscher.ch/httpdocs/wp-content/themes/stockholm
    auto_update: Aktiviert
    
    ### wp-themes-inactive (4) ###
    
    Stockholm: version: 5.0.7, author: Select Themes, Automatische Aktualisierungen aktiviert
    Twenty Twenty: version: 1.9, author: WordPress-Team, Automatische Aktualisierungen aktiviert
    Twenty Twenty-One: version: 1.5, author: the WordPress team, Automatische Aktualisierungen aktiviert
    Twenty Twenty-Two: version: 1.1, author: the WordPress team, Automatische Aktualisierungen aktiviert
    
    ### wp-mu-plugins (1) ###
    
    assets-manager.php: author: (undefined), version: 1.0.9
    
    ### wp-plugins-active (9) ###
    
    Autoptimize: version: 3.0.3, author: Frank Goossens (futtta), Automatische Aktualisierungen aktiviert
    Envato Market: version: 2.0.7, author: Envato, Automatische Aktualisierungen aktiviert
    EWWW Image Optimizer: version: 6.5.0, author: Exactly WWW, Automatische Aktualisierungen aktiviert
    Flow-Flow: version: 4.9.0, author: Looks Awesome, Automatische Aktualisierungen aktiviert
    Post Types Order: version: 1.9.8, author: Nsp Code, Automatische Aktualisierungen aktiviert
    Stockholm Core: version: 1.1, author: Select Themes, Automatische Aktualisierungen aktiviert
    Webcraftic Clearfy – WordPress optimization plugin: version: 2.0.1, author: Creative Motion <info@cm-wp.com>, Automatische Aktualisierungen aktiviert
    WPBakery Page Builder: version: 6.0.4, author: Michael M - WPBakery.com (latest version: 6.9.0), Automatische Aktualisierungen aktiviert
    Yoast SEO: version: 18.6, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-inactive (1) ###
    
    Enable jQuery Migrate Helper: version: 1.3.0, author: The WordPress Team, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: EWWWIO_Imagick_Editor
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-68 Q16 x86_64 2021-10-13 https://imagemagick.org
    imagick_version: 3.6.0
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-962.3.2.lve1.5.66.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.3.33 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 10000
    time_limit: 300
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.29.0 NSS/3.53.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.1.48-MariaDB-cll-lve
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    max_allowed_packet: 134217728
    max_connections: 100
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/vhosts/morscher.ch/httpdocs/wp-content
    WP_PLUGIN_DIR: /var/www/vhosts/morscher.ch/httpdocs/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: false
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Hallo,
    im Bericht ist mir noch aufgefallen, dass PHP 7.3.x eingestellt ist. Da solltest du über deinen Hoster auf PHP 7.4.x umstellen.

    Ggfs. ist auch sinnvoll, Autoptimize zu deaktivieren, um mal zu sehen, ob das Problem dann gelöst ist. Das würde auf fehlerhafte Einstellungen bei dem Plugin hinweisen.

    Sollte das nicht das Problem lösen, musst du dich an die Entwickler des Themes (Stockholm) bzw. an die Entwickler von WPBakery Page Builder wenden.

    Viele Grüße
    Hans-Gerd

    Thread-Starter arminsheak

    (@arminsheak)

    Hallo,

    Vielen Dank für den Hinweis. Es liegt tatsächlich zum grössten Teil an Autoptimize. Das Problem ist damit behoben.

    Vielen Dank

    super – freut mich. Danke für die Rückmeldung und “Gelöst”-Markieren. 👍

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)