Support » Allgemeine Fragen » Seite erstellen und später Domain hinzufügen

  • Gelöst lukaas

    (@lukaas)


    Hallo zusammen,

    ich hab folgendes Szenario bevorstehend:

    Ich sollte für jemanden eine Seite einrichten. Bis diese fertig ist, soll sein Server bzw. seine alte Seite bei dem Provider noch über seine Domain erreichbar sein. Bisher habe ich die Seiten sofort über die zukünfitge Domain erstellt.

    Sprich, Server aufgesetzt und zukünftige Domain genutzt.

    Wie sind eure Erfahrungen? Wie macht ihr es bzw. würdet ihr es machen?

    Ich hab schon was paar Sachen gelesen, wie z.B. die Domain im WP Admin unter den Einstellungen zu ändern und oder in der Datenbank Änderungen vornehmen. Wobei ich da eher vorsichtig bin.

    Wäre super nett, wenn mir jemand helfen kann!

    MfG
    Lukas

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Hi Lukas.
    Wenn Du einen Testserver oder eine andere Möglichkeit hast die Entwicklung z.B. auf einer Subdomain zu machen ist das kein Problem. Du entwickelst die Seite einfach auf der Subdomain und Migrierst diese nach Fertigstellung auf die Originaldomain (mit Duplicator).
    Bei diesem Szenario kannst DU ggf. auch die alte Installation auf dem Server belassen und die neue in ein anderes Verzeichnis legene (und dann natürlich das root Verzeichnis entsprechend ändern). Dann kann der Kunde bei Problemen kurzerhand wieder auf die alte Installation wechseln.
    Viel Erfolg.

    Wenn du in einem Stück entwickeln und das fertige Ergebnis anschließend übertragen möchtest, bietet sich eine lokale Installation z.B. mit Bitnami oder Local by Flywheel an. Wenn zwischendurch Absprachen mit dem Website-Inhaber erwünscht sind, ist es einfacher, auf dessen Webserver in einem Unterverzeichnis WordPress zu installieren und z.B. mit Restricted Site Access vorläufig gegen unbefugten Zugriff zu schützen.
    In beiden Fällen musst du am Ende die Installation migrieren, z.B. mit Duplicator wie von @computermobil bereits vorgeschlagen.

    Hallo,
    nur noch ein zusätzlicher Hinweis: für die lokale Entwicklung nutze ich Laragon, mit der ich beste Erfahrungen gemacht habe.
    Für die Migration hatte ich früher in der Tat auch Duplicator genutzt, nutze aber mittlerweile das Plugin All-in-One WP Migration.
    Beim Duplicator unbedingt eine aktuelle Version verwenden, weil es Ende Februar eine Sicherheitslücke gab.

    Viele Grüße
    Hans-Gerd

    @hage

    Für die Migration hatte ich früher in der Tat auch Duplicator genutzt, nutze aber mittlerweile das Plugin All-in-One WP Migration.

    Mit WP-CLI ist das übrigens noch einfacher:

    wp search-replace 'http://example.test' 'http://example.com'

    @pixolin
    danke für den Hinweis.
    Bei meinen lokalen Instanzen unter Laragon nutze ich WP CLI mittlerweile ziemlich intensiv, z. B. um Plugins oder Themes upzudaten.

    Hi zusammen,

    erstmal vielen Dank für die tolle Unterstützung!

    Ich werde mal alle Vorschläge ausprobieren.

    Viele Grüße
    Lukas

    lukaas

    (@lukaas)

    Hallo zusammen,

    jetzt melde ich mich erneut. Nachdem ich nun von Bitnami ein lokales WP auf meinem Notebook aufgesetzt habe, wollte ich es nun auf einen Server migrieren.

    Realisieren wollte ich es mit All-in-one WP Migration. Den Server hab ich davor schon mit WP (Apache, SSL usw.) fertiggestellt. Nach der Migration ist mir jedoch aufgefallen, dass beim bearbeiten über Elementor z.B. ein 404 auftritt.

    Ich könnte mir vorstellen, dass es an https liegt!? Im Netz hab ich schon danach gesucht, jedoch ohne Erfolg. Das ersetzen der Domain von localhost:8080 auf die neue Domain bringt scheinbar auch nichts, da keine betroffenen Zeilen gefunden wurden.

    Habt ihr Ideen?

    Viele Grüße
    Lukas

    Moderator Bego Mario Garde

    (@pixolin)

    Bitte versetze dich mal in die Lage der Leute, die hier mitlesen und dir gerne helfen möchten. Bei denen kommt sinngemäß an:

    • Hat lokal eine Website erstellt.
      Webserver hat scheinbar Port 8080 genutzt.
    • Möchte Website übertragen.
    • Hat irgendwas mit All-in-One-WP-Migration vor.
    • Hat irgendwo einen Apache Server.
    • Hat irgendwie eine Migration durchgeführt und dabei irgendwas gemacht.
    • Bekommt jetzt in Elemntor für irgendwas einen Fehler 404 File not Found angezeigt.
    • Meint, dass es irgendwie an https liegen könnte.

    Du merkst vielleicht selber, irgendwas fehlt da noch, um das auch nur annähernd nachvollziehen zu können. Vielleicht magst du nochmal ausführlicher beschreiben, wie du den Umzug wohin vorgenommen hast, wo wir uns die Webseiten anschauen können, wo genau Probleme auftauchten und was du bisher unternommen hast, um sie zu lösen.

    lukaas

    (@lukaas)

    Hat sich erledigt. War eine Zeile in der Apache Config.

    Moderator Bego Mario Garde

    (@pixolin)

    ¯\_(ツ)_/¯

    Dann viel Erfolg mit der Website.

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)