Support » Allgemeine Fragen » Seite lädt ständig neu

  • Gelöst lorylynn

    (@lorylynn)


    Hallo in die Runde!
    Zunächst vorweg – ich bin absoluter Anfänger in Sachen WordPress.
    Ich habe folgendes Problem: Meine Seite lädt alle paar Sekunden neu – als würde man ständig F5 drücken. Gestern lief alles noch gut und heute das.
    Ich habe alle Plugin-Updates gemacht, WordPress-Version 5.8 läuft. Ich bearbeite die Seite mit Elementor Pro, installiertes Theme ist Stockholm.
    Nach einiger Recherche im Netz habe ich z. B. Yoast SEO deaktiviert, keine Veränderung. Auch andere Plugins habe ich deaktiviert – ohne Erfolg:
    Complianz | GDPR/CCPA Cookie Consent: version: 5.1.0
    Favicon by RealFaviconGenerator: version: 1.3.20
    Slider Revolution: version: 6.2.23
    Stockholm Core: version: 2.2.7
    Evtl. könnte es etwas mit einem Javasript-Code zu tun haben. Deaktiviere ich Javascript im Browser, hört das Aktualisieren auf. Allerdings gab es ja keinerlei Veränderungen meinerseits.
    Habt ihr eine Idee? Ich bin dankbar für jeden Hinweis!

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    wenn du dann noch die URL oben einträgst, dann können wir uns das auch ansehen und dir sicher besser helfen.
    Ein ähnlicher Fall war in dem folgenden Beitrag Thema.
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller lorylynn

    (@lorylynn)

    Guten Morgen! Den genannten Beitrag hatte ich bereits studiert – daher auch das Deaktivieren von Yoast SEO. Der Lösungsvorschlag ist für mich aber nicht relevant, da das genannte Plugin nicht installiert ist.
    Die URL ist http://www.keinemachtdemhass.de und hier noch der Bericht – nicht wundern, nach diversen erfolglosen Versuchen, wurde gestern ein Backup eingespielt.
    Danke!

    
    ### wp-core ###
    
    version: 5.7.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/html/web_keinemachtdemhass.de
    wordpress_size: 50,29 MB (52734841 bytes)
    uploads_path: /var/www/html/web_keinemachtdemhass.de/wp-content/uploads
    uploads_size: 154,56 MB (162062926 bytes)
    themes_path: /var/www/html/web_keinemachtdemhass.de/wp-content/themes
    themes_size: 40,19 MB (42147056 bytes)
    plugins_path: /var/www/html/web_keinemachtdemhass.de/wp-content/plugins
    plugins_size: 104,05 MB (109106396 bytes)
    database_size: 38,34 MB (40206336 bytes)
    total_size: 387,44 MB (406257555 bytes)
    
    ### wp-active-theme ###
    
    name: Stockholm (stockholm)
    version: 8.6
    author: Select Themes
    author_website: https://qodeinteractive.com/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, post-formats, post-thumbnails, title-tag, editor-style, menus, StockholmQodeSidebar, widgets
    theme_path: /var/www/html/web_keinemachtdemhass.de/wp-content/themes/stockholm
    auto_update: Deaktiviert
    
    ### wp-plugins-active (8) ###
    
    Complianz | GDPR/CCPA Cookie Consent: version: 5.1.0, author: Really Simple Plugins (latest version: 5.2.5), Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.2.2, author: Elementor.com (latest version: 3.3.1), Automatische Aktualisierungen deaktiviert
    Elementor Pro: version: 3.3.0, author: Elementor.com (latest version: 3.3.1), Automatische Aktualisierungen deaktiviert
    Favicon by RealFaviconGenerator: version: 1.3.20, author: Philippe Bernard, Automatische Aktualisierungen deaktiviert
    Loco Translate: version: 2.5.2, author: Tim Whitlock (latest version: 2.5.3), Automatische Aktualisierungen deaktiviert
    Login Logo: version: 0.10.0, author: Mark Jaquith, Automatische Aktualisierungen deaktiviert
    Slider Revolution: version: 6.2.23, author: ThemePunch, Automatische Aktualisierungen deaktiviert
    Stockholm Core: version: 2.2.7, author: Select Themes, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (1) ###
    
    Yoast SEO: version: 16.4, author: Team Yoast (latest version: 16.7), Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 256M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.53.3
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.0-16-amd64 x86_64
    httpd_software: Apache/2.4.38 (Debian)
    php_version: 7.3.27 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 5000
    time_limit: 300
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 256M
    curl_version: 7.76.1 OpenSSL/1.1.1k
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.32
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/html/web_keinemachtdemhass.de/wp-content
    WP_PLUGIN_DIR: /var/www/html/web_keinemachtdemhass.de/wp-content/plugins
    WP_MEMORY_LIMIT: 512M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    das Problem scheint ja gelöst zu sein. Insofern hat sich das ja offensichtlich erledigt. Warum das Problem bei dir aufgetaucht ist, können wir nicht mehr feststellen.
    Lt. Bericht verwendest du noch PHP 7.3.x. Das solltest du auf PHP 7.4 umstellen.
    Denkst du bitte daran, das Thema dann auch als gelöst zu markieren, wenn das Thema für dich erledigt ist. Danke.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller lorylynn

    (@lorylynn)

    Leider besteht das Problem weiterhin.

    Jonas

    (@elbsegler)

    Das Theme Stockholm finde ich nicht im WordPress Theme Directory. Ich würde mich daher an den Support des Herstellers oder Verkäufer wenden.

    Moderator Bego Mario Garde

    (@pixolin)

    Das sehe ich auch so: Bei Fragen zu gekauften Themes (hier: Stockholm) können wir dir nicht weiterhelfen, weil sie uns für einen kostenlosen Support nicht kostenlos zur Verfügung stehen.

    Bitte wende dich bei Fragen zu diesem Theme an die Entwickler.

    Thread-Ersteller lorylynn

    (@lorylynn)

    Auf die Antwort vom Stockholm-Entwickler warte ich noch… Nur der Vollständigkeit halber: Ich habe im Reparaturmodus das Theme deaktiviert und auch alle anderen Plugins – das Problem bestand aber weiterhin. Ich als Laie würde jetzt davon ausgehen, dass es nicht am Theme liegt, oder?

    Moderator Bego Mario Garde

    (@pixolin)

    Das Problem ist, dass wir uns für einen kostenlosen Support nicht erst diverse Themes und Plugins kaufen. Wenn du Elementor Pro und das Theme Stockholm verwendest, gibt es in der Gleichung zwei unbekannte Variablen, die wir hier nicht beurteilen können. Das Problem muss gar nicht an diesem Theme/Plugin liegen, aber wir können dein „Setup“ trotzdem nicht rekonstruieren.

    Nehmen wir an, du verwendest ein kostenpflichtiges Theme „Zickzack“. Das Theme verwendet eine Funktion tuwas(), die ordentlich programmiert ist und bestens funktioniert. Soweit alles prima.
    Zusätzlich installierst du nun ein Plugin, das zufällig ebenfalls eine Funktion tuwas() enthält. Auch diese Funktion ist ordentlich programmiert und der Entwickler (der ebenfalls keinen Zugriff auf das kostenpflichtige Theme hat) erklärt, er hätte die Funktion seines Plugins gewissenhaft geprüft.
    Blöd ist jetzt, dass du Funktionen in PHP nur einmal definieren kannst und damit eine Funktion mit dem gleichen Namen in einem Theme und einem Plugin zu einem fatalen Fehler führt. Website abgeschossen, nix geht mehr. Wer findet den Fehler?

    Schauen wir uns (mangels Zugriff auf das kostenpflichtige Theme) nur das Plugin alleine an, kommen wir kaum auf die Idee, dass es einen Namenskonflikt geben kann. Das Theme funktioniert auch tadellos … solange kein Plugin mit einer gleichnamigen Funktion einführt.

    (Um solche Fehler zu vermeiden, sind Programmierer angehalten, ihre Funktionen mit einer Vorsilbe so zu benennen, dass Konflikte ausgeschlossen werden können. Alternativ können die Funktion in Objekten ausgeführt, Namensbereiche verwendet oder mit if-Statements geprüft werden, ob der Funktionsname bereits vorkommt.)

    Die anderen Angaben zu deiner Website geben leider auch keinen Hinweis auf mögliche Fehlerursachen.

    Die Übertragung der Startseite dauert recht lang, aber ein Neuladen kann ich in meinem Browser auch nicht feststellen. Ich nehme an, dass es Hans-Gerd genauso gegangen ist und er deshalb nachgefragt hat, ob das Problem bereits behoben sei.

    Thread-Ersteller lorylynn

    (@lorylynn)

    Vielen Dank für die ausführliche Erläuterung. Verstehe ich es richtig, dass die Seite bei dir nicht ständig neu lädt? Merkwürdig? Hast du evtl. Javasript deaktiviert?

    Moderator Bego Mario Garde

    (@pixolin)

    Vielen Dank für die ausführliche Erläuterung.

    Etwas krummes Beispiel, aber hoffentlich ist deutlicher geworden, worum es geht wenn wir bei gekauften Themes und Plugins an den Entwickler verweisen.

    Verstehe ich es richtig, dass die Seite bei dir nicht ständig neu lädt?

    Ja.

    Merkwürdig?

    Ja.

    Hast du evtl. Javasript deaktiviert?

    Nein.

    Thread-Ersteller lorylynn

    (@lorylynn)

    Nochmals allen vielen Dank. Das Problem ist behoben. Es hatte nichts mit WordPress, Plugins oder Themes zu tun. War ein DNS-Cache-Problem.

    Danke für die Rückmeldung. Leider auch so ein Fall, bei dem wir als Außenstehende wenig helfen können. Schön, dass du es klären konntest.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)