Support » Allgemeine Fragen » Seite nicht mehr aufrufbar durch https Umstellung in itheme Security Plugin

  • Gelöst anikamatzke

    (@anikamatzke)


    Liebe WordPress-Gemeinde,
    ich habe leider keinen Beitrag gefunden, der mir bei meinem Problem weiterhelfen könnte, daher hoffe ich sehr, hier auf Hilfe zu stoßen. Ich muss gestehen, noch absolute WordPress-Anfängerin zu sein, daher verzeiht bitte mögliche umständliche Formulierung.

    Zum Problem:
    Ich habe am Wochenende etwa 40 Warnmails mit Website-Aussperrbenachrichtigungen erhalten. Aufgrunddessen habe ich im WordPress-Backend meine Sicherheitseinstellungen überprüft, insbesondere im Plugin iTheme Security. Leider habe ich versehentlich auf die Entstellung geklickt, zur Seite mit https-Verschlüsselung umzuleiten. Das wahr wohl ein ziemlicher Fail, da ich kein Sicherheitszertifikat besitze. Ich kann mich nun selbst nicht mehr im wp-admin-Bereich einloggen, weswegen ich mir für diesen Forenbeitrag einen neuen Account angelegt habe.
    Wenn ich die Seite aufrufen möchte, kommt die Firefox-Warnung „Diese Verbindung ist nicht sicher…“. Klicke ich auf „Erweitert“, kommt der Hinweis „ERR_TOO_MANY_REDIRECTS“ und „Sichere Kommunikation mit der Gegenstelle ist nicht möglich: Angeforderter Domainname stimmt nicht mit dem Zertifikat des Servers überein. HTTP Strict Transport Security: false. HTTP Public Key Pinning: false“. Sollte es hilfreich sein, kann ich auch die Zertifikatskette noch anhängen. Wenn ich dann die Seite noch mal aufrufe, kommt „Fehler: Umleitungsfehler. Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.“

    Mein Versuch das zu beheben, war meine letzte Backupdatei vor der vorgenommenen Einstellung über Filezilla auf den Server zu spielen. Leider ohne Erfolg. In der alten wp-config.php (vor Einspielen des Backups) befand sich die Zeile „define( ‚FORCE_SSL_ADMIN‘, true ); // Weiterleitung aller HTTP-Seitenanfragen zu HTTPS – Sicherheit > Einstellungen > Secure Socket Layers (SSL) > SSL für das Dashboard
    // END iThemes Security – Diese Zeile nicht verändern oder entfernen“, in der config aus dem Upload des Backups allerdings nicht.

    Ich weiß nun nicht mehr wirklich, was ich probieren könnte. Hat von euch vielleicht jemand eine Idee, um das Problem zu beheben?

    Ich danke euch sehr!
    Liebe Grüße,
    Anika

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Versuch erst mal, die Einstellungen in der wp-config.php rückgängig zu machen, in dem du in den beiden Zeilen die Konstanten wieder auf false setzt:

    
    define( 'FORCE_SSL_LOGIN', false );
    define( 'FORCE_SSL_ADMIN', false );
    

    Gib doch danach bitte mal eine Rückmeldung: Kannst du dich danach wieder anmelden? Dann solltest du im Plugin die Änderung rückgängig machen, dass die Webseiten nur noch per SSL erreichbar sind.

    Wenn du damit zurecht gekommen bist, sprechen wir gerne nochmal über die Warnhinweise, die du per E-Mail erhalten hast. Wenn du nicht zurecht kommst, meldest du dich bitte auch, damit wir andere Dinge ausprobieren können.

    Nachtrag: ich sehe gerade, dass es damit alleine wahrscheinlich nicht klappt. Was passiert, wenn du außerdem die .htaccess umbenennst in no.htaccess? (Kann dann später neu angelegt werden.) Kannst du dich dann anmelden?

    Thread-Starter anikamatzke

    (@anikamatzke)

    Hallo,
    lieben Dank für deine schnelle Antwort!
    ich habe nun define( 'FORCE_SSL_ADMIN', false ); so übernommen und die genannte Datei in no.htaccess umbenannt. Allerdings hat sich nichts geändert.
    Die Konstante define( 'FORCE_SSL_LOGIN', false ); gibt es allerdings bei mir nicht.
    Ich kopiere dir hier noch mal die ersten Zeilen der config ein:

    <?php
    
    // BEGIN iThemes Security - Diese Zeile nicht verändern oder entfernen
    // iThemes Security Config Details: 2
    define( 'DISALLOW_FILE_EDIT', true ); // Datei-Editor deaktivieren - Sicherheit > Einstellungen > WordPress-Optimierungen > Datei-Editor
    define( 'FORCE_SSL_ADMIN', false ); // Weiterleitung aller HTTP-Seitenanfragen zu HTTPS - Sicherheit > Einstellungen > Secure Socket Layers (SSL) > SSL für das Dashboard
    // END iThemes Security - Diese Zeile nicht verändern oder entfernen
    • Diese Antwort wurde geändert vor 5 Jahre, 2 Monaten von anikamatzke.
    • Diese Antwort wurde geändert vor 5 Jahre, 2 Monaten von anikamatzke.

    Probier doch mal bitte folgendes aus:

    In der wp-config.php fügst du in einer neuen Zeile (am besten gleich nach define( ‚DISALLOW_FILE_EDIT‘, true );) folgendes ein:

    define( 'RELOCATE', true );

    Danach versuchst du erneut, dich (sinngemäß) über http://example.com/wp-login.php anzumelden. Wenn das klappt, kontrolliere bitte unter Einstellungen > Allgemein die WordPress- und Website-URL. Sobald du die geändert hast, muss die eingefügte Zeile in der wp-config.php wieder auskommentiert oder gelöscht werden.

    Wenn ich deine Domain mit als http://example.com/wordpress* aufrufe, sehe ich eine Meldung „Error establishing a database connection“. Kann es sein, dass du mehrere WordPress-Installationen ineinander kopiert hast (z.B. beim Wiederherstellen eines Backups)? Prüfe das doch bitte mal per FTP-Programm oder über das Dateiverwaltungsmenü deines Webhoster.

    (*ich erwähne hier immer http://example.com, weil ich deine URL nicht dutzendmal wiederholen möchte – du ersetzt das bitte mit deiner eigenen URL)

    Thread-Starter anikamatzke

    (@anikamatzke)

    Hallo,
    erneut tausend Dank fürs schnelle Weiterhelfen.
    Leider ändert sich nichts dabei, wenn ich die neue Zeile define( 'RELOCATE', true );einfüge. Es erscheint „casualdiscussions.de verwendet ein ungültiges Sicherheitszertifikat.
    Das Zertifikat gilt nur für folgende Namen:
    *.kasserver.com, kasserver.com
    Fehlercode: SSL_ERROR_BAD_CERT_DOMAIN“

    Ich habe das die Backup-Datei via Filezilla hochgeladen und die Daten überschreiben lassen, eigentlich ist dort nichts doppelt sichtbar.
    Macht es Sinn die Daten in der Dateiverwaltung des Webhosters plan zu machen und die Backupdatei erneut hochzuladen? Bzw. ist der Ansatz dadurch das Problem zu beheben, überhaupt sinnvoll?

    Danke und beste Grüße!

    Nachtrag: Ich habe gerade gesehen, dass gewisse Ordner im Backup-Ordner mehrfach vorhanden sind, wie wp-admin, wp-content, wp-includes. Diese sind sowohl im Ordner „backwpup“ als auch „backwpup/wordpress“. Es sind demnach u.a. zwei config-php in unterschiedlicher Ordnerstruktur zu finden.

    • Diese Antwort wurde geändert vor 5 Jahre, 2 Monaten von anikamatzke.
    • Diese Antwort wurde geändert vor 5 Jahre, 2 Monaten von anikamatzke.

    Es erscheint ….de verwendet ein ungültiges Sicherheitszertifikat.

    Hast du denn dann beim Anmelden https://… eingegeben?
    Das muss dann http://… lauten – sonst sucht der Browser wieder nach einem SSL-Zertifikat.

    Wenn du die Meldung erhälst, kannst du auf „erweitert“ klicken und das Zertifikat zulassen. Auch dann müsstest du ins Backend kommen.

    Alles zu löschen und ein Backup wiederherzustellen ist eigentlich die ideale Methode – vorausgesetzt, du hast ein funktionierendes und aktuelles Backup.

    Thread-Starter anikamatzke

    (@anikamatzke)

    Danke dir! Nein ich habe kein https:// eingegeben, jedoch erscheint dies nach der Eingabe automatisch in der Browserzeile.

    Ich füge dir noch mal den Nachtrag von eben hier ein bzgl. des Backups.
    Ich habe gerade gesehen, dass gewisse Verzeichnisse im Backup-Ordner mehrfach vorhanden sind, wie wp-admin, wp-content, wp-includes. Diese sind sowohl im Ordner „backwpup“ als auch „backwpup/wordpress“. Es sind demnach u.a. zwei config-php in unterschiedlicher Ordnerstruktur zu finden (die zweite config lässt sich auch gar nicht bearbeiten). Das verwundert mich ein wenig.
    Ich würde nun tatsächlich die Variante versuchen, alles zu löschen und das Backup einzuspielen. Sollten die doppelten Verzeichnisse gelöscht werden?

    • Diese Antwort wurde geändert vor 5 Jahre, 2 Monaten von anikamatzke.

    Hast du die Zeile auch in der richtigen wp-config.php (im Web-Stammverzeichnis, nicht im Unterverzeichnis wordpress) vorgenommen?
    Das Unterverzeichnis wordpress kannst du mal sicherheitshalber auf deinen Computer herunterladen und dann auf dem Webserver löschen.

    Du könntest vor Wiederherstellung des Backups mal versuchen, den Plugin-Ordner in no.plugins umzubenennen, um iThemes Security vorübergehend zu deaktivieren. Höchstwahrscheinlich wurden aber Website- und WordPress-URL geändert – das kannst du entweder nach Anmeldung im Menü Einstellungen > Allgemein oder per phpMyAdmin in der Datenbank in Tabelle wp_options ändern.

    Das Wiederherstellen des Backups würde ich als letzte Option lassen.

    Thread-Starter anikamatzke

    (@anikamatzke)

    Halleluja! Die Seite ist wieder da und ich konnte mich im Backend anmelden. Durch den Upload des Backups, Umbenennung in no.plugins und Löschung des WordPress-Ordners hat es nun funktioniert. Die Seite ist nun auch wieder aufrufbar. Wenn ich in die Einstellung gehe, hat sich an der URL nichts verändert.

    Wie kann ich nun die restlichen Plugins wieder zum Laufen bringen?
    Der WordPress-Ordner ist ja nun nicht mehr vorhanden. Ich frage mich nun, welchem Zweck er dient, wenn es ohne läuft?

    • Diese Antwort wurde geändert vor 5 Jahre, 2 Monaten von anikamatzke.

    Du hast vermutlich bei der Installation oder Wiederherstellung eines Backups einen zweiten Dateiensatz wordpress hinzugefügt, der da nicht hingehört und auch nicht benötigt wird.

    Durch Umbenennen des Plugin-Verzeichnisses in no.plugins findet WordPress die installierten Plugins nicht mehr und deaktiviert sie. Du kannst das Verzeichnis wieder in plugins umbenennen und dann die Plugins nach und nach wieder aktivieren. Außerdem solltest du über Einstellungen > Permalinks wieder die gewünschte Permalink-Struktur auswählen und speichern, WordPress schreibt das dann in eine neue .htaccess.

    Regelmäßige, funktionierende Backups sind wichtig.
    Schön, dass (fast) alles wieder läuft.

    Thread-Starter anikamatzke

    (@anikamatzke)

    Ich bin dir so dankbar für deine Hilfe. Es ist wirklich toll, wenn sich Menschen dem eigenen Problem (und Verschulden) in so einem Forum annehmen.

    Das Kuriose ist ja, dass innerhalb des Backups dieser zweite WordPress-Ordner angelegt wird, ohne mein Zutun.
    Die Permalink-Struktur ist bestehen geblieben.

    Nochmals ein dickes Dankeschön!

    Sorry, mir ist etwas ähnliches passiert und jetzt brauche ich dringend Ihre Hilfe.
    Vorhin habe ich auf dem Dashboard von der Seite milsantos.com das http:// für https:// geändert und seitdem funktioniert die Seite nicht mehr.
    Ich kann mich natürlich auch nicht bei WordPress einloggen.
    Heute habe ich ein Konzert und es ist sehr wichtig, dass die Seite sichtbar ist.
    Ich habe echt keine Ahnung was ich machen soll.
    Danke im Voraus für Ihre Antwort!

    Ihre Erklärungen von oben haben mir sehr geholfen. Vielen Dank!
    Die Seite funktioniert wieder. 🙂

    Hallo, ich habe auch ein ähnliches Problem: Ich habe versucht meine Website auf https umzustellen.
    In der Datei wp-config habe ich eingetragen
    define( ‚FORCE_SSL_ADMIN‘, true );
    Im Backend habe ich unter den Einstellungen / Allgemein Website und WordPress adresse von http in https geändert.

    Allerdings habe ich erst danach das SSL Zertifikat eingerichtet.
    Auf der Seite meines Hosters scheint alles zu passen. Wo kann der Fehler liegen?
    Derzeit wird mir bei Aufruf der Seite die folgende Fehlermeldung angezeigt:
    Die Domain
    http://www.geburtshaus-marburg.de
    ist nicht SSL-verschlüsselt
    (per HTTPS) verfügbar.

    Über eine Hilfe wäre ich sehr dankbar. Außerdem war mir nicht klar, wie ich im Support Forum ein neues Thema aufmache. Daher hab ich es hier meine Frage angehängt.
    Alexander

    …hat sich erledigt. Ich konnte das Problem lösen – das zertifikat war nicht richtig angelegt

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das Thema „Seite nicht mehr aufrufbar durch https Umstellung in itheme Security Plugin“ ist für neue Antworten geschlossen.