Support » Allgemeine Fragen » Seiten lassen sich nicht anzeigen

  • Ich kann seit längerem keine Links zu Seiten setzen.
    Die Seiten kann ich ganz normal anlegen, bearbeiten und veröffentlichen.
    Der Link führt aber ins leere.
    Als Workaround habe ich zb für das Impressum einen Beitrag erstellt und den dann verlinkt.
    Beispiellink der nicht funktioniert:
    https://usefulvid.com/dsvgo-eu/

    • Dieses Thema wurde geändert vor 1 Jahr, 10 Monate von theincogtion.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 16 bis 22 (von insgesamt 22)
  • Redirection brauche ich um auf externe Seiten umzuleiten (youtube erlaubt mir es links auf usefulvid.com zu setzen) aber halt nicht zu externen Seiten 🙂

    RewriteEngine On
    RewriteCond %{SERVER_PORT} !^443$
    RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
    RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge/[0-9a-zA-Z_-]+$
    RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
    RewriteRule (.*) https://%{HTTP_HOST}/$1 [R=301,L]
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    Options -Indexes
    
    IndexOptions -FancyIndexing
    
    #<IfModule mod_rewrite.c>
    #RewriteEngine on
    #RewriteCond %{HTTP_HOST} ^(www.)?usefulvid.com$
    #RewriteCond %{REQUEST_URI} !^/home/kd29314/
    #RewriteCond %{REQUEST_FILENAME} !-f
    #RewriteCond %{REQUEST_FILENAME} !-d
    #RewriteRule ^(.*)$ /home/kd29314/$1
    #RewriteCond %{HTTP_HOST} ^(www.)?usefulvid.com$
    #RewriteRule ^(/)?$ my_subdir/index.php [L] 
    #</IfModule>
    
    # php -- BEGIN cPanel-generated handler, do not edit
    # Set the “ea-php70” package as the default “PHP” programming language.
    <IfModule mime_module>
      AddType application/x-httpd-ea-php70-lsphp .php .php7 .phtml
    </IfModule>
    # php -- END cPanel-generated handler, do not edit
    
    # BEGIN cPanel-generated php ini directives, do not edit
    # Manual editing of this file may result in unexpected behavior.
    # To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
    # For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)
    <IfModule php7_module>
       php_flag display_errors Off
       php_value max_execution_time 300
       php_value max_input_time 300
       php_value max_input_vars 1000
       php_value memory_limit 256M
       php_value session.gc_maxlifetime 1440
       php_value session.save_path "/var/cpanel/php/sessions/ea-php70"
       php_value upload_max_filesize 128M
       php_value post_max_size 128M
       php_flag zlib.output_compression Off
    </IfModule>
    # END cPanel-generated php ini directives, do not edit
    • Diese Antwort wurde geändert vor 1 Jahr, 9 Monate von theincogtion.
    Moderator Bego Mario Garde

    (@pixolin)

    Der WordPress-Block

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    sollte immer als letztes ausgeführt werden.

    Wofür ist der auskommentierte Block mit Weiterleitungsregeln?

    Ansonsten finde ich jetzt aber auch nichts auffälliges. Die Error-Logs des Webservers könnten noch Informationen enthalten – falls du da dran kommst.

    Ich kann im cpanel zwar den Fehler log anklicken der ist aber lehr 🙁

    Wäre so besser? (kommentar blog ist raus ich weiß nicht für was ich den mal drin hatte und der wordpress block ist am ende eingefügt)

    RewriteEngine On
    RewriteCond %{SERVER_PORT} !^443$
    RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
    RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge/[0-9a-zA-Z_-]+$
    RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
    RewriteRule (.*) https://%{HTTP_HOST}/$1 [R=301,L]
    
    Options -Indexes
    
    IndexOptions -FancyIndexing
    
    # php -- BEGIN cPanel-generated handler, do not edit
    # Set the “ea-php70” package as the default “PHP” programming language.
    <IfModule mime_module>
      AddType application/x-httpd-ea-php70-lsphp .php .php7 .phtml
    </IfModule>
    # php -- END cPanel-generated handler, do not edit
    
    # BEGIN cPanel-generated php ini directives, do not edit
    # Manual editing of this file may result in unexpected behavior.
    # To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
    # For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)
    <IfModule php7_module>
       php_flag display_errors Off
       php_value max_execution_time 300
       php_value max_input_time 300
       php_value max_input_vars 1000
       php_value memory_limit 256M
       php_value session.gc_maxlifetime 1440
       php_value session.save_path "/var/cpanel/php/sessions/ea-php70"
       php_value upload_max_filesize 128M
       php_value post_max_size 128M
       php_flag zlib.output_compression Off
    </IfModule>
    # END cPanel-generated php ini directives, do not edit
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    Moderator Bego Mario Garde

    (@pixolin)

    Lass es so mal laufen und wenn du wieder eine Seite nicht aufrufen kannst, schreib doch mal, welche das ist, damit wir das hier besser nachvollziehen können.

    Ok ich hab jetzt auch de logs gefunden aber darin sehe ich den Fehler nicht. Ich warte mal ab bis es wieder passiert und schau dann in die logs und poste die hier.
    Danke bis dahin für deine Hilfe.
    Php konnte ich auf 7.2.3 updaten das war im cpanel etwas versteckt.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Die Permalinkstruktur ist /%postname%/ – das kann zu Problemen führen, wenn es Dopplungen gibt, also Seiten, Beiträge und Bilder (Sites bei Multisite) identisch heißen.

    Wenn du schreibst, dass es nicht mehr funktioniert, was heißt denn das konkret. Kommt ein 404 oder eine falsche Seite oder noch etwas anderes?

    Gruß, Torsten

    genau 404 kommt

Ansicht von 7 Antworten - 16 bis 22 (von insgesamt 22)
  • Das Thema „Seiten lassen sich nicht anzeigen“ ist für neue Antworten geschlossen.