Support » Allgemeine Fragen » Seiten werden im Dashboard nicht richtig angezeigt

  • Hi,
    Nach dem Umzug einiger meiner wp-Seiten von Host zu Host funktioniert 99% wie zuvor.
    Nur bei manchen Seiten erscheint das „(Seite bearbeiten)“ oben rechts auf den Seiten (wenn ich im Dashboard eingeloggt bin) nicht.
    Genau diese Seiten zeigen auch nichts an wenn ich sie direkt im Dashboard unter „Seiten“ auswähle. Weder in visueller noch in Textform.
    Manche werden dort auch nur unvollständig angezeigt.
    Ich kann sie daher nicht bzw nicht vollständig editieren.
    Jemand eine Idee?
    luggie

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Was bedeutet denn „unvollständig“ genau? Hört der Text einfach auf? Fehlt etwas bestimmtes?

    Debug-Mode probiert?
    Mal Plugins deaktiviert und Standard-Theme gewählt?

    Gruß, Torsten

    Thread-Starter luggie

    (@luggie)

    Unvollständig ist es nur bei einer Seite. Diese wird im Broweser komplett angezeigt. Der untere Teil enthält dabei Fehler, die es bei der Seite vor dem Umzug nicht gab.
    Im Dashboard wird diese Seite bis zu diesem Teil angezeigt. Dh ich kann den fehlerhaften Teil nicht bearbeiten.

    Debug spuckt folgendes aus:

    Strict Standards: Declaration of Graphene_Description_Walker::start_el() should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /var/www/*******.de/public_html/wp-content/themes/graphene/includes/theme-menu.php on line 0

    Strict Standards: Declaration of Graphene_Walker_Page::start_el() should be compatible with Walker_Page::start_el(&$output, $page, $depth = 0, $args = Array, $current_page = 0) in /var/www/*****.de/public_html/wp-content/themes/graphene/includes/theme-menu.php on line 0

    Notice: add_custom_background ist seit Version 3.4 veraltet! Benutze stattdessen add_theme_support( ‚custom-background‘, $args ). in /var/www/*****.de/public_html/wp-includes/functions.php on line 3391

    Thread-Starter luggie

    (@luggie)

    wie genau kann ich "add_theme_support( 'custom-background', $args )" einbinden?

    Das ist die betreffende Zeile:

    if ( WP_DEBUG && apply_filters( 'deprecated_function_trigger_error', true ) ) {
    		if ( function_exists( '__' ) ) {
    			if ( ! is_null( $replacement ) )
    				[--> ZEILE 3391] trigger_error( sprintf( __('%1$s is <strong>deprecated</strong> since version %2$s! Use %3$s instead.'), $function, $version, $replacement ) );
    			else
    				trigger_error( sprintf( __('%1$s is <strong>deprecated</strong> since version %2$s with no alternative available.'), $function, $version ) );
    		} else {
    			if ( ! is_null( $replacement ) )
    				trigger_error( sprintf( '%1$s is <strong>deprecated</strong> since version %2$s! Use %3$s instead.', $function, $version, $replacement ) );
    			else
    				trigger_error( sprintf( '%1$s is <strong>deprecated</strong> since version %2$s with no alternative available.', $function, $version ) );
    		}
    	}
    Thread-Starter luggie

    (@luggie)

    Die Plugins haben nichts zu tun mit den Fehlern.
    Wenn ich das Standardtheme aktiviere, erscheinen die Seiten die mit Graphene-Theme angezeigt aber nicht im Dashboard angezeigt/editerbaren waren, leer.
    Daher würde ich lieber das Graphenetheme „reparieren“ als die betreffenden Seiten komplett neu zu machen.

    Edi

    (@psychosopher)

    Hast Du die neueste Version des Themes installiert?

    Thread-Starter luggie

    (@luggie)

    … ja mittlerweile bin ich da auch schon drauf gekommen, Ein Themeupdate später gibts keine Probleme mehr.
    Da hätt ich auch mal früher drauf kommen können.
    Danke trotzdem 🙂

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „Seiten werden im Dashboard nicht richtig angezeigt“ ist für neue Antworten geschlossen.