• Gelöst joelluecking

    (@joelluecking)


    Hallo zusammen,

    ich versuche gerade, meine WordPress Seite zu indexieren und musste feststellen, dass es mir nicht ermöglicht wird, den Haken bei „Sichtbarkeit für Suchmaschinen“ zu entfernen. Es wird angezeigt, aber ist nicht anklickbar.

    Die Seite steht dementsprechend auf noindex, nofollow.

    Dinge die ich schon ausprobiert habe:

    – In der Datenbank direkt den wert bei „blog_public“ von 0 auf 1 gesetzt = sprang nach Aktualisierung wieder auf 0.

    – Yoast SEO Plugin deaktiviert

    – <meta name=“robots“ content=“index, follow“> direkt in den Quellcode zu fügen = noindex, nofollow verschwindet trotzdem nicht.

    Eine Theorie die ich noch habe: Das Profil über das WordPress für die Seite damals eingerichtet wurde, haben wir gelöscht, nachdem ich für mich und meine Teammember eigene Profile angelegt habe. Wir haben alle Administrator rechte.
    Gibt es möglicherweise noch sowas wie einen „Master-Admin“? Kann nur der die Indexierung aktivieren?

    Vielleicht weiß von euch jemand mehr? Gibt es sonst Möglichkeiten, eine WP Seite zu indexieren?

    Ich bin für jede Hilfe sehr dankbar!

Ansicht von 13 Antworten – 1 bis 13 (von insgesamt 13)
  • Hallo,
    wenn du dann noch die URL oben einträgst, dann können wir uns das auch zunächst im Frontend ansehen und dir sicher besser helfen.

    du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Viele Grüße
    Hans-Gerd

    Das Problem wurde bereits von IONOS-Kunden geschildert und hatte wohl mit einem Plugin zu tun, das IONOS installiert. Vielleicht kann Matthias @pfefferle helfen? Dazu solltest du dann aber nochmal die URL nennen.

    Genau, um genau sagen zu können ob es das known issue ist, bräuchte ich deine Domain. Dann kann ich schauen ob sie ins Muster passt.

    Thread-Starter joelluecking

    (@joelluecking)

    Vielen Dank für eure Antworten!

    Hier die URL und der Websitebericht. Ich hoffe, das hilft weiter!

    Die URL lautet: betree-online.de

    Hier der Websitezustand:

    
    ### wp-core ###
    
    version: 6.0.3
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 7
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/36/d885435104/htdocs/clickandbuilds/betree
    wordpress_size: 743,11 MB (779205959 bytes)
    uploads_path: /homepages/36/d885435104/htdocs/clickandbuilds/betree/wp-content/uploads
    uploads_size: 102,10 MB (107054843 bytes)
    themes_path: /homepages/36/d885435104/htdocs/clickandbuilds/betree/wp-content/themes
    themes_size: 28,52 MB (29903925 bytes)
    plugins_path: /homepages/36/d885435104/htdocs/clickandbuilds/betree/wp-content/plugins
    plugins_size: 142,67 MB (149595730 bytes)
    database_size: 35,30 MB (37011456 bytes)
    total_size: 1,03 GB (1102771913 bytes)
    
    ### wp-active-theme ###
    
    name: Hello Elementor (hello-elementor)
    version: 2.6.1
    author: Elementor Team
    author_website: https://elementor.com/?utm_source=wp-themes&utm_campaign=author-uri&utm_medium=wp-dash
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, menus, post-thumbnails, automatic-feed-links, title-tag, html5, custom-logo, editor-style, align-wide, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider
    theme_path: /homepages/36/d885435104/htdocs/clickandbuilds/betree/wp-content/themes/hello-elementor
    auto_update: Deaktiviert
    
    ### wp-mu-plugins (1) ###
    
    1&1 Product Subdomain: version: 1.1.0, author: 1&1
    
    ### wp-plugins-active (10) ###
    
    Classic Editor: version: 1.6.2, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    Duplicate Page: version: 4.4.9, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.7.8, author: Elementor.com, Automatische Aktualisierungen aktiviert
    Elementor Pro: version: 3.7.7, author: Elementor.com, Automatische Aktualisierungen aktiviert
    Essential Addons for Elementor: version: 5.3.2, author: WPDeveloper (latest version: 5.4.0), Automatische Aktualisierungen aktiviert
    EWWW Image Optimizer: version: 6.9.2, author: Exactly WWW, Automatische Aktualisierungen deaktiviert
    GDPR Cookie Compliance: version: 4.8.13, author: Moove Agency, Automatische Aktualisierungen deaktiviert
    Premium Addons for Elementor: version: 4.9.36, author: Leap13, Automatische Aktualisierungen aktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.23, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen aktiviert
    WP ULike: version: 4.6.4, author: TechnoWich, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    WP-Optimize - Clean, Compress, Cache: version: 3.2.9, author: David Anderson, Ruhani Rabin, Team Updraft, Automatische Aktualisierungen aktiviert
    Yoast SEO: version: 19.9, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: EWWWIO_GD_Editor
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-088 x86_64
    httpd_software: Apache
    php_version: 7.4.32 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 1024M
    max_input_time: -1
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 7.4.32
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/36/d885435104/htdocs/clickandbuilds/betree/wp-content
    WP_PLUGIN_DIR: /homepages/36/d885435104/htdocs/clickandbuilds/betree/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    @pfefferle @pixolin @hage

    Hallo @joelluecking leider passt deine Domain in das Muster, aber das heißt auch, dass sich das Problem relativ schnell beheben lässt! Hast du FTP Zugang zu deinem Webspace? Falls ja, schau bitte mal in deinem mu-plugins Ordner (wp-content/mu-plugins) nach einer Datei namens 1and1-subdomain.php. Falls du sie dort findest, einfach löschen und alles sollte wieder funktionieren.

    Entschuldige die Unannehmlichkeiten!

    Thread-Starter joelluecking

    (@joelluecking)

    Hammer!! Hat funktioniert! Vielen, vielen Dank dir! Und traurig das IONOS so ein gravierenden Bug verursacht und man nicht ganz einfach an eine Lösung kommt! @pfefferle

    Naja, viel einfacher als eine persönliche Antwort von einem IONOS-Mitarbeiter geht ja kaum? 😀

    Danke @pfefferle fürs Einspringen. 👍🏼

    Thread-Starter joelluecking

    (@joelluecking)

    … 😀 So sollte das nicht rüberkommen 😀 Aber der einfache Weg über eine Google Recherche hat leider zu keinem Ziel geführt. Das meine ich mit „nicht ganz einfach“ 😀

    Ja, das haben wir bissle verbockt! Bei unseren Managed Installationen konnten wir das automatisch fixen, aber bei den One-Click Installationen leider nicht, da wir da keine Update-Möglichkeiten haben.

    Und nochmal sorry für die Umstände! 🙁

    Hallo @pfefferle
    verstehe ich das also richtig, dass das Script grundsätzlich gelöscht werden sollte oder nur bei Problemen in solchen Fällen? – Hintergrund: Wir haben auch einen Kunden, bei dem das der Fall ist.

    Viele Grüße
    Hans-Gerd

    Thread-Starter joelluecking

    (@joelluecking)

    Wenn mehrere Leute diesen Bug haben, vielleicht von IONOS Seite mal einen „Blog Beitrag“ oder YouTube Video drüber verfassen? Wie gesagt, ich habe über Google, YouTube mein Netzwerk etc. keine Lösung gefunden.

    Dieses Forum war meine letzte Anlaufstelle

    Nur als Input @pfefferle Wenn’s einer in die Wege leiten kann, dann du 🙂

    @hage nur in diesen problematischen Fällen, es macht aber auch nicht viel kaputt wenn du es generell löschst. Das Script sorgt dafür, dass Seiten nur dann indiziert werden wenn sie eine echte Domain aufgeschaltet haben. Man kann einen Blog auch erstmal unter einer IONOS Subdomain installieren um auszuprobieren und zu experimentieren, diese Domain sollte aber nicht auf Google & Co. landen (weil eben nur zu Test-Zwecken). Leider gibt es einen kleinen Fehler in einer alten Version, die alle *-online.de Domains fälschlicherweise als IONOS Subdomain einstuft und so das indizieren verhindert. Es ist ein ärgerlicher Bug, sollte aber sehr selten auftreten.

    @joelluecking Notiert! 🙂

    @pfefferle
    alles klar – danke für die schnelle Rückmeldung 👍

Ansicht von 13 Antworten – 1 bis 13 (von insgesamt 13)
  • Das Thema „Seitenindexierung nicht möglich“ ist für neue Antworten geschlossen.