Support » Allgemeine Fragen » Seitenoptimierung: WordPress lädt Fonts von C-Laufwerk

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    die Fehler kannst du in der developer console (Aufruf mit STRG+SHIFT+J bei Chrome) sehen.

    Das Problem mit den defekten Links kannst du mit dem Plugin „Better Search and Replace“ korrigieren. Einträge in der Datenbank https://www.xxx-band.de/wp-content/fonts/C:/xampp/htdocs/dosenbier/wp-content/fonts/poppins/pxiByp8kv8JHgFVrLEj6Z1xlFQ.woff2 werden dann ersetzt durch https://www.xxx-band.de/wp-content/fonts/poppins/pxiByp8kv8JHgFVrLEj6Z1xlFQ.woff2 (xxx musst du natürlich durch deine domain ersetzen).

    Vorher bitte eine Sicherung zumindest von der Datenbank erstellen.

    Die Korrektur der beiden anderen beiden Links führst du dann in ähnlicher Art durch.

    Allerdings solltest du gewährleisten, dass sich in dem genannten Ordner /wp-content/fonts/ auch die entsprechenden Dateien befinden.

    Danach solltest du dann in der developer console prüfen, ob die 3 Fehler nicht mehr auftauchen. Danach kannst du das Plugin Better Search and Replace wieder deinstallieren.

    Viele Grüße
    Hans-Gerd

    Thread-Starter kunzi98

    (@kunzi98)

    Hallo @hage!

    Danke für die schnelle Antwort.

    Deinen Tipp mit Better Search an Replace konnte ich umsetzen. Allerdings hatte das kein Erfolg. Die Einträge scheinen ersetzt zu werden, allerdings taucht der fehler immer noch auf.

    Beste Grüße

    Daniel

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo @kunzi98
    ich sehe da allerdings nur noch 2 statt der 3 Fehler. Du musst das eben noch für die anderen beiden Fehler in ähnlicher Weise durchführen, siehe hier:
    https://www.xxx-band.de/wp-content/fonts/C:/xampp/htdocs/dosenbier/wp-content/fonts/poppins/pxiEyp8kv8JHgFVrJJfecg.woff2 ersetzen durch:
    https://www.xxx-band.de/wp-content/fonts/poppins/pxiEyp8kv8JHgFVrJJfecg.woff2

    und

    https://www.xxx-band.de/wp-content/fonts/C:/xampp/htdocs/dosenbier/wp-content/fonts/poppins/pxiByp8kv8JHgFVrLCz7Z1xlFQ.woff2 ersetzen durch:
    https://www.xxx-band.de/wp-content/fonts/poppins/pxiByp8kv8JHgFVrLCz7Z1xlFQ.woff2

    Übrigens ist es sinnvoll, während der Entwicklung keine Cache-Plugins zu aktivieren.

    Viele Grüße
    Hans-Gerd

    Moderator Hans-Gerd Gerhards

    (@hage)

    Nachtrag: Auf eurer Website werden trotzdem die Google Fonts geladen.
    Abhilfe schafft z. B. das Plugin Disable and Remove Google Fonts.
    Weitere Infos findest du z. B. in dem folgenden Beitrag.

    Moderator Angelika Reisiger

    (@la-geek)

    @kunzi98

    Mach einfach das folgende
    ersetze mithilfe von Better Search and Replace:
    /C:/xampp/htdocs/dosenbier/wp-content/fonts/
    durch
    /

    Und noch ein Tipp, der nichts mit dem Problem zu tun hat: Auf der Startseite wird unter Neuigkeiten der Standard-Beitrag angezeigt

    Hallo Welt!
    23. August 2022
    Willkommen bei WordPress. Dies ist dein erster Beitrag. Bearbeite oder lösche ihn und beginne mit dem Schreiben!

    Navigiere im Backend zu „Beiträge“ und ändere Titel und Text in etwas Sinnvolles.

    Thread-Starter kunzi98

    (@kunzi98)

    Hey @la-geek!

    Das erste ist natürlich sehr sinnvoll – warum bin ich da nicht drauf gekommen? hehe sehr clever.

    Ja die Beitragsseite ist noch nicht fertig. Seite ist noch im Aufbau 🙂

    Danke @hage für die Tipps – ich war mir eigentlich sicher, alle ersetzt habe, wie du beschrieben hast. Die Einträge blieben aber. Vielleicht lag es wirklich an den Cache Plugins. Ich habe die jetzt erst mal deaktiviert.

    Sofort nach dem Ersetzen und der Installation von „Disable and Remove Google Fonts“ erscheint die Meldung allerdings immer noch. Ich werde mir die Sache morgen nochmal ansehen. Vielleicht braucht es ein bisschen.

    Jedenfalls ist die neue Form des Dateipfades in der Fehlermeldung „file:///C:/xampp/htdocs/dosenbier/wp-content//fonts/poppins/pxiEyp8kv8JHgFVrJJbecmNE.woff2“ Es scheint mir irgendwo noch eine alte Einstellung zu sein. Sollte ich auch diese Pfade ersetzen? wenn ja womit? Mit den Fonts in dem richtigen Pfad so wie davor erledigt?

    Danke für die Hilfe 🙂

    • Diese Antwort wurde geändert vor 4 Wochen von kunzi98.
    • Diese Antwort wurde geändert vor 4 Wochen von kunzi98.

    Hallo,

    Jedenfalls ist die neue Form des Dateipfades in der Fehlermeldung „file:///C:/xampp/htdocs/dosenbier/wp-content//fonts/poppins/pxiEyp8kv8JHgFVrJJbecmNE.woff2“

    .
    Das kann ich in der developer console sehen.
    Ich vermute eher, dass du bei der Ersetzung einen Fehler gemacht hast. Prüfe bzw. korrigiere das doch bitte noch mal mit Better Search and Replace.

    Viele Grüße
    Hans-Gerd

    @kunzi98 verwendet doch Elementor?

    Für Elementor gibt es einen eigenes Werkzeug zur Ersetzung von URLs. Das findest du unter Elementor > Werkzeuge: wp-admin/admin.php?page=elementor-tools#tab-replace_url

    Außerdem erzeugt Elementor eigene CSS-Stylesheets, die von Ersetzungen in der Datenbank nicht erfasst werden. Dafür gibt es unter Elementor > Werkzeuge einen Button bei „CSS & Daten neu generieren“: wp-admin/admin.php?page=elementor-tools#tab-general.

    Thread-Starter kunzi98

    (@kunzi98)

    Guten Morgen zusammen!

    Jetzt nochmal in aller Frische.

    @hage

    Ich denke dass ich keinen Fehler gemacht habe. Beim ersetzen der Einträge kommt einfach 0 gefundene und 0 ersetzte. Ich gehe also davon aus, dass die Einträge alle aktuell sind in der Datenbank und hier nichts mehr mit :C gefunden wird.

    @pixolin

    Ja ich nutze Elementor. Ich habe „CSS & Daten neu generieren“ ausgeführt und gespeichert. Die Fehler bleiben bestehen. Bei dem Ersetzen Tool von Elementor weiß ich jetzt aber nicht genau was ich da ersetzen soll. Denn die neuen „falschen“ URLs sind „file:///C:/xampp/htdocs/dosenbier/wp-content//fonts/poppins/pxiByp8kv8JHgFVrLEj6Z1xlFQ.woff2“ etc. (eben für alle .woff2 Dateien). Soll ich diese URLs mit den URLs des eigentlichen Speicherplatzes (so wie zuvor auch schon getan) ersetzen?

    VG

    Daniel

    Ich würde die Datenbank vom Server mal exportieren und dann in der SQL-Datei nach Xampp suchen. Falls dort ein Eintrag zu finden ist, wurde ich den zur Not manuell anpassen.

    Wenn gar nichts hilft, könnte man die Datei https://www.dosenbier-band.de/wp-content/fonts/f0009557a92d0e123e0aeab734da6647.css manuell anpassen, aber das kann sehr schnell wieder in die Hose gehen. Man müsste herausfinden, wer diese Datei erstellt und dann prüfen, warum da immer noch der falsche Pfad benutzt wird.

    • Diese Antwort wurde geändert vor 3 Wochen, 6 Tage von bscu.
    • Diese Antwort wurde geändert vor 3 Wochen, 6 Tage von bscu.
    Thread-Starter kunzi98

    (@kunzi98)

    @bscu und was soll dann stattdessen in den Eintrag? Der Pfad zur eigentlichen Font-Datei?

    Der Pfad zur eigentlichen Font-Datei?

    Was sonst?

    Thread-Starter kunzi98

    (@kunzi98)

    Also Update: Ich habe in der Datenbank alle einträge mit XAMPP gesucht und mit den Pfaden zu den Fonts ersetzt. Dazu habe ich file://wp-content/..... anstatt den XAMPP Pfaden von meinem C-Laufwerk genommen. Ich habe den Cache der Seite und die Browserdaten meines Browsers gelöscht. Ich finde keine weiteren Einträge in der Datenbank mit „XAMPP“ drinnen. Die Fehler bleiben nach wie vor bestehen. Welchen Ort habe ich noch nicht gefunden? Ich bin ratlos.

    VG

    Daniel

    • Diese Antwort wurde geändert vor 3 Wochen, 6 Tage von kunzi98.

    Wieso file:// ??? 🙁 Da muss ein URL rein, z.B. https://www.example.com/wp-content/fonts

    @bscu das hatte ich an sich @kunzi98 schon in der folgenden Antwort geschrieben, aber 🤷‍♂️

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)