Support » Allgemeine Fragen » Selbes Bild mehrfach verwenden mit Unterschiedlichen ALT Texten. Möglich? Wie?

  • Gelöst mpprada

    (@mpprada)


    Ich hab folgende Frage:
    Ich würde gerne auf diversen Lentingpages, die auf unterschiedliche Inhalte optimiert sind, zum Teil das selbe Bild verwenden wollen, wobei ich allerdings gerne immer unterschiedliche für den Inhalt der Seite optimierte ALT Texte benutzen würde.
    Jetzt habe ich aber das Problem, dass sich der ALT Text des Bildes nach einer Änderung im Medienbereich oder beim Einfügen des Bildes auf die Seite global zu verändern scheint.
    Habe ich zum Beispiel auf Seite 1 ein BMW Bild mit dem All Text „München“ drin und füge anschließend das selbe Bild auf Seite 2 mit dem All Text „Düsseldorf“ ein, lautet der Alt Text des Bildes nun auf Seite 1 auch „Düsseldorf“ statt „München“.

    Ich kann natürlich ein und das selbe Bild mehrfach in die Mediathek hochladen und entsprechend mit unterschiedlichen ALT Texten versehen. Das fühlt sich allerdings redundant und falsch ein. Gibt es irgendeine Möglichkeit nur ein Bild in der Mediathek zu haben und Instanzen davon mit unterschiedlichen ALT Texten auf Einzelseiten zu verwenden?

    Ich habe zum Teil etwas ältere Artikel gelesen bei denen angeblich beim Einfügen von Bildern in Posts die ALT Texte gespeichert bleiben. Dies scheint bei Einzelseiten aber definitiv nicht der Fall zu sein oder aber in der neueren Version von WordPress.

    Ich bin für jeden Tipp dankbar.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Hallo,
    dann gib doch einfach als ALT-Text mehrere Begriffe ein:
    München Düsseldorf Berlin
    Viele Grüße,
    Hans-Gerd

    Würde ich gerne aus SEO Gründen vermeiden wollen. Da das Bild mitunter 10-20x verwendet werden könnte würde das recht schnell zum Keyword Stuffing führen, was ich vermeiden möchte.
    Gibt es keine andere Möglichkeit, als das Bild dann redundant in der Mediathek zu führen? (Also worst case 10-20x 😳)?

    Da das Bild mitunter 10-20x verwendet werden könnte würde das recht schnell zum Keyword Stuffing führen, was ich vermeiden möchte.

    … das ist natürlich richtig, aber du hattest in deiner Frage nicht erwähnt, dass du das Bild in 10-20 unterschiedlichen Beiträgen verwenden willst.
    In diesen Fällen verwende ich ähnliche Fotos. Wenn ich also mehrere Beiträge zu Fahrrädern habe, dann lade ich entsprechend unterschiedliche Fotos zu Fahrrädern hoch und verwende die Fotos maximal 2-3 mal mit entsprechenden ALT.
    Oder ich nutze ein Foto als Platzhalter und habe dann nur wenige Begriffe als ALT-Attribut. Um bei deinem Beispiel zu bleiben: Ein Foto von einem Motorrad (BMW) und dann als ALT-Attribut „BMW“.
    Mehr Infos zu der Thematik findest du z. B. hier

    Moderator Bego Mario Garde

    (@pixolin)

    Das Attribut alt des <img>-Tag wird vom W3C als „Fallback-Inhalt für ein Bild“ beschrieben und soll dazu dienen, etwas anzuzeigen, wenn Bilder aus unterschiedlichen Gründen (Einschränkungen des Webbrowsers, Benutzereinstellung wegen limitierter Bandbreite, Verwendung eines Screenreaders) nicht angezeigt werden können oder sollen. (vgl. https://www.w3.org/wiki/Html/Elements/img#HTML_Attributes)

    Für jemanden mit einer Sehbehinderung ist die Ausgabe des Screenreaders von z.B. „Wild gestikulierender Bundesverkehrsminister von Untersuchungsausschuss“ hilfreicher als der gesprochene Hinweis „Bild“.

    Suchmaschinen können bisher Fotos nur sehr eingeschränkt wahrnehmen und werten deshalb stattdessen das alt-Attribut aus, was aber nicht bedeutet, dass hier wahlfrei SEO-Keywords untergebracht werden sollen um das Ranking zu pushen. Für ein Bild, das ein Auto der Marke „Flitzblitz“ zeigt, ist ein alt-Attribut mit Inhalt „Flitzbitz, Modell 2020E“ hilfreich, während ein Inhalt „Berlin“, „München“ oder „Hamburg“ eher irreführend ist und nicht dem Sinn des alt-Tags entspricht. Wenn das Bild hingegen für den Inhalt der Website unbedeutend ist und mehr dekorativen/illustrativen Charakter hat, empfiehlt das W3C sogar, das alt-Tag wegzulassen oder das Bild per CSS einzubinden:

    Wenn ein Bild dekorativ, aber nicht besonders seitenspezifisch ist, z. B. ein Bild, das Teil eines standortweiten Designsystems ist, sollte das Bild im CSS der Website angegeben werden, nicht im Markup des Dokuments.

    Hallo @mpprada

    Jetzt habe ich aber das Problem, dass sich der ALT Text des Bildes nach einer Änderung im Medienbereich oder beim Einfügen des Bildes auf die Seite global zu verändern scheint.

    Das liegt dann aber nicht an WordPress, sondern da funkt vermutlich ein SEO-Plugin oder ähnliches dazwischen.

    Ich hatte das vor längerer Zeit einmal getestet. Und nun erneut: Mit WP 5.5 Beta 1 (Block Bild), mit WP 5.4.2 (Block Bild) sowie WP 5.4.2 und Classic Editor (Datei hinzufügen). Jeweils 3 Beiträge, immer dasselbe Bild und alle behalten ihren geänderten ALT-Tag.

    Hier ist der Vorgang noch einmal näher beschrieben (zu finden unter… „Der Test“ -> aufklappen -> „Kapitel lesen“ -> „Der Prozess in WordPress“), daran hat sich rein gar nichts geändert.

    Hi Angelika,

    danke dir. Das klingt nach dem Feedback, nach dem ich gesucht habe (die allgemeine Benutzung des ALT Titles ist mir natürlich bestens bekannt).

    Ok, sprich, es ist kein WP Problem, sondern wird von einem PlugIn verursacht. Interessant.

    Wobei nicht ganz ersichtlich wird, ob es sich bei den Beiträgen in dem Artikel um Posts oder Pages handelt. Bei Posts scheint es zu funktionieren…Nicht aber bei Pages.

    Sollte es an PlugIns liegen, kommen bei mir diesbezüglich pot. drei Übeltäter in Frage:

      SEOPress
      TranslatePress
      Enable Media Replace

    Jemand mit einem der beiden das ALT Title Text Problem erlebt?
    Und falls ja, hat jemand einen Work-Around?

    Habe es jetzt auch nochmal getestet….bei Posts, die im WP eigenen Editor verfasst werden, geht es wie beschrieben…

    Wenn ich aber Seiten mit Elementor erstelle, werden die ALT Titel entsprechend global verändert (also z.B. wenn ich das selbe Bild auf zwei unterschiedlichen Elementor Seiten nutze, tragen sie danach beide den letzten Stand des ALT Titles)

    • Diese Antwort wurde geändert vor 4 Wochen, 1 Tag von mpprada.
    • Diese Antwort wurde geändert vor 4 Wochen, 1 Tag von mpprada.

    Das mit Elementor (Pro) kann ich reproduzieren. Auf dieser Website sind jedoch viele andere Plugins, inklusive Elementor-Add-ons installiert (u. a. auch SeoPress). Es wäre jetzt wenig zielführend, wenn ich weitere Tests machen würde, denn trotzdem könnten sich unsere Systeme unterscheiden, hinsichtlich WordPress-Version, Classic Editor oder nicht, Elementor Pro oder free usw.

    Daher bleibt dir jetzt wohl nur:
    Alle! Plugins außer Elementor deaktivieren. zuvor evtl. Plugin-Caches leeren, nach Deaktivierung Browser-Cache leeren, und dann testen, ob es immer noch mit Elementor auftritt, nur in Pro (falls vorhanden) oder in Free.

    Wenn du Elementor als ursächlich verifizieren kannst, dann solltest du den Support von Elementor kontaktieren.

    Hallo @la-geek ,
    danke für die interessante Info. Das hatte ich noch gar nicht so auf dem Schirm.
    Viele Grüße und schönen Abend,
    Hans-Gerd

    Hallo @hage

    gerne und danke, ich wünsche dir auch einen schönen Abend :). Ja das war damals schon spannend, das zu „erforschen“ 😀

    @mpprada

    noch als Ergänzung: Auch das Theme könnte eventuell das Speichern des ALT-Tags beeinflussen, hier solltest du aim Ausschlussverfahren auf ein Standard-Theme wechseln und testen.

    @la-geek

    Danke schonmal. Werde ich mal entsprechend antesten. Auf jeden Fall schonmal interessant zu wissen, dass es da einen Unterschied zwischen Pages und Posts gibt im Bezug auf die Einbindung von Medieninhalten.

    Aktuell kommt das Hello-Elementor Theme vom Elementor Team zum Einsatz.

    Bei mir gab es keinerlei Unterschiede zwischen Beiträgen und Seiten hinsichtlich ALT-Tag.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)