Support » Installation » Server sehr langsam seit Update 4.3.1

  • Hallo Community,

    wir haben seit dem automatischen Update auf 4.3.1 am 15.09 ein Problem mit den Ladezeiten. PHP Dateien laden sehr langsam, bei einzelnen Seiten beträgt die Ladezeit über 30 Sekunden. Wird der WordPress Blog wieder deaktiviert funktioniert alles (Shop) wieder einwandfrei. Profihost hat festgestellt, dass aus dem Blog heraus sehr viele Prozesse gestartet werden, die den Server stark belasten. Ein Fehler am Server wurde ausgeschlossen. Die langen Ladezzeiten wurden knapp 3 Stunden nach dem automatischen Update festgestellt. Zwischenzeitlich wurden keine Ändeurngen vorgenommen. Woran könnte es liegen?

    Viele Grüße

    Niklas

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Edi

    (@psychosopher)

    Profihost hat festgestellt, dass aus dem Blog heraus sehr viele Prozesse gestartet werden, die den Server stark belasten.

    Um was für Prozesse handelt es sich?

    hi RSRamendo
    welche Plugins nutzt ihr?
    habt ihr custom post types,

    ich frage deshalb, weil diese hohe CPU last könnte von einem Plugin kommen, dass die custom post types URLs verändert
    https://wordpress.org/support/topic/431-high-cpu-usage?replies=1

    Hallo,

    das Problem wurde durch ein Update von WordPress gelöst.

    Vielen Dank!

    Ramendo

    Edi

    (@psychosopher)

    Und wie ist das zu verstehen? Das Problem ergab sich doch durch ein Update…

    Hallo Edi,
    das Problem ist nach 12 Stunden wieder aufgetreten. Mit Update habe ich eine Neuinstalltion gemeint und bin davon ausgegangen, dass dieses Installtion ein Update enthalten hat. Wir haben es auf einer anderer Umgebung getestet und der Blog funktioniert einwandfrei. Offensichtlich liegt es gar nicht an WordPress sondern an irgendwelchen Servereinstellungen. Profihost konnte das Problem jedenfalls nicht nachvollziehen. Ergebnis: nach 3 Wochen werden wir den Blog morgen auf einen anderen Server umziehen.

    Viele Grüße

    Ramendo

    Hallo Monika,
    Plugins wurden zwischenzeitlich auf den neuesten Stand gebracht bzw. deaktiviert. Damit hat es nichts zu tun.

    Viele Grüße

    Ramendo

    Hallo,

    inzwischen habe ich einen Downgrade durchgeführt, aber auch das hatte keinen Erfolg. Es ist so, dass 5 PHPProzesse immer gleichzeitig gestartet werden, sobald WordPress aktiviert wird. Im Shop-Forum wurde ich in diesem Zusasmmenhang auf folgendes aufmerksam gemacht:

    “ Ich kann mir nur vorstellen, dass die Anweisung

    @header(„Cache-Control: no-cache, must-revalidate“);

    aus der Smartstore-Datei von einer WordPress-Datei überschrieben wird, und daher die Smartstore-Datei immer wieder neu lädt.

    Begründung:
    “Ziel war es, dass der Client immer kurz den Server anfragt (must-revalidate), dabei den HTTP_IF_MODIFIED_SINCE-Header mitsendet und ich so überprüfen kann, ob der Browser-Cache-Inhalt noch aktuell ist. ”
    Das ist ja insofern wichtig, dass der gecachte Warenkorb-Inhalt immer auf dem letzten Stand ist.“

    Gibt es so einen Code bzw. Befehl in WordPress?

    Viele Grüße

    Ramendo

    Hallo Zusammen,

    wir haben den Shop jetzt auf eigenen Vhost ausgelagert und serverseitig eine Umleitung einrichten lassen. Das Problem mit der Geschwindigkeit besteht jetzt nicht mehr. Dafür werden aber die CSS-Dateien nicht mehr geladen. Ich habe hierzu einen neuen Thread eröffnet:

    https://de.forums.wordpress.org/topic/wordpress-als-vhost?replies=1#post-545847

    Viele Grüße

    Ramendo

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „Server sehr langsam seit Update 4.3.1“ ist für neue Antworten geschlossen.