Support » Installation » Server-Verschiebung

  • Gelöst barcalex

    (@barcalex)


    Hallo,

    ich hätte eine Frage:
    Ich habe gerade meinen Anbieter gewechselt und mich an die Anleitung von hier gehalten. https://www.checkdomain.de/blog/tipp/wordpress-auf-einen-anderen-server-umziehen/

    Soweit so gut, aber leider scheit es nicht ganz so funktiniert zu haben wie gewünscht.
    Es erscheint die Fehlermeldung „Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0 „

    Mein Blog:
    http://www.allekochen.com

    Ich kann mich aber über die WordPress-Login-Adresse normal in meinen Blog einloggen und auch dort ganz normal editieren, aktualisieren usw. Nur scheint es einen Konflikt zu geben zwischen intern und Erscheinungsbild.

    Kann mir wer weiterhelfen ???

    vielen Dank im Vorraus, Alex

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Die Fehlermeldung ist tatsächlich nicht sehr aussagekräftig.

    Da du dich im Back End anmelden kannst … hast Du mal versucht, alle Plugins zu deaktivieren um sie als mögliche Fehlerquelle auszuschließen?

    Manchmal werden bei der Übertragung Dateien nicht richtig hochgeladen, funktionieren also nicht und erzeugen deshalb Fehlermeldungen. Das gilt natürlich nicht ausschließlich für Plugin-Dateien. Aber irgendwo muss man ja mal anfangen zu suchen 😉

    Ich habe jetzt alle Plugins nach der Reihe ausgeschalten.
    Bei WP Minify hat sich was geändert danach. Es ist eine unglaublich lange Liste gekommen mit den unterscheidlichsten Error-Meldungen und dabei stürzt dann mein Browser ab.

    Ich hab es deinstalliert – die Fehlermeldung ist geblieben. Ich es wieder installiert und aktiviert und der oben genannte Bildschirm mit dem Fatal Error war wieder da.

    Ich komme leider nicht weiter. Wäre es vielleicht ratsam WordPress komplett neu zu installieren ? Welche Dateien muss ich dann löschen und wo befindet sich mein ganzer Inhalt drinnen ? Gibt es hier eine gute Anleitung ?

    danke, Alex

    Probier doch mal folgendes:

    • Alle Plugins deaktivieren.
    • Datei .htaccess umbenennen
    • Unter Einstellungen > Permalinks die gewünschte Form auswählen und sichern

    Geht es dann wieder? Welche Fehlermeldungen erscheinen?

    Hast Du ein Cache-Plugin wie z.B. WP Super Cache verwendet? Hier reicht es nicht, das Plugin zu deaktivieren, sondern es müssen auch alle vom Plugin vollzogenen Änderungen rückgängig gemacht werden (siehe Plugin-Seite).

    Hi,

    danke erstmal dass du mir so viele Tips gibt.

    Ich habe jetzt das gemacht was du geschieben hast … leider funktioniert die Seite nicht und es kommt die Error-Meldungs-Seite die ich auch schonmal hatte.
    Ich lasse die Seite jetzt so aktiv damit du sehen kannst was ich meine.

    WP Super Cache habe ich nicht …

    Wo hast Du denn die WordPress-Dateien hinkopiert? Ist das ein Ordner htdocs oder www? Und gibt es einen Ordner für temporäre Dateien /TMP außerhalb des Web-Verzeichnisses?

    Ähm, wir du vielleicht schon mitbekommen hast, bin ich leider nur ein Endverbrauchen und kein „Wissender“ … tu mir dementsprechend schwer zu antworten.

    Also ich versuch es mal so gut wie möglich:

    Habe die Dateien einfach von meinem alten Server per FTP auf meine Platte gezogen und den Inhalt ganz gleich wieder retour gelegt.

    Wo sehe ich ob es ein Odner htdocs oder www ist ?
    Und wo sollte der Ornder für temp. Dateien sein ?

    Sorry

    Was für Verzeichnisse werden im FTP-Programm angegeben?

    cgi-bin
    error
    logs
    stats
    usage
    wp-admin
    wp-content
    wp-includes

    Hast du das gemeint ?

    Ist das alles in einem Verzeichnis? Was passiert, wenn Du ein Verzeichnis tmp hinzufügst?

    Leider nichts …

    Frage: glaubst du, dass wenn ich wordpress vom Server entferne und wieder komplett neu installiere, den wp-content-Ordner und die Datenbank neu einlese – es wieder wie vorher funktionieren könnte ?

    Laut der Anleitung sollst du die Domain nur in der wp_options-Tabelle anpassen. Da gibt es aber noch tausend andere Orte wo der alte Link steht (alle individuellen Menüpunkte, Grafik-Links, Plugin-Einstellungen, etc.).

    Versuche mal dieses Tool, um den Rest auch anzupassen:
    http://interconnectit.com/products/search-and-replace-for-wordpress-databases/

    Gruß, Torsten

    Hallo,

    ich habe das Problem jetzt endlich lösen können.

    Ich habe soweit wohl alles richtig gemacht gehabt, aber was ich vergessen habe, war in der Datenbank alle Links auf das alte Stammverzeichnis auf das neue zu ersetzen. Sobald ich das gemacht habe, hat alles laut Anleitung geklappt.

    danke fürs Helfen,
    Alex
    http://www.allekochen.com

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „Server-Verschiebung“ ist für neue Antworten geschlossen.