Support » WooCommerce » Shop leer, keine Artikel werden angezeigt!

  • linzerseife

    (@linzerseife)


    Hallo zusammen!
    Ich bin die Birgit aus Österreich und betreibe einen kleinen Onlineshop mit WooCommerce!
    Und ich bin im Moment am verzweifeln:(
    Mein Problem:
    Seit einiger Zeit, kommt es immer wieder vor, das der Shop keine Artikel anzeigt. (es sind jedoch welche vorhanden)
    Was wir (der Herr der ihn erstellt hat) herausgefunden haben, ist, dass wenn man bei den Einstellungen auf die Permalinks klickt, diese dann aktualisiert, alles wieder ganz normal ist. Das hält dann ca einen Tag!
    Alle Plugins deaktiviern und wieder nacheinander aktivieren, hat keine Erkenntnis gebracht.
    Folgendes hat auch keine Ergebnise gebracht:
    Der Wert WP_DEBUG_LOG wurde der Konfigurationsdatei dieser Website hinzugefügt. Das bedeutet, dass alle Fehler auf der Website in eine Datei geschrieben werden, die möglicherweise für alle Benutzer verfügbar ist.

    Ich bin leider ein absoluter Laie, darum bitte ich um Entschuldigung! Falls noch Infos benötigt werden. Sehr gerne.

    Ich hoffe ihr könnt mir weiterhelfen.

    Vielen Dank und liebe Grüße
    Birgit

    Der fehlende Bericht:

    
    ### wp-core ###
    
    version: 5.9
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Vienna
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 35
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/vhosts/siedepunkt.cc/httpdocs/siedepunkt.cc
    wordpress_size: 107,56 MB (112781387 bytes)
    uploads_path: /var/www/vhosts/siedepunkt.cc/httpdocs/siedepunkt.cc/wp-content/uploads
    uploads_size: 1,49 GB (1599742838 bytes)
    themes_path: /var/www/vhosts/siedepunkt.cc/httpdocs/siedepunkt.cc/wp-content/themes
    themes_size: 55,99 MB (58707003 bytes)
    plugins_path: /var/www/vhosts/siedepunkt.cc/httpdocs/siedepunkt.cc/wp-content/plugins
    plugins_size: 143,17 MB (150127218 bytes)
    database_size: 30,66 MB (32145408 bytes)
    total_size: 1,82 GB (1953503854 bytes)
    
    ### wp-dropins (1) ###
    
    maintenance.php: true
    
    ### wp-active-theme ###
    
    name: Enfold (enfold)
    version: 4.8.9.1
    author: Kriesi
    author_website: https://kriesi.at
    parent_theme: none
    theme_features: core-block-patterns, avia_exclude_bbPress, deactivate_tribe_events_calendar, avia_exclude_GFForms, avia_exclude_menu_exchange, avia_exclude_pojo_accessibility, avia_exclude_wp_accessibility, avia_exclude_relevanssi, avia_exclude_wpSEO, avia_exclude_wpml, avia_exclude_instagram_feed, avia_exclude_leaflet_map, avia_mega_menu, avia_improved_backend_style, avia_option_pages_toggles, avia_sidebar_manager, automatic-feed-links, nav_menus, menus, widgets, woocommerce, post-formats, avia_post_meta_compat, force-post-thumbnails-in-widget, post-thumbnails, widgets-block-editor, title-tag, editor-styles, editor-style, customize-selective-refresh-widgets, responsive-embeds, editor-color-palette, editor-font-sizes, wc-product-gallery-zoom, wc-product-gallery-slider, avia-wc-30-product-gallery-feature, avia_no_session_support
    theme_path: /var/www/vhosts/siedepunkt.cc/httpdocs/siedepunkt.cc/wp-content/themes/enfold
    auto_update: Deaktiviert
    
    ### wp-plugins-active (24) ###
    
    Advanced WordPress Backgrounds: version: 1.8.0, author: nK, Automatische Aktualisierungen aktiviert
    Akismet Anti-Spam: version: 4.2.2, author: Automattic, Automatische Aktualisierungen aktiviert
    Booster for WooCommerce: version: 5.5.1, author: Pluggabl LLC, Automatische Aktualisierungen aktiviert
    Classic Editor: version: 1.6.2, author: WordPress Contributors, Automatische Aktualisierungen aktiviert
    Custom Product Tabs for WooCommerce: version: 1.7.7, author: YIKES, Inc., Automatische Aktualisierungen aktiviert
    Easy Social Icons: version: 3.1.3, author: cybernetikz, Automatische Aktualisierungen aktiviert
    Germanized for WooCommerce: version: 3.8.3, author: vendidero, Automatische Aktualisierungen aktiviert
    Google Analytics for WordPress by MonsterInsights: version: 8.3.4, author: MonsterInsights, Automatische Aktualisierungen aktiviert
    Google XML Sitemaps: version: 4.1.1, author: Auctollo, Automatische Aktualisierungen aktiviert
    Insert Headers and Footers: version: 1.6.0, author: WPBeginner, Automatische Aktualisierungen aktiviert
    Klarna Checkout for WooCommerce: version: 2.6.4, author: Krokedil, Automatische Aktualisierungen aktiviert
    Klarna Order Management for WooCommerce: version: 1.6.8, author: klarna, krokedil, Automatische Aktualisierungen aktiviert
    Klarna Payments for WooCommerce: version: 2.8.1, author: krokedil, klarna, automattic, Automatische Aktualisierungen aktiviert
    Loco Translate: version: 2.5.8, author: Tim Whitlock, Automatische Aktualisierungen aktiviert
    MC4WP: Mailchimp for WordPress: version: 4.8.6, author: ibericode, Automatische Aktualisierungen aktiviert
    MetaSlider: version: 3.26.0, author: MetaSlider, Automatische Aktualisierungen aktiviert
    Popup Maker: version: 1.16.4, author: Popup Maker, Automatische Aktualisierungen aktiviert
    PublishPress Future: version: 2.7.3, author: PublishPress, Automatische Aktualisierungen aktiviert
    Trustpilot-reviews: version: 2.5.901, author: Trustpilot, Automatische Aktualisierungen aktiviert
    WooCommerce: version: 6.2.0, author: Automattic, Automatische Aktualisierungen aktiviert
    WooCommerce Blocks: version: 7.0.0, author: Automattic, Automatische Aktualisierungen aktiviert
    WooCommerce Load More Products: version: 1.1.9.4, author: BeRocket, Automatische Aktualisierungen deaktiviert
    WooCommerce Menu Cart: version: 2.10.4, author: WP Overnight, Automatische Aktualisierungen aktiviert
    WooCommerce PDF Invoices & Packing Slips: version: 2.13.1, author: WP Overnight, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-inactive (4) ###
    
    Cache Enabler: version: 1.8.7, author: KeyCDN, Automatische Aktualisierungen aktiviert
    Smush: version: 3.9.5, author: WPMU DEV, Automatische Aktualisierungen deaktiviert
    Yoast Duplicate Post: version: 4.4, author: Enrico Battocchi & Team Yoast, Automatische Aktualisierungen aktiviert
    Yoast SEO: version: 18.1, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 256M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GROUP4, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMV, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.9.0-16-amd64 x86_64
    httpd_software: Apache
    php_version: 8.0.15 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 64M
    php_post_max_size: 256M
    curl_version: 7.52.1 OpenSSL/1.0.2u
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.1.48-MariaDB-0+deb9u2
    client_version: mysqlnd 8.0.15
    max_allowed_packet: 16777216
    max_connections: 151
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/vhosts/siedepunkt.cc/httpdocs/siedepunkt.cc/wp-content
    WP_PLUGIN_DIR: /var/www/vhosts/siedepunkt.cc/httpdocs/siedepunkt.cc/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: false
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: false
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    • Dieses Thema wurde geändert vor 4 Monaten von linzerseife.
    • Dieses Thema wurde geändert vor 4 Monaten von linzerseife.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 31 bis 45 (von insgesamt 48)
  • Moderator espiat

    (@espiat)

    PS: Staging (exakte copy) aufsetzen auf dem selben Server und schauen, ob das Verhalten auch dort auftritt.

    Die htaccess ändert sich nicht, auf das habe ich früher schon geachtet.

    Ich vermute noch immer, dass es ein oder mehrere Plugins sind, die hier Mist bauen. Es kann doch nichts anderes sein, oder sehe ich das falsch?

    Diff der Datenbanken schau ich gleich mal, melde mich dann nochmal.

    PHP 8.x ist anscheinend nicht das Problem, vorher auf 7.4 war es leider das selbe. Allerdings ist das Problem nicht schon immer bestanden, auch nicht bei PHP 7.4.

    Die Debug.log ist hier, aber da sind wohl auch so manche Fehler von Versuchen drinnen:

    Moderator note: Extremely large log file redacted.

    Exakte Kopie haben wir schon versucht, war leider das selbe… :-(((

    Also im Log wird mehrfach das Memory Limit angemarkert. Das solltet ihr erhöhen.

    Ausserdem müsst ihr immernoch versuchen die scripte von Plesk zu beenden. Zumindest läuft um 1 Uhr nachts irgendein Prozess der wp toolkit / wp cli nutzt.

    Das Memory Limit ist schon auf Extremwerten, weil mir das auch schon aufgefallen ist:

    memory_limit 512M
    post_max_size 256M
    upload_max_filesize 64M

    Siehe hier der Screenshot aus Plesk: https://ibb.co/KKCFs2v

    Es gab dadurch aber keine Änderung, das läuft mittlerweile schon seit ca. 1 Monat mit so hohen Werten. Standard ist weit drunter und funktioniert bei anderen Seiten auf dem selben Server problemlos.

    Nun zu den Diffs:
    [ gelöscht ]


    Moderationshinweis: Bitte poste hier keine vollständige Logs, sondern nutze dafür Dienste wie pastebin.com

    Oh nein, das hat er mir jetzt komplett zerschossen…

    Die „options“-Datenbank scheint ja Unterschiede zu haben, aber da zeigt mir der Diff nicht genau an wo. Irgendwie scheint das sehr „zugemüllt“ zu sein, arrrggghhh… :-(((

    Im Plesk sind folgende Crons in Bezug auf WP-Toolkit gespeichert:

    root@plesk1:~# crontab -u psaadm -l
    12      *       *       *       *       /opt/psa/admin/bin/php -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/wp-toolkit/scripts/maintenance.php'
    21      2       *       *       *       /opt/psa/admin/bin/php -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/wp-toolkit/scripts/instances-auto-update.php'

    Testweise den „maintenance.php“ ausgeführt, passiert nichts.

    Aber wenn ich den „auto-update.php“ ausführe, sind die bekannten Fehler bei den „Rewrite Rules“ wieder vorhanden. Dieser Cron wird um 2:21 Uhr ausgeführt, was von Plesk anscheinend automatisch so definiert wurde.

    Wenn ich nun aber diese Funktion nicht abschalten will, dann muss ich die Ursache bzw. den Fehler finden, oder ich kappe die ganze Automatik, was aber eigentlich nicht Sinn des Erfinders von WP-T. ist. 🙁

    Das php memory limit kannst du vermutlich nicht über Plesk festlegen. Die Einstellungen dort gelten nur für die Webserver, nicht aber für php via Konsole.

    Ist das toolkit auf dem neusten Stand? Eventuell hilft ja ein Update.

    Da die Ursache nun gefunden ist, bin ich diesbezüglich nun raus.

    Wende dich an die toolkit Support, verzichte auf die Funktion (so wie Millionen andere wp Benutzer) oder beauftragte einen Webentwickler, der da mal genauer schaut 🙂

    Hallo in die Runde,

    mir hat es keine Ruhe gelassen und aufgrund von https://talk.plesk.com/threads/rewrite-wordpress-issues-403.363320/ habe ich mal einiges durchprobiert und anscheinend das Problem gefunden:

    Im WordPress Toolkit gibt es ja einiges an Optionen um die Sicherheit zu verbessern, darunter auch der Punkt „Autorenscans blockieren“, siehe hier:

    https://ibb.co/VHxPJ4v

    Sobald diese Option aktiviert ist und man in WordPress Toolkit versucht Updates (für WordPress selbst, sowie auch für Themes und Plugins) werden die Rewrite Rules kaputt konfiguriert.

    Geholfen hat mir dabei auch der „Rewrite Rules Inspector unter https://de.wordpress.org/plugins/rewrite-rules-inspector.

    Ich für meinen Teil habe diese Funktion nun deaktivert und es scheint zu laufen. Sofern sich an diesem Status was ändern sollte, melde ich mich hier nochmal.

    Insgesamt herzlichen Dank für so manchen Tritt in die richtige Richtung und noch ein tolles Wochenende.

    Lg, Jürgen

    Edit: Anscheinend klappt es doch nicht zuverlässig. Ich werde nun die betroffene Installation von WordPress aus dem Toolkit entfernen und hoffe, dass wir dann Ruhe haben. Ich habe die Fresse voll von dem ganzen Sch…marrn. 🙂

    Moderator espiat

    (@espiat)

    Lt. Log laufen deine Cronjobs nicht sauber durch.
    Aufgrund des Memory Limit. Das dürfte auch das Problem sein, wenn du die Plesk WP funktion ausgeschaltet hast. Läuft eben nicht richtig durch.

    Jetzt bitte aufmerksam lesen:

    Der angezeigte Memory Wert in Plesk ist eventuell nicht der Richtige.
    Und der im WP health angezeigte vielleicht auch nicht.

    Lege im root des WP eine php an mit einem phpinfo(); an und lasse dir mal den echten memory limit anzeigen. Du hast da nämlich nur 124 mb

    [04-Mar-2022 01:19:43 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20480 bytes) in /var/www/vhosts/siedepunkt.cc/httpdocs/siedepunkt.cc/wp-includes/functions.php on line 4749

    Erhöhe dann mit einer anderen Methode.

    Also:
    memeory limit checken und ggf. erhöhen.
    dann auf PHP 7.4xxx, weil einige Fehler durch PHP 8 hervorgerufen werden:https://talk.plesk.com/threads/error-wpcli-wp-toolkit.354537/

    @espiat

    Danke für die Info, also momentan sehe ich die eingestellten 512M, wobei mir persönlich das sowieso viel zu viel ist. Die meisten anderen Seiten laufen problemlos mit 64M, aber auf keinen Fall auf so einem hohen Wert.

    Hier der Link zur PHP-Info:
    https://linzerseife.at/abc

    (Ich hoffe, dass ich das posten darf. Ansonsten bitte den Link entfernen!)

    Der Artikel von https://talk.plesk.com/threads/error-wpcli-wp-toolkit.354537/ ist allerdings von 2019. Eigentlich sollte sich mit den Updates von Plesk und WP-Toolkit schon einiges getan haben – ich bin auf jeden Fall auf der aktuellsten Version.

    Ich bin jetzt auf PHP 7.4.x, aber wie gesagt trat das Problem sowohl mit 7.4.x und auch mit PHP 8.x auf. Daher scheint es nicht wirklich an PHP liegen, oder?

    Momentan (ohne WP-Toolkit, da ich es herausgetrennt habe) läuft es anscheinend. Bisher gab es keine Probleme. Aber ich würde WP halt doch gerne mit dem Toolkit laufen lassen.

    Gerne bin ich für weitere Tests bereit um das Problem zu lösen, wovon ggf. auch andere Benutzer lernen können.

    • Diese Antwort wurde geändert vor 3 Monaten, 3 Wochen von espiat. Grund: sensiblen link entfernt zur phpinfo

    @juergendiermaier du redest die ganze zeit vom php memory limit dass für den Webserver Prozess gilt..

    @espiat und ich meinen das php memory limit dass für die Konsole/ php-cli gilt.

    Webserver und Cli sind zwei völlig unterschiedliche Dinge.

    Das Limit das für die Konsole gilt ist derzeit 128mb. Zumindest lässt die Fehlermeldung darauf schließen.

    Bin kein Plesk Admin, und wenn man den Befehl sieht, scheint es auch eine Plesk spezifisches php runtime zu sein…

    Durchsuch den Server mal nach php.ini – irgendwo wird hoffentlich eine php ini auftauchen in der die 128MB stehen.

    Hab mal gegoogelt, welche Optionen es so gibt.
    Versuch mal den cron anzupassen:

    root@plesk1:~# crontab -u psaadm -l
    12      *       *       *       *       /opt/psa/admin/bin/php -dmemory_limit=256M -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/wp-toolkit/scripts/maintenance.php'
    21      2       *       *       *       /opt/psa/admin/bin/php -dmemory_limit=256M -dauto_prepend_file=sdk.php '/opt/psa/admin/plib/modules/wp-toolkit/scripts/instances-auto-update.php'

    Alternativ schau mal ob eine Änderung in /usr/local/psa/admin/conf/php.ini hilft. Dazu auch die Backend Dienste neu starten
    (https://support.plesk.com/hc/en-us/articles/213931485-Operations-in-Plesk-fail-Allowed-memory-size-of-X-bytes-exhausted-tried-to-allocate-Y-bytes-)

    • Diese Antwort wurde geändert vor 3 Monaten, 3 Wochen von Michi91.
    • Diese Antwort wurde geändert vor 3 Monaten, 3 Wochen von Michi91. Grund: Typo

    Ahhhh, tut mir leid…

    Jetzt habe ich es verstanden und habe sofort in Google gesucht, wie ich das finde:

    To change the memory_limit globally, go to Plesk > Tools & Settings > PHP Settings > PHP handler > php. ini > find memory_limit and type the new value, e.g. 128M. Note: These settings will be only applied to the domains configured with the default value.

    Ich versuche es aber vorher nochmal mit dem angepassten Cron…

    Also WP-Toolkit wieder einbinden und dann mal testen. Ich melde mich dann wieder, was sich so ergibt und ob die Rewrite Rules wieder abgeschossen werden.

    @juergendiermaier wenn es nicht klappt, bitte uns unbedingt wieder den Auszug aus der php error log zur Verfügung stellen 🙂

Ansicht von 15 Antworten - 31 bis 45 (von insgesamt 48)