Support » Allgemeine Fragen » Sichtbarkeit für Suchmaschinen

  • Gelöst ichlernewordpress

    (@ichlernewordpress)


    Hallo Forenmitglieder,

    meine Webseite kann bei Google etc. nicht gefunden werden.

    Unter dem Punkt “Einstellungen/lesen” habe ich die Möglichkeit “Suchmaschinen davon abzuhalten diese Webseite zu indexieren” zu aktivieren bzw. deaktivieren.
    Ich deaktiviere durch Entfernung des Hakens im Auswahlfeld und speichere danach die Einstellung.
    Leider ist diese Einstellung nicht dauerhaft, der Haken ist nicht dauerhaft entfernt, sondern am nächsten Tag wieder automatisch gesetzt. Resultat ist, dass die Webseite über Google z.B. nicht angezeigt wird.
    Habe inzwischen vieles ohne Erfolg ausprobiert:

    Sitmaps aktualisiert.
    YoastSeo aktualisiert und Einstellungen überprüft
    Die Header.php des Themes kadence die Zeile <meta name=“robots“ content=“index“> eingefügt.
    Beim Ionos Support (Managed WP) nachgefragt – ohne Ergebnis
    Erfolglose Recherche über Google Search Console.
    WP-Foren durchsucht.

    Gibt es eine Lösung für das Problem?

    Bin für jeden Hinweis dankbar.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Moderator Bego Mario Garde

    (@pixolin)

    Das kann ich nicht nachvollziehen – die Website gibt im Meta-Tag im Header aus, dass die Seiten indexiert werden sollen und die Sitemap gibt auch nichts gegenteiliges aus. Hast du mal im Browser den Cache geleert?

    Wie sieht’s denn mit der Anmeldung der Website in der Google Search Console aus?

    Thread-Starter ichlernewordpress

    (@ichlernewordpress)

    Danke @bego Mario Garde,

    Browser Cache ist geleert. Auch mit anderen Browsern und Endgeräten lässt sich die Anzeige in Suchmaschinen nicht aktivieren.

    Du meinst die Indexierung in der Google Search Console beantragen? Ja- schon mehrfach gemacht und gecrawled. Andert aber nichts daran, dass WP die Webseite wieder auf „noindex“ setzt.

    Hi, @ichlernewordpress.

    Ich vermute, dass es sich um das selbe Problem handelt, das in dieser Anfrage vor einigen Wochen schonmal besprochen wurde.

    Der IONOS-Support kann mit Hinweis auf diesen Thread vielleicht helfen, ansonsten kann ich mich nächsten Montag darum kümmern.

    Richtig. Da war doch was. 🙈

    Danke Simon für den Hinweis.

    Thread-Starter ichlernewordpress

    (@ichlernewordpress)

    @acali @all
    Habe gerade IONOS kontaktiert.
    Leider konnte / wollte man mir nicht weiterhelfen, da es ein durch WordPress zu klärendes Thema sei.
    Also, wenn mir jemand das entsprechende Plugin (https://de.wordpress.org/support/topic/suchmaschinen-davon-abhalten-haekchen-laeasst-sich-nicht-wegklicken/#post-118160) benennen kann, fliegt es raus.

    ping @krafit

    Vielleicht weiß der Simon da mehr?
    Grundsätzlich ist die Aussage, dass der Webhoster nicht für die Webanwendung zuständig ist, korrekt. Aber hier handelt es sich wohl um ein vorinstalliertes (Must-Use-)Plugin von ionos?

    Hallo @ichlernewordpress hast du einen Managed WordPress Vertrag oder einfach nur Click&Build benutzt um WordPress zu installieren? Beim ersten, muss IONOS das Problem am Montag beheben (wie @krafit schon angekündigt hat) und im 2. Fall kannst du das Subdomain Plugin im mu-Plugins Ordner löschen und es sollte wieder funktionieren.

    Entschuldige die Umstände und frohe Weihnachten!

    Danke, Matthias. Wenn sich diese Information dann vielleicht noch im Support bei ionos rumsprechen würde … 😉

    Ich lag mit meiner anfänglichen Vermutung falsch, dass es sich um das Problem mit dem mu-plugin handelt. Anders als bei diesem Problem, kann die Option Sichtbarkeit für Suchmaschinen hier verändert werden und die Checkbox ist nicht deaktiviert. Das Problem geht also leider tatsächlich von einem anderen Teil der Installation aus. Deshalb kann der Support da auch nichts machen.

    @bego würdest du mir zustimmen, dass es vielleicht einen Versuch wert wäre, gezielt Plugins zu deaktivieren?

    @ichlernewordpress ich schließe mich @krafit an… Ich hab nochmal in den Code geschaut und deine Domain passt nicht in des Schema des Bugs…

    @bego du hast natürlich recht, aber das sind ne ganze Menge Leute und da kann so eine Info immer mal unter gehen. Aber wir werden sehen wie wir die Info nochmal besser verteilen können.

    Alle Plugins deaktivieren und schauen, ob ein Fehler dadurch verschwindet (also vermutlich durch ein Plugin ausgelöst wurde) ist immer eine schicke Idee. Ich habe sehe allerdings, dass der Webseiten-Quellcode keine Hinweise ergibt, dass die Webseiten nicht indexiert werden.

    Klicke ich im Backend unter Einstellungen > Lesen das Kontrollkästchen bei „Suchmaschinen davon abhalten, diese Website zu indexieren.“ an, erscheint im <head> meines Seiten-Quellcodes der Eintrag <meta name="robots" content="noindex, nofollow"> und es gibt keine sitemap.xml.
    Das ist in diesem konkreten fall aber anders. Es gibt sowohl einen recht ausführlichen Meta-Eintrag <meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1"> als auch eine sitemap_index.xml (als Weiterleitung von sitemap.xml).

    Beide Einträge sind wohl von Yoast eingeführt worden und sicher, auch hier wäre ein Programmierfehler möglich. Vielleicht lässt sich das Kontrollkästchen deaktivieren, wenn vorher Yoast deaktviert wird?

    Dass es ein gemeines geheimes Plugin des Webhosters gewesen wäre, klang nach so einer einfachen Lösung.

    @bego du hast natürlich recht, aber das sind ne ganze Menge Leute und da kann so eine Info immer mal unter gehen. Aber wir werden sehen wie wir die Info nochmal besser verteilen können.

    @pfefferle Ich habe da sicher eine völlig falsche Sichtweise, weil wir das Forum hier meistens mit gerade mal fünf, sechs aktiven Teilnehmenden betreiben, die sich mit Antworten beteiligen.

    Thread-Starter ichlernewordpress

    (@ichlernewordpress)

    Ich Danke Euch für die Hinweise.

    @pfefferle ja – das ist managed wordpress. Deshalb bin ich auch der Meinung, dass es bei Ionos richtig platziert ist.

    @krafit Weitere Plugins habe ich nun deaktiviert. Bin mal gespannt, ob das Häkchen bei der Indexierung wieder neu gesetzt wird.

    @bego Nachdem ich von google die Rückmeldung bekommen habe, dass die Seite nicht gecrawlt werden kann, habe ich den Meta-Eintrag ergänzt und die sitemap ebenfalls auf den aktuellen Stand gebracht. außerdem wird das ja von YoastSEO aktuell gehalten. Dennochwird eigenwillig – ohne mein Einwirken – in WordPress das Häkchen gesetzt. Entferne dies händisch jeden Morgen. Ist aber auf Dauer keine Lösung.
    Gemeinheimes Plugin schließe ich immer noch nicht aus. Sollte ich morgen keine Veränderung feststellen, versuche ich es mit der Deaktivierung von YoastSEO.
    Bei IONOS ist das Problem seit zwei Wochen bekannt. Heute wurde mir auf Nachfrage mitgeteilt, dass die Techniker sich bereits im Weihnachtsurlaub befinden und die Bearbeitung deshalb noch einige Zeit benötigen würde.

    Halten wir fest: das Team beim Webhoster ist nicht nur größer, die bekommen auch noch bezahlten Weihnachtsurlaub. 🙈

    Ich bin gespannt auf die Lösung.

    Thread-Starter ichlernewordpress

    (@ichlernewordpress)

    @pixolin Ich habe nix gegen bezahlten Weihnachtsurlaub- wenn er verdient ist.

    An den von mir installierten Plugin inkl. YoastSEO liegt es auf jeden Fall nicht. Habe alle deaktiviert und dennoch wurden am nächsten Tag die Suchmaschinen davon abgehalten, die Webseite zu indexieren.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Das Thema „Sichtbarkeit für Suchmaschinen“ ist für neue Antworten geschlossen.