Support » Allgemeine Fragen » SIE-Version verschwindet immer wieder

  • Hallo, ich bin neu hier, und es kann sein, dass ich nicht alles beim richtigen Namen nenne. Seht mir das bitte nach.

    Ich habe folgendes Problem: Die formelle Version meiner deutschen WordPress-Installation (also „Sie“ statt „Du“) verschwindet immer wieder, aber das will ich nicht.

    Ich habe meine (öffentlich noch gesperrte Seite) blickraum.com bei all-inkl.com eingerichtet und mir dafür WordPress 4.1 auf dem Server installiert. Als ich während der Installation auf den Unterschied zwischen den beiden deutschen Sprachpaketen hingewiesen wurde, war es mir egal, ob WordPress mich duzt oder siezt, deshalb habe ich es beim „Du“ belassen. Zu diesem Zeitpunkt war mir noch nicht klar, dass sich diese Entscheidung auch auf die Texte innerhalb der Themes auswirkt und dann auch die Besucher meiner Website geduzt werden. Das geht aber gar nicht, und deshalb habe ich mich umgesehen, wie ich für meine Besucher zum distanzierten „Sie“ kommen kann.

    Ich habe – wie auf den Hilfeseiten zu lesen – das Sprachpaket „de_DE.zip“ durch „de_DE_Sie.zip“ ersetzt und hatte damit auch den gewünschten Erfolg. Im Backend und im Frontend stand alles wie gewünscht auf „Sie“.

    Bis zum nächsten Tag. Da war wieder das „Du“ anwesend. Enttäuscht habe ich die Prozedur wiederholt und per FTP-Upload erneut das Paket „de_DE.zip“ durch „de_DE_Sie.zip“ ersetzt. Für einen weiteren Tag war alles in Ordnung, aber tags darauf waren wir wieder per „Du“.

    Gerade eben habe ich das Sie-Paket zum nunmehr vierten Mal installiert – und ich bin mir sicher, dass morgen wieder alles auf „Du“ stehen wird.

    Was mache ich falsch?

    Ich bin für jeden Hinweis dankbar.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Die automatischen Updates haben als „Huckepack“-Download immer die Sprachdatei, damit diese immer aktuell ist. Leider gibt es aktuelle keine Möglichkeit das Sie-Paket anzuwählen, weshalb das automatische Update immer die Du-Version „aktualisiert“. Das erklärt das beschriebene Phänomen.

    Der Workaround ist das Deaktivieren der Updates für die Sprachdateien. Hier der Link zum Bugticket mit dem Link zur Lösung im Codex:
    https://core.trac.wordpress.org/ticket/28303

    Leider auch mit 4.1 noch nicht gelöst.

    Gruß, Torsten

    Thread-Ersteller Lentwojt

    (@lentwojt)

    Hallo Torsten,

    dankeschön für die Antwort. Ich verstehe, wo das Problem liegt. Aber ich bin nicht vom Fach, und die Seite http://codex.wordpress.org/Editing_wp-config.php#Language_and_Language_Directory überfordert mich in meiner Sachverständnis. Ich komme nicht dahinter, was ich jetzt tun muss.

    Wahrscheinlich soll ich irgendwo den Eintrag „define( ‚WPLANG‘, ‚de_DE‘ );“ in sowas wie „define( ‚WPLANG‘, ‚de_DE_Sie‘ );“ ändern – oder? Aber ich weiß nicht wo.

    Kannst Du es bitte für einen Laien erklären?

    Viele Grüße

    Peter

    Wahrscheinlich soll ich irgendwo den Eintrag „define( ‚WPLANG‘, ‚de_DE‘ );“ in sowas wie „define( ‚WPLANG‘, ‚de_DE_Sie‘ );“ ändern – oder? Aber ich weiß nicht wo.

    Eben genau das geht aktuell nicht, deshalb das Bugticket.

    Kannst Du es bitte für einen Laien erklären?

    Sorry, war der falsche Link. Den hier wollte ich posten:
    http://codex.wordpress.org/Configuring_Automatic_Background_Updates#Translation_Updates_via_Filter

    Da ist auch ein Link zu einem Plugin:
    https://wordpress.org/plugins/stops-core-theme-and-plugin-updates/

    Aber bitte nur die Translation Updates deaktivieren!

    Gruß, Torsten

    Thread-Ersteller Lentwojt

    (@lentwojt)

    Hallo Torsten,

    dank Dir. Ich habe jetzt das Plugin installiert, aktiviert und den Eintrag „Disable Automatic Translation Updates“ ausgewählt. Nun warte ich mal ab und beobachte, ob es was bringt. Allerdings hat sich vor meinen Augen einige Minuten nach der Aktivierung des Plugins im Menü „Aktualisierungen“ innerhalb des WordPress-Dashboards eine kleine 1 gezeigt. Folgt man ihr, steht unter der Rubrik „Übersetzungen“ leider „Einige Ihrer Übersetzungen sind nicht mehr auf dem neuesten Stand.“ – Das lässt nichts Gutes erwarten…

    Aber ich schau mal, wie es morgen aussieht.

    Vielen Dank vorerst

    Peter

    Thread-Ersteller Lentwojt

    (@lentwojt)

    So. Ein Tag später.

    Es hat sich was getan. Es muss wohl wieder ein Update stattgefunden haben, denn WordPress duzt mich im Dashboard wieder. Zum Glück aber nur mich innerhalb des Backends. Im Frontend der Website ist es beim förmlichen „Sie“ geblieben, wie ich mir das gewünscht habe.

    Wie es aussieht, scheint das empfohlene Plugin „Disable Updates Manager“ also zu arbeiten und seinen Dienst zu tun. – Ich muss mich nur zusammenreißen und dem Drang widerstehen, auf die „1“ hinter den Aktualisierungen zu klicken, sonst hole ich mir das „Du“ eigenhändig wieder an Bord.

    Herzlichen Dank für die kompetente Unterstützung. Alleine hätte ich diese Lösung sicher nicht gefunden. 🙂

    Das mit dem DU im Backend ist aber nicht okay. Hast Du auch alle Dateien ausgetauscht? Klingt ja so, als ob die Admin-Sprachdatei doch wieder auf die DU-Version aktualisiert wurde …

    Kannst Du das anhand der Dateien verifizieren?

    Gruß, Torsten

    Thread-Ersteller Lentwojt

    (@lentwojt)

    Du hast leider recht. Das Datum der Dateien zeigt mir, dass tatsächlich wieder die DU-Version nachinstalliert wurde.

    Was rätst Du mir nun?

    Gruß, Peter

    1. Nachricht im Supportforum des Plugins hinterlassen:
    https://wordpress.org/support/plugin/stops-core-theme-and-plugin-updates

    2. Mal direkt mit dem Code versuchen (ohne Plugin)

    Gruß, Torsten

    Thread-Ersteller Lentwojt

    (@lentwojt)

    Tut mir leid, aber da bin ich schon wieder…

    Ich komme nicht weiter.

    Vorhin war vorübergehend auch im Backend die förmliche Anrede „Sie“ angesagt, jetzt wird im Backend und im Frontend wieder munter geduzt. Das nervt tierisch.

    Während unseres letzten Kontakts hattest Du mir empfohlen:

    2. Mal direkt mit dem Code versuchen (ohne Plugin)

    Ich blick mit dem Code nicht durch. Was muss ich tun? Was Du mit http://codex.wordpress.org/Configuring_Automatic_Background_Updates#Translation_Updates_via_Filter verlinkt hattest, sagt mir nichts.

    Ich komme nicht aus der EDV-Ecke und murkse momentan nur rum.

    Nun habe ich in der wp-config.php die Zeile „add_filter( ‚auto_update_translation‘, ‚__return_false‘ );“ eingetragen. Natürlich einfach *irgendwo*, weil ich keinen blassen Schimmer habe, wo der richtige Platz dafür wäre. Daraufhin ließ sich sich WordPress gar nicht mehr verwenden. Ich erhielt diese Fehlermeldung nach dem Login-Schirm:

    Fatal error: Call to undefined function add_filter() in /www/htdocs/w012705a/blickraum.com/wp-config.php on line 77

    Also habe ich die erwähnte Zeile wieder aus der wp-config.php entfernt und sie in ihren ursprünglichen Zustand versetzt.

    Momentaner Stand: Alles beim Alten. WordPress funktioniert wieder. Aber: Im Backend wie im Frontend alles auf „Du“ – also genau so, wie es nicht sein soll…

    Schreib mir doch bitte mal in deutscher Sprache, was Deiner Ansicht nach wo eingetragen werden muss. Das wäre echt nett.

    Peter

    Nun habe ich in der wp-config.php die Zeile „add_filter( ‚auto_update_translation‘, ‚__return_false‘ );“ eingetragen.

    Filter sollten nicht in der wp-config.php genutzt werden:

    Note: Do not add add_filter() calls in wp-config.php – causes conflicts with WP-CLI and possibly other problems.

    Steht so auch auf der verlinkten Codex-Seite.

    Die Zeile:
    add_filter( 'auto_update_translation', '__return_false' );

    muss also irgendwo anders eingebunden werden. Das kann z.B. die functions.php eines (Child-)Themes sein. Oder du machst ein functionality-Plugin daraus:
    http://justintadlock.com/archives/2011/02/02/creating-a-custom-functions-plugin-for-end-users

    Gruß, Torsten

    Thread-Ersteller Lentwojt

    (@lentwojt)

    Oh, bitte: Versteh doch endlich, dass ich kein Techniker, kein Programmierer und ein restlos überforderter Laie bin, dessen Englischkenntnisse auch nicht für Anleitungen dieser Komplexität ausreichen.

    Was soll ich tun? Oder wo finde ich jemanden, der es für mich übernimmt? Gerne auch gegen Bezahlung.

    Viele Grüße

    Peter

    Es ist aber auch keine Raketenwissenschaft. 😉

    functions.php des Themes öffnen und den Code ergänzen:
    add_filter( 'auto_update_translation', '__return_false' );

    Bei einem Update des Themes wird die functions.php dann allerdings überschrieben, also entweder in einem Child-Theme machen oder in einem Funktionsplugin. Dazu musst du nur die Zeilen aus dem Artikel nehmen, darunter die Zeile von oben kopieren und das ganze in einen eigenen Ordner als PHP-Datei speichern und diesen Ordner dann in den Plugin-Ordner kopieren und dann das Plugin aktivieren. Versuche es einfach. Bei Problemen kannst Du hier fragen. Wenn Du es geschafft hast, wirst du sehen, dass dazu keine Programmier-Ausbildung oder Technikwissen nötig ist. Es reicht gesunder Menschenverstand und die Bereitschaft lernen zu wollen!

    Viel Erfolg!
    Torsten

    P.S.: Da Jobanfragen hier nicht erwünscht sind: In diesem Forum beantworten einige User regelmäßig Fragen und alle können dir sicher bei deinem Problem helfen. Einfach den Links folgen und Kontakt aufnehmen.

    Thread-Ersteller Lentwojt

    (@lentwojt)

    Hallo Torsten,

    nein, es ist keine Raketenwissenschaft. Die wäre geradliniger…

    Ich habe es jetzt mit den selbst erstellten versucht.

    Das da habe ich eine Datei gespeichert, die ich „kein_du.php“ genannt habe und sie in einen gleichnamigen Ordner geschoben:

    <?php
    /**
     * Plugin Name: Deutsche Sprachdatei nicht aktualisieren
     * Plugin URI: http://blickraum.com
     * Description: Dieses selbsterstellte Plugin soll verhindern, dass die SIE-Version der deutschen Sprachdatei durch eine DU-Version überschrieben wird.
     * Author: Peter Lentwojt
     * Author URI: http://blickraum.com
     * Version: 0.1.0
     */
    
    /* Place custom code below this line. */
    add_filter( 'auto_update_translation', '__return_false' );
    /* Place custom code above this line. */
    ?>

    Danach habe ich den Ordner in das plugin-Verzeichnis geladen.

    Als ich versuchte, das Plugin zu aktivieren, kam das:

    Das Plugin kann nicht aktiviert werden, da es einen fatalen Fehler erzeugt.

    Parse error: syntax error, unexpected ‚?>‘ in /www/htdocs/w012705a/blickraum.com/wp-content/plugins/kein_du/kein_du.php on line 14

    Peter

    Lösche mal das „?>“ am Ende. Funktioniert es dann?

    Ist dahinter vielleicht noch versehentlich eine Leerzeile? Dann alternativ diese löschen und schauen, ob es dann klappt.

    Gruß, Torsten

    Thread-Ersteller Lentwojt

    (@lentwojt)

    Auch ohne ?> lässt sich das Plugin nicht aktivieren. Es bleibt bei

    Das Plugin kann nicht aktiviert werden, da es einen fatalen Fehler erzeugt.

    Parse error: syntax error, unexpected end of file in /www/htdocs/w012705a/blickraum.com/wp-content/plugins/kein_du/kein_du.php on line 13

    Eine Leerzeile gibt es nicht.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Das Thema „SIE-Version verschwindet immer wieder“ ist für neue Antworten geschlossen.