Support » Allgemeine Fragen » Sonderzeichen für externen Link wie bei Selfhtml von Stefan Münz

  • Ich habe eine Frage:
    Auf der 1. Webseite hddpz:/_/barbara-hofmann.ch/ habe ich einen Link zu einer Firma im ersten Absatz mit einem Zeichen (Viereck mit Pfeil). Das ist so gewünscht.
    Theme Twenty Sixteen

    Link maskiert aus Angst als Spamer zu gelten und gesperrt zu werden. Ist aber eine ernsthafte Frage und kein Rahm. Sorry und danke…

    Auf der 2. Webseite hddpz:/_/nirwana.logisch.ch/ hat es ganz unten „Gibt es ein Physikalisches…“ ebefals einen Link. Aber da ist das Zeichen „nur“ ein viereck anstelle des gewünschten Zeichens.
    Theme Twenty Twenty-One

    Eingebunden ist das wie folgt:

    Obere Webseite funktioniert:

    .entry-content a[href^="http://"]:not([href*="barbara-hofmann.ch"]):after,
    .entry-content a[href^="https://"]:not([href*="barbara-hofmann.ch"]):after {
    font: normal 16px/1 'Genericons';
    content: "\f442";
    padding-left:5px;
    vertical-align:sub;
    font-size:1.5em;
    }

    Untere Webseite falsches Zeichen:

    .entry-content a[href^="http://"]:not([href*="nirwana.logisch.ch/"]):after,
    .entry-content a[href^="https://"]:not([href*="nirwana.logisch.ch/"]):after {
    font: normal 16px/1 'Genericons';
    content: "\f442";
    padding-left:5px;
    vertical-align:sub;
    font-size:1.5em;
    }

    Ziel ist es, externe Links speziell zu markieren, wie das Stefan Münz in seinem Kompendium Selfhtml auch macht und empfiehlt.

    • Dieses Thema wurde geändert vor 10 Monaten, 2 Wochen von Markus Winter.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Hallo,
    ich vermute, dass das verwendete Theme nicht den notwendigen Icon Font mitbringt.
    Evtl. hilft dir dieser Beitrag weiter, in dem das Problem angesprochen wird.

    In dem Beitrag wird übrigens auch auf das Problem beim Einbinden von Icon Fonts hinsichtlich DSGVO hingewiesen.

    Viele Grüße
    Hans-Gerd

    … oder ein Plugin verwenden, z.B. External Links – nofollow, noopener & new window

    target="_blank" sollte aus einer Reihe von Gründen nicht verwendet werden (vgl. When to use target=”_blank”).

    Aber ohne target=“_blank“ geht’s ja nicht, es erscheint kein Symbol/Icon.
    Das vergessen eigentlich alle Anleitungen, egal wie lang und komplex es beschrieben wird.
    Vllt. geht das auch ohne target=“_blank“, nur auf Basis des http(s)?

    Und selbst wenn wer 999 Gründe aufzählt, warum man das nicht mehr machen soll und wenn dem alle nachlaufen: Externe Links will ich auch extern öffnen!
    Sicher gewöhnt man sich irgendwann daran und klickt mit dem Mausrad, mittlere Taste.

    Ich ärgere mich zum Bleistift jedes Mal hier, wenn jemand eine Frage hat, Codes, Settings usw., postet und dann klickt man dessen Site oder einen externen Tipp mit links an.
    Dann klickt man sich dort durch, studiert dessen Problem und hä? wo ist denn nun die Ausgangsfrage? Was wollte der noch genau? Was hat der TO gemacht?
    Also wieder umständlich zurück oder sich den nochmals suchen oder …

    Wo ist bitte dein Problem?

    Die Frage wurde mit zwei verschiedenen Lösungsansätzen beantwortet und außerdem darauf hingewiesen, dass die Verwendung von target="_blank" aus gut nachvollziehbaren Gründen nicht genutzt werden sollte, weil das „best practice“ ist.

    Wenn du deine Webseite anders gestalten möchtest und dir Barrierefreiheit egal ist, kannst du es für dich anders handhaben – deine Website, deine Regeln. Hier im Forum halten wir uns an die Vorgaben für valides HTML und versuchen zumindest, Grundregeln der Barrierefreiheit und Sicherheit einzuhalten.

    Es gibt andere Lösungsansätze, um externe Links per CSS anders zu gestalten. Nur ist das hier off topic, weil wir hier keine Grundlagen in HTML, PHP, JavaScript, CSS oder der Bedienung eines Browsers vermitteln möchten.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Sonderzeichen für externen Link wie bei Selfhtml von Stefan Münz“ ist für neue Antworten geschlossen.