Support » Allgemeine Fragen » Sprache der Website englisch statt deutsch

  • Hallo,

    für meine einsprachige, deutsche Website wird statt deutsch English (USA) angezeigt. Die Eingabe zurück zu deutsch wird nicht gespeichert. Daher benützt ein Plug-In wie Table Press nun englisch als Sprache (–> entries statt Einträge). Ich verwende keine Plugin wie WPML oder ähnliche.

    Wie komme ich zurück zu deutsch?

    Danke für jeden Hinweis!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Wenn Du unter Einstellungen –> Allgemein die Sprache nicht ändern kannst, versuch sie mal unter Benutzer –> Dein Profil zu ändern.

    Sollte das auch nicht gehen, kannst Du die deutschen Sprachdateien (https://translate.wordpress.org/) herunterladen und in /wp-content/languages/ speichern.

    Vielen Dank, elschnuppero,

    ich bin vorgegangen, wie Du empfohlen hast, resp. die Sprache unter „Profil“ war bereits korrekt ausgewählt.

    Installiert in „languages“ sind bereits:
    admin-de_CH.mo
    admin-de_CH.po
    admin-de_DE.mo
    admin-de_DE.po
    admin-network-de_CH.mo
    admin-network-de_CH.po
    admin-network-de_DE.mo
    admin-network-de_DE.po
    continents-cities-de_CH.mo
    continents-cities-de_CH.po
    continents-cities-de_DE.mo
    continents-cities-de_DE.po
    de_CH.mo
    de_CH.po
    de_DE.mo
    de_DE.po

    Dein translate-Link führt genau dahin: zu den zu übersetzenden Sprachen, nicht zum Download derselben, sorry…

    Die Sprache unter „Profil“ ist nur für den Admin-Bereich, nicht das Frontend.

    Kannst du erläutern, was du mit „Die Eingabe zurück zu deutsch wird nicht gespeichert.“ meinst?

    Unter Einstellungen -> Allgemein kannst du Deutsch auswählen und anschliessend unter Dashboard -> Aktualisierungen alle Übersetzungen aktualisieren. Dann sollte auch TablePress auf Deutsch sein, sofern es übersetzt wurde (was ich annehme).

    Unter translate.wordpress.org müsstest du eigentlich nichts herunterladen müssen.

    Danke für Deine Frage, Pascal,
    sorry, dass es solange gedauert hat mit der Antwort. Ich bin in «Einstellungen –Allgemein», dort möchte ich gerne den Eintrag «English (United States)» ersetzen. Ich wähle nun im Drop-Down Menu «Deutsch», Deutsch (Sie), Schweiz oder Schweiz (Du)» an.

    Dann speichere ich die Änderung und sofort steht unter «Sprache der Website» wieder: «English (United States)».

    Das meinte ich…

    Falls Du dazu noch eine Idee hättest, wäre ich dankbar!

    LG, Olaf

    Hallo, WordPress-Community!

    Ich habe seit einiger Zeit dasselbe Problem wie midway88. Ich kann es nichtmal genau datieren, weil es mir eher zufällig aufgefallen ist. Aber der Erstellzeitpunkt des Threads könnte auch bei mir gut hinkommen. Vielleicht ist da bei WordPress selbst was quer im Magen?

    Wenn man auf die WordPress-Einstellungen geht, steht da „English (US)“. Ändern und speichern bringt nichts, es bleibt einfach eng_US stehen. Und das obwohl auf den ersten Blick alles auf deutsch im Backend und Frontend ist. Auf den zweiten Blick fällt allerdings auf, dass es sich um ein seltsames Gemisch handelt. Auf meinen Blog-Buttons steht „Submit comment“. Diverse andere Stellen sind ebenfalls auf englisch. Plugins wie Yoast arbeiten jetzt auch nicht mehr richtig und erstellen ihre Textbewertung auf Basis englischer Sprache.

    Wenn man in den Quellcode meiner Seite schaut, ist auch „eng_US“ als Sprache der Seite gesetzt. Ist auch entsprechend das, was andere Webseiten von außen über meine Webseite als Hauptsprache sehen.

    Ich habe:
    – versucht die Sprache unter „Allgemein“ einfach zu ändern -> erfolglos
    – die alte WPLANG-Variante probiert -> erfolglos
    – alle Sprachpakete gelöscht und neu installiert -> erfolglos
    – alle Plugins deaktiviert und geprüft, ob es sich dann wieder ändern lässt -> erfolglos

    …und noch während ich diese Liste erstellt habe, hatte ich gerade noch eine andere Idee … Olaf, welches Theme verwendest du? Ich verwende DIVI-Theme für meine Seite. Ich habe es gerade kurz deaktiviert und prompt sprang die Anzeige wieder auf „deutsch“. Ist das bei dir eventuell auch der Fall?

    • Diese Antwort wurde geändert vor 2 Jahre, 2 Monaten von saschariehl.

    Vielen Dank, Sascha,

    ich habe versucht, das Theme zu deaktivieren, aber das ging schief, Website wie Backend waren nicht mehr zugänglich… Nach dem FTP-Upload des Twentyseventeen-Themes, das bei einem Theme-Problem von WordPress automatisch verwendet wird, ging es dann weiter.

    Der Clou bei Divi ist der: In den Divi Theme Options gehst Du zu «Disable Translations». Entgegen der Logik – ich hatte «enabled» für ja, ich möchte keine Übersetzung – muss dort ausgegraut stehen «disabled».

    Jetzt stimmt die Sprache wieder.

    Hoffe, das hilft Dir auch, schönen Gruss,
    Olaf

    Manchmal kann sich WordPress aber auch unnötig bockig anstellen 😉 Freut mich aber zu lesen, dass du das Problem lösen konntest. Hat auch bei mir so funktioniert! Und ja, es scheint da wirklich eine etwas komische Übersetzung an der Stelle zu sein…

    Dann können wir jetzt ja beide endlich auf Deutsch weiterarbeiten 😉 Etwas seltsam, dass das Problem bei uns quasi gleichzeitig auftrat. Eventuell hat DIVI ja auch etwas durch ein Update in der Logik geändert. Das nächste mal sind wir ja aber dafür sensibilisiert.

    Dir ebenfalls einen schönen Gruß und besten Dank zurück,
    Sascha

    • Diese Antwort wurde geändert vor 2 Jahre, 1 Monat von saschariehl.
Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Sprache der Website englisch statt deutsch“ ist für neue Antworten geschlossen.