Support » Installation » Sprache lässt sich nicht ändern

  • Hallo und guten Morgen zusammen,
    ich benötige Hilfe, da ich langsam verzweifel. Von vorne herein muss ich dazu sagen, dass ich absoluter Laie bin was WP betrifft. Hier im Forum und allgemein im Internet habe ich auch schon nach einer Lösung gesucht, aber die Antworten waren nur teilweise Hilfreich oder haben nicht funktioniert.
    Mein Problem (wie das scheinbar einiger anderer auch) ist, dass die WP Sprache auf Englisch steht und sich einfach nicht ändern lässt.
    Deutsch ist zwar installiert, aber beim speichern springt er immer wieder auf Englisch.

    Ich bin derzeit dabei einen mini shop für meine Songs via woocommerce einzubinden und der Warenkorb und die Bestellabwicklung sind dann auf Englisch.(soweit ich das verstanden habe liegt das an der Spracheinstellung)
    Alles andere ist jedoch auf Deutsch.
    – Ich benutze ein gekauftes Theme wo jedoch keinerlei Einstellungen bezüglich einer Sprache sind.
    – Woocommerce ist samt Deutschem Plug installiert und erscheint komplett in Deutsch bis auf die beiden besagten Bereiche.

    – Beim Provider habe ich auch bereits nachgefragt, ob es an deren Server liegt, weil ich auch das gelesen habe, aber daran liegt es nicht.

    Ich hoffe, dass ich hier im richtigen Forum gepostet habe und jemand auf einfache Weise helfen kann, dass ich als Laie das auch umgesetzt bekomme. Ein entsprechendes Plug nur für die beiden Bereiche habe ich leider nicht gefunden.

    Vielen Dank im Voraus

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das liegt vermutlich an deinem gekauften Theme, dass nicht übersetzt ist.
    Mit dem Plugin Loco Translate kannst du das Theme selber in deinem WordPress-Bacend übersetzen, wenn das Theme die Übersetzungsfunktionen richtig verwendet (kann ich bei einem gekauften Theme nicht beurteilen).

    Automatisch abspielende Musik wird übrigens von vielen Webseitenbesuchern eher als ärgerlich empfunden. (z.B. Punkt 10 auf dieser Liste)

    Danke für die beiden Tips
    Autostart hab ich direkt mal deaktiviert und das Plug werde ich direkt mal installieren und testen. Ich hoffe, dass es hilft.
    Hatte auch schon an das Theme gedacht, da aber alles auf Deutsch ist, dachte ich frag ich mal nach möglichen anderen Ursachen.

    Loco translate installiert
    wenn ich dann auf Themes gehe steht da Deutsch 100%

    Nachdem ich nun im www weitere std nach einer Lösung gesucht habe, wurde ich auf der Seite
    https://designers-inn.de/kurzanleitung-wordpress-auf-deutsch-umstellen/
    fündig….. dachte ich
    Diese besagte Zeile fehlt bei mir, also habe ich sie hinzugefügt
    define(‘WPLANG’, ‘de_DE’);

    sobald ich das jedoch mache und hochlade, erscheint im Dashboard eine Fehlermedlung, dass Zeite 76 (nämlich die soeben geänderte) einen Fehler verursacht.
    Ändere ich dann die Sprache auf Deutsch, schmiert alles ganz ab. Jemand Ideen?

    Diese besagte Zeile fehlt bei mir, also habe ich sie hinzugefügt
    define(‚WPLANG‘, ‚de_DE‘);

    Das ist eine veraltete Konstante, die du bei aktuellen WordPress-Versionen nicht mehr benötigst.

    Fehlermedlung, dass Zeite 76 (nämlich die soeben geänderte) einen Fehler

    Vielleicht hast du typographischen Anführungszeichen statt Hochkomma ' verwendet?

    Die Frage ob „jemand eine Idee“ hat ist übrigens in einem Forum in etwa so sinnig, wie in einer Eckkneipe zu fragen, ob man ein Getränk bestellen könne. 😉

    Nein, dass habe ich geprüft. Hab es einfach nur kopiert und eingefügt.
    Aber wenn es eine veraltete Konstante ist, die nicht mehr benötigt wird, sollte das ja auch mein Problem nicht lösen. 🙂

    Richtig.

    Die Aktualisierungen hast du auf neue Sprachdateien geprüft? (Dashboard > Aktualisierungen, dort nach Übersetzungen suchen)

    Wenn du übrigens möchtest, dass in deinem Menü Platzhalter stehen, bei denen sich ein Untermenü ausklappt, solltest du den Link des Platzhalters löschen:

    Screenshot Menüeintrag Platzhalter

    Also im Dashhboard steht dass alles aktuell ist, eine Funktion
    „nach übersetzungen suchen“ habe ich hier gar nicht. Da steht, dass alles automatisch passiert. Kann ich das manuell irgendwo nachschauen?

    Laut dem installierten Loco ist mein Theme aber 100% Deutsch.
    das Woocommerce auch.

    … eine Funktion „nach übersetzungen suchen“ habe ich hier gar nicht

    Nein, du solltest nach dem Begriff Übersetzungen suchen:

    Screenshot Aktualisierungen

    Die Übersetzung ist eigentlich Bestandteil von WooCommerce, wird aber unter Umständen vom Theme überschrieben. Ist das Theme richtig programmiert, bietet es für die Zeichenketten eine Übersetzungsfunktion an und du kannst mit Loco Translate eine eigene Übersetzung hinzufügen. War der Entwickler schlampig, hast du Pech gehabt.

    Hallo,
    vielleicht hilft das (wenn ich das richtig verstanden habe):
    Die (deutschen) Sprachdateien liegen im Ordner \wp-content\themes\dein_theme\lang bzw. bei plugins im Ordner wp-content\plugins\dein_plugin\languages
    Das sind Dateien mit der Erweiterung .po bzw. .mo
    In einzelnen Fällen kann es sein, dass die Dateien im Ordner wp-content\languages\themes bzw. wp-content\languages\plugins nicht aktuell sind.
    In dem Fall werden die Übersetzungen nicht korrekt umgesetzt, siehe auch hier: Yes, this is typical – the wp-content/languages/plugins location is actually better. Poedit’s FTP connectivity options always uploads to there, because files won’t be overwritten by plugin updates, and because it is the highest-priority location where WP looks first. (Autor von poedit)
    Du kannst also versuchen, die entsprechenden Sprachdateien in den jeweiligen Ordner (plugins bzw. themes) zu kopieren.
    Viele Grüße
    Hans-Gerd

    Diese Dateien sind alle aktuell, hab gerade alle Verzeichnisse nochmals geprüft
    im Plugins Ordner waren diese Dateien zwar nicht, aber nach dem hinzufügen hat sich leider trotzdem nichts getan.

    Wenn ich wüsste, wo sich diese 2 „Formulare“ befinden würde ich sie ja fix selbst übersetzen

    Hast du danach auch noch mal (falls du ein Caching-Plugin einsetzt) den Cache über das Plugin gelöscht und anschließend die Seite auch mal z. B. im Inkognito-Modus von Chrome geöffnet bzw. den Browsercache gelöscht?

    Ich habe kein solches Plugin. Und alle meine Änderungen prüfe ich stets noch im Explorer bei mir, der nach jeder Sitzung alles wieder löscht.
    Da sieht man auch wenn man auf die Seite geht..
    Warenkorb
    No products in the cart.

    Also so ein Mischmasch aus Deutsch und Englisch. Und wenn ich das bei mir samt Artikeln und Kasse teste halt, dass es leider auf englisch ist.

    Ich hab auch bereits die neuste Version von WP über das Dashboard „erneut installiert“. Da tut sich aber auch nichts.

    Wenn ich auf Loco Translate klicke und mir unter Sprachen anzeigen lasse wie weit alles übersetzt ist, werden die paar wenigen Plugs die ich habe mit 100% angezeigt.
    Bis auf
    WP Maintenace Mode. Das steht drei mal in meiner Liste, 52%, 84% und 100%
    Wenn ich dann jedoch auf „bearbeiten/übersetzen klicke sind da keinerlei Einträge die auch nur ansatzweise in die Richtung meiner 2 „Problemseiten“ Warenkorb/Kasse gehen.
    Daher denke ich, dasss es daran nicht liegt

    Du nutzt ein gekauftes Theme, das uns nicht zur Verfügung steht. Deshalb können wir auch nicht beurteilen, ob in den Theme-Dateien eigene Templates für WooCommerce vorhanden sind und falls ja, ob sie übersetzbar sind. Du kannst über Design > Editor nachschauen, ob es WooCoommerce-Templates gibt und ob on diesen Templates entsprechende Zeichenketten vorkommen. Ansonsten wende dich bitte an den Theme-Entwickler.

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)