• Liebes Forum

    Unsere Website ist mit WPGlobal in drei Sprachen implementiert. Seit einiger Zeit funktioniert der Sprachwechsel nicht mehr richtig:
    Wenn man (automatisch) auf der deutschen Version landet und dann auf die englische umschaltet, bleibt der deutschsprachige Content und nur das Menü ändert sich. Manchmal erscheint dann auch die französische Sprachversion. Aber nicht die Englische.
    Manchmal passiert das auch, wenn man von der deutschen Version zur englischen Version wechselt: Dann erscheint auch die französische Version. Irgendwann bleibt dann die Sprachversion endgültig auf Französisch oder Deutsch hängen.
    Wenn man dann weiter hin und her wechselt, wird die Menüanzeige in der französischen Version zerstört.

    GPS Sportplatz Linienmarkierung (swozi.com)

    Ich habe auch schon letzte Woche den Support von WPGlobus kontaktiert, aber seit letzter Woche noch keine Antwort erhalten.
    Danke im Voraus für Eure Hilfe.

    Hier der Website-Zustands-Bericht:

    wp-core
    
    version: 6.2.2
    site_language: de_DE
    user_language: de_DE
    timezone: +01:00
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 10
    dotorg_communication: true wp-paths-sizes wordpress_path: /home/httpd/vhosts/swozi.com/httpdocs/wp/wp2018
    wordpress_size: 5.19 GB (5568045256 bytes)
    uploads_path: /home/httpd/vhosts/swozi.com/httpdocs/wp/wp2018/wp-content/uploads
    uploads_size: 1.07 GB (1144988904 bytes)
    themes_path: /home/httpd/vhosts/swozi.com/httpdocs/wp/wp2018/wp-content/themes
    themes_size: 23.67 MB (24824658 bytes)
    plugins_path: /home/httpd/vhosts/swozi.com/httpdocs/wp/wp2018/wp-content/plugins
    plugins_size: 122.76 MB (128722045 bytes)
    database_size: 71.24 MB (74704240 bytes)
    total_size: 6.46 GB (6941285103 bytes) wp-active-theme name: Felladesigns (felladesigns)
    version: 5.0.7
    author: Chris Jones - Felladesigns
    author_website: (undefined)
    parent_theme: Jupiter (jupiter)
    theme_features: core-block-patterns, editor-style, widgets-block-editor, automatic-feed-links, title-tag, editor-styles, post-thumbnails, yoast-seo-breadcrumbs, wp-block-styles, menus, widgets
    theme_path: /home/httpd/vhosts/swozi.com/httpdocs/wp/wp2018/wp-content/themes/felladesigns
    auto_update: Deaktiviert wp-parent-theme name: Jupiter (jupiter)
    version: 6.10.2
    author: Artbees
    author_website: http://themeforest.net/user/artbees
    theme_path: /home/httpd/vhosts/swozi.com/httpdocs/wp/wp2018/wp-content/themes/jupiter
    auto_update: Deaktiviert wp-themes-inactive (1) Twenty Twenty: version: 2.2, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert wp-plugins-active (16) Artbees Themes Captcha: version: 1.0, author: Jose Rodriguez jose.rodriguez@exec.cl, Automatische Aktualisierungen aktiviert
    Classic Editor: version: 1.6.3, author: WordPress Contributors, Automatische Aktualisierungen aktiviert
    Duplicator: version: 1.5.4, author: Duplicator, Automatische Aktualisierungen aktiviert
    Gravity Forms: version: 2.7.7, author: Gravity Forms, Automatische Aktualisierungen aktiviert
    Gravity Forms Akismet Add-On: version: 1.0, author: Gravity Forms, Automatische Aktualisierungen deaktiviert
    Gravity Forms Mailchimp Add-On: version: 5.2.0, author: Gravity Forms, Automatische Aktualisierungen aktiviert
    Jupiter Core: version: 1.0.4, author: Artbees, Automatische Aktualisierungen aktiviert
    Jupiter Donut: version: 1.4.3, author: Artbees, Automatische Aktualisierungen aktiviert
    LayerSlider: version: 7.3.0, author: Kreatura Media (latest version: 7.7.5), Automatische Aktualisierungen deaktiviert
    Simple Google reCAPTCHA: version: 4.0, author: Michal Novák, Automatische Aktualisierungen aktiviert
    SVG Support: version: 2.5.5, author: Benbodhi, Automatische Aktualisierungen aktiviert
    Wordfence Security: version: 7.9.3, author: Wordfence, Automatische Aktualisierungen aktiviert
    WPBakery Page Builder (Modified Version): version: 6.11.0, author: Michael M - WPBakery.com, Automatische Aktualisierungen aktiviert
    WPGlobus: version: 2.12.0, author: WPGlobus, Automatische Aktualisierungen aktiviert
    Yoast Duplicate Post: version: 4.5, author: Enrico Battocchi & Team Yoast, Automatische Aktualisierungen aktiviert
    Yoast SEO: version: 20.8, author: Team Yoast, Automatische Aktualisierungen aktiviert wp-plugins-inactive (1) WPBakery Page Builder: version: 6.10.0, author: Michael M - WPBakery.com, Automatische Aktualisierungen deaktiviert wp-media image_editor: BFI_Image_Editor_GD_1_3
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-89 Q16 x86_64 17850 https://legacy.imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 100
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.25 wp-server server_architecture: Linux 3.10.0-1160.90.1.el7.x86_64 x86_64
    httpd_software: nginx/1.22.1
    php_version: 7.4.33 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 200000
    time_limit: 60
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.29.0 NSS/3.53.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true wp-database extension: mysqli
    server_version: 10.6.13-MariaDB
    client_version: mysqlnd 7.4.33
    max_allowed_packet: 1073741824
    max_connections: 500 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/httpd/vhosts/swozi.com/httpdocs/wp/wp2018/wp-content
    WP_PLUGIN_DIR: /home/httpd/vhosts/swozi.com/httpdocs/wp/wp2018/wp-content/plugins
    WP_MEMORY_LIMIT: 96M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable

    Hier noch die Systeminfos:

    home_url = https://www.swozi.com
    site_url = https://www.swozi.com
    REMOTE_ADDR = 188.63.165.162
    SERVER_PORT = 443
    OS = Linux 3.10.0-1160.90.1.el7.x86_64 #1 SMP Thu May 4 15:21:22 UTC 2023
    PHP_SAPI = fpm-fcgi
    PHP_VERSION = 7.4.33
    loaded_extensions = Core, date, libxml, openssl, pcre, zlib, filter, hash, Reflection, SPL, session, standard, cgi-fcgi, bcmath, bz2, calendar, ctype, curl, dba, dom, enchant, mbstring, fileinfo, ftp, gd, gettext, gmp, iconv, imap, intl, json, ldap, exif, mysqlnd, odbc, PDO, Phar, posix, pspell, shmop, SimpleXML, soap, sockets, sodium, sqlite3, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, xml, xmlwriter, xsl, mysqli, pdo_mysql, PDO_ODBC, pdo_sqlite, xmlreader, xmlrpc, zip, imagick, ionCube Loader, Zend OPcache
    wp_version = 6.2.2
    is_multisite = N
    theme = Felladesigns by Chris Jones - Felladesigns ; child of jupiter
    enabled_languages = en, de, fr
    gravityforms = 2.7.7
    LayerSlider = 7.3.0
    artbees-captcha = 1.0
    classic-editor = 1.6.3
    duplicator = 1.5.4
    gravityformsakismet = 1.0
    gravityformsmailchimp = 5.2.0
    js_composer_theme = 6.11.0
    jupiter-core = 1.0.4
    jupiter-donut = 1.4.3
    simple-google-recaptcha = 4.0
    svg-support = 2.5.5
    wordfence = 7.9.3
    wordpress-seo = 20.8
    wpglobus = 2.12.0

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten – 1 bis 5 (von insgesamt 5)
  • Moderator Bego Mario Garde

    (@pixolin)

    Wenn du ein Problem bei deiner Website hast, solltest du als erstes Cache- und Optimierungs-Plugins deaktivieren, weil sie sonst trotz Änderungen möglicherweise eine zwischengespeicherte Version der Website ausgeben. Ein fehlerhaft konfigurierter Cache könnte auch ein Grund für das beschriebene Problem sein.

    Ansonsten fehlt auch hier der Website-Bericht, um das Problem beurteilen zu können. Bitte lies dir dazu den angehefteten Beitrag durch: Bevor du ein neues Thema (Thread) erstellst.

    Vorsorglich noch ein Hinweis, dass wir bei gekauften Themes und Plugins keinen Support anbieten, weil sie uns für kostenlosen Support nicht zur Verfügung stehen. Wir können auch nicht den Support eines kommerziellen Anbieters übernehmen. Wenn du auf eine Supportanfrage keine Antwort bekommst, solltest du überlegen, ob du künftig ein anderes Plugin verwendest.

    Nachtrag: da du nachträglich noch irgendwelche Daten angehängt hast, hier nachträglich der Hinweis, dass es sich dabei nicht um den Website-Bericht handelt. Dabei ist es ganz einfach:

    Thread-Starter nicolerosenbohm

    (@nicolerosenbohm)

    Danke für die Info zum Zustandsbericht. Habe ich nachgefügt. Die Cache Plugins, sowie alle anderen PlugIns hatte ich auch bereits zeitweise deaktiviert, was aber auch nicht geholfen hat.
    Ich werde natürlich bei der nächsten Website ein anderes PlugIn verwenden, aber ich weiss nicht, wie ich es im laufenden Betrieb wechseln kann, ohne alles nochmal neu mit Content zu füllen.

    Moderator Bego Mario Garde

    (@pixolin)

    Ich bekomme auch nach Entfernen des Cache-Plugins im Quellcode diese Zeile angezeigt: „Performance optimized by W3 Total Cache.“ Das kann damit zusammenhängen, dass sich W3TC mehr als andere Plugins in die Installation einnistet und etwas umständlich entfernt werden muss. Unter dem Suchbegriff „W3 Total Cache vollständig entfernen“ findest du im Web einige Anleitungen.

    Nochmal der Hinweis: bei gekauften Themes (Jupiter) und Verwendung gekaufter Plugins (Gravity Forms) können wir nicht helfen. Ich werde mir nicht Theme und Plugin kaufen, um dein Problem nachvollziehen und damit kostenlosen Support anbieten zu können.

    Die PHP-Version 7.4 ist veraltet und sollte nicht mehr genutzt werden, weil es dafür keine Sicherheitsupdates mehr gibt.

    Moderator Michi91

    (@michi91)

    Leider kenne ich WPGlobus nicht und kann nicht spezifisch helfen. Allerdings fällt auf, dass du einen WP Bakery verwendest.

    Wenn ich nun WPGlobus und WP Bakery bei meiner Suchmaschine eingebe, wird dort u.a. https://wordpress.org/plugins/wpglobus-for-wpbakery-visual-composer/ erwähnt.

    Eventuell braucht es diese Erweiterung?

    Thread-Starter nicolerosenbohm

    (@nicolerosenbohm)

    Alles klar. Ich danke dir trotzdem. Und recherchiere mal weiter…

Ansicht von 5 Antworten – 1 bis 5 (von insgesamt 5)
  • Das Thema „Sprachwechsel mit WPGlobus funktioniert nicht korrekt“ ist für neue Antworten geschlossen.