Support » Allgemeine Fragen » SSL Fehler bei www eingabe

  • Gelöst Julian

    (@julian25)


    Hallo, wenn jemand meine Website über rescuetent-app.net aufruft, wird das automatisch zu https://rescuetent-app.net. Das funktioniert alles einwandfrei. Wenn allerdings jemand http://www.rescuetent-app.net wird das zu https://www.rescuetent-app.net und der Nutzer bekommt die Meldung, dass die Seite nicht sicher wäre. Bei Chrome leitet er aber ordnungsgemäß zu https://rescuetent-app.net weiter. Die Browserdaten habe ich bereits gelöscht, daran kann es nicht liegen. Auch bei meiner anderen Domain (rescuetent-app.de) habe ich das Problem (hier funktioniert es aber auch bei Chrome nicht) Wie kann ich diesen Fehler beheben? Was habe ich falsch gemacht? Vielen Dank für eure Antwort im voraus! Hier ist meine .htaccess Datei, vielleicht liegt der Fehler in ihr:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # http Anfragen zu https Anfragen umwandeln
    
    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    
    # .net Domain mit www auf .net Domain ohne www umleiten
    
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www\.rescuetent-app\.net$ [NC]
    RewriteRule ^(.*)$ https://rescuetent-app.net/$1 [L,R=301]
    
    # .de Domain auf .net Domain umleiten (ohne www)
    
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^rescuetent-app\.de$ [NC]
    RewriteRule ^(.*)$ https://rescuetent-app.net/$1 [L,R=301]
    
    # .de Domain auf .net Domain umleiten (mit www)
    
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www\.rescuetent-app\.de$ [NC]
    RewriteRule ^(.*)$ https://rescuetent-app.net/$1 [L,R=301]
    

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Moderator Bego Mario Garde

    (@pixolin)

    Grundregel: Die Rewrite-Regeln von WordPress immer ans Ende stellen.

    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www\.rescuetent-app\.net$ [NC,OR]
    RewriteCond %{HTTPS} =off
    RewriteRule ^(.*)$ https://rescuetent-app.net/$1 [R=301,L]
    </IfModule>
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    Julian

    (@julian25)

    Super, dann habe ich schon mal etwas was ich ändern kann. Ich danke für die schnelle Antwort und für das freischalten des Beitrages.

    Moderator Bego Mario Garde

    (@pixolin)

    Durch die vielen Links war dein Beitrag erst einmal in die Moderations-Schleife geraten; normalerweise werden Beiträge direkt veröffentlicht. Das soll dich aber nicht davon abhalten, URLs anzugeben, wenn es der Beantwortung der Frage dient.

    Julian

    (@julian25)

    Geht klar, ich hoffe mir kann jemand helfen. Mein Hoster (Bplaced) bietet nun die Möglichkeit an, https zu verwenden. Nun musste man alles umstellen und da ist mir der Fehler aufgefallen. Ich habe bereits Kontakt mit meinem Hoster aufgenommen, allerdings hat mir die Erklärung nicht weiter geholfen. Bin echt etwas verzweifelt.

    Moderator Bego Mario Garde

    (@pixolin)

    Was fehlt denn jetzt noch?

    Julian

    (@julian25)

    Also zusammengefasst, habe ich das Problem, dass man nicht mit http://www.rescuetent-app.net und http://www.rescuetent-app.de auf meine Website kommt, weil dann ein ssl Fehler angezeigt wird (Meine Seite wäre nicht sicher usw). Wie kann ich das beheben?

    Edit: Allerdings kann ich mit dem Handy auf den Link http://www.rescuetent-app.net klicken, da funktioniert die Weiterleitung… Bei allen anderen Geräten gar nicht. Bei der Domain http://www.rescuetent-app.de Geht es auch nicht beim Handy.

    • Diese Antwort wurde geändert vor 2 Jahre von Julian.
    Moderator Bego Mario Garde

    (@pixolin)

    Das sind ja auch wieder andere URLs.
    Liegen für diese URLs SSL-Zertifikate vor?
    Was haben diese URLs mit der anderen URL zu tun?

    Julian

    (@julian25)

    Das bedeutet, ich müsste das www noch eintragen damit die Subdomain ein Zertifikat bekommt?

    Julian

    (@julian25)

    Also beide Domains haben ein Zertifikat
    .. Weiter heißt es auf der Seite vom Hoster: „Subdomains werden erfasst, daher bitte ohne „www.” eintragen“. Das bedeutet, eigentlich müsste es einwandfrei funktionieren… wenn man beide Domains ohne www eingibt, funktioniert das auch…

    Moderator Bego Mario Garde

    (@pixolin)

    Ich verstehe trotzdem noch nicht, was du mit den Domains vorhast.
    Sollen alle Domains auf die gleiche WordPress-Installation verweisen?
    Oder sind das getrennte WordPress-Installationen?

    Schau … ich kenn‘ weder dich noch deine Websites und kann nur das beurteilen, was du schreibst. Zuerst ging es um die Weiterleitungsregeln in der .htaccess, jetzt um SSL-Zertifikate ganz anderer URLs. Sorry, aber ich blicke da noch nicht durch.

    Julian

    (@julian25)

    Alles gut, beide Domains sollen auf eine WordPress Installation weiterleiten. Die .net Domain ist meine Hauptdomain und die .de Domain ist eine „Nebendomain“. Jetzt hat mein Hoster auf ssl umgestellt und ich daraufhin musste auch meine Seite anpassen. Beide Domains funktionieren, allerdings nur, wenn man kein www davor schreibt. Wenn man www davor schreibt, funktioniert es nicht, dann wird nämlich angezeigt, dass meine Website nicht sicher wäre. Das ist mein Problem. Wie bekomme ich es hin, dass der Nutzer wieder http://www.rescuetent-app.net bzw http://www.rescuetent-app.de eingeben kann, ohne das er eine ssl Fehlermeldung angezeigt bekommt. Die htaccess habe ich angehängt, weil ich dachte, es würde daran liegen.

    • Diese Antwort wurde geändert vor 2 Jahre von Julian.
    Moderator Bego Mario Garde

    (@pixolin)

    Alles gut, beide Domains sollen auf eine WordPress Installation weiterleiten.

    Wenn mehrere Domains für die gleiche WordPress-Installation verwendet werden sollten (nicht Multisite), hättest du abgesehen von für SEO ungünstigem „Double Content“ wahrscheinlich Probleme mit „Cross-Origin-Inhalten“. Wenn ein Browser eine Webseite mit https anzeigen soll, darf vereinfach gesagt der Inhalt dieser Webseite auch nur aus der selben Quelle (Domain) stammen. Du kannst also nicht die Webseite unter der einen Domain aufrufen, dann aber Bilder der anderen Domain auf der gleichen Webseite anzeigen.

    Allerdings schreibst du ja Weiterleitung und es sollte eigentlich gar kein Problem sein, wenn du mit dem HTTP-Error Code 301 – Permanently Moved auf die eigentlich richtige Domain verweist.

    Beide Domains funktionieren, allerdings nur, wenn man kein www davor schreibt.

    Das hört sich für mich eher nach einem Problem bei der Einrichtung des SSL-Zertifikats an. Was passiert denn, wenn du für die Domains gar keine Weiterleitung eingibst und sie auf ein anderes Verzeichnis zeigen lässt?

    Julian

    (@julian25)

    Okay, dann werde ich das Morgen mal versuchen. Ich melde mich Morgen wieder, wenn ich noch ein paar Sachen versucht habe. Danke für die Hilfe und die Geduld.

    Julian

    (@julian25)

    Das hat mein Hoster noch geschrieben:

    hast du entsprechend die Pfade, nicht in der .htaccess Datei sondern innerhalb deiner Software angesehen bzw angepasst? „/“ ist nicht mehr korrekt, sondern /www/ – das ist das neue öffentliche Verzeichnis. Darauf sollten auch die Pfade deines Scriptes zeigen.

    Habe das allerdings noch nicht ganz verstanden.

    Julian

    (@julian25)

    Hallo, folgendes wird angezeigt, wenn man http://www.rescuetent-app.de besuchen möchte:http://www.bilder-upload.eu/show.php?file=9b1404-1527577394.jpg

    Wenn man unten auf erweitert klickt, kommt folgende Erklärung dazu: http://www.bilder-upload.eu/show.php?file=feb9f1-1527577516.jpg

    Wenn man dann weiter zur Seite klickt, wird man tatsächlich richtig weitergeleitet.

    • Diese Antwort wurde geändert vor 2 Jahre von Julian.
Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Das Thema „SSL Fehler bei www eingabe“ ist für neue Antworten geschlossen.