Support » Allgemeine Fragen » SSL / HTTPS wird von WordPress nicht erkannt

  • Hallo!
    Ich betreibe eine Website mit WordPress und habe auch SSL bzw. HTTPS eingerichtet.
    Das geht alles aber WordPress meint das die Adresse auf HTTPS eingerichtet ist aber die Website nicht mit HTTPS aufgerufen werden kann obwohl dies möglich ist.
    Weiß jemand von euch wie ich das beheben kann? Hoste die Website selber und kann daher nicht einem Hoster um Hilfe fragen.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Hallo,
    nicht ganz klar ist mir aufgrund deiner Äußerungen, ob die Webseite überhaupt aufgerufen werden kann.
    Wenn du dann noch die URL oben einträgst, dann können wir uns das auch ansehen und dir sicher besser helfen.
    Viele Grüße
    Hans-Gerd

    Verstehe ich das richtig, dass du in auf einem Computer oder einer NAS WordPress mit einem SSL-Zertifikat eingerichtet hast und unter Website-Zustand den Hinweis bekommst?

    WordPress 5.7 hat eine neue Funktion eingeführt, die prüft ob die Website unter der Website-URL mit vorangestelltem https erreichbar wäre. Wenn du jetzt eine URL wie „wordpress.test“ in der Datei /etc/hosts deines Computers einträgst, kannst du zwar auf die Website zugreifen, aber der Zugriff von WordPress selbst scheitert weil die URL nicht gefunden wird. Die Rückmeldung, dass WordPress die Website unter https nicht erreichen kann, ist dann etwas irreführend – WordPress kann die URL nicht erreichen, was aber nichts mit dem SSL-Zertifikat zu tun hat.

    Wie auch immer … bei einer lokalen Installation kannst du den Hinweis ignorieren. Bei allen anderen Installationen sollte noch erwähnt werden, dass die Prüfung im Moment noch zu streng ausfällt und daher auch bei korrekter Installation eine Fehlermeldung ausgibt. Mit der nächsten Zwischenversion soll hier nachgebessert werden.

    ich glaube, ich kann da helfen.
    Hatte das gleiche Problem – WP meinte auch, ich zeige zwar https:// an, nutze es aber nicht, und empfohl mir, meinen provider zu kontaktieren.

    Der hatte am gleichen tag sein eigenes Zertifikat erneuert und eben dazu eine rundmail ausgeschickt, dass eventuell einige email-abfragen oder andere dienste nicht richtig funktionieren könnten.

    nach 24 stunden war das problem von selbst erledigt – ich denke einfach, dass es eben eine zeitlang gedauert hat, bis bei hosteurope selbst (meinem provider) alles wieder upgedatet war.

    schönen osterfeiertag noch in die runde!
    lg johanna

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)