Support » Allgemeine Fragen » SSL im Nachhinein aktiviert, bei Änderung der Websiteadresse ausgesperrt

  • Hallo erstmal!

    Ich habe da ein etwas delikates Problem – habe schon alle möglichen Foren abgesucht, Chat GPT gefragt, mit dem Hoster gesprochen, und den Elementor Support bemüht, aber keiner kann mir sagen wo das Problem liegt – daher dieser neue Thread.

    Nachdem ich eine Website auf einem Hetznerserver mit einer vorläufigen URL gemacht habe (die alte Website liegt bei einem anderen Hoster und sollte während der Neuerstellung erreichbar bleiben und die Domain beim alten Hoster bleiben), dann eine Weiterleitung der Domain auf die neue IP eingerichtet habe und zu guter letzt ein LetsEncrypt SSL direkt über das Hostingpanel (Hetzner) eingerichtet und authentifiziert habe wollte ich die WordPress URL und Website Adresse ändern – ging nicht, Seite plötzlich nicht erreichbar (bekannte Geschichte) – also rein in die DB und die wpoptions wieder auf die domain ohne SSl zurückgestellt – also http://wenighofer.at.
    Bei Eingabe der domain mit https wirft der Server eine Fehlermeldung aus.

    Auf Anfrage bei Hetzner folgende Antwort:
    „Die Warnmeldung wird angezeigt, da noch Grafiken über „http“ statt „https“ geladen werden. (Liste von 18 Bildern) Sobald diese Grafiken via https geladen werden wird die Fehlermeldung nicht mehr angezeigt. „
    Ich denke mir also ich muss die Links aktualisieren, nutze erst Velvet blues, dann noch ein anderes Plugin weil ersteres nicht geklappt hat – kein erfolg.

    Da ich JupiterX mit Elementor nutze habe ich auch noch das Elementor -eigene Tool bemüht – auch das ohne Erfolg. Für mich sieht es so aus als ob das SSL schlichtweg nicht aktiv wäre, oder übersehe ich etwas wesentliches? In der Hetzner Konsole wird es aber als aktiv angezeigt. Ich bin wirklich verwirrt.

    Wieso haben sich auch die Links trotz 3 verschiedener Plugins nicht ändern lassen??

    Vielen Dank schonmal für eure Hilfe und LG
    Patrick

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • … wollte ich die WordPress URL und Website Adresse ändern

    Das geht eigentlich viel einfacher: unter Werkzeuge > Website-Zustand bekommst du nach kurzer Wartezeit einen Hinweis eingeblendet, dass du deine Website auf https umstellen solltest. Dann brauchst du nur noch einen Button anklicken, fertig.

    Die Warnmeldung wird angezeigt, da noch Grafiken über „http“ statt „https“ geladen werden …

    Der berühmte „Mixed Content“. Wenn ich eine Website aufrufe und eine URL mit https eingebe, erwarte ich, dass alles was ich sehe, verschlüsselt übertragen wird. Würde da zwischenzeitlich ein wenig unverschlüsselter Inhalt hier und da übertragen, wäre die Vertraulichkeit nicht mehr gewährleistet. Der Browser lehnt deshalb gemischte (verschlüsselte und unverschlüsselte) Inhalte ab.

    Der klassische Ansatz ist, nach der Änderung der URL in wp-options bzw. in Einstellungen > Allgemien mit einem Plugin wie z.B. Better Search Replace die URL in allen Datenbanktabellen (auch in serialisierten Datenbankfeldern) abzuändern. Der komfortablere Ansatz ist, in Werkzeuge > Website-Zustand einen Button anzuklicken – siehe oben.

    Für mich sieht es so aus als ob das SSL schlichtweg nicht aktiv wäre, oder übersehe ich etwas wesentliches?

    Du übersiehst etwas. 😀

    Ruf mal im Browser https://wen…fer.at/readme.html auf und du bekommst eine prima verschlüsselt übertragene Webseite zu sehen.

    Thread-Starter ans234

    (@ans234)

    ok das ist mir jetzt etwas peinlich ehrlich gesagt – ich habe aufgrund eines anderen Foreneintrages mir zwar den Websitezustand angesehen, aber der Text im SSL Tab hat sich für mich so angehört, als würden nach Drücken des Buttons wieder nur die Website adresse und URL geändert werden. leider kann ich hier kein Facepalm Meme einfügen 😀 Die Funktion ist natürlich die Lösung für ein Problem das ich seit 3h recherchiere. VIELEN DANK!!!

    Und es wurden auch noch alle Links berichtigt 🙂 Einzig der Iframe bei den Gebrauchtwagen scheint ein Problem zu haben – aber das ist das kleinste Übel.

    Danke vielmals! Made my day.
    LG
    Patrick

    So kann man auch mit kleinen Sachen den Lieben eine Freude machen … 😀

    Danke für die Rückmeldung und weiterhin viel Erfolg mit der Website.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „SSL im Nachhinein aktiviert, bei Änderung der Websiteadresse ausgesperrt“ ist für neue Antworten geschlossen.