Support » Themes » SSL Verbindung nicht sicher aufgrund von Mixed Content

  • Gelöst wuestenblumesamy

    (@wuestenblumesamy)


    Hallo,
    Ich hoffe, jemand kann mir helfen.
    Habe folgendes Phänomen: Im Firefox erscheint beim erstmaligen Aufrufen der Website ein Warndreieck im Schloss. Sobald ich im Menü hin- und herspringe und eine Seite zum 2. Mal aufrufe, ist die Warnung plötzlich verschwunden.

    – Mit dem SSL Zertifikat ist alles ok
    – alle Bilder und Grafiken haben die URL mit https:// …
    – das Plugin „Really Simple SSL“ ist installiert und die WordPress 301-Weiterleitung aktiv und auch der Mixed Content Fixer

    Ich weiß nicht, was ich noch machen kann.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • bscu

    (@bscu)

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    du kannst dir das auch ansehen, wenn du die Webseite prüfst.
    Wie die Probleme behoben werden können, habe ich in dem folgenden Beitrag beschrieben.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller wuestenblumesamy

    (@wuestenblumesamy)

    Hallo Zusammen,
    erst mal danke für Eure Rückmeldungen.

    Ich habe alle Bilder geprüft und die URL der Dateien beginnt überall mit https://… Ich verstehe nicht, warum sie anders geladen werden.

    Ich habe noch die Website geprüft und die PHP Version angepasst. Hier ist der Bericht zum Website-Zustand:

    
    ### wp-core ###
    
    version: 5.7.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/463318_45329/webseiten/wordpress
    wordpress_size: 263,08 MB (275861486 bytes)
    uploads_path: /kunden/463318_45329/webseiten/wordpress/wp-content/uploads
    uploads_size: 31,18 MB (32695427 bytes)
    themes_path: /kunden/463318_45329/webseiten/wordpress/wp-content/themes
    themes_size: 19,76 MB (20718752 bytes)
    plugins_path: /kunden/463318_45329/webseiten/wordpress/wp-content/plugins
    plugins_size: 122,36 MB (128299767 bytes)
    database_size: 39,86 MB (41796416 bytes)
    total_size: 476,24 MB (499371848 bytes)
    
    ### wp-active-theme ###
    
    name: Astra (astra)
    version: 3.6.2
    author: Brainstorm Force
    author_website: https://wpastra.com/about/
    parent_theme: none
    theme_features: core-block-patterns, astra_hooks, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, amp, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets, menus
    theme_path: /kunden/463318_45329/webseiten/wordpress/wp-content/themes/astra
    auto_update: Deaktiviert
    
    ### wp-mu-plugins (1) ###
    
    Elementor Safe Mode: version: 1.0.0, author: Elementor.com
    
    ### wp-plugins-active (19) ###
    
    Better Search Replace: version: 1.3.4, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    CartFlows: version: 1.6.15, author: CartFlows Inc, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.4.1, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Cookie Notice & Compliance for GDPR / CCPA: version: 2.0.4, author: Hu-manity.co, Automatische Aktualisierungen deaktiviert
    Disable Emojis (GDPR friendly): version: 1.7.2, author: Ryan Hellyer, Automatische Aktualisierungen deaktiviert
    Easy WP SMTP: version: 1.4.6, author: wpecommerce, alexanderfoxc, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.2.5, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Essential Addons for Elementor: version: 4.7.4, author: WPDeveloper, Automatische Aktualisierungen aktiviert
    Germanized for WooCommerce: version: 3.5.0, author: vendidero, Automatische Aktualisierungen aktiviert
    Honeypot for Contact Form 7: version: 2.1, author: Nocean, Automatische Aktualisierungen deaktiviert
    Really Simple SSL: version: 4.0.15, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    Starter Templates: version: 2.6.13, author: Brainstorm Force, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.16.56, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    User Role Editor: version: 4.60, author: Vladimir Garagulya, Automatische Aktualisierungen deaktiviert
    WooCommerce: version: 5.4.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    WooCommerce Stripe Gateway: version: 5.2.3, author: WooCommerce, Automatische Aktualisierungen deaktiviert
    WP Fastest Cache: version: 0.9.1.9, author: Emre Vona, Automatische Aktualisierungen deaktiviert
    Yoast Duplicate Post: version: 4.1.2, author: Enrico Battocchi & Team Yoast, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 16.6.1, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-10 Q16 x86_64 2021-04-29 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 75M
    upload_max_filesize: 50M
    max_effective_size: 50 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 59 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 59 GB
    	imagick::RESOURCETYPE_MEMORY: 29 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: 2.2.5
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-1160.31.1.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.19 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1500
    time_limit: 60
    memory_limit: 128M
    max_input_time: 60
    upload_max_filesize: 50M
    php_post_max_size: 75M
    curl_version: 7.61.1 OpenSSL/1.1.1g
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.4.17-MariaDB
    client_version: mysqlnd 7.4.19
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/463318_45329/webseiten/wordpress/wp-content
    WP_PLUGIN_DIR: /kunden/463318_45329/webseiten/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 128M
    WP_MAX_MEMORY_LIMIT: 128M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Dann steht noch als empfohlene Verbesserungen:
    Es sind nicht alle empfohlenen Sicherheits-Header installiert

    Deine .htaccess-Datei enthält nicht alle empfohlenen Sicherheits-Header.
    
        HTTP Strict Transport Security
        Content Security Policy: Upgrade Insecure Requests
        X-XSS protection
        X-Content Type Options
        Referrer-Policy
        Expect-CT

    Ich weiß allerdings nichts damit anzufangen!??

    VG

    Moderator Bego Mario Garde

    (@pixolin)

    Ich habe alle Bilder geprüft …

    Es sind trotzdem Bilder enthalten, die mit http:// übertragen werden sollen.
    Hans-Gerd hatte dir zum Testen doch den Link https://www.whynopadlock.com empfohlen – schau dir doch bitte die Website damit nochmal an.

    Unter Elementor > Werkzeuge kannst du die URL mit http:// mit der neuen URL mit https:// ersetzen:

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    Anschließend kannst du im Tab Generell noch „CSS erneuern“ anklicken.

    Vor solchen Aktionen ist es immer sinnvoll, ein Backup (hier insbesondere von der Datenbank) vorzunehmen.

    Die Fehlermeldungen zum Sicherheits-Header werden vom Plugin Really Simple SSL ausgespuckt, das nach meiner persönlichen Meinung aber nur eine Krücke für Anwender/-innen ist, die den Umstieg auf https nicht hinbekommen. Dabei ist das inzwischen so einfach: Zertifikat einrichten (hast du schon), in Einstellungen > Allgemein beide URLs auf https:// ändern, dann mit einem Plugin wie Better Search Replace – oder in deinem Fall über Elementor > Werkzeuge, wie oben beschrieben – die URLs in der Datenbank ersetzen, fertig. Seit WordPress 5.7 gibt es außerdem in Werkzeuge > Website-Zustand einen Button, mit dem du das ebenfalls umsetzen kannst. Einfacher geht’s kaum. Das Plugin Really Simple SSL kannst du vorher deinstallieren.

    Thread-Ersteller wuestenblumesamy

    (@wuestenblumesamy)

    Hallo,

    super, jetzt hab ich´s.
    Der Tipp mit den Elementor Werkzeuge war genau das, was ausschlaggebend war.
    Better Search Replace hatte ich vorher auch schon ausprobiert ohne Erfolg.

    Echt toll – Ganz herzlichen Dank!!!!!!

    Viele Grüße

    Moderator Bego Mario Garde

    (@pixolin)

    Danke für deine Rückmeldung.

    Denkst du nur bitte demnächst noch daran, den Thread auch als „gelöst“ zu markieren? (Unter dem Eingabeformular ist dafür ein Kontrollkästchen.) Dann können wir gleich bei den ungelösten Problemen weitermachen.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)