Support » Allgemeine Fragen » Startseite auf Smartphones nicht vollständig angezeigt

  • Gelöst f2a2b3i4a5n6

    (@f2a2b3i4a5n6)


    Hallo,

    die Startseite meiner KleinanzeigenSeite http://www.ezigarette-kleinanzeigen.de wird auf PCs und Tablets korrekt angezeigt. Auf Smartphones fehlt jedoch das CallToAction Element, die Startseite ist also leer.

    Kann ich denn irgendein CSS Code an das Element haften, damit es korrekt auf Smartphones angezeigt wird ?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Moderator Bego Mario Garde

    (@pixolin)

    Im Moment hat diese Website katastrophale Ladezeiten. Als Faustformel kannst du davon ausgehen, dass Webseiten mit einer Ladezeit über 3 Sekunden unbrauchbar sind, weil die Besucher ungeduldig zur nächsten Website wechseln. Die Ladezeit deiner Homepage liegt über 8 Sekunden, weil alle möglichen JavaScript-Frameworks eingebunden und Plugins geladen werden, obwohl sie gar nicht verwendet werden.

    Das von dir verwendete Theme ist ein gekauftes Theme, bei dem du deine Fragen bitte an den Theme-Entwickler stellen solltest. Wir können, da uns das Theme nicht kostenlos zur Verfügung steht, nicht beurteilen, ob es in den Theme-Einstellungen (Customizer?) einen Button gibt, um die Anzeige des Call-to-Action-Abschnitts auf Endgeräten mit kleinen Bildschirmen auszublenden. Im Moment wird der Abschnitt mit einer Media-Query vollständig ausgeblendet:

    @media (min-width: 320px) and (max-width: 767px) {
    .tech-call-to-action {
             display: none;
    }
    }

    Mit Zusätzlichem CSS im Customizer kannst du das korrigieren:

    @media (min-width: 320px) and (max-width: 767px) {
    .tech-call-to-action {
             display: auto;
    }
    }

    Das wäre aber aufgrund der anderen Probleme nur Flickschusterei.

    Es gibt leider keine option im customizer,

    ich habe den Code zur Custom css hinzugefügt, hat jedoch nichts geändert 🙁
    Dennoch vielen Dank für Ihre Mühe. LG

    Hallo,
    sonst teste mal den Code von Bego mit !important wie folgt:

    @media (min-width: 320px) and (max-width: 767px) {
    .tech-call-to-action {
             display: auto !important;
    }
    }

    Ansonsten wende Dich an den Support der Entwickler.
    Und bezüglich der katastrophalen Ladezeiten sehe ich das genauso wie Bego.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Hm, sorry, es sollte wohl eher heißen …

    @media (min-width: 320px) and (max-width: 767px) {
    .tech-call-to-action {
             display: block;
    }
    }

    Klappt’s damit?

    Perfekt, es klappt!
    Vielen Lieben Dank.

    Die katastrophaleb Ladezeiten hängen bestimmt damit zusammen, dass mein theme etwa 20 verschiedene layouts hat und alle Seiten mitgeladen werden. Ich werde dort mal ausmisten.

    Vielen Dank nocheinmal und einen herzlichen Gruß aus Mitelhessen.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Startseite auf Smartphones nicht vollständig angezeigt“ ist für neue Antworten geschlossen.