Support » Allgemeine Fragen » Startseite kann nicht erstellt werden

  • Laut WP-Tutorial kann ich über Einstellungen/Lesen festlegen, ob ich eine fixe Startseite haben will, oder die neuesten Blogeinträge. Diese Option wird mir aber gar nicht erst angeboten!? Habe WP 5.8. Liegts an der Version, oder muss ich auf irgendwas updaten?

    So sollte es aussehen.

    So sieht es aus.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Moderator Bego Mario Garde

    (@pixolin)

    Hast du denn schon eine statische Seite veröffentlicht? Wenn nicht, kannt du auch keine auswählen. Macht ja auch irgendwie Sinn. 🙂

    Thread-Ersteller schallundwort

    (@schallundwort)

    Ja, hab ich und das ist ja auch nicht das Problem, um das es geht. Es geht darum, dass ich, ich zitiere mich selbst, „über Einstellungen/Lesen nicht festlegen kann, ob ich eine fixe Startseite haben will, oder die neuesten Blogeinträge.“ Die Sceenshots sollten eigentlich das Problem deutlich machen, haben sie aber offenbar nicht!?

    • Diese Antwort wurde geändert vor 1 Woche, 6 Tage von schallundwort.

    Hallo,

    Ja, hab ich und das ist ja auch nicht das Problem, um das es geht.

    Das hätte aber durchaus eine Fehlerursache sein können, daher auch berechtigterweise der Hinweis von Bego. Und genau die Screenshots von dir lassen das vermuten 😉
    Es könnte auch sein, dass du zwar eine Seite erstellt, diese aber noch nicht veröffentlicht hast. Auch in dem Fall erscheint die Option zur Einstellung der Seite (logischerweise) nicht, also wie bei „So sieht es aus.“
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller schallundwort

    (@schallundwort)

    Die fehlende Option ist normalerweise immer da, egal ob ein Beitrag öffentlich ist, oder nicht. Ist er nicht öffentlich, kann er lediglich nicht ausgewählt werden. Ist nicht meine erste WP-Anwendung und ich habe diese Option immer genutzt. Ich kann mir nur vorstellen, dass es was mit der Version 5.8 zu tun hat.

    Moin,
    nein, an WP 5.8 liegt es nicht. Ich habe gerade mit dem Standard Theme Twenty Twenty-One nachgeschaut.
    Welches Theme nutzt du?

    Ich kann mir nur vorstellen, dass es was mit der Version 5.8 zu tun hat.

    Eben nicht, sondern eher was mit deiner Instanz. Abgesehen davon, dass entsprechende Fehlermeldungen ziemlich schnell hier oder im englischsprachigen Support auflaufen würden.
    Aber ohne nähere Angaben (Bericht, URL) können wir dir wohl nicht weiterhelfen.

    Thread-Ersteller schallundwort

    (@schallundwort)

    Danke für den Hinweis mit dem verwendeten Theme. Tatsächlich hat mein Theme weder eine home.php, noch eine front-page.php. Verwende das Theme Newswire das erste Mal und vermutlich ist das der Grund, warum diese Option plötzlich fehlt!?

    Dann teste das doch mal kurz mit einem Standardtheme wie Twenty Twenty. Übrigens ist das von dir verwendete Theme (The Newswire) seit über 2 Jahren nicht mehr upgedatet worden. Das könnte auch ein Grund sein, wenn es nicht mehr den aktuellen Gegebenheiten entspricht.

    Moderator Bego Mario Garde

    (@pixolin)

    Die fehlende Option ist normalerweise immer da, egal ob ein Beitrag öffentlich ist, oder nicht.

    Es geht darum, ob du eine Seite veröffentlicht hast und die fehlende Option ist normalerweise nicht da, wenn du noch keine Seite veröffentlicht hast.

    Die Sceenshots sollten eigentlich das Problem deutlich machen, haben sie aber offenbar nicht!?

    Ich verstehe deine Reaktion nicht. Den Screenshot hab ich mir angeschaut und dazu eine mögliche Lösung vorgeschlagen. Sicher, dass du hier Hilfe möchtest?

    Tatsächlich hat mein Theme weder eine home.php, noch eine front-page.php

    Muss ja auch nicht. Die Template Hierarchy in WordPress besagt nur, dass WordPress bevorzugt auf solche Templates zugreift – vorausgesetzt die Templates sind vorhanden. Entscheidet sich der Theme-Entwickler, lieber mit Conditional Tags zu arbeiten, funktioniert das Theme genauso gut.

    Thread-Ersteller schallundwort

    (@schallundwort)

    Ich hab es hier schon mehrmals gesagt, dass ich die Startseite veröffentlich habe und es daran nicht liegen kann. Ich brauche schon Hilfe, aber keine, die meine Antworten ignoriert. Ich werde jetzt andere Themes ausprobieren und dann mal schauen, was passiert. Danke allen!

    Moderator Bego Mario Garde

    (@pixolin)

    Ich hab es hier schon mehrmals gesagt, dass ich die Startseite veröffentlich habe und es daran nicht liegen kann.

    Mehrmals nicht, nur einmal.

    Ich brauche schon Hilfe, aber keine, die meine Antworten ignoriert.

    Aufgrund deiner Formulierung („egal ob ein Beitrag öffentlich ist, oder nicht“) fand ich eine Rückfrage legitim. Abgesehen davon bin ich aber auch auf deine Frage zu den Templates home.php und front-page.php eingegangen. Es sollte dich aber nichts davon abhalten, andere Themes auszuprobieren. Viel Erfolg dabei.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)