• Gelöst mirkorichter

    (@mirkorichter)


    Hallo zusammen,

    ich habe Probleme mit der WP-Startseite, nachdem ich in den WP-Einstellungen die Website-Adresse (URL) geändert und bei einer weiteren Fehlersuche an index.php sowie .htaccess geschraubt habe.

    Die Startseite funktioniert nicht mehr, da bei Aufruf zwar globaler Header, Footer und Menü geladen werden, jedoch nicht der Seiteninhalt. Bei Aufruf erscheint in der URL zudem – entgegen meiner Erwartung – die Domain mit dem WP-Unterverzeichnis (wie eine Weiterleitung).

    Alle andere Seiten funktionieren fehlerfrei (insbesondere auch ohne WP-Unterverzeichnis in der URL).

    Hintergrund:

    • Ich nutze für die Seiten Peramalinks (/%postname%/)
    • WordPress ist in einem Unterverzeichnis installiert (beispiel.de/wp/)
    • ich habe in den WP-Einstellungen die Seiten-URL auf das „Stammverzeichnis“ umgestellt (beispiel.de/)
    • die index.php im Stammverzeichnis lautet (ohne Kommentare):
      <?php
      define( 'WP_USE_THEMES', true );
      require __DIR__ . '/wp/wp-blog-header.php';
    • die .htaccess im Stammverzeichnis lautet (ohne Kommentare):
      # BEGIN WordPress
      <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
      RewriteBase /
      RewriteRule ^index\.php$ - [L]
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule . /index.php [L]
      </IfModule>
      # END WordPress
    • die index.php im WP-Verzeichnis lautet (ohne Kommentare):
      <?php
      define( 'WP_USE_THEMES', true );
      require __DIR__ . '/wp-blog-header.php';
    • die .htaccess im WP-Verzeichnis lautet (ohne Kommentare):
      # BEGIN WordPress
      <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
      RewriteBase /
      RewriteRule ^index\.php$ - [L]
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule . /index.php [L]
      </IfModule>
      # END WordPress
    • in den Einstellungen unter Permalinks habe ich schon mehrfach versucht, durch „Änderungen speichern“ das Problem zu beheben.
      Frage: was mache ich falsch?
      Danke für eure Hilfe
    • Dieses Thema wurde geändert vor 3 Jahren, 3 Monaten von Bego Mario Garde. Grund: Codeformatierung
Ansicht von 5 Antworten – 1 bis 5 (von insgesamt 5)
  • Frage: was mache ich falsch?

    Du hast keine URL zur Website angegeben. 🙂

    Thread-Starter mirkorichter

    (@mirkorichter)

    Hi,

    ja ich dachte, das wäre nicht von Belang. Aber vielleicht hilft es ja doch:
    zahn-arzt-leipzig.de

    Danke

    Sieht alles völlig OK aus. URLs sind korrekt eingetragen, Website wird richtig angezeigt, Unterseiten funktionieren …

    Lösch doch mal den Browser-Cache. Vielleicht sind da noch alte Links hinterlegt.

    Ansonsten habe ich in deiner Beschreibung (bis auf deine grottige Codeformatierung 😉 ) nichts Auffälliges entdeckt.

    Du könntest noch im Customizer ein Website-Icon hinzufügen und das Logo kommt auf einem hochauflösenden Display etwas flau rüber. Das würde ich in anderthalbfacher Größe neu hochladen und dann ggf. mit einer CSS-Regel auf die gewünschte Größe verkleinern.

    Thread-Starter mirkorichter

    (@mirkorichter)

    LOL!
    Ja, den Text hier hätte ich mir sparen können, der Browser hat mich in die Irre geführt. Einfach mal etwas anderes ausprobieren! 😉

    Den Code hätte ich auch gern anders, sauber und übersichtlich. Thrive Architect und die anderen Plugins produzieren viel Müll.

    Die anderen Hinweise nehme ich gern mit.

    Danke und noch einen schönen Tag!

    Den Code hätte ich auch gern anders, sauber und übersichtlich.

    Ich meinte eigentlich den Code, den du hier in deiner Frage geteilt hast und den ich dann erst einmal ein wenig korrigieren musste. Aber … egal. Hauptsache, es läuft alles. 😀

Ansicht von 5 Antworten – 1 bis 5 (von insgesamt 5)
  • Das Thema „Startseite kaputt nach Umstellung der Website-Adresse“ ist für neue Antworten geschlossen.