Support » Themes » Startseite läßt sich nicht scrollen

  • Gelöst wortpressender38

    (@wortpressender38)


    Meine Webseite (auf Basis Theme twentytwentytwo) besteht aus mehreren Einzelseiten, die sich, wenn sie für den Bildschirm zu lang sind, problemlos vertikal scrollen lassen.
    Lediglich die Startseite kann aus mir nicht verständlichen Gründen nicht gescrollt werden, d.h. der Text wird am Bildschirmende abgeschnitten.

    Bei Betätigung des Scrollrads sieht man wie sich der vertikale dunkelgraue Abschnitts des Scrollbalken durch das vertikale Scrollfeld bewegt. Nur der Seiteninhalt ist einbetoniert.

    Wenn ich die Startseite als normale Seite (und eine andere Seite als Startseite) deklariere, lässt sich die ursprüngliche Seite ohne weitere Änderung scrollen. Das Problem tritt dann bei der neuen Seite auf.

    Ich habe schon erfolglos einige Plugins, die mir „verdächtig“ erschienen sind (z.B. sticky header) deaktiviert… hat aber nichts gebracht.

    Hat jemand eine Idee, was die Ursache sein könnte?

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Wie @bscu schon geschrieben hat:
    Wenn du dann noch die URL oben einträgst, dann können wir uns das auch zunächst im Frontend ansehen und dir sicher besser helfen.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Thread-Starter wortpressender38

    (@wortpressender38)

    Sorry…. habe ich nach dem Texten vergessen einzufügen.

    ———————————————————-

    
    ### wp-core ###
    
    version: 6.1.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: G:\A10_Webseite\htdocs\BS-Bilder
    wordpress_size: 4,56 GB (4891931107 bytes)
    uploads_path: G:\A10_Webseite\htdocs\BS-Bilder/wp-content/uploads
    uploads_size: 555,24 MB (582207484 bytes)
    themes_path: G:\A10_Webseite\htdocs\BS-Bilder/wp-content/themes
    themes_size: 8,84 MB (9273941 bytes)
    plugins_path: G:\A10_Webseite\htdocs\BS-Bilder/wp-content/plugins
    plugins_size: 64,79 MB (67934647 bytes)
    database_size: 33,52 MB (35143680 bytes)
    total_size: 5,20 GB (5586490859 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Twenty-Two (twentytwentytwo)
    version: 1.3
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, responsive-embeds, editor-styles, html5, automatic-feed-links, block-templates, widgets-block-editor, wp-block-styles, editor-style
    theme_path: G:\A10_Webseite\htdocs\BS-Bilder/wp-content/themes/twentytwentytwo
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Three: version: 1.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (16) ###
    
    Back Button Widget: version: 1.6.0, author: WPFactory, Automatische Aktualisierungen deaktiviert
    Customizer Export/Import: version: 0.9.5, author: The Beaver Builder Team, Automatische Aktualisierungen deaktiviert
    Duplicator: version: 1.5.1, author: Snap Creek, Automatische Aktualisierungen deaktiviert
    Favicon Rotator: version: 1.2.10, author: Archetyped, Automatische Aktualisierungen deaktiviert
    Flexy Breadcrumb: version: 1.2.1, author: PressTigers, Automatische Aktualisierungen deaktiviert
    Gwolle Guestbook: version: 4.4.1, author: Marcel Pol, Automatische Aktualisierungen deaktiviert
    Media Cleaner: version: 6.5.0, author: Jordy Meow, Automatische Aktualisierungen deaktiviert
    Media Library Assistant: version: 3.04, author: David Lingren, Automatische Aktualisierungen deaktiviert
    myStickymenu: version: 2.6.1, author: Premio, Automatische Aktualisierungen deaktiviert
    Nested Pages: version: 3.2.3, author: Kyle Phillips, Automatische Aktualisierungen deaktiviert
    Relevanssi: version: 4.18.0, author: Mikko Saari, Automatische Aktualisierungen deaktiviert
    Responsive Accordion And Collapse: version: 2.3.8, author: wpshopmart, Automatische Aktualisierungen aktiviert
    Responsive Lightbox & Gallery: version: 2.4.2, author: dFactory, Automatische Aktualisierungen deaktiviert
    TablePress: version: 1.14, author: Tobias Bäthge, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.23, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WPFront Scroll Top: version: 2.0.7.08086, author: Syam Mohan, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: false
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 40M
    upload_max_filesize: 40M
    max_effective_size: 40 MB
    max_file_uploads: 20
    gd_version: not available
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Windows NT 10.0 AMD64
    httpd_software: Apache/2.4.53 (Win64) OpenSSL/1.1.1n PHP/8.1.6
    php_version: 8.1.6 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 120
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 40M
    php_post_max_size: 40M
    curl_version: 7.77.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.4.24-MariaDB
    client_version: mysqlnd 8.1.6
    max_allowed_packet: 1048576
    max_connections: 151
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: G:\A10_Webseite\htdocs\BS-Bilder/wp-content
    WP_PLUGIN_DIR: G:\A10_Webseite\htdocs\BS-Bilder/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    • Diese Antwort wurde geändert vor 6 Tage, 10 Stunden von Hans-Gerd Gerhards. Grund: Korrektur Code

    hmmm, und die URL?

    Thread-Starter wortpressender38

    (@wortpressender38)

    Wenn du dann noch die URL oben einträgst, dann können wir uns das auch zunächst im Frontend ansehen und dir sicher besser helfen.

    Nachtrag: Die Seite liegt bei mir nur lokal auf dem Rechner (XAMPP), d.h. ist noch nicht online.

    tja, dann wird es schwierig.

    Deaktiviere doch mal bitte zuerst alle Plugins und aktiviere anschließend Plugin für Plugin und schaue jeweils, ob das Problem dann immer noch besteht.

    Thread-Starter wortpressender38

    (@wortpressender38)

    Moin,
    nach einer Nachtsitzung habe ich die Ursache gefunden. In der Startseite waren 2 verschachtelte Header. Unter dem Standardheader „Seite (großer Header“ war mein eigener Header „BS-Header“. Keine Ahnung wie das passiert ist. An der Struktur der Startseite hatte ich bislang nicht (bewusst) herumgespielt. Ich habe dort lediglich einen kurzen Dummy-Text eingegeben. Das Scroll-Problem habe ich erst bemerkt, nachdem ich mehr Inhalt eingegeben habe, der Scrollen erfordert.
    Mit dieser verquasten Header-Konstellation auf der Startseite ist das Plugin myStickyMenu nicht klargekommen. Ich habe dann den Header auf der Startseite „aufgeräumt“. Jetzt funktioniert es 🙂
    Für mich als Anfänger ist die Oberfläche des Themees Twentytwentytwo nach meinem Geschmack etwas intransparent, aber das ist eine andere Baustelle…
    Nochmal Danke an Euch für die schnellen Antworten.

    Hallo,
    super – freut uns. Danke für die Rückmeldung und “Gelöst”-Markieren. 👍

    Mit dieser verquasten Header-Konstellation auf der Startseite ist das Plugin myStickyMenu nicht klargekommen..

    Block Themes wie TT2 sind in der Tat erst mal gewöhnungsbedürftig, wenn man damit noch nicht gearbeitet hat.

    Allerdings kannst du ein Sticky Menue auch per CSS hinbekommen. Vielleicht ist der folgende Beitrag von mir hilfreich. Das wäre aber ein neues Thema, wenn du dazu Fragen hast.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 5 Tage, 18 Stunden von Hans-Gerd Gerhards. Grund: Tippfehler
Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)