Support » Installation » Startseitenfehler

  • Gelöst jroe277

    (@jroe277)


    Hallo zusammen,

    ich bin gerade etwas verzweifelt und schaffe es daher auch nicht das gesamte Forum zu durchforsten. Ich habe aus Versehen die Webseiten URL in WordPress verändert und habe danach ein Backup vom vorherigen Tag draufgespielt. Vorher war die Seite über den Link http://www.dj-mister-music.de/ erreichbar. Nachdem ich das Backup draufgespielt habe wird man direkt auf /home weitergeleitet. Die eigentlich eingerichtete Startseite hat jedoch als Permalink den Link ohne /home. Ich dachte erst die Seite wäre weg, jedoch ist sie noch unverändert über „Seiten“ erreichbar und sieht wie vorher aus. Wie bekomme ich das ganze jetzt geradegebügelt?

    Würde mich über Hilfe sehr freuen. Zugriff auf den Server usw ist vorhanden.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Ich habe aus Versehen die Webseiten URL in WordPress verändert …

    Keine Ahnung warum, aber es gibt immer wieder Anwender/-innen, die die URL ändern und dann ganz überrascht sind, wieso ihre Website nicht mehr funktioniert. Dazu haben wir auch im Forum dutzendweise Antworten geschrieben. Kurzform: in die Datenbank gehen, Tabelle wp_options aufrufen, Felder siteurl und home korrigieren, fertig.

    … und habe danach ein Backup vom vorherigen Tag draufgespielt.

    Immerhin gehörst du schon mal zu den Leuten, die ein funktionierendes Backup haben und das auch verwenden. Prima.

    Vorher war die Seite über den Link http://www.dj-mister-music.de/ erreichbar.

    Das ist sie wohl auch immer noch – zumindest für die anderen Seiten, die in der Nagivationsleiste verlinkt sind.

    Die eigentlich eingerichtete Startseite hat jedoch als Permalink den Link ohne /home.

    Hm, strange … Geh mal auf Einstellungen > Permalinks. Was ist dort eingetragen? Speicher den Eintrag nochmal.
    Geh auch auf Einstellungen > Lesen. Was ist dort als Startseite eingetragen?

    Wenn du damit alleine noch nicht weiterkommst, brauchen wir mehr Input. Also Werkzeuge > Website-Zustand > Bericht, warten bis die Anzeige oben den Zustand anzeigt, dann auf den Button klicken. Neue Antwort erstellen, Strg-V drücken, absenden. Damit können wir dann besser beurteilen, worüber wie sprechen schreiben.

    Thread-Ersteller jroe277

    (@jroe277)

    Danke für die schnelle Antwort.

    Einstellungen > Permalinks zeigt Tag und Name
    Einstellungen > Lesen zeigt Home als Startseite

    Anbei der angeforderte Bericht:

    
    ### wp-core ###
    
    version: 5.9.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/web6we9iw/html/dj_mister_music/website
    wordpress_size: 61,54 MB (64525821 bytes)
    uploads_path: /home/web6we9iw/html/dj_mister_music/website/wp-content/uploads
    uploads_size: 7,71 GB (8275258315 bytes)
    themes_path: /home/web6we9iw/html/dj_mister_music/website/wp-content/themes
    themes_size: 23,91 MB (25066670 bytes)
    plugins_path: /home/web6we9iw/html/dj_mister_music/website/wp-content/plugins
    plugins_size: 194,21 MB (203645002 bytes)
    database_size: 103,86 MB (108904448 bytes)
    total_size: 8,08 GB (8677400256 bytes)
    
    ### wp-active-theme ###
    
    name: Oshin (oshin)
    version: 7.0.6
    author: Brand Exponents
    author_website: http://www.brandexponents.com/
    parent_theme: none
    theme_features: core-block-patterns, title-tag, editor-style, menus, automatic-feed-links, post-thumbnails, post-formats, custom-header, custom-background, woocommerce, tatsu-global-sections, widgets
    theme_path: /home/web6we9iw/html/dj_mister_music/website/wp-content/themes/oshin
    auto_update: Aktiviert
    
    ### wp-themes-inactive (2) ###
    
    Twenty Twenty-One: version: 1.5, author: WordPress-Team, Automatische Aktualisierungen aktiviert
    Twenty Twenty-Two: version: 1.1, author: WordPress-Team, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-active (17) ###
    
    BackWPup: version: 3.10.0, author: Inpsyde GmbH, Automatische Aktualisierungen aktiviert
    BE GDPR Compliance: version: 1.1.5, author: Brand Exponents, Automatische Aktualisierungen deaktiviert
    BE Portfolio Post: version: 1.1.1, author: Brandexponents, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.5.6, author: Takayuki Miyoshi, Automatische Aktualisierungen aktiviert
    Cookie Notice & Compliance for GDPR / CCPA: version: 2.2.3, author: Hu-manity.co, Automatische Aktualisierungen aktiviert
    Disable Gutenberg: version: 2.6, author: Jeff Starr, Automatische Aktualisierungen aktiviert
    iThemes Security: version: 8.1.0, author: iThemes, Automatische Aktualisierungen aktiviert
    LiteSpeed Cache: version: 4.5.0.1, author: LiteSpeed Technologies, Automatische Aktualisierungen deaktiviert
    Master Slider Pro: version: 3.6.1, author: averta, Automatische Aktualisierungen aktiviert
    Meta Box: version: 5.6.1, author: MetaBox.io, Automatische Aktualisierungen aktiviert
    Meta Box Conditional Logic: version: 1.6.17, author: MetaBox.io, Automatische Aktualisierungen aktiviert
    Meta Box Tabs: version: 1.1.10, author: MetaBox.io, Automatische Aktualisierungen aktiviert
    Oshine Core: version: 1.5.5, author: brandexponents team, Automatische Aktualisierungen aktiviert
    Oshine Modules: version: 3.2.8, author: Brand Exponents, Automatische Aktualisierungen aktiviert
    Slider Revolution: version: 6.5.18, author: ThemePunch, Automatische Aktualisierungen deaktiviert
    Tatsu: version: 3.3.12, author: Brand Exponents, Automatische Aktualisierungen aktiviert
    Yoast SEO: version: 18.4.1, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-inactive (5) ###
    
    Color Hub: version: 1.0.7, author: Brand Exponents, Automatische Aktualisierungen deaktiviert
    Edit Author Slug: version: 1.8.4, author: Brandon Allen, Automatische Aktualisierungen aktiviert
    Meta Box Show Hide: version: 1.3.0, author: MetaBox.io, Automatische Aktualisierungen deaktiviert
    Modern Events Calendar Lite: version: 6.4.8, author: Webnus, Automatische Aktualisierungen aktiviert
    Type Hub: version: 2.0.6, author: Brand Exponents, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.0-17-amd64 x86_64
    httpd_software: Apache
    php_version: 7.3.33 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 3000
    time_limit: 60
    memory_limit: 256M
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.20-MariaDB-deb10-keen
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    max_allowed_packet: 16777216
    max_connections: 200
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/web6we9iw/html/dj_mister_music/website/wp-content
    WP_PLUGIN_DIR: /home/web6we9iw/html/dj_mister_music/website/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    

    Hm. Wenn ich die Website jetzt aufrufe, scheint aber doch alles zu stimmen?

    Thread-Ersteller jroe277

    (@jroe277)

    Bei mir funktionierts auch wieder. Es lag wahrscheinlich am Browser Cache. Danke dir vielmals! Falls wir uns irgendwann mal begegnen gibts einen ausgegeben 🙂

    OK. 😀

    Ich vermute, dass es an den Permalinks gelegen hat.
    Durch Aufruf des Menüs liest WordPress die Permalinks neu ein.
    Wie auch immer: schön, dass es wieder klappt.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)