Support » Allgemeine Fragen » Styling vom Gutenberg-Editor lokal ganz anders

  • Gelöst montviso

    (@montviso)


    Ich baue gerade die erste Webseite mit WP 5.1 und Gutenberg auf.
    Die Benutzerfreundlichkeit auf der Testumgebung bei 1&1 finde ich nicht so toll.
    Aber ansonsten doch ganz zufrieden.

    Nun habe ich – um ein paar Dinge zu testen, die in dem anderen Projekt nichts verloren haben – das ganze Projekte auf meinen lokalen Rechner geholt, wo Apache 2 + PHP 5.6.4 läuft.

    Und ich staune nicht schlecht: die Editier-Ansicht sieht viel besser aus.
    Es poppt bei MouseOver ein blauer Rahmen auf.
    Die Markierungen, wo man anfassen muss, um einen Block zu verschieben, löschen ect. sind besser erreichbar.
    Insgesamt anders.

    Aber es wurde NICHTS geändert. die Installation ist original die Gleiche.

    Ich hätte ja eher vermutet, dass unter dem alten PHP was nicht funktioniert.
    Aber alles Bestens, soweit ich sehe.

    Hat jemand einen Tipp, wie ich den Gutenberg auch bei 1-und-1 schöner formatieren kann? Also so, dass auch der Kunde blickt, welchen Block er gerade editiert oder anfasst zum Verschieben?

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Hallo @montviso
    das klingt interessant, aber ich bezweifle, dass hier jemand willens oder in der Lage ist, das mit der nicht mehr supporteten PHP-Version 5.6.4 nachzuvollziehen.

    Vielleicht wären ein paar Screenshots oder ein kleiner Screencast hilfreich.

    Man muss auch nicht nachvollziehen, warum es unter 5.6. Benutzerfreundlich aussieht, sondern, warum es unter dem aktuellen php 7.2 so gar nicht schön aussieht. 😉

    Es ist gar nicht so einfach, einen Screen zu machen, weil die Effekte ja alle erst bei MouseOver sichtbar werden.

    Da wäre z.B. der Container für HTML lokal
    https://www.gartenstauden.de/funktioniert.JPG
    dazu kommt noch ein blauer Rand bei MouseOver oder Klick.
    Und beim Hoster
    https://www.gartenstauden.de/funktioniert-nicht.JPG
    Da fehlen die Bedienelemente.
    Ich nutze die Bedienelemente ganz oben auf der Seite, aber für den Kunden ist das vermutlich verwirrend, wo er hinklicken muss, damit er z.B. den richtigen Block verschiebt oder löscht.
    Das ist auf der lokalen Version viel intuitiver.

    Hier noch ein Sreen von der Gesamtansicht beim Hoster:
    https://www.gartenstauden.de/screen.JPG
    Da ändert sich auch bei MouseOver nicht sofort was.
    Ich muss immer erst lange suchen, wo ich mit der Mouse hinklicken muss, damit ich den Block z.B. verschieden kann, oder bei Spalten die Eigenschaften ändern kann, ect.

    Wie sieht denn bei Dir die Ansicht so einer einfachen Seite im Editiermodus aus?

    Was anderes: Wie kann ich hier eigentlich Bilder einfügen? Ich habe nichts gefunden, deshalb die blanken Links.

    Man muss auch nicht nachvollziehen, warum es unter 5.6. Benutzerfreundlich aussieht, sondern, warum es unter dem aktuellen php 7.2 so gar nicht schön aussieht

    Und wo sind die Vergleichswerte in diesem Fall? Ich kann mir immer noch nicht vorstellen, wie sich das jetzt unterscheidet. Vielleicht haben andere ja mehr Phantasie als ich 😀

    Bilder kannst du nur woanders hochladen, hier im Forum nicht.

    Naja, wenn Du die beiden ersten Bilder anschaust, siehst Du doch bei dem einen die Bedienelemente über dem Block?
    Die fehlen bei der anderen Installation.

    Und in der benutzerfreunlichen Variante ist der blaue Rand bei MouseOver um den Block, so dass man immer weiß, welcher gerade aktiv ist, wenn man z.B. auf Löschen geht.

    Aber ich verstehe schon das Problem, dass man es schlecht nachvollziehen kann.

    Sieht denn bei Dir der Editor auch genauso aus, wie bei mir in dem dritten Bild?

    Oder anders gefragt, auch an andere Leser:
    Übernimmt Ihr den Editor wie er ist oder stylt Ihr ihn um via einer benutzerdefinierten block.css?

    Ich habe überall (eigene, Kunden- und künftige Websites) das Plugin Classic Editor installiert, mir ist der Block-Editor (Gutenberg) einfach noch viel zu verbuggt, als dass man es wirklich auf Live-Sites einsetzen könnte. Auch das User-Interface finde ich grottig.

    Auf Test-Websites hab ich es installiert und die Anzeige irgendwelcher Elemente ist sehr unlogisch, da gebe ich dir vollkommen recht. Wieso das aber auf PHP 5.6 plötzlich einen blauen Rand zeigen soll, dafür gibt es keinen schlüssigen Grund. Das hat was mit CSS zu tun, oder JavaScript aber nicht mit PHP.

    Bugs kann ich nicht erkenne. Ich bin eigentlich eher erstaunt, wie gut alles funktioniert.
    BEi vorhandenen Kunden-Websites habe ich auch überall beim Update auf Classic umgestellt.
    Bei dieser neuen Webseite, sollte ein bestimmtes mächtiges Kauf-Theme mit PageBuilder zum Einsatz kommen, das aber noch nicht komnpatibel ist zum Gutenberg.
    Natürlich hätte ich das jetzt verwenden können, aber was, wenn es dann bei abschalten des Classic Editors immer noch nicht kompatibel ist?
    Wie soll ich DANN dem Kunden plausibel machen, dass wir ein neues Theme brauchen und alles nachbauen müssen?
    Deshalb habe ich mich jetzt einfach mal an das Abenteuer gewagt.
    Man kann ja nur hoffen, dass ich da noch was tut…

    Und in der benutzerfreunlichen Variante ist der blaue Rand bei MouseOver um den Block, so dass man immer weiß, welcher gerade aktiv ist, wenn man z.B. auf Löschen geht.

    Den habe ich auch, den blauen Rand, PHP 7.2 (nicht lokal). Der blaue Rand wird um Blöcke bei Maus hover angezeigt. Um Blöcke, in die man hinein geklickt hat, wird der blaue Rand bei Maus hover nicht angezeigt. Dafür werden aber bei Blöcken, in die hinein geklickt wurde, die Bedienelemente angezeigt, soferm man diese sich nicht ganz oben auf der Seite anzeigen lässt.

    Bugs kann ich nicht erkenne. Ich bin eigentlich eher erstaunt, wie gut alles funktioniert.

    https://github.com/WordPress/gutenberg/issues?q=is%3Aissue+is%3Aopen+label%3A%22%5BType%5D+Bug%22

    Oder hier im Trac, 5 von mir erstellte Tickets, alle noch offen. Für die Anzeige weiterer Bugs gib mal in die Suche „editor“ ein. Die Bugs werden auf Github und im Trac behandelt/gemeldet, können schon mal doppelt sein, aber meistens sind es unterschiedliche.

    Danke für’s Nachschauen.
    Das Grundsätzlich Unterschiede bestehen, die evt. davon abhängen, dass man versch. Themes verwendet, würde ich ja einsehen.
    Aber es handelt sich ja bei beiden Installationen um das gleiche Theme.
    Hört sich so an, als wäre bei Dir eher so wie bei mir lokal.
    Ja, das wegen den Bugs schaue ich mir auch noch näher an.

    @montviso

    kann es eventuell sein, dass du auf der Online-Website den Spotlight-Modus aktiviert hast? Bin gerade durch diesen Thread darauf gekommen.

    Uiuiui…was es alles gibt. 😉
    Danke, das schaue ich mir mal an.

    Moderator Angelika Reisiger

    (@la-geek)

    Problem gelöst?

    montviso

    (@montviso)

    OH, gut für die Erinnerung, wegen dem Spotlight.
    Gerade bin ich wieder über dem Projekt und schau mal nach.
    Zwischenzeitlich war ich auf einer anderen baustelle…;-)

    Gelöst nicht, aber ich habe einige Styles eingebaut und damit kann ist es etwas besser zu handhaben.

    Eben habe ich auf der Seite einen Redakteur-Account eingerichtet und mache Screenshots für den Kunden und stelle zu meiner Verblüffung und gleichzeitigen Erleichterung fest, dass hier die Ansicht genauso ist, wie auf der anderen Installation, also wesentlich benutzerfreundlicher.
    Fragt mich nicht, woran das liegt, ich bin einfach froh, dass es so ist.

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „Styling vom Gutenberg-Editor lokal ganz anders“ ist für neue Antworten geschlossen.