Support » Installation » Suchfunktionen funktionieren nicht mehr

  • Gelöst faltinl

    (@faltinl)


    Ich verwende WP4.3.16 und das Theme Adapt. Vermutlich seit einem Versuch WP4.9 zu installieren funktionieren die im Sidebar verwendeten Suchfunktionen nicht mehr – leider habe ich den Fehler erst viel später entdeckt, ich bin also nicht sicher, ob das der richtige Zusammenhang ist. Ich habe aufgrund dieser Vermutung mit WP-downgrade wieder WP4.3.16 installiert, aber das Problem ist geblieben.

    Folgende Suchfunktionen, die alle mit den WP-eigenen Widgets realisiert sind, sind betroffen – die Links danach geben jeweils 1 Beispiel an; die in der nach dem Anklicken aufgelisteten Titel sind nicht mehr wie früher mit dem zugehörigen Link zu diesem Titel hinterlegt, sondern enthalten immer nur den Link der Auflistung selbst – man kommt also durch die Suche nicht mehr zu den gefundenen Titeln:

    – Suche https://meincoach.at/?s=team
    – Kategorien-Liste https://meincoach.at/category/fallbeispiele/
    – Archiv https://meincoach.at/2016/11/
    – Wortwolke https://meincoach.at/tag/lateral-fuehren/

    Nur mehr die Aufzählung „letzte Posts“ funktioniert wie früher. Auch alle übrigen in der Webseite angegebenen Links funktionieren unverändert.

    Irgendwie habe ich den Verdacht, dass das Problem mit der Datenbank zu tun hat, weil offensichtlich nur dynamisch erstellte Links betroffen sind. Ich habe dort aber noch nie direkt eingegriffen, weil ich mich dort nicht auskenne. Wie könnte ich bei der Lösungssuche weiterkommen?

    Vielen Dank für Hinweise im Voraus!
    Leo

    • Dieses Thema wurde geändert vor 4 Jahre, 5 Monaten von faltinl. Grund: mit dem Link-Button erstellte Links haben nicht funktioniert

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Hallo @faltinl und willkommen im Forum,

    ein Downgrade ist in den meisten Fällen keine gute Idee.
    Updates sollen nicht nur neue Features hinzufügen, sondern beheben auch oft Sicherheitslücken.

    Führ doch bitte erst einmal wieder die Aktualisierung auf die neueste Version 4.9.6 durch.

    Aufgrund deiner Fehlerbeschreibung würde ich zunächst annehmen, dass die Permalinkstruktur nicht mehr richtig verarbeitet wird. Ruf bitte mal unter Einstellungen das Menü Permalink auf – mehr brauchst du nicht machen, durch den Aufruf wird die Permalinkstruktur bereits neu eingelesen. Funktioniert danach der Zugriff auf die genannten Seiten?

    Thread-Starter faltinl

    (@faltinl)

    Danke für diesen Hinweis, aber: nein, das hat nichts geändert. Es geht ja auch nicht um die Permalinks – ausnahmslos alle vorhandenen Seiten sind über Ihre Permalinks auch immer zugänglich geblieben, was man durch Anklicken vorhandener Webseiten-interner Links auch jederzeit überprüfen kann, und werden z.B. auch von Google indiziert. Vielmehr geht es um die von den diversen Suchfunktionen (d.h. in allen als Beispiele genannten Fällen) DYNAMISCH erstellten Links der Suchresultate. Alle Suchfunktionen, auch die Liste der Kategorien, listen die zutreffenden Seiten/Beiträge korrekt auf, bloß die Links, die DABEI hinterlegt werden, sind falsch.

    Das WP-Downgrade habe ich nicht zuletzt deswegen gemacht, weil das ganze Problem vor der Aktualisierung auf WP4.9 ganz sicher NICHT existiert hat. Wenn ich jetzt neuerlich aktualisiere, führe ich eine mögliche Fehlerquelle zusätzlich ein. Das scheint mir im aktuellen Zustand nicht die logisch-richtige Vorgangsweise zu sein. (Dass eine Aktualisierung grundsätzlich wünschenswert erscheint, ist mir natürlich klar, sonst hätte ich sie ja gar nicht erst versucht).

    Die Wahrscheinlichkeit ist hoch, dass das Problem durch ein Plugin oder das verwendete Theme verursacht wird. Um die Fehlerursache weiter einzugrenzen, kannst du das Plugin Health Check verwenden, das im Problembehandlungsmodus – nur für dich – alle Plugins deaktiviert und ein Standard-Theme aktiviert. Durch Beenden des Problembehandlungsmodus über die Admin-Leiste oder erneute Anmeldung im Backend wird der ursprüngliche Zustand wiederhergestellt. (Mehr Infos findest du auf unserer FAQ Seite zum Health Check Plugin.) Mit dem Plugin kannst du auch ganz komfortabel Informationen über deine Website sammeln, per Button kopieren und dann hier einfügen, damit wir etwas mehr über deine WordPress-Installation erfahren.

    Du nutzt Adapt 1.5.

    „Aktuell“ ist 3.1.1 vom 22. November 2016.
    https://wpexplorer-updates.com/changelog/adapt-wordpress-theme/

    Vielleicht hilft ein Update des Themes. Da es aber scheinbar seit zwei Jahren nicht mehr aktualisiert wird, ist ein Wechsel des Themes vielleicht sinnvoller.

    Gruß, Torsten

    Thread-Starter faltinl

    (@faltinl)

    ad @pixolin: Dieser Plugin hat 18 vernichtende Kritiken, insbes. mehrere Hinweise auf nicht mehr korrigierbare Veränderungen – genau vor derartigen Folgen habe ich nach ähnlichen schlechten Erfahrungen ganz einfach Angst! Die div. Infos über Versionen und veraltete Plugins habe ich auch so – ***und an all dem kann es nicht liegen, weil es vorher ja auch funktioniert hat***.

    ad @zodiac1978: Das führt nur weitere unbekannte Variable ein. Die Seite hat ja bis vor dem Aktualisierungsversuch zu WP4.9 einwandfrei funktioniert, es liegt also nicht am Theme. Wenn ich jetzt alleine zur Fehlersuche neue Unbekannte einführe (womöglich noch ein völlig anderes Theme!), mache ich womöglich noch mehr kaputt und kann mögliche echte Fehlerursachen überhaupt nicht mehr eingrenzen.

    Ich verwende PHP5.6, MySQL5.5, Adapt 1.5, WP4.3.16. und die Webseite ist seit ca. 1 Jahr auf SSL umgestellt – alles lange vor dem Auftreten der aktuellen Probleme.

    Grüße
    Leo

    Das Health Check Plugin wurde vom WordPress Support Team für den Zweck entwickelt, AnwenderInnen bei der Fehlersuche zu unterstützen. Das habe ich in dem verlinkten Beitrag in unserer FAQ aber auch alles beschrieben.

    Scheinbar sind einige Anwender trotz ausführlichen Hinweisen nicht in der Lage, den Problembehandlungsmodus wieder auszuschalten. Ich weiß nicht, was wir hier noch tun können, außer darauf hinzuweisen. Wir haben das Plugin auch hier im deutschsprachigen Support immer wieder eingesetzt und konnten damit bereits vielen AnwenderInnen helfen, Informationen zu ihren Websites zu sammeln oder über den Problembehandlungsmodus die Ursache herauszufinden und damit den Fehler zu beheben. Aber selbstverständlich zwingt dich hier niemand zu irgendwas.

    Ohne Informationen zu deiner Website kann ich dir nicht weiterhelfen.
    Ich wünsche dir trotzdem viel Erfolg bei der Lösung deines Problems.

    Thread-Starter faltinl

    (@faltinl)

    Ich anerkenne voll die Leistungen all jener, die zu WP beigetragen haben und noch beitragen – das ist nicht das Problem. Ich habe nur in letzter Zeit und im Zusammenhang mit genau meinen aktuellen Schwierigkeiten so viele unangenehme Erfahrungen gemacht, dass ich sehr vorsichtig geworden bin.

    Also gut. Ich habe Backups für Inhalte und Datenbank angelegt und den Health Check Plugin installiert. Hier ist der Inhalt, der sich auf die Konfiguration bezieht:
    ___________________
    PHP-Version 5.6.36 – Für beste Performance empfehlen wir die Verwendung von PHP 7.2 oder höher.

    MySQL-Server-Version 5.1.73
    – Aus Performance- und Sicherheitsgründen empfehlen wir dringend, MySQL in Version 5.6 oder höher zu nutzen.

    JSON-Erweiterung Deine PHP-Installation unterstützt JSON.

    Unterstützung von MySQL utf8mb4 Die Unterstüztung von utf8mb4 durch WordPress erfordert MySQL Version 5.5.3 oder höher.

    Kommunikation mit WordPress.org WordPress.org ist von deinem Server erreichbar.

    HTTPS-Status Du greifst auf diese Website unter Verwendung von HTTPS zu.

    Sicherer Austausch Deine WordPress-Installation konnte sich nicht sicher mit anderen Diensten austauschen.

    Geplante Ereignisse Keine geplanten Ereignisse wurden verpasst.

    Aktualisierungen im Hintergrund

    Es wurde kein Versionskontrollsystem gefunden.
    Deine WordPress-Installation benötigt für Aktualisierungen keine FTP-Zugangsdaten.
    Alle deine WordPress-Dateien sind beschreibbar.

    Loopback Request Der Loopback Request für deine Website wurde erfolgreich abgeschlossen.
    ____________________

    Und hier ist der Inhalt des Feldes Debugging Information:

    				### WordPress ###
    
    Version: 4.9.6
    Sprache: de_DE
    Permalink-Struktur: /%postname%/
    Verwendet diese Website HTTPS?: Ja
    Kann sich jeder auf dieser Website registrieren?: Nein
    Standard-Kommentarstatus: open
    Ist dies ein Netzwerk?: Nein
    Benutzeranzahl: 2
    Kommunikation mit WordPress.org: WordPress.org ist erreichbar
    Erzeuge Loopback Requests: Der Loopback Request für deine Website wurde erfolgreich abgeschlossen.
    
    ### Größe der Installation ###
    
    Uploads-Verzeichnis: 36,32 MB
    Theme-Verzeichnis: 3,14 MB
    Plugin-Verzeichnis: 38,39 MB
    Datenbank-Größe: 32,68 MB
    Gesamtes WordPress-Verzeichnis: 0,00 B
    Gesamtgröße der Installation: 32,68 MBEinige Fehler, die wahrscheinlich durch ungültige Berechtigungen verursacht wurden, sind bei der Bestimmung der Größe deiner Installation aufgetreten. Dies bedeutet, dass die dargestellten Werte ungenau sein können.
    
    ### Drop-ins ###
    
    advanced-cache.php: Erweitertes Caching-Plugin.
    
    ### Aktives Theme ###
    
    Name: Twenty Seventeen
    Version: 1.6
    Autor: dem WordPress-Team
    Website des Autors: https://de.wordpress.org/
    Parent Theme: Kein Child Theme
    Unterstützte Theme-Funktionalität: automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, starter-content, custom-header, widgets
    
    ### Andere Themes (2) ###
    
    Adapt (adapt): Version 1.5 von WPExplorer
    Twenty Sixteen (twentysixteen): Version 1.5 von dem WordPress-Team
    
    ### Must Use Plugins (1) ###
    
    Health Check Troubleshooting Mode: Version 1.4.1
    
    ### Aktive Plugins (2) ###
    
    Health Check: Version 1.1.2 von The WordPress.org community
    Yoast SEO: Version 7.7.2 von Team Yoast
    
    ### Inaktive Plugins (16) ###
    
    Akismet Anti-Spam: Version 4.0.8 von Automattic
    All-in-One WP Migration: Version 6.70 von ServMask
    All in one Favicon: Version 4.6 von Arne Franken
    Comet Cache: Version 170220 von WebSharks, Inc.
    Compact Audio Player: Version 1.9.6 von Tips and Tricks HQ
    Google Analytics Dashboard for WP (GADWP): Version 5.3.5 von ExactMetrics
    Google Website Translator: Version 1.4 von Prisna
    NextGEN Gallery: Version 3.0.1 von Imagely
    Print, PDF & Email by PrintFriendly: Version 3.14.3 von Print, PDF, & Email by PrintFriendly
    Safe Redirect Manager: Version 1.9 von 10up
    WP Downgrade | Specific Core Version: Version 1.1.4 von Reisetiger
    WPML CMS Nav: Version 1.3 von ICanLocalize
    WPML Multilingual CMS: Version 2.9 von ICanLocalize
    WPML Sticky Links: Version 1.3 von ICanLocalize
    WPML String Translation: Version 1.8 von ICanLocalize
    WPML Translation Management: Version 1.7 von ICanLocalize
    
    ### Medienhandling ###
    
    Aktiver Editor: WP_Image_Editor_GD
    Imagick Modul Version: Imagick not available
    ImageMagick-Version: Imagick not available
    GD-Version: bundled (2.1.0 compatible)
    Ghostscript-Version: 8.70
    
    ### Server ###
    
    Server-Architektur: Linux 3.10.0-714.10.2.lve1.4.79.el6h.x86_64 x86_64
    PHP-Version: 5.6.36 (Unterstützt 64bit-Werte)
    PHP SAPI: cgi-fcgi
    PHP max input variables: 10000
    PHP time limit: 120
    PHP memory limit: 256M
    Max input time: 60
    Maximale Dateigröße Upload: 200M
    PHP post max size: 200M
    cURL-Version: 7.59.0 OpenSSL/1.0.1e
    SUHOSIN installiert: Ja
    Ist die Imagick-Library verfügbar: Nein
    htaccess Regeln: Individuelle Regeln wurden zu deiner htaccess-Datei hinzugefügt.
    
    ### Datenbank ###
    
    Erweiterung: mysqli
    Server-Version: 5.1.73
    Client-Version: mysqlnd 5.0.11-dev - 20120503 - $Id: 76b08b24596e12d4553bd41fc93cccd5bac2fe7a $
    Datenbankpräfix: wp_
    
    ### WordPress-Konstanten ###
    
    ABSPATH: /home/.sites/142/site2208/web/
    WP_HOME: Nicht definiert
    WP_SITEURL: Nicht definiert
    WP_DEBUG: Deaktiviert
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG_DISPLAY: Aktiviert
    WP_DEBUG_LOG: Deaktiviert
    SCRIPT_DEBUG: Deaktiviert
    WP_CACHE: Aktiviert
    CONCATENATE_SCRIPTS: Nicht definiert
    COMPRESS_SCRIPTS: Nicht definiert
    COMPRESS_CSS: Nicht definiert
    WP_LOCAL_DEV: Nicht definiert
    
    ### Dateisystem-Rechte ###
    
    Das Haupt-WordPress-Verzeichnis: Schreibbar
    Das Verzeichnis wp-content: Schreibbar
    Das Uploads-Verzeichnis: Schreibbar
    Das Plugin-Verzeichnis: Schreibbar
    Das Theme-Verzeichnis: Schreibbar
    Das Must-Use-Plugin-Verzeichnis : Schreibbar
    

    Solange der Fehlerdiagnose-Modus EIN ist, sieht meine Webseite, vom selben Computere aus beobachtet völlig anders aus als normal. Die problematischen Funktionen sind nicht auffindbar. Im Handy und unangemeldet sehe ich die Webseite wie gewohnt und mit den zuetzt beobachteten Fehlern, soweit ist alles normal. Braucht Ihr noch weitere Infos?

    Grüße
    Leo

    Thread-Starter faltinl

    (@faltinl)

    Ergänzung: Die beiden Tests „Dateiintegrität“ und „E-Mail“ sind ok gemeldet worden.
    Grüße
    Leo

    Thread-Starter faltinl

    (@faltinl)

    Noch eine Ergänzung: Der WP-Downgrade-Plugin stellt die Webseite ***bei Deaktivierung*** auf die zuvor vorhandene WP-Version zurück; deshalb erscheint als aktuelle WP-Version im Problembehandlungsmodus auch WP4.9.6.
    Grüße
    Leo

    Die aktuellen negativen Rezensionen (und die überaus geduldigen Antworten vom Plugin-Entwickler) stammen übrigens überwiegend von Anwendern, die scheinbar keine Zeit oder keine Lust hatten, sich die unmissverständlichen Hinweise des Plugins durchzulesen und einfach einen Button angeklickt haben, ohne zu verstehen, worum es eigentlich geht. Hier nochmal im Einzelnen:

    Der Problembehandlungsmodus des Health Check

    • deaktiviert alle Plugins, allerdings nur für den Nutzer, der das Plugin ausführt
    • aktiviert ein Standard-Theme („Twenty …“), allerdings nur für den Nutzer, der das Plugin ausführt
    • bietet über die Admin-Leiste die Möglichkeit, das normalerweise verwendete Theme und die Plugins einzeln wieder zu aktivieren und
    • kann über die Admin-Leiste oder durch erneute Anmeldung wieder abgeschaltet werden.

    Der Sinn der Aktion ist, mögliche Fehlerquellen einzugrenzen.

    • Funktioniert z.B. der Abruf von https://example.com/?s=team im Problembehandlungsmodus, kann davon ausgegangen werden, dass eines der verwendeten Plugins oder das Theme Probleme bereitet.
    • Funktioniert die Abfrage auch mit abgeschalteten Plugins und Theme weiterhin nicht, stimmt höchstwahrscheinlich etwas mit der Serverkonfiguration nicht – z.B. bei den Weiterleitungsregeln der .htaccess.
    • Eher unwahrscheinlich ist ein Problem in einer aktuellen WordPress-Version – die wird millionenfach eingesetzt und so ein massiver Fehler würde sehr schnell gemeldet und behoben. Ich habe aber schon öfter Fälle gesehen, bei denen einzelne Dateien bei einem Update nicht richtig übertragen wurden. Hier hilft eine erneute Aktualisierung (Dashboard > Aktualisierungen > WordPress erneut aktualisieren.

    Das steht aber alles auch – etwas anders formuliert – in unserem FAQ-Beitrag zum Health Check Plugin.

    Thread-Starter faltinl

    (@faltinl)

    Die Situation ist völlig eindeutig: die falschen Links erscheinen
    1. unabhängig von der WP-Version, also sowohl mit WP4.3.16 als auch mit WP4.9.6;
    2. unabhängig davon, ob die Versionen nochmals aktualisiert wurden;
    3. auch mit allen Plugins abgeschaltet.

    Mit den Twenty-xx-Themes kann ich nichts testen, weil sie die Widgets nicht wiedergeben, d.h. die diversen Suchfunktionen werden in diesen Themes nicht gezeigt.

    Demnach wäre bei der Serverkonfiguration anzusetzen. Das verstehe ich nun überhaupt nicht: Inwiefern wirken sich Serverkonfiguration (ist mir als User ja auch überhaupt nicht zugänglich) und/oder .htaccess auf Funktionen wie die Darstellung dynamischer Links aus? Und was kann da ein möglicher konkreter Ansatzpunkt sein?

    Die Seite hat ja bis vor dem Aktualisierungsversuch zu WP4.9 einwandfrei funktioniert, es liegt also nicht am Theme.

    Das ist nicht richtig. Funktionen können sich in neueren WP-Versionen ändern und so Anpassungen am Theme erfordern. Wenn dieses nicht aktualisiert wird, dann gibt es Probleme. Das ist zwar nicht sehr wahrscheinlich bei WordPress und seiner Backwards Compatibility Einstellung, aber in deinem Fall das naheliegendste, denn für die Ausgabe der Links auf den von dir genannten Seiten ist das Theme (daher ist die Serverkonfiguration sicher nicht der richtige Ansatzpunkt).

    Insbesondere, wenn im oben von mir verlinkten Changelog des Themes folgendes zu finden ist:

    v2.2.0 – February 19, 2016
    […]
    FIXED: Blog entry links on blog page not linking correctly to posts

    Gruß, Torsten

    Thread-Starter faltinl

    (@faltinl)

    ad @zodiac1978
    Was mit „Blog entry links on blog page not linking correctly to posts“ gemeint sein könnte, betrifft u.U. ganz andere Fehler als jene bei meiner Webseite.

    Die Umstellung von WP4.3.16 auf WP4.9.6 erfolgte im Zeitraum 26.-31.5.2018 (nicht durch mich, daher kein genauer Zeitpunkt). Ich nütze Adapt 1.5 seit 2013 bis heute und bis einige Tage nach der WP-Umstellung sind mir nie Probleme im Zshg mit Verlinkung aufgefallen.

    Auf der Basis scheint mir das Risiko, mit einer nochmals neueren Adapt-Version zu experimentieren, doch um Einiges größer als die Erfolgschancen solcher Experimente. Ich verschiebe daher diese Experimente auf einen Zeitpunkt, wenn vorerst erfolgversprechendere Optionen erfolglos geblieben sein sollten.

    ad @zodiac1978 & @pixolin
    Im übrigen weiß ich es zu schätzen, durch zwei offensichtlich unabhängige Moderatoren zwei sehr unterschiedliche Perspektiven geboten zu bekommen. Gerade weil es für die Fehler bei meiner Webseite offenbar keine a priori selbstverständliche Lösung gibt, ist das für mich sehr wertvoll und ich lerne viel dazu.

    Thread-Starter faltinl

    (@faltinl)

    Also – ich hab’s trotzdem getan:
    1. Ich habe unter WP4.9.6. zusätzlich zur Version 1.5 von Adapt die neueste verfügbare Version (keine Nummer verfügbar) runtergeladen, installiert (nicht aktiviert!) und im Problembehandlungsmodus von Health-Check angesehen. Das bisher beobachtete Link-Problem war tatsächlich weg. Allerdings funktionierte die Sprach-Umschaltung nicht, es wurde alles parallel angeboten.

    2. Um zu testen, ob das mit WP4.3.16 vielleicht auch geht (die Sprachumschaltung hat damit auch bis zuletzt immer funktioniert), habe ich den Health-Check nach Ausstieg aus der Problembehandlung deaktiviert und mit WP-Downgrade die Umstellung auf WP4.3.16 eingeleitet (habe ich früher schon mehrmals erfolgreich gemacht). Die ist nach einigen Minuten abgestürzt mit der Fehlermeldung

    Fatal error: Call to undefined function wp_installing() in /home/.sites/142/site2208/web/wp-content/plugins/wordpress-seo/wp-seo-main.php on line 445

    und die Seite ist jetzt nicht mehr erreichbar. Gibt es Möglichkeiten, die Seite wiederzubeleben oder bleibt mir jetzt nur mehr ein Komplett-Backup durch den Provider?

    Wir alle lernen in diesem Forum immer wieder dazu.

    Ich versuche eigentlich immer, meine Websites auf dem neuesten Stand zu halten. Dabei gehe ich davon aus, das Updates nicht gemacht werden, um AnwenderInnen zu frustrieren oder mit neuen Features zu belästigen, sondern um bekannt gewordene Fehler zu beheben und für Schwierigekeiten in der Bedienung neue Lösungen zu finden. Ohne Updates werden keine Fehler behoben und mit Downgrades bereits gelöste Probleme wieder hergestellt.

    Es gibt sicherlich Websites, bei denen ein Ausfall kritisch ist und zu finanziellen Schäden (z.B. durch entgangenen Umsatz) führen kann. In solchen Fällen ist es sinnvoll, die Website auf einem lokalen Webserver zu klonen, Updates dort durchzuführen und ausgiebig zu testen und erst anschließend in den produktiven Betrieb zu übernehmen. Für alle anderen, „kleinen“ Websites reicht vermutlich ein vorheriges Backup, ein zügiges Update und eine kurze Sichtprüfung.

    Diese vielleicht etwas langatmige Ausführung vorab, weil ich die mehreren Anläufe mit alten Versionen und einem Downgrade-Plugin überhaupt nicht nachvollziehen kann. Ich lerne aber, dass nicht jeder so vorbehaltlos mit Updates umgeht.

    Wenn wir hier im Forum helfen, Fehler zu beheben, versuchen wir zunächst im Ausschlußprinzip die Ursache des Problems zu finden. In den meisten Fällen ist die Ursache ein fehlerhaft programmiertes Plugin oder Theme, die mit Hilfe des Health-Check-Plugins kurzzeitig zur Fehleranalyse deaktiviert werden können. Bevor es das Plugin gab, wäre die Standard-Empfehlung gewesen, das Plugin-Verzeichnis vorübergehend umzubenennen und dann die Plugins einzeln wieder zu aktivieren – was auch in dem aktuellen Fall der Fehlermeldung mit dem Yoast-Plugin sinnvoll erscheint.

    Wenn ich Support anbiete, kann ich mich nur auf aktuelle Versionen beziehen. Ältere Versionen sehe ich als bereits fehlerbehaftet an (deshalb gab es ja ein Update) und die erste Empfehlung wird immer sein, ein Update von Core, Plugins und Themes vorzunehmen, um mögliche Fehlerquellen zu reduzieren.

    Wenn das „bisher beobachtete Link-Problem [im Problembehandlungsmodus] tatsächlich weg“ war, ist das ein erster Erfolg. Zusätzliche Funktionen wie der Sprachumschalter bei WPML müssten dann getrennt davon betrachtet werden.

    WPML ist allerdings auch ein gekauftes Plugin. Zu gekauften Plugins und Themes können wir hier nicht weiterhelfen. Wir müssten uns erst einmal selber die Plugins oder Themes kaufen, um dann kostenlos den Support anbieten zu können, für den die AnwenderInnnen den Theme-Entwickler bezahlt haben.

    Ob die Fehlermeldung des Yoast-Plugin nun eigentlich vom Downgrade-Plugin verursacht wurde, kann ich nicht beurteilen. Die sauberste Lösung wäre sicherlich, den ursprünglichen Zustand per Restore eines Backups wiederherzustellen und gleich als allererstes das Downgrade-Plugin rauszuschmeißen. Dann Updates durchführen und anschließend testen, was nicht funktioniert. Hier dann im Einzelfall nachbessern. Aus Bequemlichkeit würde ich aber erst einmal (vorheriges Backup vorausgesetzt) einfach die Verzeichnisse des Downgrade- und Yoast-Plugin löschen und schauen, ob die Website damit zunächst stabil läuft; dann das Yoast Plugin wieder installieren.

    Um Mißverständnissen vorzubeugen: Wir bieten hier gerne Hilfe zur Selbsthilfe an und unterstützen AnwenderInnen „nach bestem Wissen und Gewissen“, übernehmen aber keine Gewährleistung für mögliche Schäden. Im Zweifelsfall ist es vielleicht besser, einen Dienstleister zu beauftragen.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Das Thema „Suchfunktionen funktionieren nicht mehr“ ist für neue Antworten geschlossen.