Support » Themes » Sydney update 2.14 Beitragsbilder nicht mehr angezeigt

  • Gelöst planwerkplus

    (@planwerkplus)


    Hallo.
    Seit dem update auf Sydney 2.14 werden die Beitragsbilder auf der Startseite nicht mehr angezeigt.
    Außerdem wird die Bildschirm Breite reduziert, sodass das Header Bild nur noch ganz schmal ist.
    Ansonsten habe ich nichts in den Einstellungen geändert.
    Ich musste jetzt auf ein anderes Theme umstellen, damit die Seite noch funktioniert.
    Kann man das Problem irgendwie beheben?
    Danke.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Es ist ein bisschn schwierig ein Problem mit einem Theme zu beurteilen, wenn du kurzerhand zu einem anderen Theme wechselst. Wir benötigen außerdem mehr Informationen zu deiner Website:

    1. Geh ins Backend, klick auf Werkzeuge (1), dort auf Website-Bericht (2), dort auf den Tab Bericht (3), warte die Zustandsanzeige ab (4), lies den Text (5), ziele mit der Maus und klicke auf den Button (6).
      Screenshot Einstellungen
      (zum Vergrößern anklicken)
    2. Erstelle eine neue Antwort. Dabei Strg-V (Mac: Cmd-V) drücken, um den Website-Bericht unverändert einzufügen. Die Akzentzeichen ` am Anfang und Ende nicht löschen, sie dienen der Formatierung.
    Thread-Starter planwerkplus

    (@planwerkplus)

    
    ### wp-core ###
    
    version: 6.1
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web306/b3/64/58635464/htdocs/WordPress_01
    wordpress_size: 2,08 GB (2229826446 bytes)
    uploads_path: /mnt/web306/b3/64/58635464/htdocs/WordPress_01/wp-content/uploads
    uploads_size: 937,89 MB (983445426 bytes)
    themes_path: /mnt/web306/b3/64/58635464/htdocs/WordPress_01/wp-content/themes
    themes_size: 9,84 MB (10319963 bytes)
    plugins_path: /mnt/web306/b3/64/58635464/htdocs/WordPress_01/wp-content/plugins
    plugins_size: 42,11 MB (44150618 bytes)
    database_size: 9,23 MB (9682944 bytes)
    total_size: 3,05 GB (3277425397 bytes)
    
    ### wp-active-theme ###
    
    name: Sydney (sydney)
    version: 2.14
    author: aThemes
    author_website: https://athemes.com
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, siteorigin-panels, widgets-block-editor, automatic-feed-links, title-tag, menus, html5, post-formats, custom-background, align-wide, block-templates, custom-header, infinite-scroll, widgets
    theme_path: /mnt/web306/b3/64/58635464/htdocs/WordPress_01/wp-content/themes/sydney
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Hitchcock: version: 2.2.1, author: Anders Norén, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (10) ###
    
    Akismet Anti-Spam: version: 5.0.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    aThemes Starter Sites: version: 1.0.24, author: aThemes, Automatische Aktualisierungen deaktiviert
    Column Shortcodes: version: 1.0.1, author: Codepress, Automatische Aktualisierungen deaktiviert
    Content Views: version: 2.5.0, author: Content Views, Automatische Aktualisierungen deaktiviert
    Disable Google Fonts: version: 2.0, author: Milan Dinić, Automatische Aktualisierungen deaktiviert
    Exclude Pages From Menu: version: 3.0, author: Vinod Dalvi, Automatische Aktualisierungen deaktiviert
    Page Builder by SiteOrigin: version: 2.18.4, author: SiteOrigin, Automatische Aktualisierungen deaktiviert
    Post Types Order: version: 1.9.9.1, author: Nsp Code, Automatische Aktualisierungen deaktiviert
    Self-Hosted Google Fonts: version: 1.0.1, author: asadkn, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.23, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (1) ###
    
    WP Fastest Cache: version: 1.0.7, author: Emre Vona, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-60 Q16 x86_64 17403 https://legacy.imagemagick.org
    imagick_version: 3.5.1
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 4 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 4 GB
    	imagick::RESOURCETYPE_MEMORY: 2 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, A, AAI, AI, APNG, ART, ARW, AVI, AVS, B, BGR, BGRA, BGRO, BMP, BMP2, BMP3, BRF, C, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K, K25, KDC, LABEL, M, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, R, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCREENSHOT, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMV, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, Y, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux localhost 3.10.0-1160.71.1.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.71.1.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.71.1.el7.x86_64 #1 SMP
    httpd_software: Apache/2.4.54 (Unix)
    php_version: 7.4.32 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.85.0 OpenSSL/1.1.1q
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: 5.6.45
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web306/b3/64/58635464/htdocs/WordPress_01/wp-content
    WP_PLUGIN_DIR: /mnt/web306/b3/64/58635464/htdocs/WordPress_01/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Hallo,
    auf der Website gibt es mixed content. Das dürfte wohl die Ursache sein.
    Mixed Content bedeutet, dass eine Website, die verschlüsselt über HTTPS aufgerufen wird, Inhalte teilweise unverschlüsselt über HTTP ausliefert.
    Das kannst du sehen, wenn du z. B. über Chrome in die developer console schaust (Shortcut für Developer Console: F12).
    Du kannst deine Seite aber auch mal auf der folgenden Webseite prüfen und siehst dann die Fehler.
    Diese Fehler lassen sich z. B. über das Plugin „Better Search and Replace“ korrigieren (ersetzen von http://example.com/ durch https://example.com/).
    Vorher aber bitte auf jeden Fall eine Sicherung der Datenbank erstellen.

    Teste auch mal bitte, ob das Problem behoben ist, wenn du den Cache bei dem Plugin WP Fastest Cache erneuerst bzw. das Plugin deaktivierst.

    Akismet entspricht nicht den europäischen Datenschutzvorgaben. Schau dir mal Antispam Bee an. Kostenlos, leistungsfähig und datenschutzkonform.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 2 Wochen, 3 Tage von Hans-Gerd Gerhards. Grund: Tippfehler

    Deine Website zeigt an, dass gemischte Inhalte (mit https verschlüsselt und unverschlüsselt) angezeigt werden sollen. Der Browser zeigt dann nur die verschlüsselten Inhalte, um deine Webseitenbesucher zu schützen.
    Du kannst das beheben, indem du unter Einstellungen > Allgemein zunächst die beiden URLs auf http://pla***lus.net zurücksetzt (beides mit http am Anfang). Danch gehst du auf Werkzeuge > Website-Zustand und wartest, bis WordPress den Zustand deiner Website vollständig aktualisiert hat. Du solltest dann einen Hinweis sehen, dass deine Website Informationen unverschlüsselt überträgt. Klappst du das Feld auf, bekommst du einen Button, um die Website komplett auf verschlüsselte Übertragung umzustellen. Dann sollten auch die Bilder richtig eingebunden werden.

    Noch ein paar Zeilen zum Website-Bericht, die aber nichts mit dem Problem zu tun haben:

    • timezone: +00:00 – stell das auf „Berlin“ um, dann klappt es auch mit der nächsten Zeitumstellung.
    • total_size: 3,05 GB – du hast da recht viele Dateien angesammelt. Schau mal, ob du Backups löschen kannst, die längst überflüssig sind und ändere ggf. die Backup-Einstellungen.
    • Akismet Anti-Spam – soviel ich auf einen ersten Blick sehe, verwendest du doch gar keine Kommentar-Funktion, über die Spam-Beiträge reinkommen könnten? Dann brauchst du das Plugin auch nicht, das außerdem nicht unseren Datenschutzvorgaben entspricht.
    • Disable Google Fonts und Self-Hosted Google Fonts scheint mir etwas redundant. Wenn du die Fonts eh schon selber hostest, brauchst du sie ja nicht noch deaktivieren?
    • php_version: 7.4.32 64bit – der Support für PHP 7.4 läuft Ende dieses Monats aus. Prüf mal, ob deine Website auch mit PHP 8.0 läuft.
    Thread-Starter planwerkplus

    (@planwerkplus)

    Hallo zusammen.
    Danke, alles ausprobiert. Funktioniert aber leider immer noch nicht.
    Die Plugins akismet und fastest cache hatte ich erst heute morgen beim rum probieren aktiviert. An denen kann es also auch nicht liegen. Hatte auch schon alle Plugins deaktiviert.
    Den Button „auf https umstellen“ hatte ich auch heute morgen schon ausprobiert.
    Auf der von Hans-Gerd empfohlenen website wird allerdings immer noch mixed content angezeigt. Das Plugin „better search and replace“ hat hier auch nicht geholfen.
    Ich habe auch versucht, die Beitragsbilder zu löschen und neu hochzuladen. Das hilft auch nicht.
    Vielleicht habt ihr noch eine Idee, was ich noch ausprobieren könnte?
    Gibt es eine Möglichkeit, das update von Sydney rückgängig zu machen?
    Viele Grüße Sara

    Hallo,

    Gibt es eine Möglichkeit, das update von Sydney rückgängig zu machen?

    ja, die einfachste Möglichkeit besteht über das Plugin WP Rollback. Wie das funktioniert, habe ich in dem folgenden Beitrag beschrieben.

    Viele Grüße
    Hans-Gerd

    Nachtrag: Ich vermute aber eher, dass die fehlenden Bilder (auf der Hauptseite?) aufgrund einer Einstellung beim Theme nicht mehr gezeigt werden. Schau doch mal bitte bei dem Theme unter Design > Customizer unter Deine Anpassungen für ▸ Blog
    Blog archives, ob da die Einstellung „Enable Featured Image“ deaktiviert ist.

    Abgesehen davon, ist ein Rollback schon aus Sicherheitsgründen immer nur als eine Zwischenlösung zu verstehen, bis das Problem vom Entwickler behoben worden ist bzw. eine anderweitige Lösung gefunden wurde.

    Die Plugins akismet und fastest cache hatte ich erst heute morgen beim rum probieren aktiviert. An denen kann es also auch nicht liegen. Hatte auch schon alle Plugins deaktiviert.

    Wenn du versuchst, einen Fehler zu beseitigen, solltest du nicht noch weitere Plugins installieren. Ein Cache-Plugin liefert unter Umständen eine zwischengespeicherte Fassung der Webseiten aus und berücksichtigt nicht die letzten Änderungen, die du vorgenommen hast.

    Den Button „auf https umstellen“ hatte ich auch heute morgen schon ausprobiert.
    Auf der von Hans-Gerd empfohlenen website wird allerdings immer noch mixed content angezeigt. Das Plugin „better search and replace“ hat hier auch nicht geholfen.

    Die Antworten von Hans-Gerd und mir haben sich überschnitten.

    Auf https://www.whynopadlock.com/results/d1e2dd57-7ebd-4d89-b569-f1f730aeb2c9 wird angezeigt, dass die Startseite jetzt korrekt verschlüsselt übertragen wird. Das war zuerst nicht so.

    Wenn du wie von mir beschrieben vorgegangen bist, ist die Ersetzung mit Better Search Replace überflüssig. Sie schadet aber auch nicht (weil wahrscheinlich nichts ersetzt wird).

    Gibt es eine Möglichkeit, das update von Sydney rückgängig zu machen?

    Du kannst das Plugin WP Rollback installieren, dann Design > Themes aufrufen und in die Theme-Details gehen. Über den Button Rollback kannst du eine ältere Version des Themes auswählen.

    Wie hast du denn das Masonry-Grid (versetzte Darstellung der Beiträge) eingefügt? Ich vermute eher, dass hier eine Einstellung geändert werden muss, um die Beitragsbilder anzuzeigen.

    Thread-Starter planwerkplus

    (@planwerkplus)

    Hallo nochmal. Vielen Dank für die schnellen Antworten!
    Die Einstellungen von Sydney hatte ich schon alle ausprobiert. Habe das Problem ja schon seit Freitag. Enable featured image ist aktiviert.
    Mit Rollback funktionierte es kurzzeitig, aber damit habe ich Sydney dann anscheinend kaputt gemacht. Seite kann nicht mehr laden und sagt: Fehler: Stylesheet is missing.
    Habe Sydney neu installiert, aber jetzt sind natürlich die Einstellungen teilweise weg.
    Ich werde erstmal mein Ersatz-Theme aktivieren und später versuchen, die Sicherung von heute morgen wiederherzustellen und dann schaue ich mal weiter.
    Danke und viele Grüße Sara

    Habe Sydney neu installiert, aber jetzt sind natürlich die Einstellungen teilweise weg.

    Wieso natürlich? Die Einstellungen werden themebezogen in der Datenbank gespeichert und nicht gelöscht, wenn du ein Theme löschst.

    Ich würde auf ein Backup zurückgreifen um den Stand vor dem Update wiederherzustellen. Wenn du selber kein Backup gemacht hast (nicht gut), frag den Support deines Webhosters, ob sie aushelfen können.

    Thread-Starter planwerkplus

    (@planwerkplus)

    Und ein letztes mal: nach dem Herstellen der Sicherungsdatei funktioniert es wieder!
    Ich weiß nicht, woran es jetzt lag, vielleicht war es ja doch nur ein falsch gesetztes Häkchen…
    Vielen Dank jedenfalls für die Hilfe und die Tipps zur Verbesserung der Website!

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)