Support » Plugins » Tablepress Änderungen nicht mehr speicherbar

  • Gelöst twototoulouse

    (@twototoulouse)


    Seit einiger Zeit kann ich erstellte Tabellen zwar öffnen und ändern, kann sie dann allerdings nicht mehr speichern. Kann mir da jemand helfen?

    Mit freundlichen Grüßen

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Hallo,
    aha, interessant. Besser wäre allerdings, wenn du dann noch schreibst, was dann genau passiert. So können wir dir wohl kaum helfen.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller twototoulouse

    (@twototoulouse)

    Hallo Hans-Gerd!
    Also, ich öffne eine erstellte Tabelle, ändere darin eine email-Adresse und drücke dann auf „Änderungen speichern“. Es passiert nichts.Auch wenn ich auf Vorschau gehe, ist die Änderung nicht zu sehen. Der Button „Änderungen speichern“ ändert kurz die Umrandung, aber es passiert absolut nichts.

    Mit freundlichen Grüßen
    Hans-Jörg

    Hallo,
    damit wissen wir leider nicht sehr viel mehr als vorher:

    • hast du die Tabelle mit dem Classic Editor oder dem Block Editor erstellt?
    • oder hast du die Tabelle über ein Plugin wie Table Press erstellt?
    • WordPress-Version?, etc.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Eine ungenaue Fehlerbeschreibung bedeutet für uns, dass wir unnötigerweise Zeit investieren müssen. Da wir eine Handvoll Freiwilliger sind, die in unserer Freizeit Probleme von WordPress-Anwendern versuchen zu lösen, erwarten wir, dass du auch Zeit investiert, um dein Problem umfassend zu beschreiben. Du solltest dabei auch bedenken, dass sich zwangsläufig die Zeit bis zur Lösung deines Problems verlängert, wenn du das nicht machst, weil wir in dem Fall häufiger nachfragen müssen. Das kann dann durchaus auch etwas dauern, weil wir den Support wie gesagt in unserer Freizeit leisten.
    Viele Grüße
    Hans-Gerd

    Der Überschrift nach nehme ich mal an, dass die Tabelle mit TablePress erstellt wurde. Ich vermute, dass ein JavaScript-Fehler dazu führt, dass die Eingabe keine Auswirkung hat. Ein Blick in die Konsole der Webentwickler-Tools des Browsers wäre vielleicht hilfreich.

    Unter Umständen spielen hier auch wieder veraltete JavaScript-Bibliotheken eine Rolle. Wenn du ein älteres Theme oder Plugin verwendest, kann das Ursache für die genannten Probleme sein. Bis der Theme-/Plugin-Entwickler ein Update liefert kannst du als Übergangslösung (!) das Plugin Enable jQuery Migrate Helper nutzen. (Unter Werkzeuge > jQuery Migrate musst du dann noch im Pulldown-Menü die jQuery-Version „Legacy“ auswählen.)

    Probier mal, ob damit die Probleme verschwinden.

    Ansonsten sind die Informationen (wie Hans-Gerd bereits völlig zu Recht hingewiesen hat) so dünn, dass wir den Thread auch gleich schließen könnten. Wir sind Anwender, keine Hellseher.

    Thread-Ersteller twototoulouse

    (@twototoulouse)

    Hallo!
    Die Tablle wurde mit Tablepress erstellt.
    Ich habe auch schon versucht über Werkzeuge, Websitezustand mir den Bericht anzuschauen, das funktioniert aber auch nicht. Bei Zustand steht: „Die Ergebnisse werden noch geladen“, passiert aber nichts, und bei „Bericht zum Websitezustand“ dreht sich bei „Verzeichnisse und Größen“ ewig ein Kreis und ich kann keinen einzigen Bericht öffnen. Es passiert einfach nichts. Ich nehme an, dass die ganze Webseite, also evt. nicht nur tablepress, wahrscheinlich irgendwo einen Fehler hat.Ich habe auch laufend eine Fehlermeldung, dass die website visual composer benötigt, dass ich den installieren und aktivieren soll. Der war aber von Anfang an drauf.Habe ihn trotzdem nochmal neu aktualisiert und installiert, aber es tut sich nichts. Die Mediathek kann ich auf dem Dashboard nicht mehr öffnen, was wohl mit dem visual composer zu tun hat.
    Das ist jetzt hier sehr umfangreich mit meiner website und ich denke, dass man das wohl hier im Forum auch nicht so einfach beantworten kann. Weiß auch nicht, ob das mit dem visual composer mit dem tablepress Problem zusammenhängt.
    Ist OK, wenn ihr sagt, das klappt so hier im Forum nicht.
    Ich versuche mal das mit dem Enable jQuery Migrate Helper . Melde mich dann nochmal.
    Vielen Dank
    Viele Grüße
    Hans-Jörg

    Thread-Ersteller twototoulouse

    (@twototoulouse)

    Habe gerade vor der Installation von EnablejQuery Migrate Helper folgende Meldung bekommen:
    jQuery Migrate Helper — Warnings encountered

    Diese Seite erzeugte folgende Warnungen:

    https://tsg-bsa.de/wp-content/plugins/kode_shortcode/tinymce/js/popup.js: jQuery.fn.live() is deprecated

    Bitte stelle sicher, dass du die aktuellen Versionen all deiner Plugins und deines Themes benutzt. Falls das der Fall ist, könntest du die Entwickler des in deinen Warnungen erwähnten Codes bitten, diesen zu aktualisieren.

    Damit kann ich jetzt irgendwie nichts anfangen. Mache erstmal nicht weiter
    Viele Grüße Hans-Jörg

    Thread-Ersteller twototoulouse

    (@twototoulouse)

    Hallo!
    Habe eben die Tablle bearbeitet und auch speichern können. Also trotz der Warnmeldung, funktioniert es wieder.
    Vielen Dank
    Muss ich jetz noch was wegen der Warnmeldung beachten?
    Viele Grüße
    Hans-Jörg

    Thread-Ersteller twototoulouse

    (@twototoulouse)

    Ich bin begeistert, die Mediathek im Dashboard ist auch wieder da.
    Könntet ihr mir vielleicht noch erklären, wir ich die ganzen Fehlermeldungen ( 19 Stück, alle gleich:“requires Visual Composer plugin to be installed and activated on your site.“) löschen kann? Die haben nämlich kein Kreuz zum löschen! Und soll ich auf WordPress 5,6 aktualisieren, behebt das evt, auch Probleme?
    Vielen Dank
    Viele Grüße
    Hans-Jörg

    Ich versuch’s nochmal ausführlicher zu erklären:

    Weil nicht jeder das Rad neu erfinden muss, enthält der WordPress-Core auch Code von anderen Entwicklern. Dieser Code kann dann auch für Funktionen in Themes und Plugins genutzt werden.
    Nun war aber eine JavaScript-Bibliothek enthalten, die von ihren Entwicklern nicht mehr weiter gepflegt wird. Deshalb haben sich die WordPress-Entwickler entschieden, die alte Version zu entfernen. Die Plugin- und Theme-Entwickler wurden darüber informiert, haben sich aber in vielen Fällen nicht weiter darum gekümmert. Ergebnis war, dass einige Websites nach dem WordPress-Update kaputt waren.

    Da sich die AnwenderInnen danach bei den WordPress-Core-Entwicklern beschwert haben (und nicht bei den Theme- und Plugin-Entwicklern, die die Änderung verpennt haben), wurde das Plugin Enable jQuery Migrate Helper als Übergangslösung bereitgestellt.

    Dadurch kann die JavaScript-Bibliothek wieder genutzt werden, aber das Problem, dass hier eine veraltete und nicht mehr gepflegte Bibliothek genutzt wird, besteht weiterhin. Deshalb bekommst du inzwischen von diesem Plugin einen Hinweis, dass deine Website veralteten Code verwendet:

    Bitte stelle sicher, dass du die aktuellen Versionen all deiner Plugins und deines Themes benutzt. Falls das der Fall ist, könntest du die Entwickler des in deinen Warnungen erwähnten Codes bitten, diesen zu aktualisieren.

    Es wird sogar angezeigt, wo das Problem liegt:

    https://tsg-bsa.de/wp-content/plugins/kode_shortcode/tinymce/js/popup.js: jQuery.fn.live() is deprecated

    Offensichtlich nutzt du also ein Plugin „Kode Shortcode“, dass in einer JavaScript-Datei popup.js die veraltete jQuery-Funktion jQuery.fn.live() nutzt.

    Du könntest jetzt, wie vorgeschlagen, den Entwickler deines Plugins freundlich bitten, das in Ordnung zu bringen. Oder du deaktivierst das Plugin. Oder du verwendest Enable jQuery Migrate Helper als Übergangslösung. Oder … ach, ich weiß auch nicht. Erstmal nicht weiterzumachen scheint ja auch eine Option zu sein?

    Thread-Ersteller twototoulouse

    (@twototoulouse)

    Hallo!
    Vielen Dank für Eure Mühe!
    @bego
    Habe das jetzt soweit in Ordnung, das entsprechende Plugin deaktiviert, Update auf wordpress 5.6, klappt jetzt auch mit Websitezustandsbericht. Alles gut, vielen Dank für Deine langen Ausführungen.
    Habe jetzt nur noch das Problem, die ganzen Meldungen zu löschen, die auf jeder Seite erscheinen. Hast Du evt, dafür noch ne Lösung?
    Mit freundlichen Grüßen
    Hans-Jörg

    Wenn Fehlermeldungen angezeigt werden, ist wahrscheinlich der Debug-Modus in der wp-config.php aktiviert. Öffne die Datei mal mit einem geeigneten Code-Editor (z.B. mit dem kostenlos für alle Betriebssysteme erhältlichen Programm VS Code) und such nach einer Zeile define( 'WP_DEBUG', true );. Den Eintrag änderst du auf false.

    Falls das nicht hilft, bräuchten wir eine URL zur Website, um uns das mal anzuschauen. Der Bericht (Werkzeuge > Website-Zustand > Bericht) wäre auch hilfreich.

    Thread-Ersteller twototoulouse

    (@twototoulouse)

    Hallo!
    Ich habe da jetzt noch ein Problem. Um zur wp-config.php zu kommen, muss ich mich wohl via ftp mit dem file-server verbinden.
    Unsere Webseite für unseren Sportverein wurde von jemandem eingerichtet, zu dem wir keinen Kontakt mehr haben. Leider habe ich jetzt wohl auch keine Zugansdaten, um an die wp-config.php zu kommen. Gibt’s da eine andere Möglichkeit, da was zu ändern?
    Mit freundlichen Grüßen
    Hans-Jörg

    Du kannst das Plugin File Manager installieren und schauen, ob du damit Zugriff auf die wp-config.php bekommst. Das Plugin bietet sogar einen eingebauten Code-Editor (per Rechtsklick auf die Datei öffnen). Du solltest dir allerdings darüber im Klaren sein, dass eine Fehleingabe in der wp-config.php die Website unzugänglich machen kann und dadurch auch den Zugriff über dieses Plugin versperrt. Ideal ist das alles nicht – eher ein letzter Strohhalm.

    Der bessere Weg wäre, dass du dir wieder Zugang per FTP verschaffst.

    Irgendjemand bezahlt die Rechnungen fürs Webhosting. Über die Rechnungen lässt sich herausfinden, wer der Webhoster ist. Über den Support des Webhosters lässt sich der Zugriff auf das Kundenmenü des Webhosters zurücksetzen bzw. ein neues Passwort vergeben. Mit Zugriff auf das Kundenmenü kann ein FTP-Zugang eingerichtet werden. Und mit dem kommst du an die wp-config.php.

    Alles mühsam, aber so ist das wenn man den Ersteller der Website verliert und niemand rechtzeitig Interesse hatte, Zugangsdaten zu notieren.

    Thread-Ersteller twototoulouse

    (@twototoulouse)

    OK, dann werde ich versuchen, die Zugangsdaten zu bekommen.
    Die Probleme, die ich hatte, sind ja jetzt behoben, dass mit den Fehlermeldungen ist ja nur noch ne kosmetische Sache.
    Vielen Dank nochmal für Deine Mühe und Ausdauer.
    Mit freundlichen Grüßen
    Hans-Jörg

    Jo. Und wer macht jetzt das Licht aus markiert den Thread jetzt als „gelöst“? 💡

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)