Support » Themes » Taxonomien einbinden

  • Hallo werte Community,

    ich setze irgendwie fest!

    Ich habe mir eine eigenes Template für diverse Einträge erstellt. diese Einträge haben dazu noch Taxonomien, welche ich gesondert als Auswahl anzeigen lassen möchte.

    Sobald nun die Taxonomie angezeigt werden soll, kommt nur die Standardanzeige von wordpress mit dem Kopf „Blog Archiv“. Ich habe aber für die insgesamt zwei Taxonomien jeweils eine eigene Datei erstellt. Nur wird diese für die Anzeige ignoriert. Warum ist das so?

    Die Dateien lauten

    taxonomy-namederersten.php
    taxonomy-namederzweiten.php

    in einem anderen Forum habe ich was über eine Zugriffsberechtigung gelesen. Wenn es darin liegen sollte, wo muss man das einstellen? Ich habe dieses Schema offline mittels Xampp laufen, nur online will es nicht funktionieren!

    Danke und Gruß

    @edit: Die Seite lautet: http://www.kabel-tvaue.de

    Derzeit bin ich am Einrichten. Was nichts funktioniert ist die Strassen Übersicht (Link im Menu). Unter diesem Link kommt eine Strassenüerbsicht. Auf eine Strasse klicken, gelangt man in die Single-Ansicht. Soweit sogut. Nun hat man zwei Taxonomien in der Ansicht. Einmal den Verein selbst (sind nur zwei)^^ und darunter die Buchstaben. Also entsprechende Kategorien. Also bspw. a und a-f Soll heissen, zweige alle anderen Strassen mit a an oder zeige alle Strasse von a bis f. Das funktioniert nur bedingt. Eben mit der wordpress eigenen Blog-Ansicht. ICh habe aber zwei Dateien extra dafür angelegt. Werden nun nicht verwendet!

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Hast du die Taxonomie vor dem Term vielleicht vergessen?
    https://developer.wordpress.org/themes/basics/template-hierarchy/#custom-taxonomies

    Gruß, Torsten

    Hallo Torsten,

    wie gesagt, offline auf meinem Rechner funktioniert es, nur online nicht. Alles was ich gemacht habe, alle Dateien des Themes-Ordners nach der Installation von WordPress einzuspielen.

    Die Daten der DB wurden neu erstellt. Sind ja nicht viele gewesen.^^

    GRuß Mike

    Ruf doch mal in der Online-Version Einstellungen > Permalinks auf.

    Hallo Bego,

    vielen Dank für den Hinweis. Leider brachte er auch keinen Erfolg. Ich hatte leider auch die Seite vorerst wieder offline genommen.

    Nun wäre sie nochmal online geschaltet. Vllt. kann ich auch die Standard-Datei für die Blog-Nachrichten ändern. Ist sicher nicht die eleganteste Lösung, aber weis derzeit keinen Rat. Offline auf dem Rechner funktioniert es. Sicher nur ein kleiner Fehler, aber wo. ;O)

    Gruß Mike

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Taxonomien einbinden“ ist für neue Antworten geschlossen.