Support » Themes » Textfarben lassen sich nicht ändern

  • Gelöst s2762047

    (@s2762047)


    Hallo zusammen, ich habe das Gutenix School Theme aktiviert. Nun ändern sich meine Textfarben aber scheinbar wahllos.
    Ich kann Button, Überschrift und Textfarbe zum einen über Customizer einstellen und auch für den jeweiligen Block beim erstellen der Seite. Während ich die Seite bearbeite sieht auch alles richtig aus. Sehe ich sie mir aber dann fertig an, ist mein Vorstellungstext auf der Startseite schwarz und nicht weiß, meine Beitragsüberschriften grell rot statt schwarz und die Button unten haben sogar verschiedene Farben, aber keine passt zu meinen Einstellungen im Customizer. Was mache ich falsch?

    
    ### wp-core ###
    
    version: 6.0
    site_language: de_DE
    user_language: de_DE
    timezone: +02:00
    permalink: /%year%/%monthnum%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/25/d912735748/htdocs/app912737984
    wordpress_size: 51,03 MB (53506055 bytes)
    uploads_path: /homepages/25/d912735748/htdocs/app912737984/wp-content/uploads
    uploads_size: 257,39 MB (269893274 bytes)
    themes_path: /homepages/25/d912735748/htdocs/app912737984/wp-content/themes
    themes_size: 13,74 MB (14403593 bytes)
    plugins_path: /homepages/25/d912735748/htdocs/app912737984/wp-content/plugins
    plugins_size: 50,32 MB (52767475 bytes)
    database_size: 8,69 MB (9109504 bytes)
    total_size: 381,16 MB (399679901 bytes)
    
    ### wp-active-theme ###
    
    name: Gutenix School (gutenix-school)
    version: 1.0.0
    author: Gutenix
    author_website: https://gutenix.com/
    parent_theme: Gutenix (gutenix)
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-background, customize-selective-refresh-widgets, custom-logo, custom-header, editor-styles, editor-style, editor-color-palette, widgets
    theme_path: /homepages/25/d912735748/htdocs/app912737984/wp-content/themes/gutenix-school
    auto_update: Aktiviert
    
    ### wp-parent-theme ###
    
    name: Gutenix (gutenix)
    version: 1.1.5
    author: Gutenix
    author_website: https://gutenix.com/
    theme_path: /homepages/25/d912735748/htdocs/app912737984/wp-content/themes/gutenix
    auto_update: Aktiviert
    
    ### wp-themes-inactive (1) ###
    
    Gutenix Child: version: 1.0, author: Gutenix, Automatische Aktualisierungen aktiviert
    
    ### wp-mu-plugins (3) ###
    
    1&1 Managed WordPress: version: 1.1.0, author: 1&1
    1&1 Product Subdomain: version: 1.1.0, author: 1&1
    IONOS Marketplace: version: 1.1.3, author: <AUTHOR>
    
    ### wp-plugins-active (20) ###
    
    Advanced Editor Tools (previously TinyMCE Advanced): version: 5.6.0, author: Automattic, Automatische Aktualisierungen aktiviert
    Antispam Bee: version: 2.11.0, author: pluginkollektiv, Automatische Aktualisierungen aktiviert
    Broken Link Checker: version: 1.11.16, author: WPMU DEV, Automatische Aktualisierungen aktiviert
    Delicious Recipes: version: 1.3.9, author: WP Delicious, Automatische Aktualisierungen aktiviert
    Getwid: version: 1.8.1, author: MotoPress, Automatische Aktualisierungen aktiviert
    GutenixPro: version: 1.0.4, author: Gutenix, Automatische Aktualisierungen aktiviert
    Gutenix Wizard: version: 1.0.4, author: Gutenix, Automatische Aktualisierungen aktiviert
    IONOS Assistant: version: 7.4.0, author: IONOS, Automatische Aktualisierungen aktiviert
    IONOS Help: version: 2.1.2, author: IONOS, Automatische Aktualisierungen aktiviert
    IONOS Journey: version: 1.0.2, author: IONOS, Automatische Aktualisierungen aktiviert
    IONOS Login: version: 2.1.1, author: IONOS, Automatische Aktualisierungen aktiviert
    IONOS Navigation: version: 1.0.4, author: IONOS, Automatische Aktualisierungen aktiviert
    IONOS Performance: version: 1.0.1, author: IONOS, Automatische Aktualisierungen aktiviert
    Kadence Blocks – Gutenberg Blocks for Page Builder Features: version: 2.4.9, author: Kadence WP, Automatische Aktualisierungen aktiviert
    Limit Login Attempts Reloaded: version: 2.25.3, author: Limit Login Attempts Reloaded, Automatische Aktualisierungen aktiviert
    Real Cookie Banner (Free): version: 3.0.0, author: devowl.io, Automatische Aktualisierungen aktiviert
    Regenerate Thumbnails Advanced: version: 2.4.0, author: ShortPixel, Automatische Aktualisierungen aktiviert
    Shariff Wrapper: version: 4.6.7, author: Jan-Peter Lambeck & 3UU, Automatische Aktualisierungen aktiviert
    Statify: version: 1.8.3, author: pluginkollektiv, Automatische Aktualisierungen aktiviert
    Timetable and Event Schedule: version: 2.4.6, author: MotoPress, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-083 x86_64
    httpd_software: Apache
    php_version: 7.4.29 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 1024M
    max_input_time: -1
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.5.15-MariaDB-1:10.5.15+maria~bullseye-log
    client_version: mysqlnd 7.4.29
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: https://sophiesrefugium.live-website.com/
    WP_SITEURL: https://sophiesrefugium.live-website.com/
    WP_CONTENT_DIR: /homepages/25/d912735748/htdocs/app912737984/wp-content
    WP_PLUGIN_DIR: /homepages/25/d912735748/htdocs/app912737984/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 30)
  • Thread-Ersteller s2762047

    (@s2762047)

    Ich danke dir sehr für deine Zeit, aber ich habe das Gefühl ich drehe mich im Kreis. Die Rezeptkarten sind nicht das Problem, da die Karten selbst weiß sind, muss der Text darauf schwarz bleiben. Für einen Dienstleister habe ich leider kein Budget und Ionos ist nur für technische Seitenfehler zuständig nach deren Aussage.

    Der Fehler den das health tool gefunden hat, war im Theme Gutenix. Aber worin er lag konnte ich nicht erkennen. Das gesamte Theme ließ sich einfach nicht mehr aktivieren. Dabei sagte er immer nur Fehler.

    Da mir das Twentytwenty Theme absolut nicht zusagt, habe ich nun das Ashe Theme aktiviert, in der Hoffnung, dass es mit einem WordPress Theme nicht ständig Probleme gibt die darauf hinauslaufen, dass ich das ganze Theme wechseln muss.

    Ich fange jetzt wieder von vorn an den Aufbau meiner Seite herzustellen und kann noch nicht sagen, ob ich nun hier mit den Farben umgehen kann.

    Ich danke dir trotzdem für deine Bemühungen.

    Thread-Ersteller s2762047

    (@s2762047)

    @pixolin
    Ich habe noch nie etwas an einem Theme oder PLugin geändert, da ich auch gar nicht wüsste wie. Ich habe kostenlose Themes aktibiert und lediglich über customizer und den Editor Dinge eingstellt und dass ich meine Überschrift nicht in dem plötzlich auftauchenden grellen rot möchte finde ich persönlich jetzt keinen Sonderwunsch, aber vielleicht habe ich da auch zu hohe Erwartungen.

    Ich habe keinerlei Problem damit Fragen zubeantworten oder ins Detail zu gehen. Allerdings habe ich das Gefühl, dass die Hilfestellung hier übers Ziel hinaus geschossen ist. Denn meine Seite hatte funktioniert, es ging mir nur um eine Farbe. Und nun ist das ganze Theme nicht mehr aktivierbar.
    Vielleicht sehe ich auch einen für euch offensichtlichen Zusammenhang nicht, fakt ist aber ich kann mein Theme jetzt nicht mehr verwenden und fange nun, wie nach meiner letzten Frage auch, schon wieder mit einem neuen Theme von vorn an.

    Ja mein Content ist noch vorhanden, aber verschoben und nicht lesbar mit neuen Farben und Bildern. Für mich persönlich bedeutet das von vorn anzufangen, da mein Content auf meiner alten Website, die ich versuche umzuziehen, die ganze Zeit enthalten ist. Ich wollte eigentlich nur den Anbieter wechseln und schaffe es aber seit drei Wochen nicht, mit WordPress meine Seite aufzustellen ehe ich meine Domain umziehe.

    Aber ja vermutlich sind meine Ansprüche wohl doch zu hoch und ich sollte einfach bei einem weißen Blatt mit schwarzen Beiträgen drauf bleiben, ohne icon oder Farbe.

    Hallo @s2762047,
    ich würde an deiner Stelle auch nicht ein Theme verwenden, das ganz offensichtlich relativ wenige Installationen aufweist.

    Wir verwenden bei unseren Projekten gerne das Theme GeneratePress. Auch das Theme Go ist eine gute Alternative.

    Neben der Anzahl der Installationen spielt auch die Bewertung und der Support für das Theme eine große Rolle.

    Denn meine Seite hatte funktioniert, es ging mir nur um eine Farbe. Und nun ist das ganze Theme nicht mehr aktivierbar.

    Deine Website hatte einen Fehler (siehe meine erste Antwort). Wenn das Theme auf deiner Website nicht sauber funktioniert, dann können wir daran nichts ändern. Ich habe mir sogar die Mühe gemacht und habe das Theme auf meiner Testumgebung neu eingerichtet und da funktioniert das Theme absolut fehlerfrei.

    Daher noch mal meine Vermutung: Wenn du alle Plugins deaktivierst und Plugin für Plugin aktivierst und jeweils danach schaust, ob das Problem wieder auftaucht, dann hast du den Übeltäter (Plugin).

    Warum du das aber nicht machst, ist mir schleierhaft. Das wäre ehrlich gesagt auch wirklich nicht so schwer.

    Moderator Bego Mario Garde

    (@pixolin)

    Ich habe keinerlei Problem damit Fragen zubeantworten oder ins Detail zu gehen.

    Dann tu das doch einfach mal. ¯\_(ツ)_/¯

    Allerdings habe ich das Gefühl, dass die Hilfestellung hier übers Ziel hinaus geschossen ist.

    Unsere kostenlose Hilfe ist ein Angebot. Du bist selber für deine Website verantwortlich und musst auch selber entscheiden, ob du diese Hilfe annimmst oder dir woanders Hilfe holst. Im Supportforum um Hilfe zu bitten, die Vorschläge halbherzig umzusetzen und sich dann zu beschweren, es wäre alles schlimmer geworden, ist nicht der richtige Weg.

    Ja mein Content ist noch vorhanden, aber verschoben und nicht lesbar mit neuen Farben und Bildern.

    Üblicherweise ist das eine Sache, die mit ein paar wenigen Einstellungen behoben werden kann. Oder du stellst ein Backup wieder her, dass du sicher zwischenzeitlich angelegt hast. Hast du nicht? Dann frag bei deinem Webhoster nach. Die haben meistens selber ein Backup und können das wiederherstellen.

    Aber ja vermutlich sind meine Ansprüche wohl doch zu hoch und ich sollte einfach bei einem weißen Blatt mit schwarzen Beiträgen drauf bleiben, ohne icon oder Farbe.

    Was uns allen hier am wenigsten weiterhilft, sind sarkastische Bemerkungen.

    Ich habe versucht zu erklären, wann und wieso wir mit CSS-Regeln aushelfen und dass das eigentlich gar nicht unser Wunsch ist, weil Themes grundsätzlich „out of the box“ funktionieren. Das hat mit „weißen Blatt mit schwarzen Beiträgen drauf“ nichts zu tun.

    Thread-Ersteller s2762047

    (@s2762047)

    Das war in keinerlei Weise sarkastisch gemeint, sondern mein voller Ernst. Alle Schwierigkeiten die ich persönlich bisher hatte, rührten daher, das ich keine weiße Homepage möchte.
    Ich HABE die Hilfe angenommen und kam nicht weiter. Vielleicht reden wir aneinander vorbei, aber es hat nicht funktioniert.

    @hage Ich kam ja leider nicht bis zu den PLugin.
    Also nochmal ganz deteiliert:

    Healthcheck gestartet –> Wiederherstellungsansicht –> Fehler: Gutenix Theme lässt sich nicht aktivieren –> Anderes Theme probiert –> Farbe ebenfalls rot –> Ich wollte wieder gutenix probieren und mich dann nach und nach an den Plugins versuchen, wie du beschrieben hast, aber das Theme lässt sich nicht aktivieren. Da steht nur failed.
    Ich weiß leider nicht wie ich screenshots am pc mache.

    Als Korrektur zu meinem vorherigen Beitrag:

    Du hattest Recht, die Seite ist nun wieder wie vorher, ich hatte lediglich den Wiederherstellungsmodus beendet, der Problembehandlungsmodus war aber noch an. Nach Beendigung dieses, war alles wie vorher.
    Hierzu also Entschuldigung, mein Fehler.
    Ich kann nun gern nochmal die Problembehandlung starten, weiß aber leider nicht wie ich dann weiter kommen soll. Er sagt beim aktivieren des Gutenix Theme ist ein Fehler aufgetreten und sagt mir leider nicht wie ich diesen ändern kann.

    Ich kann nun gern nochmal die Problembehandlung starten, weiß aber leider nicht wie ich dann weiter kommen soll. Er sagt beim aktivieren des Gutenix Theme ist ein Fehler aufgetreten und sagt mir leider nicht wie ich diesen ändern kann.

    Mach das doch mal bitte ohne das Plugin Health Check & Troubleshooting –
    Dann könntest du doch mal das testen, was ich oben bereits geschrieben habe:

    • zunächst erstellst du eine Sicherung. Bis jetzt hast du offensichtlich kein Plugin dafür installiert. Als Plugin könntest du z. B. UpdraftPlus verwenden und erst mal eine Sicherung erstellen.
    • Dann deaktivierst du im Dashboard > Plugins alle Plugins.
    • Danach aktivierst du Plugin für Plugin und schaust jeweils nach, ob das Problem noch existiert.

    Ich weiß leider nicht wie ich screenshots am pc mache.

    Einfach auf die Druck-Taste klicken – siehe auch hier
    Wie kann man hier Bilder in einen Forenbeitrag einfügen?

    • Diese Antwort wurde geändert vor 1 Woche, 5 Tage von Hans-Gerd Gerhards. Grund: Ergänzung
    Thread-Ersteller s2762047

    (@s2762047)

    ok, ich hatte das im Zusammenhang verstanden. Ich werde das versuchen und mich melden

    Thread-Ersteller s2762047

    (@s2762047)

    Nur nochmal für mein Verständnis, woran hast du gesehen, bzw. woran sehe ich denn, dass überhaupt ein Problem besteht? Denn bis auf die Farbe hatte mich ja ursprünglich nichts gestört und jetzt hat der Healthcheck ja aber ein gravierenden Problem gefunden, weswegen das Theme nicht aktivierbar ist. Hätte mir das auch ohne Healthcheck irgendwo auffallen müssen?

    Also: Wenn du die Farben über den Customizer nicht ändern konntest, dann hast du doch mit der Website ein dickes Problem. 🤔
    Mich würde das jedenfalls massiv stören und ich würde wie hier beschrieben versuchen, das Problem zu lösen.

    Vorher würde ich das Plugin Health Check & Troubleshooting erst mal deaktivieren.

    Aber ehrlich gesagt: Ich kann dir wohl kaum noch weiterhelfen, weil du – wie @pixolin schon geschrieben hat – unsere Vorschläge nicht oder nur halbherzig umsetzt. So kommen wir nicht weiter.

    Noch mal: Auf meiner Testinstanz funktioniert das Theme absolut korrekt. Die Plugins hast du allerdings immer noch allesamt offensichtlich aktiviert, wie ich gerade festgestellt habe.

    Erst wenn die Struktur feststeht und das Design wunschgemäß funktioniert, ist es sinnvoll, weitere Funktionalitäten mittels Plugins dazuzuschalten. Vorher würde ich das nicht machen (Stichwort Plugin Delicious Recipes, bei dem die Farbgebung schwarze Schrift auf dunkelbraunem Hintergrund nicht wirklich gut lesbar ist).

    Thread-Ersteller s2762047

    (@s2762047)

    Ich habe drei Kinder zuhause und gerade nicht am PC gesessen. Ja bis eben waren noch alle aktiviert. Ich habe nun das Delicious Recipe Plugin deaktiviert. Nun ist die Farbe wie im Customizer eingestellt, allerdings ist mein Beitragsauszug nun nicht mehr zu sehen. Kann das auch an dem Plugin liegen? Ich dachte eigentlich, dass die Rezeptkarten nichts mit den Blogposts zu tun haben.

    Ich möchte ihre Hinweise sehr gern umsetzen, mache das ganze aber nebenbei wenn ich mal ein paar Minuten an den PC komme und versuche halt auch zu verstehen, was ich hier mache XD

    Thread-Ersteller s2762047

    (@s2762047)

    Ah sie sind weiß und nicht weg, ok das liegt dann an meinen Customizer einstellungen.

    Was kann ich denn machen, damit das Rezept Plugin nicht auf meine Postbeiträge wirkt?

    aha, damit haben wir doch – wenn ich dich richtig verstehe – den Übeltäter, sprich das Plugin.

    Im WordPress Repository findest du weitere Plugins zu dem Stichwort „Rezepte“ (recipes) . Ich würde erst mal ein anderes Plugin testen.

    Vorher bitte sichern.

    Thread-Ersteller s2762047

    (@s2762047)

    Alles klar, vielen Dank und tut mir Leid, dass ich so umständlich war.
    Da wäre ich im Leben nicht drauf gekommen, das die Rezeptkarten auf einer anderen Seite die Schrift auf der Startseite beeinflusst.
    Muss ich mir wegen dem vom Healthcheck gefundenen Problem im Theme sorgen machen?
    Ohne den Healthcheck ist mir kein Problem aufgefallen

    Alles klar, vielen Dank und tut mir Leid, dass ich so umständlich war.

    alles ok 😊

    Da wäre ich im Leben nicht drauf gekommen, das die Rezeptkarten auf einer anderen Seite die Schrift auf der Startseite beeinflusst.

    das sollte so auch nicht sein. Leider kann ich das nicht reproduzieren, weil das doch mit relativ viel Aufwand verbunden wäre, wenn ich das auf meiner Testinstanz einrichten würde.

    Muss ich mir wegen dem vom Healthcheck gefundenen Problem im Theme sorgen machen?

    Wie gesagt: Bei mir habe ich kein Problem mit diesem Theme. Daher ja auch mein Vorschlag, die Plugins zu deaktivieren, um dann mal zu schauen, ob das Problem dann noch auftaucht.
    Viel mehr können wir hier auch vermutlich nicht für dich tun.

    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    @s2762047
    schade, wir hätten uns gefreut, wenn du das Thema als gelöst markierst. Ok, dann mache ich es halt 🤨

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 30)