Support » Installation » the plugin api

  • Liebe WP-Community,

    mir passiert dieser Fehler immer wieder beim Provider Easyserver, bei verschiedenen Domains. Mein Standort und meine Leitung sind egal (Magenta, A1, verschiedene Orte, …), das Plugin ist egal.

    Bei der Installation von Plugins (Themes) kommt folgende Fehlermeldung:

    Warning:
    Ein unerwarteter Fehler ist aufgetreten. Es scheint etwas bei WordPress.org oder mit dieser Serverkonfiguration nicht zu stimmen. Sollte das Problem weiter bestehen, nutze bitte die Support-Foren. (WordPress konnte keine sichere Verbindung zu WordPress.org herstellen. Bitte kontaktiere deinen Server-Administrator.) in /srv/www/3/9/7/3977/www/www.kurs.wien/htdocs/wp-admin/includes/plugin-install.php on line 183
    Something went wrong with the plugin API.

    Wenn ich auf Plugins/installieren klicke, kommt folgende Fehlermeldung:

    Ein unerwarteter Fehler ist aufgetreten. Es scheint etwas bei WordPress.org oder mit dieser Serverkonfiguration nicht zu stimmen. Sollte das Problem weiter bestehen, nutze bitte die Support-Foren.

    Darum bitte liebe Forums-LeserInnen, habt ihr eine Idee, woher der Fehler kommt und wie er zu beheben ist?

    DANKE! Liebe Grüße, Brisch

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Moderator Bego Mario Garde

    (@pixolin)

    Üblicherweise kommt diese Fehlermeldung, wenn die WordPress-Installation keine Verbindung zum Server von WordPress.org aufnehmen kann, weil z.B. Schnittstellen gesperrt sind oder die Serverkonfiguration die Nutzung bestimmter Erweiterungen ausschließt. Sprich doch bitte mal mit dem Support des Webhosters.

    Thread-Ersteller Brisch

    (@brisch)

    Danke, das tue ich seit mindestens einem Jahr. Die Admins dort erklären mir, sie finden nichts, wenn sie es probieren klappt alles.

    Hast Du einen Hinweis, was ich den Admins weiter geben kann?

    Danke!

    Danke, das tue ich seit mindestens einem Jahr.

    Ähm, das hilft dir jetzt hier nicht weiter, aber bei so einem Support solltest du über einen Hoster-Wechsel nachdenken.

    Moderator Bego Mario Garde

    (@pixolin)

    Hast du denn mal geschaut, ob unter Werkzeuge > Website-Zustand Fehlermeldungen ausgegeben werden?

    Die letzte Frage zu diesem Problem kam von einem Benutzer mit einer Website beim Anbieter für kostenloses (werbefinanziertes) Webhosting bplaced. Dieser Anbieter hat einfach die Schnittstellen nach Außen gekappt, weil das den Server zu sehr belasten würde. Einen entsprechenden Hinweis gibt es dort auf der Website unter „mögliche WordPress-Fehlermeldungen„.

    Eine andere Ursache könnte sein, dass du mit einem Sicherheits-Plugin die Installation von Themes und Plugins untersagt hast.

    Vielleicht können wir mehr dazu sagen, wenn du einen Bericht zu deiner Website postest: Geh bitte auf Werkzeuge > Website-Zustand > Bericht, warte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist. Klick auf den Button „Bericht in die Zwischenablage kopieren“. Den Bericht kannst du dann hier in einer neuen Antwort mit Strg-V (Mac: Cmd-V) unverändert einfügen.

    Thread-Ersteller Brisch

    (@brisch)

    Danke für Deine Hilfe und den Hinweis, dort steht Folgendes:

    WordPress.org konnte nicht erreicht werden

    Die Verbindung mit den WordPress-Servern wird verwendet, um nach neuen Versionen zu suchen und sowohl WordPress-Core, Themes oder Plugins zu installieren und zu aktualisieren.

    Fehler Deine Website kann WordPress.org nicht unter 198.143.164.251 erreichen und gab den Fehler zurück: cURL error 28: Connection timed out after 10001 milliseconds

    Sicherheitsplugin habe ich keines, das steht bei Bericht als erstes:
    Warning: Ein unerwarteter Fehler ist aufgetreten. Es scheint etwas bei WordPress.org oder mit dieser Serverkonfiguration nicht zu stimmen. Sollte das Problem weiter bestehen, nutze bitte die Support-Foren. (WordPress konnte keine sichere Verbindung zu WordPress.org herstellen. Bitte kontaktiere deinen Server-Administrator.) in /srv/www/3/9/7/3977/www/www.kurs.wien/htdocs/wp-includes/update.php on line 175

    Hier der Bericht:

    
    ### wp-core ###
    
    version: 5.7
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 15
    dotorg_communication: cURL error 28: Connection timed out after 10001 milliseconds
    
    ### wp-paths-sizes ###
    
    wordpress_path: /srv/www/3/9/7/3977/www/www.kurs.wien/htdocs
    wordpress_size: loading...
    uploads_path: /srv/www/3/9/7/3977/www/www.kurs.wien/htdocs/wp-content/uploads
    uploads_size: loading...
    themes_path: /srv/www/3/9/7/3977/www/www.kurs.wien/htdocs/wp-content/themes
    themes_size: loading...
    plugins_path: /srv/www/3/9/7/3977/www/www.kurs.wien/htdocs/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: Esotera Plus Child (esotera-plus-child)
    version: 0.5
    author: Cryout Creations
    author_website: http://www.cryoutcreations.eu
    parent_theme: Esotera Plus (esotera-plus)
    theme_features: core-block-patterns, editor-style, title-tag, automatic-feed-links, html5, post-formats, custom-background, custom-logo, menus, post-thumbnails, custom-header, responsive-embeds, align-wide, editor-color-palette, editor-font-sizes, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets
    theme_path: /srv/www/3/9/7/3977/www/www.kurs.wien/htdocs/wp-content/themes/esotera-plus-child
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: Esotera Plus (esotera-plus)
    version: 1.2.4
    author: Cryout Creations
    author_website: http://www.cryoutcreations.eu
    theme_path: /srv/www/3/9/7/3977/www/www.kurs.wien/htdocs/wp-content/themes/esotera-plus
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (2) ###
    
    Twenty Nineteen: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (9) ###
    
    Content Control: version: 1.1.6, author: Code Atlantic, Automatische Aktualisierungen deaktiviert
    Cryout Featured Content: version: 1.2, author: Cryout Creations, Automatische Aktualisierungen deaktiviert
    Disable Gutenberg: version: 2.4, author: Jeff Starr, Automatische Aktualisierungen deaktiviert
    Enlighter - Customizable Syntax Highlighter: version: 4.4.2, author: Andi Dittrich, Automatische Aktualisierungen deaktiviert
    Loco Translate: version: 2.5.2, author: Tim Whitlock, Automatische Aktualisierungen deaktiviert
    Progress Bar WP: version: 1.3.5, author: wpshopmart, Automatische Aktualisierungen deaktiviert
    Simple Lightbox: version: 2.8.1, author: Archetyped, Automatische Aktualisierungen deaktiviert
    WP Dashboard Notes: version: 1.0.10, author: Jeroen Sormani, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 16.1.1, author: Team Yoast, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-inactive (2) ###
    
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    Modula: version: 2.5.1, author: WPChill, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-86 Q16 x86_64 2020-01-13 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 1500M
    upload_max_filesize: 1000M
    max_effective_size: 1.000 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 16 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 16 GB
    	imagick::RESOURCETYPE_MEMORY: 8 GB
    	imagick::RESOURCETYPE_THREAD: 6
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: Linux 4.18.0-240.15.1.el8_3.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.3.22 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 10000
    time_limit: 300
    memory_limit: 512M
    max_input_time: 300
    upload_max_filesize: 1000M
    php_post_max_size: 1500M
    curl_version: 7.61.1 OpenSSL/1.1.1g
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 8.0.17
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /srv/www/3/9/7/3977/www/www.kurs.wien/htdocs/wp-content
    WP_PLUGIN_DIR: /srv/www/3/9/7/3977/www/www.kurs.wien/htdocs/wp-content/plugins
    WP_MEMORY_LIMIT: 512M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Moderator Bego Mario Garde

    (@pixolin)

    Die cURL-Version, die dein Webhoster da verwendet, ist etwas angestaubt. Frau mal wieso das so ist. Aktuell gibt es eine Version 7.76.0 vom 31. März, die Version die dein Webhoster verwendet ist vom September 2018 (vgl. https://curl.se/changes.html).

    Ansonsten scheint, soweit ich den unvollständigen Bericht einsehen kann (demnächst einfach ein bisschen abwarten 😉 ), alles OK zu sein.

    Oft hast du im Kundenmenü des Webhosters die Möglichkeit, „Experten-Einstellungen“ zu PHP vorzunehmen. Schau mal, ob sich da noch etwas verstellen lässt – danach bitte immer mindestens zehn Minuten abwarten, dann erneut die Plugin-Installation testen. Ich tippe aber eher auf eine fehlerhafte Serverkonfiguration, z.B. dass der DNS-Server die Adressen nicht schnell genug auflösen kann.

    Mit dem Plugin Query Monitor soll sich der Fehler auch weiter debuggen lassen, aber ich kann da nicht viel zu sagen. Ausprobieren …

    • Diese Antwort wurde geändert vor 1 Woche, 5 Tage von Bego Mario Garde. Grund: Nachtrag
    Thread-Ersteller Brisch

    (@brisch)

    Danke, werde ich meinem Provider weiter geben.

    Thread-Ersteller Brisch

    (@brisch)

    Kann ich selbst über FTP die Zeiten in der .php.ini ändern?

    max_input_time: 300
    upload_max_filesize: 1000M

    Sollten 3000 sein oder?

    Danke!

    Moderator Bego Mario Garde

    (@pixolin)

    Die Werte sind eigentlich schon überdimensioniert. (Mediendateien mit einer Größe von fast einen Gigabyte hochzuladen erscheint auch nicht sinnvoll.)

    Thread-Ersteller Brisch

    (@brisch)

    Die Werte habe ich aus einem Blog-Beitrag. Mir sind die Werte egal, ich kenne mich da nicht aus. Nur mein Provider tut nichts, ich muss anscheinend selbst etwas tun.

    Hast Du darauf eine Antwort?

    Kann ich selbst über FTP die Zeiten in der .php.ini ändern?

    Moderator Bego Mario Garde

    (@pixolin)

    Kommt darauf an. Manche Webhoster erlauben das, andere bieten im Kundemenü eine Einstellungsmöglichkeit, wieder andere erlauben gar keinen Eingriff.

    Du kannst per FTP im WordPress-Verzeichnis eine php.ini anlegen und dann schauen, ob die Werte in Werkzeuge > Website-Zustand so übernommen werden. Meistens handhaben die Webhoster das aber restriktiv, damit sie möglichst viele Kunden auf ihrem Webserver unterbringen können. Wenn da jeder Benutzer beliebige Werte setzen könnte, geht die Rechnung des Webhosters nicht auf.

    Thread-Ersteller Brisch

    (@brisch)

    Habe ich probiert, hat nichts gebracht. Zumindest nicht im Hauptverzeichnis. Der Zusatz zur .htaccess hat die Website lahmgelegt (Error 500):

    php_value upload_max_filesize 200M
    php_value post_max_size 200M

    @brisch ich habe das gleiche Problem. Konntest du die Lösung finden? Falls nicht hat es überhaupt dann noch Sinn mit WordPress weiter zu machen? Ich stehe ganz am Anfang und möchte nicht unnötig Zeit verplämpern.

    Danke im Voraus

    Falls nicht hat es überhaupt dann noch Sinn mit WordPress weiter zu machen?

    Ernsthaft?

    Thread-Ersteller Brisch

    (@brisch)

    Hallo an alle,
    Updates funktionieren jetzt wieder, ich habe vor 2 Tagen endlich eine Antwort von meinem Internet Serviceprovider bekommen (easyserver). Hier ein Auszug:

    In Absprache mit meinen Kollegen haben wir die loadbalancing Funktion für unsere
    Webserver angepasst. Diese läuft vorerst nach einem anderen Schema und
    wir beobachten das Problem weiter.
    
    Zusammenfassend:
    Der Vorteil bei der aktuellen Konfiguration bedeutet eine längere
    Zeitspanne vor Timeouts und eine "stabilere" Verbindung bei Downloads
    auf den Webspaces.
    Der Nachteil jedoch ist eine ungleiche Lastenverteilung zwischen den
    Webservern, welche vielleicht zu einem Problem werden kann.
    
    Ob dies nun eine endgültige Lösung darstellt, wird sich in den nächsten
    Wochen zeigen.

    Hoffe sie lassen die Einstellungen so, dann passt es.
    LG Brisch

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)