Support » Themes » Theme erkennt Einstellung nicht

  • Gelöst thummel

    (@thummel)


    Hi, ich hoffe jemand kann mir helfen.
    Ich nutze das Theme Nirvana. Hat auch bisher alles gut geklappt. Seit gestern oder vorgestern kann ich jedoch die im Theme angegebene Präsentationsseite nicht mehr aktivierten. Ich sehe die Meldung:

    Die OptionFrontpage-Anzeige von WordPress ist auf eine statische Seite eingestellt. Die WordPress-Richtlinien verlangen, dass die Option der statischen Seite den Vorzug vor den Theme-Optionen hat.
    Gehe zu Einstellungen » Lesen und stelle die Option Frontpage-Anzeige auf Deine letzten Beiträge, um die Präsentationsseite zu aktivieren.

    Aber in den Einstellungen ist „letzte Beiträge“ aktiviert. Das macht mich jetzt doch ziemlich ratlos. Habe jetzt schon öfter die entsprechenden Optionen aus- und eingeschaltet, jedoch ohne Erfolg. Bakup (wie sollt’s auch anders sein) habe ich keins.
    Jemand eine Idee?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Bei Fragen zu gekauften Themes (hier: Nirvana) können wir dir nicht weiterhelfen, weil sie uns für einen kostenlosen Support nicht kostenlos zur Verfügung stehen.

    Bitte wende dich bei Fragen zu diesem Theme an die Entwickler.

    Thread-Starter thummel

    (@thummel)

    Ich bezweifle zwar mal, dass es am Theme liegt, da ich da seit einem Jahr nix mehr dran gemacht habe, aber nun gut.

    Du bekommst den Hinweis

    Die WordPress-Richtlinien verlangen, dass die Option der statischen Seite den Vorzug vor den Theme-Optionen hat.

    … und meinst, das hätte nichts mit deinem Theme zu tun? Von welchen Theme-Optionen sollte dann die Rede sein?

    Aber in den Einstellungen ist „letzte Beiträge“ aktiviert.

    Was meinst du mit „den Einstellungen“? Vom Theme? Unter Einstellungen > Lesen?

    Da wir für kostenlosen Support das Theme nicht zur Verfügung gestellt bekommen, können wir die Meldung die du erhältst auch nicht reproduzieren. Du kannst aber zu einem Standard-Theme („Twenty …“) wechseln und prüfen, ob die Fehlermeldung dann auch noch erscheint. In dem Fall wäre es hilfreich, wenn du uns mit Informationen versorgst, wie im angehefteten Beitrag Bevor du ein neues Thema (Thread) erstellst beschrieben.

    Thread-Starter thummel

    (@thummel)

    OK, sorry. Erstmal danke für den Hinweis mit den neuen Threads. Die Infos hänge ich dann noch dran.
    Mit Einstellungen meine ich die WP Einstellungen unter „Einstellungen / lesen“. Dort gibt es die Einstellmöglichkeiten „Deine letzten Beiträge“ und „Eine statische Seite“. Ausgewählt ist (und war immer) „Deine letzten Beiträge“.
    Im Nirvana Theme sehe ich die o.g. Meldung „Die OptionFrontpage-Anzeige von WordPress ist auf eine statische Seite eingestellt. …“ und bei der Anzeige wird der WP Standard angezeigt. Hier besteht also eine Verbindung zwischen WP Settings und den Nirvana Settings und da ich an den Nirvana Settings nichts aktualisiert habe vermute ich, dass sich ggf. was bei der Benamung der WP Lesesettings geändert hat, so dass hier keine korrekte Zuordnung mehr möglich ist.
    Ich habe auch im Nirvana Support Forum geschrieben, aber das scheint so ziemlich tot zu sein, so dass meine Hoffnungen jetzt hier liegen.
    Wenn dieser Thread nicht gewünscht ist, dann bitte gerne löschen bzw. mir Bescheid sagen, damit ich das als gelöst markiere.

    Thread-Starter thummel

    (@thummel)

    
    ### wp-core ###
    
    version: 6.0.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 7
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/11/d28762413/htdocs/eckenheim
    wordpress_size: 315,05 MB (330352261 bytes)
    uploads_path: /homepages/11/d28762413/htdocs/eckenheim/wp-content/uploads
    uploads_size: 201,97 MB (211781156 bytes)
    themes_path: /homepages/11/d28762413/htdocs/eckenheim/wp-content/themes
    themes_size: 15,13 MB (15861906 bytes)
    plugins_path: /homepages/11/d28762413/htdocs/eckenheim/wp-content/plugins
    plugins_size: 119,27 MB (125065975 bytes)
    database_size: 67,14 MB (70402048 bytes)
    total_size: 718,56 MB (753463346 bytes)
    
    ### wp-active-theme ###
    
    name: Nirvana (nirvana)
    version: 1.6.2
    author: Cryout Creations
    author_website: https://www.cryoutcreations.eu
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, editor-style, widgets-block-editor, title-tag, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, automatic-feed-links, post-formats, menus, custom-background, custom-header, widgets
    theme_path: /homepages/11/d28762413/htdocs/eckenheim/wp-content/themes/nirvana
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (13) ###
    
    Advanced Custom Fields: Font Awesome: version: 4.0.3, author: Matt Keys, Automatische Aktualisierungen deaktiviert
    Better Font Awesome: version: 2.0.3, author: Mickey Kay, Automatische Aktualisierungen deaktiviert
    Classic Editor: version: 1.6.2, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    Content Views: version: 2.4.0.7, author: Content Views, Automatische Aktualisierungen deaktiviert
    Cryout Serious Theme Settings: version: 0.5.14, author: Cryout Creations, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.7.8, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Essential Addons for Elementor: version: 5.3.2, author: WPDeveloper, Automatische Aktualisierungen deaktiviert
    Events Manager: version: 6.1.2.1, author: Marcus Sykes, Automatische Aktualisierungen deaktiviert
    reSmush.it Image Optimizer: version: 0.4.6, author: reSmush.it, Automatische Aktualisierungen deaktiviert
    Unlimited Elements for Elementor: version: 1.5.32, author: Unlimited Elements, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.23, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WP Maintenance Mode & Coming Soon: version: 2.5.4, author: Themeisle, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 19.8, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (3) ###
    
    Insert PHP Code Snippet: version: 1.3.3, author: xyzscripts.com, Automatische Aktualisierungen deaktiviert
    Menu Icons: version: 0.13.0, author: ThemeIsle, Automatische Aktualisierungen deaktiviert
    Page Builder by SiteOrigin: version: 2.17.0, author: SiteOrigin, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-088 x86_64
    httpd_software: Apache
    php_version: 7.4.32 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 7.4.32
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/11/d28762413/htdocs/eckenheim/wp-content
    WP_PLUGIN_DIR: /homepages/11/d28762413/htdocs/eckenheim/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Hallo,
    ich habe jetzt mal testweise auf einer WordPress-Instanz das kostenfreie Theme Nirvana und das empfohlene Plugin Cryout Serious Theme Settings installiert.

    Die Meldung „Die OptionFrontpage-Anzeige von WordPress ist auf eine statische Seite eingestellt. …“ kam bei mir nicht. Die Website wurde mit den von dir genannten Einstellungen > Lesen korrekt dargestellt. Das muss daher andere Gründe haben.

    Bego hatte dich ja bereits gebeten, testweise ein anderes (Standard)-Theme zu installieren. Hast du das bereits gemacht? – und was hat sich dabei ergeben?

    Du kannst ja mal nach einer Sicherung das Plugin Health Check & Troubleshooting installieren. Anschließend kannst du unter Werkzeuge > Website Zustand unter Problembehandlung auf den Button „Problembehandlungsmodus aktivieren“ klicken. Dann werden alle Plugins deaktiviert und als Standardtheme z. B. Twenty Twenty-Two aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme von dir und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass Besucher deine Website weiter mit allen Infos und Plugins sehen, während nur für dich alle Plugins deaktiviert sind.

    Außerdem stellt sich die Frage, ob das Theme noch weiter gepflegt wird: Die letzte Aktualisierung ist jetzt fast ein Jahr alt.

    Viele Grüße
    Hans-Gerd

    Thread-Starter thummel

    (@thummel)

    Hallo Hans-Gerd (und alle anderen Beteiligten),
    es wird wohl ein ungelöstes Rätsel bleiben. Ich habe mit dem Plugin Updraft eine komplette Sicherung der defekten Installation durchgeführt, dann eine neue „nackte“ WordPress Installation aufgesetzt und die Sicherung dort eingespielt.. und siehe da es funktioniert wieder.
    Wenn ich nochmal Zeit habe mache ich einen diff und schau mal ob ich da was auffälliges finde.
    Vielen Dank aber für Deine Bemühungen. Finde ich echt toll.
    Liebe Grüße
    Thomas

    Thread-Starter thummel

    (@thummel)

    Ich schließe das Thema. Vielen Dank

    super – freut uns. Danke für die Rückmeldung und “Gelöst”-Markieren. 👍

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Das Thema „Theme erkennt Einstellung nicht“ ist für neue Antworten geschlossen.