Support » Themes » Theme Installation fehlgeschlagen

  • Liebes Forum,

    ich möchte meine muse Webseite auf WordPress umstellen. Vor ein paar Tagen habe ich WordPress lokal installiert und will jetzt den html code meiner alten Mus Webseite gerne in WordPress hochladen, um nicht noch einmal alles neu gestalten zu müssen. Gerne würde ich dies erst „lokal“ ausprobieren, bevor ich alles online stelle.
    Nach zahlreicher google Recherche versuche ich ein neues Theme hochzuladen, eine .zip Datei mit den html codes. Sobald ich installieren drücke, erhalte ich folgende Fehlermeldung:

    The target folder already exists. /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/themes/mytheme/
    
    Theme Installation failed.
    
    Warning: copy(/Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/languages/plugins/hello-dolly-de_DE.mo): failed to open stream: Permission denied in /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 281
    
    Warning: chmod(): No such file or directory in /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 168
    
    Warning: chmod(): No such file or directory in /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 168
    
    Warning: copy(/Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/languages/plugins/hello-dolly-de_DE.mo): failed to open stream: Permission denied in /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 281
    
    Warning: chmod(): No such file or directory in /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-admin/includes/class-wp-filesystem-direct.php on line 168
    
    The file couldn’t be copied.
    /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/languages/plugins/hello-dolly-de_DE.mo

    Weiß jemand was hier schief läuft? Ein style.css sheet habe ich bereits angelegt, dennoch dasselbe Problem.

    Ich bin über jeden Tipp dankbar.
    Liebe Grüße

    • Dieses Thema wurde geändert vor 1 Monat, 2 Wochen von Bego Mario Garde. Grund: Fehlermeldung als Code formatiert
Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Da scheint es Probleme mit den Dateien zu geben. Schau mal nach, ob im Verzeichnis XAMPP/xamppfiles/htdocs/wordpress/wp-content/themes/ bereits ein Unterverzeichnis mytheme vorhanden ist und lösche es gegebenenfalls.

    Falls das Verzeichnis nicht existiert, scheinen die Dateirechte nicht zu stimmen.

    Vielen Dank für die schnelle Antwort. Es gab tatsächlich bereits den besagten Ordner, die Dateirechte/Zugriffsrechte habe ich für das Verzeichnis jetzt auch geändert und siehe da, die Meldung „Installation erfolgreich“ erscheint. Allerdings leider nicht wirklich erfolgreich, denn jetzt habe ich eine leere weiße Seite in WordPress…

    Hilfreich wäre ein Error-Log, den du durch einen Eintrag in der wp-config.php erhältst:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );

    (Quelle: Debugging in WordPress)

    Bitte nutze dazu einen geeigneten Programmiereditor (z.B. Atom Editor, Visual Studio Code oder Notepad++, alle kostenlos erhältlich).

    Welche PHP-Version nutzt du?

    Ich benutze PHP-Version: 7.4.1

    Ich habe den Error-Log jetzt eingefügt, habe ich das richtig verstanden, dass ich dann eine Datei debug.log Datei nach erneutem Installationsversuch finden sollte? Diese konnte ich bisher leider nicht finden..

    Stell das mal auf PHP 7.3 um. Klappt es dann?

    Den Code hast du oberhalb von oberhalb von /* That's all, stop editing! Happy blogging. */ eingefügt?

    Ja, den Code habe ich direkt davor eingefügt.

    Um auf PHP 7.3 umzustellen, muss ich PHP erneut herunterladen oder?

    Scheint so.

    Hier ist eine hübsche Anleitung: https://webhostingmedia.net/update-xampp-php-version-windows/

    Wobei ich eigentlich die Bitnami-Pakete besser finde:
    https://bitnami.com/stack/wordpress/installer

    @pixolin hat jetzt doch etwas länger gedauert, ich habe PHP 7.3 heruntergeladen, die Datei entpackt und im xampp/xamppfiles gespeichert. Sobald ich das XAMPP Control Panel öffne, heißt dieser mich jedoch weiterhin zu XAMPP 7.4.1. willkommen.. gibt es noch etwas anderes, das ich ändern muss?

    Von XAMPP habe ich mich schon lange verabschiedet, aber ich vermute mal, dass du die httpd-xampp.conf nicht angepasst hast.

    Moderator Bego Mario Garde

    (@pixolin)

    Steht übrigens auch in der verlinkten Anleitung. 🙂

    Ich habe mich auch vor einigen Monaten von XAMPP verabschiedet.
    Für mich nach wie vor eine Superalternative ist Laragon.
    Übrigens eine wunderbare lokale Umgebung, um mal intensiver WP CLI zu testen, siehe auch diesen thread

    @pixolin
    Ich habe schon mal überlegt, mein Paket mit Apache 2.4.41, MariaDB 10.4.10, PHP 5.6.40, PHP 7.3.1,PHP 7.4.2 und einem FTP-Server so zum Download anzubieten, dass man mit einem Entpacken und Starten von einem Batch-File die Komponenten als Dienst einrichten kann. PHP-Versionen kann man auch mit einer Batch-Datei wechseln. Auch weitere PHP-Versionen kann man spielend einbauen und jederzeit wechseln.

    XAMPP ist mir einfach zu überladen und scheint auch immer wieder Probeme zu machen. Ich scheue mich nur vor der Dokumentation von meinem Paket, denn es schwierig, alles idiotensicher zu beschreiben, wenn vieles davon für einen selbstverständlich ist.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)