Support » Themes » Twenty Seventeen Beitragstitel fehlen

  • Gelöst leckofunny

    (@leckofunny)


    Guten Morgen allerseits!

    Ich habe eine frische WordPress Installation auf meiner lokalen Maschine.
    Bei Twenty Seventeen bin ich auf folgendes Problem gestoßen.
    Auf der Startseite lasse ich die letzten Beiträge anzeigen, allerdings steht über dem Beitrag nur das Datum und der Name des Autors. Der Beitragstitel fehlt dort.
    Selbiges trifft auch auf wenn ich eine Kategorieseite aufrufe.

    Hier ist ein Screenshot von dem Problem:
    https://i.imgur.com/P3ntsVX.png

    Ich bin mir nicht sicher, ob das Problem schon nach der Installation bestand oder ob das durch eine meiner Änderungen kam.

    Folgendes habe ich sinngemäß gemacht:

    – Widgets aus Footer entfernt
    – Einspaltiges Design ausgewählt
    – Startseite zeigt letzte Beiträge an
    – Plugins PDF Embedder und Shortcodes Ultimate installiert
    – Top Menü bearbeitet

    Ich freue mich über jeden Tipp zum Debugging =)

    • Dieses Thema wurde geändert vor 6 Monaten von leckofunny.
Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Moderator Bego Mario Garde

    (@pixolin)

    Auf der Startseite lasse ich die letzten Beiträge anzeigen …

    Wie hast du das eingestellt? Im Moment scheint auf der Startseite eine Seite mit dem Titel Beiträge ausgegeben zu werden, nicht aber die Beiträge selbst.

    Ein Link zu deiner Website wäre hilfreich.

    leckofunny

    (@leckofunny)

    Einen Link habe ich leider nicht, weil ich die Seite lokal gehostet habe.

    Die Startseite ist auf „zeigt Deine letzten Beiträge“ eingestellt.

    Moderator Bego Mario Garde

    (@pixolin)

    Vermutest du das oder hast du das wirklich geprüft?

    Wenn du einstellst, dass die Startseite die Beiträge zeigt, wird im Customizer der Menüeintrag für die Theme-Optionen ausgeschaltet; dann gibt es auch kein „Einspaltiges Design ausgewählt“.

    Im Moment hat es eher den Anschein, dass deine Startseite eine statische Seite „Luisendorf“ anzeigt und im Customizer unter (den dann einstellbaren) Theme-Optionen eine Seite Beiträge zugewiesen wurde, die Platzhalter für die Beiträge ist.

    leckofunny

    (@leckofunny)

    Die Themen-optionen werden nicht angezeigt.

    Eine statische Seite ist nicht ausgewählt.

    Moderator Bego Mario Garde

    (@pixolin)

    Die Themen-optionen werden nicht angezeigt.

    Das widerspricht wie gesagt deiner ursprünglichen Angabe „Einspaltiges Design ausgewählt“, was nur mit den Theme-Optionen möglich ist. Aber vielleicht hast du das auch zuerst eingestellt und anschließend die Startseiten-Einstellungen geändert.

    Hast du den Browser-Cache mal geleert?

    leckofunny

    (@leckofunny)

    Den Browser-Cache zu leeren habe ich gerade ohne Erfolg ausgeführt.

    Ich habe gerade eine Portfreigabe zu der Seite gemacht via dieser IP: 80.132.63.148
    Nachteil ist da nun, dass die ganzen Links über die Adresse nicht stimmen, da diese über localhost benannt sind.

    Moderator Bego Mario Garde

    (@pixolin)

    Du kannst unter Einstellungen > Allgemein auch die URL http://loaclhost mit der IP-Adresse ersetzen: http://123.123.42.123

    Das Backend erreichst du dann unter http://123.123.42.123/wp-login.php
    Eine spätere Anpassung/Zurücksetzen der URL ist auch direkt in der Datenbank-Tabelle wp-options möglich. Dort findest du die Felder siteurl und home.

    Moderator Bego Mario Garde

    (@pixolin)

    OK, ich hab mir die Webseite angeschaut und rasch versucht, das in meiner Testumgebung nachzubauen. Ergebnis ist, dass diese zweispaltige Darstellung vom Entwickler vorgesehen ist, sobald es keine Widgets in der Sidebar mehr gibt. Das kannst du leicht nachvollziehen, in dem du in der Sidebar ein HTML-Widget platzierst und als Inhalt ein geschütztes Leerzeichen eingibst:  .

    Du müsstest also für den Fall, dass du keine Sidebar verwenden möchtest und der Text die (nahezu) vollständige Seitenbreite einnehmen soll (was übrigens die Lesbarkeit erschwert – deshalb hier der Wert 90%), eine eigene CSS-Regel hinzufügen:

    @media screen and (min-width: 48em) {
    
    .blog:not(.has-sidebar) #primary article, 
    .archive:not(.page-one-column):not(.has-sidebar) #primary article,
    .search:not(.has-sidebar) #primary article, 
    .error404:not(.has-sidebar) #primary .page-content, 
    .error404.has-sidebar #primary .page-content {
        float: none;
        width: 90%;
    }
    
    }
    leckofunny

    (@leckofunny)

    Werden bei dir denn die Beitragstitel angezeigt wie z.B. „Ausgabe 08 – September 2019“?

    Moderator Bego Mario Garde

    (@pixolin)

    Die Titel werden mit ausgegeben (hier: „Lorem Ipum“):

    Screenshot der Website im Customizer zeigt Beitragstitel

    Die CSS-Regel habe ich wegen der Überschrift „Beiträge“ noch etwas ergänzt:

    @media screen and (min-width: 48em) {
    body:not(.has-sidebar):not(.page-one-column) .page-header, 
    .blog:not(.has-sidebar) #primary article, 
    .archive:not(.page-one-column):not(.has-sidebar) #primary article,
    .search:not(.has-sidebar) #primary article, 
    .error404:not(.has-sidebar) #primary .page-content, 
    .error404.has-sidebar #primary .page-content {
        float: none;
        width: 90%;
    }
    
    }

    Nachtrag: Dass in deinem Fall keine Beitragstitel ausgegeben werden liegt am gewählten Beitragsformat „Kurzmitteilung“, dass du im Beitragseditor in der rechten Spalte auswählen kannst.

    • Diese Antwort wurde geändert vor 6 Monaten von Bego Mario Garde. Grund: Nachtrag
    leckofunny

    (@leckofunny)

    Ahhh, an dem Beitragsformat lag es also.
    Damit ist mein Problem gelöst.

    Besten Dank!

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Das Thema „Twenty Seventeen Beitragstitel fehlen“ ist für neue Antworten geschlossen.