Support » Themes » Twenty Seventeen: Mobiles Menü funktioniert nicht

  • Gelöst jojobee

    (@jojobee)


    Liebe Community,
    bei dem WordPress-Theme Twenty Seventeen funktioniert bei mir das Mobile Menü nicht auf der Startseite. Ich habe das Theme nochmal komplett neu installiert, weil ich dachte, dass ich durch meine Änderungen am Footer etwas falsch gemacht hätte. Das Mobile Menü geht aber trotzdem nicht.
    Hat vielleicht jemand eine Idee woran das liegen könnte?

    Viele Grüße,
    Johanna

Ansicht von 9 Antworten - 16 bis 24 (von insgesamt 24)
  • Bringt alles nix. Habe jetzt auch nochmal das Theme neu installiert und verschiedene Sachen ausprobiert. Menü geht nicht.

    Kann ich diese body-Class .twentyseventeen-front-page komplett entfernen?

    „Rename wp-login“ und „WP limit login attempts“ ist etwas übervorsichtig. 🙂 Hat aber mit dem Problem hier nichts zu tun.

    Wenn du die Klasse .twentyseventeen-front-page entfernst, ändert sich auch der Header, der auf Folgeseiten kleiner dargestellt wird. Das ist also auch keine Lösung.

    Wie hast du denn die statische Startseite eingerichtet? Über Einstellungen > Lesen > Startseite zeigt …?

    Die Startseite habe ich über den Costumizer eingerichtet, scheinen aber die gleichen Einstell-Möglichkeiten zu sein

    Hi,

    das liegt daran:
    https://www.praxis-disselhoff.de/wp-content/themes/twentyseventeen_child/style.css?ver=4.7.3

    Entferne mal das
    top: 60px;

    bzw., mach aus (code alt)

    .has-header-image.twentyseventeen-front-page .site-branding, 
    .has-header-video.twentyseventeen-front-page .site-branding, 
    .has-header-image.home.blog .site-branding, 
    .has-header-video.home.blog .site-branding 
    { top: 60px; vertical-align: top; }

    das (code neu)

    .has-header-image.twentyseventeen-front-page .site-branding .wrap, 
    .has-header-video.twentyseventeen-front-page .site-branding .wrap, 
    .has-header-image.home.blog .site-branding .wrap, 
    .has-header-video.home.blog .site-branding .wrap
    { padding-top: 60px; vertical-align: top; }

    Getestet mit kleinerem Viewport und Startseite.

    Super, das war’s! 👏🏻

    (Allerdings würde das Menü dann auch funktionieren, wenn das Parent Theme aktiviert wird.) 😞

    Wird es vermutlich auch, allerdings nur, wenn man auch den Cache löscht.

    Wahnsinn! Funktioniert tatsächlich! Vielen vielen Dank!!!

    Gerne 🙂
    Du hast allerdings zwar das padding-top eingefügt, aber nicht das .wrap.
    So richtet die Anweisung überhaupt nichts aus.

    Um denselben Abstand zu erhalten, musst du schon exakt den Code nehmen

    .has-header-image.twentyseventeen-front-page .site-branding, 
    .has-header-video.twentyseventeen-front-page .site-branding, 
    .has-header-image.home.blog .site-branding, 
    .has-header-video.home.blog .site-branding 
    { vertical-align: top; }
    
    .has-header-image.twentyseventeen-front-page .site-branding .wrap, 
    .has-header-video.twentyseventeen-front-page .site-branding .wrap, 
    .has-header-image.home.blog .site-branding .wrap, 
    .has-header-video.home.blog .site-branding .wrap 
    { padding-top: 60px; }

    Ah das .wrap hatte ich übersehen. Danke für den Hinweis!!!

Ansicht von 9 Antworten - 16 bis 24 (von insgesamt 24)
  • Das Thema „Twenty Seventeen: Mobiles Menü funktioniert nicht“ ist für neue Antworten geschlossen.