Support » Themes » Twenty Twenty-One Theme full width nicht mehr möglich

  • Gelöst lux55

    (@lux55)


    Hallo zusammen,
    als WordPress-Anfängerin erstelle ich gerade meine erste Webseite. Nachdem ich ohne Erfolg versucht habe das Cookie-Plugin von Cookiebot zu installieren, hat sich das Layout des Headers, der Pages sowie des Footers geändert. Jetzt lassen sich die einzelnen Elemente nicht mehr in der gesamten Breite darstellen, sondern auf es ist ein Rand zu sehen.

    Könnte mir jemand diesbzüglich weiterhelfen?
    Danke und viele Grüße,
    Lux

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Moderator Bego Mario Garde

    (@pixolin)

    Ein Link zu deiner Website wäre hilfreich:
    Warum ein Link zu deiner Website wichtig ist

    Hast du den Browser-Cache geleert?

    Vielleicht magst du uns auch noch ein paar Informationen zu deiner Website zukommen lassen? Geh bitte auf Werkzeuge > Website-Zustand > Bericht, klick auf den Button und füge den Bericht mit Strg-V unverändert in deine Antwort ein.

    Thread-Ersteller lux55

    (@lux55)

    Hallo Bego,

    danke für die schnelle Rückmeldung.Den Browser-Cache habe ich geleert.
    Der Link zur Website: https://www.luxleipzig.de/

    Der Bericht:

    
    ### wp-core ###
    
    version: 5.8.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: undefined
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/sites/site100025707/web/luxleipzig.de
    wordpress_size: 140,32 MB (147135418 bytes)
    uploads_path: /home/sites/site100025707/web/luxleipzig.de/wp-content/uploads
    uploads_size: 64,87 MB (68017526 bytes)
    themes_path: /home/sites/site100025707/web/luxleipzig.de/wp-content/themes
    themes_size: 3,61 MB (3783309 bytes)
    plugins_path: /home/sites/site100025707/web/luxleipzig.de/wp-content/plugins
    plugins_size: 59,77 MB (62676340 bytes)
    database_size: 3,40 MB (3568442 bytes)
    total_size: 271,97 MB (285181035 bytes)
    
    ### wp-dropins (1) ###
    
    object-cache.php: true
    
    ### wp-active-theme ###
    
    name: Twenty Twenty-One (twentytwentyone)
    version: 1.4
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, title-tag, post-formats, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, align-wide, editor-styles, editor-style, editor-font-sizes, custom-background, editor-color-palette, editor-gradient-presets, responsive-embeds, custom-line-height, experimental-link-color, custom-spacing, custom-units, widgets
    theme_path: /home/sites/site100025707/web/luxleipzig.de/wp-content/themes/twentytwentyone
    auto_update: Deaktiviert
    
    ### wp-plugins-active (9) ###
    
    Akismet Anti-Spam: version: 4.2.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    Classic Editor: version: 1.6.2, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    EditorsKit: version: 1.31.7, author: Extendify, Automatische Aktualisierungen deaktiviert
    GDPR Cookie Compliance (CCPA, PIPEDA ready): version: 4.5.11, author: Moove Agency, Automatische Aktualisierungen deaktiviert
    LiteSpeed Cache: version: 4.4.2, author: LiteSpeed Technologies, Automatische Aktualisierungen deaktiviert
    Options for Twenty Twenty-One: version: 1.5.5, author: Webd Ltd, Automatische Aktualisierungen deaktiviert
    Twentig: version: 1.3.6, author: Twentig, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.16.62, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WP Maintenance Mode: version: 2.4.1, author: Designmodo, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    Booking Calendar: version: 8.8.2, author: wpdevelop, oplugins, Automatische Aktualisierungen deaktiviert
    Cookiebot | GDPR/CCPA Compliant Cookie Consent and Control: version: 3.11.1, author: Cybot A/S, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1808
    imagemagick_version: ImageMagick 7.1.0-2 Q16 x86_64 2021-06-25 https://imagemagick.org
    imagick_version: 3.4.4
    file_uploads: File uploads is turned off
    post_max_size: 500M
    upload_max_filesize: 500M
    max_effective_size: 500 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 75000
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, ASHLAR, AVI, AVIF, AVS, BGR, BGRA, BGRO, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUBE, CUR, CUT, DATA, DCM, DCR, DCRAW, DCX, DDS, DFONT, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FARBFELD, FAX, FF, FILE, FITS, FL32, FLV, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, HALD, HDR, HEIC, HEIF, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K25, KDC, KERNEL, LABEL, M2V, M4V, MAC, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORA, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PHM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGB565, RGBA, RGBO, RGF, RLA, RLE, RMF, RSVG, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TM2, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMV, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, YAML, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: 9.53.3
    
    ### wp-server ###
    
    server_architecture: Linux 5.10.53 x86_64
    httpd_software: Apache
    php_version: 7.4.21 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 60
    memory_limit: 256M
    max_input_time: 240
    upload_max_filesize: 500M
    php_post_max_size: 500M
    curl_version: 7.77.0 OpenSSL/1.1.1l
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.2.36-MariaDB-log
    client_version: mysqlnd 7.4.21
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/sites/site100025707/web/luxleipzig.de/wp-content
    WP_PLUGIN_DIR: /home/sites/site100025707/web/luxleipzig.de/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Moderator Bego Mario Garde

    (@pixolin)

    Das gif-Bild auf der Startseite wurde mit „weiter Breite“ eingefügt und steckt dann wohl auch noch in zwei Spalten-Blöcken, die nur weite Breite zugewiesen bekommen haben. Füg das Bild doch nochmal neu ein, ohne Spalten-Blöcke und mit „voller Breite“.

    Nachtrag: du hast wohl zusätzlich über das Plugin Twentig im Customizer > Site-Layout > Site-Max-Width eine maximale Breite von 1200 Pixeln eingegeben, die ebenfalls auf größeren Bildschirmen Seitenränder erzeugen.

    Thread-Ersteller lux55

    (@lux55)

    Danke für den Hinweis. Ich habe das gif-Bild mal ganz rausgenommen, leider ändert sich nichts an der Darstellung.

    Schade, ich wollte mir das gerade ansehen, aber die Seite ist im Wartungsmodus.

    Thread-Ersteller lux55

    (@lux55)

    Sorry, ist jetzt wieder im normalen Modus.

    Moderator Bego Mario Garde

    (@pixolin)

    Das ist jetzt (vor allem bei aktiviertem Maintenance-Modus) in etwa so hilfreich, wie wenn ich dir antworte „dann hast du etwas falsch gemacht“. ¯\_(ツ)_/¯

    Hast du im Customizer die Begrenzung der Seitenbreite rausgenommen?
    Dann ein Bild (ohne Spalten) neu eingefügt? Kontrolliert, ob die Bildbreite mit „volle Breite“ angegeben ist?

    Ohne einen Blick auf die Webseiten kann ich nicht mal raten. Schade. Da bleibt mir nur, dir viel Erfolg zu wünschen.

    Moderator Bego Mario Garde

    (@pixolin)

    … ist jetzt wieder im normalen Modus.

    „Und wie Sie sehen, sehen Sie nix …“?
    Wie sollen wir ein Bild beurteilen, das nicht da ist?

    Die Maximalbreite der Seite von 1200 Pixeln ist immer noch vorgegeben.
    Da muss es Seitenränder geben.

    Sorry, ich bin raus – dafür ist mir jetzt meine Zeit zu wertvoll.

    Hallo,
    hmm, ich kann an der Darstellung jetzt nichts (mehr) ungewöhnliches feststellen.
    Evtl. hilft es, wenn du zunächst das Cache-Plugin (LiteSpeed Cache) deaktivierst und – falls das nicht hilft – die Plugins alle deaktivierst und dann einzeln wieder aktivierst. Danach schaust du dann jeweils, ob das Problem behoben ist.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller lux55

    (@lux55)

    Danke für die Hilfe und die Zeit. Ich überprüfe nochmal alles!

    Hier vielleicht noch ein Hinweis:
    Auf einer Testseite mit Nutzung von Twenty Twenty One habe ich außer einigen Plugins zum Betatest, etc. nichts weiter installiert. Mit ein paar CSS-Regeln lässt sich damit eine schöne Webseite bauen.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Stell dir vor, du hast einen Luftballon, den du auf eine beliebige Größe immer weiter aufblasen kannst. Wenn du den Ballon nun in eine Kiste steckst und dann versuchst, ihn aufzublasen, wird er nie größer werden, als die Kiste.

    Wenn du ein Bild mit „100% Breite“ in eine Spalte packst, wird das Bild nie breiter werden, als die Spalte.

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    Das Bild ist zwar jetzt auf alignfull gesetzt, aber die umgebende Spalte (die „Kiste“) hat nur einen Breite alignwide.

    Moderator Bego Mario Garde

    (@pixolin)

    Da die Website inzwischen wieder im Maintenance-Mode ist, zwischenzeitlich aber eine Webseite mit einem Bild von voller Breite vorhanden war, nehme ich an, dass das Problem gelöst ist und ändere den Status des Threads entsprechend.

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)