Support » Allgemeine Fragen » Umlaut Probleme seit Update von Theme

  • Gelöst stephuu

    (@stephuu)


    Hallo liebe Community,

    seit des letzten Updates meinen Wp-Themes „Nation“ werden alle Umlaute und gewisse Zeichen umgewandelt in Java-Code also ein kleines ä wird zu u00e4.

    Wenn ich den Text in WP neu eintippe und auf aktualisieren gehe wird er direkt umgewandelt also noch im Editor.

    An der Schriftart kann es nicht liegen weil es vorher immer funktionierte alles. Was könnten die Hersteller den vergessen haben im Code? Ich habe bereits versucht in die header.php mit meta charset utf8 einzugeben aber das hat auch nichts bewirkt. Und in der Wp-config ist auch alles korrekt.

    Ich brauch eure Hilfe

    Hier könnt ihr euch selbst den Fehler anschauen http://stephandonner.com

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Moderator La Geek

    (@la-geek)

    Bist du zufällig beim Hoster Hostpoint?

    https://www.walterlernt.ch/2016/02/04/wordpress-sonderzeichen-problem/

    Kommentar 3 und danach beachten.

    Thread-Starter stephuu

    (@stephuu)

    Nein bin ich nicht, den Artikel hatte aber ich auch gelesen. Aber trotzdem Danke :/

    Moderator La Geek

    (@la-geek)

    Schade, wie sieht denn der String bei dir in der wp-config.php aus?

    So?

    define('DB_CHARSET', '');

    Könnte helfen, wenn du es mal so einträgst (testweise).

    Noch eine Möglichkeit:
    http://www.ceterumcenseo.net/umlaut-problem-utf-8/

    Thread-Starter stephuu

    (@stephuu)

    So sah er vorher aus:

    define('DB_CHARSET', 'utf8');

    und so wie du es geschrieben hast hat es leider auch nicht funktioniert, habe es eben nochmal ausprobiert.

    Moderator La Geek

    (@la-geek)

    Ist das nur bei dem Theme so oder auch bei einem Standardtheme?

    Thread-Starter stephuu

    (@stephuu)

    Nein das ist wohl ein Problem mit dem Theme 🙁 Deswegen fragte ich ja was die Theme-Hersteller geändert haben könnten beim Update. Irgendwas müssen sie ja vergessen haben bezüglich der utf8 Tabelle. Und dazu kommt ja dass alle alten Seiten, wie zum Beispiel mein Portfolio noch funktionieren, nur sobald ich etwas ändere und neu absichere wird es umgewandelt.

    Moderator La Geek

    (@la-geek)

    Das scheint ein Kauf-Theme zu sein, oder? Jedenfalls sollte dir der Theme-Entwickler weiterhelfen können.

    Thread-Starter stephuu

    (@stephuu)

    Ja genau, ich habe gestern die Entwickler angeschrieben, mal sehen was die sagen. Hatte nur gehofft hier hätte jemand vielleicht auch eine Lösung 🙂

    Moderator La Geek

    (@la-geek)

    Du könntest mit Winmerge die alte und neue Version vergleichen und daraus dann vielleicht Rückschlüsse ziehen.
    Wenn du ein Backup hast, besitzt du auch die ältere Theme-Version.

    Wäre super wenn du die Lösung hier posten könntest, falls dir die Entwickler helfen können.

    Frage: Welche MySQL Version verwendest du für die Datenbank?

    // define(‘DB_CHARSET’, ‘utf8’);
    // define(‘DB_COLLATE’, ”);

    Kurz vor meiner Abreise gestern hatte ich im Netz noch den gerade zitierten Workaround als Lösungsansatz gefunden. Allerdings gab es weder dort noch anderswo Erläuterungen über mögliche „Kollateralschäden“ bzw. darüber, warum dadurch bei einigen Usern das Problem tatsächlich behoben werden konnte. Ich bin vorhin erst heimgekommen und sehe, dass die Umlaute auf deiner Seite wieder richtig angezeigt werden, dein Problem also inzwischen offenbar außerhalb des Forums gelöst wurde.

    Spanne uns bitte nicht lange auf die Folter und erzähle uns doch mal die Details der (eventuell eruierten Ursachen) und der Lösung! 😉

    Moderator La Geek

    (@la-geek)

    @angelika,

    aahh, sooo hat das geklappt…!! 😉

    Nee, im Ernst:
    „You must be logged in to see this reply.“

    Mist 😉

    Thread-Starter stephuu

    (@stephuu)

    Hallo, sorry das ich jetzt erst schreibe. Ja das Problem hat sich gelöst. Der herrsteller hat auf meine Nachricht direkt reagiert und ein Update zur Verfügung gestellt. Was genau er vergessen hat weis ich leider nicht aber ich konnte die Texte ändern und nun ist es wieder richtig dargestellt. 🙂 Vielen Dank für eure Tipps trotzdem:)

    Danke schön für die Rückmeldung, @stephuu!
    Schade, dass du keine Details erfahren hast, das hätte hier sicher so einige interessiert.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • Das Thema „Umlaut Probleme seit Update von Theme“ ist für neue Antworten geschlossen.