Support » Allgemeine Fragen » Umlaute erscheinen nach klicken auf weiterlesen nicht mehr

  • Gelöst flocke

    (@flocke)


    Hallo,

    bei mir werden nach dem Klicken auf weiterlesen die Umlaute nicht mehr richtig angezeigt. Bei der Vorschau auf meiner Website sind sie noch da.
    Kann mir da jemand helfen?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 26)
  • Nur mit der Auskunft „Umlaute werden nicht mehr richtig angezeigt“ können wir kaum weiterhelfen. Gib uns doch mal ein paar Informationen, damit wir uns die Sache anschauen können:

    Wo finden wir deine Website? (URL fehlt)

    Außerdem bräuchten wir mehr Informationen zu deiner Website:
    Werkzeuge > Website-Zustand (gibt es hier Fehlermeldungen? Welche?) > Bericht > per Button in die Zwischenablage kopieren, dann hier unverändert in eine Antwort einfügen.

    Nutzt du gekaufte Themes oder Plugins?

    Hast du in letzter Zeit Änderungen vorgenommen? Welche?

    Thread-Starter flocke

    (@flocke)

    Guten Morgen,

    es geht um diese Seite. Ich habe keine neuen Plugins installiert, benutze seit längerem dieses Theme.

    http://mf-ontour.de/2020/04/04/wasser-filtern-im-wohnmobil/#more-4305

    
    ### wp-core ###
    
    version: 5.4
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: false
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/web898/html/wordpress
    wordpress_size: 177,62 MB (186244144 bytes)
    uploads_path: /var/www/web898/html/wordpress/wp-content/uploads
    uploads_size: 5,36 GB (5759894279 bytes)
    themes_path: /var/www/web898/html/wordpress/wp-content/themes
    themes_size: 1,95 MB (2049368 bytes)
    plugins_path: /var/www/web898/html/wordpress/wp-content/plugins
    plugins_size: 59,52 MB (62415042 bytes)
    database_size: 26,37 MB (27648442 bytes)
    total_size: 5,62 GB (6038251275 bytes)
    
    ### wp-active-theme ###
    
    name: Bhari (bhari)
    version: 1.0.4.9
    author: Mahesh M. Waghmare
    author_website: https://maheshwaghmare.wordpress.com/
    parent_theme: none
    theme_features: automatic-feed-links, customize-selective-refresh-widgets, title-tag, post-thumbnails, menus, html5, custom-background, editor-style, starter-content, custom-logo, custom-header, infinite-scroll, jetpack-responsive-videos, widgets
    theme_path: /var/www/web898/html/wordpress/wp-content/themes/bhari
    
    ### wp-themes-inactive (1) ###
    
    OneColumn: version: 6.7, author: Guido
    
    ### wp-plugins-active (10) ###
    
    Add From Server: version: 3.3.3, author: Dion Hulse
    Akismet Anti-Spam: version: 4.1.4, author: Automattic
    Amazon Associates Link Builder: version: 1.9.3, author: Amazon Associates Program
    Broken Link Checker: version: 1.11.12, author: WPMU DEV
    Duplicator: version: 1.3.28, author: Snap Creek
    EWWW Image Optimizer: version: 5.2.5, author: Exactly WWW
    Jetpack by WordPress.com: version: 8.3, author: Automattic
    PayPal Donations: version: 1.9.5, author: Tips and Tricks HQ, Johan Steen
    Smash Balloon Instagram Feed: version: 2.3, author: Smash Balloon
    Yoast SEO: version: 13.4.1, author: Team Yoast
    
    ### wp-media ###
    
    image_editor: EWWWIO_Imagick_Editor
    imagick_module_version: 1673
    imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-12-29 http://www.imagemagick.org
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.18-13-pve x86_64
    httpd_software: Apache
    php_version: 7.3.13 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 60
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 64M
    curl_version: 7.38.0 OpenSSL/1.0.1t
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.25
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/web898/html/wordpress/wp-content
    WP_PLUGIN_DIR: /var/www/web898/html/wordpress/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### jetpack ###
    
    site_id: 132537654
    ssl_cert: No
    time_diff: undefined
    version_option: 8.3:1583281971
    old_version: 8.2.3:1583281949
    public: Public
    master_user: #1 web898 (florianmattes.flocke@gmail.com)
    current_user: #1 web898 (florianmattes.flocke@gmail.com)
    tokens_set: Blog User
    blog_token: YVYx2oWV^J!XjbCS%LQY@fI2CCFHDtpv
    user_token: 4hj2sF4)aUc8Sai1U^!6Xt61P)ctv33t
    version: 8.3
    jp_plugin_dir: /var/www/web898/html/wordpress/wp-content/plugins/jetpack/
    plan: free
    HTTP_HOST: mf-ontour.de
    SERVER_PORT: 80
    REMOTE_ADDR: 37.201.7.184
    protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
    full_sync: {"started":"Thu, 01 Jan 1970 00:00:00 +0000","finished":"Thu, 01 Jan 1970 00:00:00 +0000","progress":[],"config":[]}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"http:\/\/mf-ontour.de","siteurl":"http:\/\/mf-ontour.de","WP_HOME":"","WP_SITEURL":""}
    idc_error_option: false
    idc_optin: true
    cxn_tests: All Pass.
    
    

    Irgendeine Funktion zerstört die Umlaute, macht z.B. aus „ü“ das hier: „ü“. Ich vermute, dass es am Theme liegt. Das gibt es nicht mehr im Theme Verzeichnis.
    Wechsle auf ein aktuelles Theme.

    Ich vermute, dass es am Theme liegt.

    Weshalb? 🙂

    Nur weil ein Theme nicht mehr im Repo ist, muss es nicht kaputt sein.

    @flocke
    Öffne bitte mal die wp-config.php per FTP mit einem geeigneten Programmiereditor (z.B. Atom Editor, Visual Studio Code oder Notepad++, alle kostenlos erhältlich). Schau ob du die Zeilen

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    findest und kommentiere sie beide aus:

    // define('DB_CHARSET', 'utf8');
    // define('DB_COLLATE', '');

    Ist der Fehler damit behoben?

    Thread-Starter flocke

    (@flocke)

    Hab beide auskommentiert.
    Jetzt kommen statt Umlauten nur Fragezeichen an deren Stelle.

    OK, dann mach den letzten Schritt bitte wieder rückgängig.
    Kannst du dann bitte mal über das Kundenmenü deines Webhosters in die Datenbankverwaltung gehen – üblicherweise ist das phpMyAdmin. Dort sollte stehen, mit welcher Zeichenkodierung die Datenbanken angelegt sind:

    Screenshot phpMyAdmin

    Thread-Starter flocke

    (@flocke)

    Ok.
    utf8mb4_general_ci steht dort.

    Update:
    hab grad gesehen, dass es bei der WordPress Datenbank verschiedene sind.

    • Diese Antwort wurde geändert vor 2 Jahre, 7 Monaten von flocke.
    • Diese Antwort wurde geändert vor 2 Jahre, 7 Monaten von flocke.

    Wenn du ein Backup der Datenbank hast, kannst du das doch mal einheitlich auf utf8mb4_general_ci ändern.

    Thread-Starter flocke

    (@flocke)

    Ok, aber wie stell ich das einheitlich um?

    Datenbank hast du vorher exportiert?

    Unter dem Reiter „Operationen“ solltest du unten ein passendes Pulldown-Menü finden:

    Datenbankkollation ändern in phpMyAdmin

    Thread-Starter flocke

    (@flocke)

    Die Auswahlfenster kommen bei mir nicht.
    Tabellen hab ich zuvor exportiert.
    Anschliessend auf utf8mb4_unicode_ci gestellt und ok gedrückt.
    Es kam dann auch die Meldung, dass der Befehl ausgeführt wurde.
    Leider stehen aber immer noch die selben Kollektionen drin.

    Hattest du denn die Kommentare in der wp-config.php wieder rausgenommen?

    Wie ich geschrieben habe: OK, dann mach den letzten Schritt bitte wieder rückgängig. …

    Thread-Starter flocke

    (@flocke)

    Ja, hab die Kommentare wieder rausgenommen.

    Hast du mal in der Datenbanktabelle wp_posts nachgeschaut, ob da die Umlaute richtig drin sind?

    Es scheint weder am Thema noch an der Datenbank zu liegen. Die älteren Blogbeiträge sind okay.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 26)
  • Das Thema „Umlaute erscheinen nach klicken auf weiterlesen nicht mehr“ ist für neue Antworten geschlossen.