Support » Installation » Umlaute werden nicht angezeigt

  • Ich habe das nicht ganz unbekannte Problem von den Umlauten, die nicht angezeigt werden. Trotz intensiver Suche finde ich die Lösung leider nicht.
    Das Problem trat auf, nachdem ich die Seite mit Akeeba Kickstart von der Testumgebung auf die Live-Umgebung transferierte. Vorher war es korrekt. Nun nicht mehr.
    Im head steht
    <meta charset="utf-8">
    Ich habe mal gehört, dass der Fehler in der Datenbank liegen könnte. Und mit irgend einer Abfrage kann man dies beheben…?!
    In der wp-config.php steht nichts zum charset (in andern Foren wird berichtet, dort Anpassungen zu machen.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Hast Du Zugriff auf die Datenbank? Normalerweise bieten Webhosts dafür einen Zugang per phpMyAdmin an. Damit könntest Du dir anschauen, wie die Datenbanktabellen codiert sind. Vorausgesetzt, Deine Datenbank spielt mit, kannst Du als Codierung utf8mb4_unicode_ci verwenden. In der wp-config.php steht üblicherweise

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    Step by Step alles kontrollieren!
    1. Frage welches Plugin wurde zuletzt installiert?

    Dann
    Gibt es ein Cache Plugin
    .htaccess kontrollieren
    Wurden alle URLS ersetzt – suchen in Mysql DB nach altem URL
    ev. mal plugins directory umbenennen _plugins testen dann wieder retour…
    ev. Theme Updaten das neuste ist vom 12.8. !
    —-

    —-stooni

    Thread-Starter rombeer

    (@rombeer)

    In der Testumgebung funktioniert alles. Plugins dürften also nicht der Grund sein.
    Das Problem tritt auf, wenn mit Akeeba Kickstart die Seite auf die Live-Umgebung transfertiert wird. Heisst also: beim Erstellen bzw. Abfüllen der Datenbank. Wenn ich die Inhalte manuell nochmal einfülle, funktioniert es ebenfalls wieder. (aber das will man ja nicht, alles nochmal manuell reinschubsen.)
    in der phpMyAdmin steht in der Kollation utf8. In der Config steht nichts von utf8. (müsste das noch rein?) Habe aber schon gelesen, dass man dies eher löschen soll, wenn dieser Fehler auftritt.
    (Hat jemand das Problem mit Akeeba auch??)

    Edi

    (@psychosopher)

    Und warum verwendest Du Akeeba und nicht ein bewährtes Tool, das funktioniert?

    Mit dem Plugin Duplicator beispielsweise müsste es problemlos gehen:

    https://wordpress.org/plugins/duplicator/

    Für Akeeba können wir keinen Support leisten. Offenbar handelt es sich dabei nicht um ein Plugin, sondern eine Stand-Alone-Applikation, die nicht direkt mit WordPress zu tun hat.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Link zur Website?

    Gruß, Torsten

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Umlaute werden nicht angezeigt“ ist für neue Antworten geschlossen.