Support » Installation » Umstellung auf ssl funktioniert nicht

  • Gelöst draal

    (@draal)


    Hallo zusammen,

    gemäss den Gesetzesrichtlinien bin ich als Anbieter mehrerer Websites wohl verpflichtet den Zugriff auf diese Seiten zu verschlüsseln, wenn Benutzerkonten angelegt werden können.

    Dies habe ich versucht, jedoch nur mit geringem Erfolg.

    Die Seiten liegen auf einem Apachen (2.4.x).
    Die PHP Version ist 7.4.
    Das Routing erfolgt über selfhost.de.
    Der Host hängt an einer FritzBox! mit geöffnetem Port 443.
    Die Schlüssel erhielt ich von letsencrypt.
    Der Apache läuft, wie man an einigen Seiten, deren Contents man unverschlüsselt abrufen kann, sieht.
    define('FORCE_SSL_ADMIN', true); wurde in die wp-config.php eingepflegt.
    Per PHPMyAdmin wurden die URLs in den entsprechenden Datenbanktabellen auf https umbenannt.

    Wenn ich nun die Seiten im Webbrowser aufrufe, ohne http vorzustellen, erscheint die URL in der Adresszeile des Browsers mit dem Vorsatz https://.

    Aber die Seite bleibt leer.

    <VirtualHost 192.168.137.2:80>
            ServerAdmin webburningheart@web.de
            ServerName www.burningheart.name
            DocumentRoot /var/www/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/www>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride FileInfo AuthConfig Indexes
                    Order allow,deny
                    allow from all
            </Directory>
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
            ErrorLog ${APACHE_LOG_DIR}/error.log
            # Possible values include: debug, info, notice, warn, error,
            # crit, alert, emerg.
            LogLevel warn
            CustomLog ${APACHE_LOG_DIR}/access.log combined
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    RewriteEngine on
    RewriteCond %{SERVER_NAME} =www.burningheart.name
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    </VirtualHost>
    <VirtualHost 192.168.137.2:443>
            ServerAdmin webburningheart@web.de
            ServerName www.burningheart.name
            DocumentRoot /var/www/www
    
           <IfModule mod_ssl.c>
                   SSLEngine on
                   SSLCertificateFile /etc/letsencrypt/live/www.burningheart.name/fullchain.pem
                   SSLCertificateKeyFile /etc/letsencrypt/live/www.burningheart.name/privkey.pem
                   Include /etc/letsencrypt/options-ssl-apache.conf
           </IfModule>
           <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/www>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride FileInfo AuthConfig Indexes
                    Order allow,deny
                    allow from all
            </Directory>
            ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
            <Directory "/usr/lib/cgi-bin">
            <Directory "/usr/lib/cgi-bin">
                    AllowOverride None
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    Order allow,deny
                    Allow from all
            </Directory>
            ErrorLog ${APACHE_LOG_DIR}/error.log
            # Possible values include: debug, info, notice, warn, error,
            # crit, alert, emerg.
            LogLevel warn
            CustomLog ${APACHE_LOG_DIR}/access.log combined
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from 127.0.0.0/255.0.0.0 ::1/128
        </Directory>
    </VirtualHost>

    Das ist ein Ausschnit aus der VHost Konfiguration des Apachen. Er startet damit ohne Fehlermeldung.
    Den Part für den Port 80 habe ich versuchsweise auskommentiert, jedoch ohne Erfolg. Auch ein direktes Abrufen mit https:// funktioniert nicht.

    Im Moment laufen die Seiten unverschlüsselt, bis ich das Problem in den Griff bekomme.

    Vielleicht hat ja jemand hier mal mit einem ähnlichen Problem gekämpft.

    Viele Grüße

    Draal

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Wenn ich die Seite per HTTPS aufrufe, bekomme ich diese Fehlermeldung:

    SSL_ERROR_RX_RECORD_TOO_LONG

    Das ist definitiv ein Server-Problem und kein WordPress-Problem und somit ist du eigentlich in diesem Forum falsch.

    google liefert mit diesem Fehler knapp über 45.000 Treffer, da solltest du eine Lösung finden.

    draal

    (@draal)

    Da wurden die Contents noch unverschlüsslet angeboten.
    Eigentlich werden die Seiten nicht gecacht, aber scheinbar lag es daran.
    Die erste Seite läuft jetzt verschlüsselt.
    Danke für die Mühe.

    Viele Grüße

    Draal

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    wenn das Problem damit für dich erledigt ist, markiere doch das Thema bitte als gelöst.
    Viele Grüße
    Hans-Gerd

    draal

    (@draal)

    Done 😉

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)